none
Problemas con páginas ASP en IIS 7 en Windows Vista Ultimate RRS feed

  • Pregunta

  • Hola a todos. Mi problema es el siguiente. Tengo instalado Windows Vista Ultimate con IIS 7 al completo. Estoy creando una web con Dreamweaver 8.0 en ASP y abre todas las paginas bien excepto las que tienen una conexion con base de datos devolviendome un error de esos http 500.

    En el xp que tenia antes de actualizar si que me funcionaba y ahora sin hacer cambios no me va. Tengo que configurar algo del IIS 7?

    A que puede ser debido. GRACIAS
    jueves, 22 de febrero de 2007 19:51

Respuestas

  • Hola,

    Luego de probar todas las soluciones para lograr que las paginas asp "clasicas" conectadas a una base de datos microsoft access funcionen correctamente en IIS 7, considero que esta es la mejor!!!!!!!!!!!.

    1)Abrir IIS7

    2)Grupo de aplicaciones > Menú acciones (en la parte derecha de la pantalla) > Establecer valores predeterminados de grupos de aplicaciones

    3)Habilitar aplicaciones de 32 bits > True (cambiar el estado por defecto false a true)

    La expliacion es "... si está establecida en true para un grupo de aplicaciones en un sistema operativo de 64 bits, los procesos de trabajo que sirven al grupo de aplicaciones estarán en modo WOW64 (windows on windows64). Los procesos en modo WOW64 son procesos de 32 bits que cargan sólo aplicaciones de 32 bits"

    Exitos a todos!!!!
    • Propuesto como respuesta .Paloke jueves, 12 de abril de 2012 8:43
    • Marcado como respuesta Uriel Almendra lunes, 1 de abril de 2013 16:27
    sábado, 1 de mayo de 2010 8:06

Todas las respuestas

  • Buenas, aunque te parezca que no viene a cuento, yo te aconsejo que pruebes también con el navegador Firefox. Mira el post que acabo de poner con problemas al crear seguridad con certificado+SSL.

    Saludos...

    viernes, 23 de febrero de 2007 9:13
  • Muchas gracias por tu respuesta. También lo he probado y me aparece el siguiente error: "An error occurred on the server when processing the URL. Please contact the system administrator"
    viernes, 23 de febrero de 2007 14:01
  • Me pasa exáctamente lo mismo, pero cuando he copiado los archivos en la aplicación por defecto.

    Si trato de crear una aplicación nueva (con otro puerto, claro) me sale un mensaje del tipo:

    Error del servidor


    HTTP Error 500.0 - Internal Server Error

    Descripción: No se puede mostrar la página. Error interno en el servidor.

    Código de error: 0x80070005

    Notificación: BeginRequest

    Módulo: IIS Web Core

    Dirección URL solicitada: http://161.67.89.30:8000/

    Ruta física: C:\Users\Jesús\Documents\Mis sitios web\prueba

    Usuario de inicio de sesión: No determinado aún

    Método de inicio de sesión: No determinado aún

    Controlador: No determinado aún

    Causas más probables:

    • IIS recibió la solicitud. No obstante, se produjo un error interno durante el procesamiento de la solicitud. La causa principal de este error depende del módulo que controla la solicitud y qué estaba sucediendo en el proceso de trabajo cuando se produjo el error.
    • IIS no pudo obtener acceso al archivo web.config del sitio o de la aplicación web. Esto puede suceder si los permisos NTFS no están establecidos correctamente.
    • IIS no pudo obtener acceso a la aplicación o al sitio web.
    • El usuario autenticado no tiene permiso para usar este archivo DLL.
    • La solicitud está asignada a un controlador administrado pero la característica Extensibilidad de .NET no está instalada.

    Qué puede intentar:

    • Asegúrese de que los permisos NTFS del archivo web.config sean correctos y permitan obtener acceso a la cuenta del equipo del servidor web.
    • Compruebe si los registros de sucesos contienen alguna información adicional.
    • Compruebe los permisos del archivo DLL.
    • Instala la característica Extensibilidad de .NET si la solicitud está asignada a un controlador administrado.
    • Cree una regla para hacer un seguimiento de las solicitudes con error para este código de estado HTTP. Para obtener más información sobre la creación de una regla de seguimiento para solicitudes con error, haga clic aquí.

    Más información... Este error indica que se ha producido un problema al procesar la solicitud. Ésta se recibió en el servidor web, pero durante su procesamiento se produjo un error grave. Error 500.

    Artículos de Microsoft Knowledge Base:

    • 294807
    miércoles, 14 de marzo de 2007 9:40
  • El error comentado me salía al principio de la instalación. Ahora que ya he comprobado que funciona "global.asa" donde especifico el origen de los datos a través de ODBC, me sale el error:

    Microsoft OLE DB Provider for ODBC Drivers error '80004005'

    [Microsoft][Controlador ODBC Microsoft Access] Error de disco o de red

     

    Pero de ahí no paso. He comprobado que los "*.asa" se ejecutan bien. Lo que va mal es el acceso a los datos. Esto es desesperante.

     

    saludos a todos

    martes, 17 de abril de 2007 15:01
  • Me pasa exactamente lo mismo! estoy cansado de re-instalar el vista! y el IIS! me estoy cansando de buscar solucion alguna y nada! no se porque pero las paginas que conecto con una ODBC de acces no va ni para atras ni para adelante! no se porque! me canse de buscar de todo y nada!

     

    viernes, 17 de agosto de 2007 15:01
  •  

    Hola, yo tengo el mismo problema y me gustaría saber si conseguiste solucionarlo y cómo. Muchas gracias
    viernes, 31 de agosto de 2007 14:44
  •  

    Hola, pues decirte que hace ya bastante tiempo que lo deje por imposible. No consigo una solucion y me he recorrido ya todos los foros sobre programación y creacion de pagias web pero nada.

     

    Un saludo.

    viernes, 31 de agosto de 2007 17:13
  • Hola,

           Hay una solución para este problema, abrir el CMD con permisos de administrador en Windows Vista, luego se debe colocar estas líneas, según informes de IIS7 y Microsoft Support:

     

    Try the following:
    ("INTENTAR LO SIGUIENTE")

    1. %windir%\system32\inetsrv\appcmd set appPool "DefaultAppPool" -processModel.loadUserProfile:false


    OR assuming your ASP page has anonymous authentication enabled:
    ("O ASUMIENDO QUE LA PAGINA ASP TIENE ACTIVADO EL ACCESO ANONIMO")

    1. icacls %WINDIR%\ServiceProfiles\NetworkService\AppData\Local\temp /grant IUSR: (CI)(RX,WD,AD)
    2. icacls %WINDIR%\serviceprofiles\networkservice\AppData\Local\Temp /grant "CREATOR OWNER": (OI)(CI)(IO)(F)


    If you use authentication you should use this command:
    ("SI USAS AUTENTIFICACION DEBES USAR ESTE COMANDO")


    icacls %WINDIR%\ServiceProfiles\NetworkService\AppData\Local\temp /grant Users: ( CI)(RX,WD,AD)

    icacls %WINDIR%\serviceprofiles\networkservice\AppData\Local\Temp /grant "CREATOR OWNER": (OI)( CI)(IO)(F)

     

    ******************************************

    Al parecer hubieron cambios en las directrices de las cuentas de usuarios y el problema son los diferentes tipos de permisos, que sino se hace lo de arriba el IIS7 no deja ejecutar las bases de datos Access.

     

    Saludos y espero que les sirva.

     

    P.D: Para que no saliera una cara del messenger tuve que poner un espacio en :+espacio ser borrado+(CI) se debe pegar todo luego de Users:

    lunes, 3 de septiembre de 2007 13:57
  • Hola a todos, yo tambien tuve el mismo problema.

    Inclui las opcines de arriba, pero tuve que ejecutar el CMD como Administrador, aparte de eso os comento que hay que añadir una opción dentro de la configuración de IIS para modulos ASP.

    La primera opción funciona si trabajas con access, pero yo necesitaba algo mas porque trabajamos con conexiones ODBC, os apunto debajo lo que hay que activar, ya que creo que viene deshabilitado por defecto.


    Activar o desactivar las caracteristicas de windows

    Una vez dentro.

    Internet information server -> Estado y diagnostico -> Registro de ODBC (permite el registro de una base de datos compatible con ODBC)

    Bueno, espero que os sirva de ayuda, ya que a mi este post me ha servido de mucha ayuda, para poder llegar a trabajar con ASP y el amigo Vista.

    Saludos.
    martes, 4 de septiembre de 2007 9:21
  • POR FIN!!!!!!... ESTA ES LA SOLUCION!!!!

     

    Yo tenia el mismo problema pero ejecute los comandos y ya funciona la pagina como en Win XP PRO con IIS 6.0

     

    MUCHAS GRACIAS!!!



    martes, 4 de septiembre de 2007 22:59
  • he hecho lo que pones , he escrito lo de

     

    icacls %WINDIR%\ServiceProfiles\NetworkService\AppData\Local\temp /grant Users: ( CI)(RX,WD,AD)

    y me responde

    Parametro no valido "Users:"

     

    con la segunda linea me da el mismo error con "CREATOR OWNER"

     

    Gracias

     

    viernes, 7 de septiembre de 2007 11:23
  •  

    yo lo solucione con esto:

    Try the following:
    ("INTENTAR LO SIGUIENTE")

    %windir%\system32\inetsrv\appcmd set appPool "DefaultAppPool" -processModel.loadUserProfile:false

     

    OR assuming your ASP page has anonymous authentication enabled:
    ("O ASUMIENDO QUE LA PAGINA ASP TIENE ACTIVADO EL ACCESO ANONIMO")


    icacls %WINDIR%\ServiceProfiles\NetworkService\AppData\Local\temp /grant IUSR: (CI)(RX,WD,AD)
    icacls %WINDIR%\serviceprofiles\networkservice\AppData\Local\Temp /grant "CREATOR OWNER": (OI)(CI)(IO)(F)

    If you use authentication you should use this command:
    ("SI USAS AUTENTIFICACION DEBES USAR ESTE COMANDO")


    icacls %WINDIR%\ServiceProfiles\NetworkService\AppData\Local\temp /grant Users: ( CI)(RX,WD,AD)

    icacls %WINDIR%\serviceprofiles\networkservice\AppData\Local\Temp /grant "CREATOR OWNER": (OI)( CI)(IO)(F)

     

    ******************************************

    Al parecer hubieron cambios en las directrices de las cuentas de usuarios y el problema son los diferentes tipos de permisos, que sino se hace lo de arriba el IIS7 no deja ejecutar las bases de datos Access.

     

    Saludos y espero que les sirva.

     

    P.D: Para que no saliera una cara del messenger tuve que poner un espacio en :+espacio ser borrado+(CI) se debe pegar todo luego de Users:

     

    de: Razeus

     

    solo le di el comando ke esta en negrita

     

     

    espero te sirva, saludos

    viernes, 7 de septiembre de 2007 14:52
  •  franmades Escribió:

    he hecho lo que pones , he escrito lo de

     

    icacls %WINDIR%\ServiceProfiles\NetworkService\AppData\Local\temp /grant Users: ( CI)(RX,WD,AD)

    y me responde

    Parametro no valido "Users:"

     

    con la segunda linea me da el mismo error con "CREATOR OWNER"

     

    Gracias

     

     

    Hola,

           A veces dependiendo del idioma del sistema operativo se debe usar la palabra Usuarios en vez de Users, y con esto se soluciona el problema puntual.

     

    Nota:

    icacls %WINDIR%\ServiceProfiles\NetworkService\AppData\Local\temp /grant Users: (CI)(RX,WD,AD)

     

    Users:_aquí viene un espacio que debe ser borrado ya que despues de los dos puntos :pegadoa(   si lo pego en este foro sale Sad ... En resumen, después de Users: todo los que viene no puede tener ningún espacio y con eso te funcionará para el caso de CREATOR OWNER.

     

    Luego se debe verificar que el grupo Users o Usuarios tenga permisos RWX sobre la carpeta donde están las bases de datos adentro del Inetpub.

     

    Saludos.

    viernes, 7 de septiembre de 2007 15:12
  • Hola:

    he intentado hacer todo lo anterior y no me funciona, alguien sabe como solucionarlo??????????

     

    saludos

    lunes, 17 de septiembre de 2007 18:40
  • Mira, yo tuve ese problema pero no fue con IIS7 ni con Windows Vista, a mi me pasó con IIS6 y Windows 2003 Server.

    La solución que encontré, fue agregar a los permisos de la base de datos el usuario, "Servicio de Red" y a este, le asignas los permisos de "Lectura y ejecución", "Leer" y si también desde la web vas hacer cambios en algún registro como por ejemplo agregar uno nuevo, entonces agrégale también el permiso de "Escritura". Una cosa bien importante, es que eso permisos, sólo los pongas en el archivo de la base de datos, ya que si lo haces a la carpeta AppData, este cambio aplicaría a todas las bases de datos que estén dentro de la carpeta si le aplicas la herencia, con el correspondiente agujero de seguridad que corresponde.
    viernes, 28 de septiembre de 2007 16:48
  • Hola, Saludos a todos.

     

    Ya corri las lineas que mencionan sin ningun problema, pero sigo sin poder ralizar conexiones a las base de datos, el archivo global.asa funciona bien, pero cuando pongo una linea de conexion a la base no jala (error http 500) quito esta liena y se muestra de manera correcta pero sin acceso a la base.

     

    Que mas se puede hacer ya otorge los permisos a la carpeta donde se encuentran las asp y el global.asa

     

    Ayuda por favor.

    martes, 2 de octubre de 2007 18:12
  • Muchísimas gracias por esta información.

    Estaba ya en el punto de desesperación con este problema.

     

    Según entiendo con esto, ¿No hay ninguna forma de gestionar permisos desde el IIS7?. O sea, que dependen de los que se les haya dado a la carpeta o fichero desde la pestaña de seguridad.

     

    Gracias.

     

    domingo, 11 de noviembre de 2007 20:02
  • Hola,

           Sí, de forma predeterminada hay que buscar esos rebusques para poder operar como se hacia antes (con las bases de datos, etc..), los cambios más que nada son a nivel de seguridad limitando severamente los permisos sobre las carpetas.

     

    Sobre IIS, las cadenas de conexión son más bien orientadas para SQL Server y en caso de Access se necesita hacer todos los pasos de arriba, dando permisos a los usuarios, etc.

     

    Hasta hoy desde la consola de IIS 7 no he podido hacer que cambien los permisos para que funcionen las bases Access.

     

    Saludos.

    domingo, 11 de noviembre de 2007 20:19
  • no me funciona hice todo lo que dice pero aun no me funciona.

    yo estoy usando II7 en windows 2008 standart

     

     

    viernes, 28 de marzo de 2008 1:17
  • Hola, yo tuve el mismo problema por bastante tiempo.

     

    Ya habia hecho lo que comentan anteriormente una y otra vez y en cada foro que entraba me encontraba con lo mismo hasta que me puse a ver las caracteristicas del iis y fue cuando me di cuenta que no tenia habilitada las aplicaciones de 32 bits .

     

    Esto lo haces de manera muy sencilla.

    Simplemente entra en tu iis selecciona "Grupos de aplicaciones"; al seleccionarla del lado derecho de las opciones aparece "Establecer valores predeterminados de grupos de aplicaciones"; damos clic y en el primer renglon que dice "Habilitar aplicaciones de 32 bits" cambiamos el valor a "True" y ¡listo!  

     

    No saben como rabiaba porque no encontraba la solucion. jejejeje

    sábado, 20 de septiembre de 2008 0:28
  • no encontre eso que dices en el iis7.0 y ya intente todos los comandos y demas que dicen anteriormente

    me desespere y cuando eso sucede empiezo a moverle por todos lados y realizar la tecnica de prueba y error
    esto me dio por resultado al fin

                   ENCONTRAR UNA SOLUCION !!!! POR FIN !!!!!!!

    si despues de haber hecho todo lo que dicen arriba y aun asi no funciona traten esto

    1. Abran la consola de IIS7 (panel de control -> herramientas administrativas) y hagan clic en "Grupos de aplicaciones"

    2. Seleccionen una aplicaicion y den clic en "Ver aplicaciones" en el menu que aparece a la derecha (Acciones)

    3. Ahora aparece en el centro "Aplicaiones", seleccionen una aplicacion (yo seleccione Aplicacion raiz), den clic en el menu derecho (Acciones) en donde dice "Cambiar grupo de aplicaciones"

                     NOTA: si no sale ninguna aplicacion en el centro den clic a "Quitar filtro"

    4. En la ventana emergente que sale elijan la opcion Classic .NET AppPool y den Aceptar


    Listo, prueben su codigo

    Observaciones: yo accedo a la base mediante OBDC, lo configuro desde el panel de "Origenes de Datos OBDC" y mi codigo es

    -----
    Set Conn = Server.CreateObject("ADODB.Connection")
    Conn.Open "mibase"
    ------

    en donde "mibase" es el nombre del origen de datos DSN de sistema

    Otra observacion es que el archivo de base de datos (yo uso access base.mdb) debe estar en la carpeta APP_DATA del servidor (C:\inetpub\wwwroot\App_Data)


    Saludos y Suerte
    domingo, 2 de noviembre de 2008 8:27
  • Bien, gente, en VIsta el principal problema es seguridad! asi que empezemos por dar permisos de ADMIN, IIS_IUSR y USERS a las carpetas y raises que contengan el sitio y a tambien damos permisos a las carpetas que contengan la base de datos y a los archivos tambien.

    En Vista 64x para configurar una conexion ODBC debemos ir a C:\Windows\SysWOW64\odbcad32.exe y NO hacer como en XP de ir a CONTROL PANEL >> ADMINSTRATOR TOOLS >> DATA SOURCE, esto solo seria para sistemas basados en 32x asi que recuerden en 64x la ruta es distinta deben ejecutar C:\Windows\SysWOW64\odbcad32.exe.
    Ahora bien ya hemos dado los permisos necesarios, hemos conectado nuestra ODBC asi que ahora hay que configurar el IIS, bien abrimos el IIS y abajo de todo hay dos formas de ver los paneles esta como VISTA CARACTERISTICA y VISTA CONTENIDO, vamos a VISTA CARACTERISTICAS y en la seccion IIS del medio hay un icono que seria AUTENTICACION >> boton derecho >> ABRIR CARACTERISTICAS y habilitamos AUTENTICACION ANONIMA y AUTENTICACION BASICA, luego en AUTENTICACION ANONIMA >> boton derecho >> MODIFICAR >> y en IDENTIDAD DE USUARIO ANONIMO seleccionamos USUARIO ESPECIFICO >> IUSR y aceptar.
    Esto serian los pasos y si no me escriben.... ademas no nos olvidemos siempre de correr una simple pagina ASP
    <% response.write "hola mundo" %> asi por lo menos sabemos si nuestro IIS esta corriendo! suerte y hasta pronto.
    arcederlis@hotmail.com 

    lunes, 1 de diciembre de 2008 1:45
  • Tambien presente el mismo problema con IIS7 en Windows 7 y SQL Server 2007 pero lo resolvi haciendo lo sigiente.

    1. %windir%\system32\inetsrv\appcmd set appPool "DefaultAppPool" -processModel.loadUserProfile:false

    2. Agregue esta linea en el web.config
        <system.web>
            <identity impersonate="true"/>
        </system.web>

    3. Habilite el usuario IUSR para inicio de sesion en la Base de Datos y otorguele los permisos necesarios, de lectura escritura o propietario

    Eso es todo Espero que sea de utilidad


    MSP Carlos Rojas
    carojaspaz@hotmail.com
    domingo, 8 de marzo de 2009 0:23
  • Problema solucionado. Comento como hice por si a alguien le pasa:

    He encontrado en un foro que parece ser que el problema es al usar un sistema operativo x64 y se soluciona con el siguiente script desde la linea de comandos:

    CSCRIPT %SYSTEMDRIVE%\Inetpub\AdminScripts\adsutil.vbs SET W3SVC/AppPools/Enable32bitAppOnWin64 1

    Lo leí en http://www.forosdelweb.com/f59/iis7-access-488470/

    Saludos.
    jueves, 21 de mayo de 2009 9:57
  • Gracias
    sábado, 1 de mayo de 2010 8:05
  • Hola,

    Luego de probar todas las soluciones para lograr que las paginas asp "clasicas" conectadas a una base de datos microsoft access funcionen correctamente en IIS 7, considero que esta es la mejor!!!!!!!!!!!.

    1)Abrir IIS7

    2)Grupo de aplicaciones > Menú acciones (en la parte derecha de la pantalla) > Establecer valores predeterminados de grupos de aplicaciones

    3)Habilitar aplicaciones de 32 bits > True (cambiar el estado por defecto false a true)

    La expliacion es "... si está establecida en true para un grupo de aplicaciones en un sistema operativo de 64 bits, los procesos de trabajo que sirven al grupo de aplicaciones estarán en modo WOW64 (windows on windows64). Los procesos en modo WOW64 son procesos de 32 bits que cargan sólo aplicaciones de 32 bits"

    Exitos a todos!!!!
    • Propuesto como respuesta .Paloke jueves, 12 de abril de 2012 8:43
    • Marcado como respuesta Uriel Almendra lunes, 1 de abril de 2013 16:27
    sábado, 1 de mayo de 2010 8:06
  • Pero que buena respuesta, te pasaste,  me salvaste la vida
    viernes, 14 de mayo de 2010 3:00
  • Hola:


    Agradecer a todos la colaboracion, y en especial SYRO.

    Resuelto problema de acceso a la intranet interna de mi PC.

    Problema que no tenia con el xp profesional. Y si con vista ultimate.

    Gracias a todos por la ayuda prestada.



    sábado, 19 de junio de 2010 19:54
  • Eres un barbamo men, me salvaste la vida, todo ese poco de garabatos alla arriba y nada funka, y vienes tu x arte dde magia no solo das la solucion sino ke la explicas de forma maestra
    miércoles, 25 de abril de 2012 19:09