none
Cross site publishing - imágenes RRS feed

  • Pregunta

  • Hola

    Tengo un site (Product Catalog) para crear contenido (aut.midom.com) y otro (Publishing site) para mostrar el contenido.

    He creado unas columnas de sitio, donde una de ellas es de tipo (Publishing Image), ésta columna sirve para seleccionar una imágen que represente a una noticia.

    Estas columnas las he añadido a una nueva lista he añadido contenido a la lista y finalmente he declarado esta lista como Catalogo

    He idexado el contenido y por último en el site de publicación he creado la conexión con el catálogo.

    Todo ha funcionado perfectamente excepto que las imágenes no aparecen, ya que la indexación devuelve el path relativo de las imágenes y claro en el site de publicación no existen.

    Como debo hacer para que aparezcan las imágenes en el webpart de la página de categorías.

    Gracias y saludos

    martes, 6 de noviembre de 2018 12:01

Todas las respuestas

  • Hola Tabletrtd

    Gracias por levantar tu consulta en los foros de TechNet. Con respecto a la misma, te recomiendo ingresar al siguiente enlace donde se expone una pequeña guía que te puede ser de utilidad para resolver el problema que presentas.

    https://docs.microsoft.com/en-us/sharepoint/dev/general-development/cross-site-publishing-in-sharepoint

    Gracias por usar los foros de TechNet.

    Juan Mondragón
     ____

    Por favor recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema, es una forma común de reconocer a aquellos que han ayudado, y hace que sea más fácil para los otros visitantes encontrar la solución más tarde. 

    Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de conocimientos relacionados con los productos y tecnologías de Microsoft.  

    Este contenido es proporcionado "tal cual" y no implica ninguna responsabilidad de parte de Microsoft.

    martes, 6 de noviembre de 2018 16:25
    Moderador
  • Desafortunadamente el enlace no hace referencia  al problema, ya que habla de realizar desarrollos aparte de la funcionalidad OOB.
    Gracias de todas maneras.

    miércoles, 7 de noviembre de 2018 11:32
  • Hola Tabletrtd

    Dando seguimiento a tu pregunta, te comparto algunos procedimientos que puedes intentar.

    https://support.office.com/es-es/article/agregar-im%C3%A1genes-y-elementos-multimedia-accesibles-a-un-sitio-de-sharepoint-online-a17dc07d-1184-49d1-adc4-87841644cda4

    https://support.office.com/es-es/article/agregar-un-archivo-de-imagen-a-una-p%C3%A1gina-de-sharepoint-4a9b0e98-c89a-4a41-8adb-b7750dccca16#ID0EAACAAA=2016,_2013,_2010

    Espero que te sean de utilidad.

    Gracias por usar los foros de TechNet.

    Pablo Rubio
     ____

    Por favor recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema, es una forma común de reconocer a aquellos que han ayudado, y hace que sea más fácil para los otros visitantes encontrar la solución más tarde. 

    Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de conocimientos relacionados con los productos y tecnologías de Microsoft.  

    Este contenido es proporcionado "tal cual" y no implica ninguna responsabilidad de parte de Microsoft.

    miércoles, 7 de noviembre de 2018 18:24
    Moderador
  • Gracias por la respuesta, pero estos enlaces sólo muestran como cargar imágenes en una página o en un campo tipo "Publishing Image" y ese no es el problema que tengo.

    Saludos

    jueves, 8 de noviembre de 2018 11:27
  • Intentaré explicarme mejor,

    • En el sitio de creación de contenido, la lista tiene un campo "Publishing Image" y cada elemento tiene una imágen en este campo. (Ésta imágen está en una biblioteca de imágenes del mismo site de creación de contenido)
    • La lista anterior se ha configurado como catálogo.
    • Se ha indexado el contenido
    • En el sitio de publicación, se ha hecho la conexión del catálogo. Y automáticamente e han creado la página de categorias y la de elementos

    Pues bien el problema es que en éstas páginas (en el sitio de publicación) aparecen los textos de los elementos (del sitio de creación de contenido) pero las imágenes no aparecen.

    El tema, es que la indexación del campo "Publishing image" contiene la url relativa a la imágen y esa url no existe en el sitio de publicación.

    Por tanto la pregunta es: ¿cómo se debe trabajar con imágenes si se quiere utilizar el product catálog?

    Gracias y saludos

    jueves, 8 de noviembre de 2018 11:37