none
¿Puede la función SI asignar colores a un texto? RRS feed

  • Pregunta

  • Hola, imaginemos que quiero usar la función SI, por ejemplo para analizar las siguientes celdas

    =SI(I35>G35;"ACEPTAR";"NO ACEPTAR")

    Quiere decir que si I35 es mayor a G35 entonces Excell muestra el texto aceptar, y si I35 es menor a G35 entonces muestra el texto NO ACEPTAR, lo que pasa es que a mi me gustaría que además del texto se muestre con un color. Por ejemplo, que aceptar se muestre en verde y no aceptar en rojo.

    ¿Se puede hacer eso con Excell?

    Saludos

    viernes, 12 de enero de 2018 18:03

Todas las respuestas

  • Hola:

    Claro que se puede hacer, solo debes usar la herramienta "Formato Condicional"y cualquiera de sus opciones. Puedes colocar  que cambie, por ejemplo, el color de relleno de la ceda dependiendo de la palabra que te da como resultado la fórmula.

    Abraham Valencia

    viernes, 12 de enero de 2018 20:16
  • Hola, a mi me interesa aplicar el formato condicional para la función SI, que puede tener dos valores, uno positivo o negativo (es decir, se cumple la fórmula, no se cumple la fórmula).

    El formato condicional basado en formula, solo me permite aplicar 1 color para una condición, pero que yo sepa no permite aplicar otro color para la otra condición.

    Explicado más claramente, lo que yo quiero es que si la celda B2 por ejemplo es mayor a 50 se muestre en rojo y si es menor a 50 se muestre en verde. Hay dos condiciones, y dos colores.

    ¿Se puede hacer esto?

    ¿Me podrías poner un ejemplo de cómo se haría?

    sábado, 13 de enero de 2018 1:03
  • Hola:

    Primero, no, el "Formato Condicional" permite, desde la versión de Excel 2007, varias alternativas pero, para que no estés variando mucho lo que tienes avanzado, mantén tu fórmula en dicha celda y aplica el formato en base al resultado, o los resultados, de dicha fórmula.

    Anda a "Formato Condicional", "Resaltar reglas de celdas", "Es igual a...",  y en el cuador de dialogo que sale, en el textbox de la izquierda colocas "ACEPTAR" (sin las comillas" y en el combobox de la derecha  elige el color rojo (o similar) y dal click al botón "Aceptar". Ahora vuelve a hace lo mismo pero utiliza la frase "NO ACPETAR" y dale otro color. Listo.

    Comentas

    Abraham Valencia

    • Propuesto como respuesta José Mª Fueyo martes, 16 de enero de 2018 9:46
    domingo, 14 de enero de 2018 0:11
  • Funciona maravillosamente ¡gracias!
    domingo, 14 de enero de 2018 16:51