none
No puedo visualizar ciertos directorios RRS feed

  • Pregunta

  • Buenas tardes, estoy teniendo un problema un poco particular. Tengo un directorio compartido en el cual hay subcarpetas con permisos NTFS para determinados usuarios. Este fin de semana me desaparecieron muchas subcarpetas. lo Extraño es que accediendo por consola puedo listarlos, pero accediendo desde el explorador de archivos no los visualizo. Por ejemplo: Mi recurso compartido es \\server\user. Al acceder no puedo visualizar la carpeta "sectorA", pero si accedo a \\server\user\sectorA si la puedo visualizar correctamente. Logueado localmente en el server con Windows Server 2012, accedo a la carpeta y no existe el directorio "sectorA". En cambio, si accedo al recurso por la direccion completa (d:\users\sectorA) si puedo hacerlo.

    Que puede estar sucediendo?

    Si no fui claro pido disculpas, Muchas gracias

    lunes, 27 de noviembre de 2017 23:13

Respuestas

  • Hola, Leandro-P:

    Sin detalles técnicos explícitos sobre el caso que nos concierne, sólo podemos ofrecer "palos de ciego" exponiendo posibles causas que hayan generado el error que señalas. Dos opciones que se me ocurren ahora mismo son:

    1.- El directorio que señalas está oculto, y no tienes configurado en tu Explorador el muestreo de TODO el contenido (Accede a las propiedades NTFS del directorio SECTOR-A y desde la solapa PROPIEDADES, confirma esté marcada la casilla OCULTA).

    2.- El directorio SECTOR-A no tiene establecidos los permisos de acceso/lectura/escritura por cuentas grupo. Ello le lleva un poco más de tiempo de sincronizar/actualizar los permisos de acceso al usuario que lo solicite, y mientras tanto.. "oculta" dicho directorio. En algunos foros esta considerado un "bug" del sistema. Desde mi punto de vista, el "bug" es del Administrador por establecer permisos individuales a recursos de red en un dominio.

    Desiderio Ondo || Engineer

    • Marcado como respuesta Leandro-P martes, 28 de noviembre de 2017 17:46
    martes, 28 de noviembre de 2017 10:39

Todas las respuestas

  • Hola, Leandro-P:

    Sin detalles técnicos explícitos sobre el caso que nos concierne, sólo podemos ofrecer "palos de ciego" exponiendo posibles causas que hayan generado el error que señalas. Dos opciones que se me ocurren ahora mismo son:

    1.- El directorio que señalas está oculto, y no tienes configurado en tu Explorador el muestreo de TODO el contenido (Accede a las propiedades NTFS del directorio SECTOR-A y desde la solapa PROPIEDADES, confirma esté marcada la casilla OCULTA).

    2.- El directorio SECTOR-A no tiene establecidos los permisos de acceso/lectura/escritura por cuentas grupo. Ello le lleva un poco más de tiempo de sincronizar/actualizar los permisos de acceso al usuario que lo solicite, y mientras tanto.. "oculta" dicho directorio. En algunos foros esta considerado un "bug" del sistema. Desde mi punto de vista, el "bug" es del Administrador por establecer permisos individuales a recursos de red en un dominio.

    Desiderio Ondo || Engineer

    • Marcado como respuesta Leandro-P martes, 28 de noviembre de 2017 17:46
    martes, 28 de noviembre de 2017 10:39
  • Creo que puede deberse a un virus. Ejecute el comando attrib -h -r -s "nombre del directorio" y ahora lo puedo visualizar. Tengo el atributo "oculto" deshabilitado. Que accion me recomiendan? Tengo antivirus en el server, pero evidentemente no funcionó de mucho
    • Editado Leandro-P martes, 28 de noviembre de 2017 12:41 correccion
    martes, 28 de noviembre de 2017 12:38
  • Hola, Leandro-P:

    No es un virus, compañero. Además de QUITARLE el atributo de "Sólo lectura" (por la variable -r), el comando que has aplicado le ha QUITADO el atributo de "Archivo de sistema" (por la variable -s) y le ha QUITADO el atributo de "Archivo oculto" (por la variable -h). Todo ello, para la cuenta logada actualmente..

    Más info:
    · Sintaxis de variables de comando Attrib:
    https://technet.microsoft.com/es-es/library/bb490868.aspx

    Desiderio Ondo || Engineer

    martes, 28 de noviembre de 2017 13:16
  • Tenes idea cual puede ser la causa de que aleatoriamente le ocurra esto a mis directorios?

    martes, 28 de noviembre de 2017 14:43
  • Ejem! No has marcado como correctas ninguna de las respuestas facilitadas hasta ahora, compañero..
    Comprende que no tiene sentido responder preguntas si las respuestas ofrecidas no te parecen correctas..

    Desiderio Ondo || Engineer

    martes, 28 de noviembre de 2017 16:33
  • Ejem! No has marcado como correctas ninguna de las respuestas facilitadas hasta ahora, compañero..
    Comprende que no tiene sentido responder preguntas si las respuestas ofrecidas no te parecen correctas..

    Desiderio Ondo || Engineer

    Es que realmente la solucion fue aplicar el comando attrib -h -r -s "nombre del directorio", pero tu primer respuesta fue de gran ayuda, como deberia hacer ? una es el complemento de otra.
    martes, 28 de noviembre de 2017 17:18
  • Hola, Leandro-P:

    No es un virus, compañero. Además de QUITARLE el atributo de "Sólo lectura" (por la variable -r), el comando que has aplicado le ha QUITADO el atributo de "Archivo de sistema" (por la variable -s) y le ha QUITADO el atributo de "Archivo oculto" (por la variable -h). Todo ello, para la cuenta logada actualmente..

    Más info:
    · Sintaxis de variables de comando Attrib:
    https://technet.microsoft.com/es-es/library/bb490868.aspx

    Desiderio Ondo || Engineer

    Aclaro, al aplicar este comando impactó en todos los usuarios, no solamente en la cuenta logueada actualmente.
    martes, 28 de noviembre de 2017 17:19
  • Hola Desiderio Ondo,

    Recuerda que la persona que realiza la consulta puede proceder al marcado de las respuestas una vez que confirme que le ha sido útil, mientras tanto se pueden votar o "proponer" como posible respuesta.

    En dado caso que la persona que pregunte ya no responda se marcará lo más cercano a la respuesta.

    Gracias por usar los foros de TechNet.

    Juan
     _____

    Por favor recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema, es una forma común de reconocer a aquellos que han ayudado, y hace que sea más fácil para los otros visitantes encontrar la solución más tarde. 

    Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de conocimientos relacionados con los productos y tecnologías de Microsoft.  

    Este contenido es proporcionado "tal cual" y no implica ninguna responsabilidad de parte de Microsoft.

    martes, 28 de noviembre de 2017 17:19
    Moderador
  • Bueno.. en realidad, el comando Attrib es la.. versión *no gráfica* (por línea de comandos) del apartado mostrado en el enlace del primer post..
    En todo caso, eres tú quien decide, compañero..

    Desiderio Ondo || Engineer

    martes, 28 de noviembre de 2017 17:29
  • En efecto: se me había "pasado" ese detalle: cualquier cambio en los atributos de un objeto, quedan adheridos al mismo, independientemente del objeto de cuenta que acceda; la única variación puede darse en tener o no permisos para aplicar los cambios en los atributos..

    Desiderio Ondo || Engineer

    martes, 28 de noviembre de 2017 17:31
  • Por eso mismo, para no entrar en una confusión, el punto 1 de la primer respuesta no es la solución, ya que el atributo "oculto" de la carpeta estaba deshabilitado y no era posible modificarlo si no era por linea de comandos. Igualmente agradezco mucho tu ayuda Desiderio! 
    martes, 28 de noviembre de 2017 17:32
  • Je! Ten en cuenta que lo que se facilita aquí es una orientación (lo más exacta possible en función a los conocimiento, experiencias.. etc) para encontrar soluciones, compañero.. no la solución "per se".
    Personalmente, considero que todos aquellos casos en que se facilita LA solución a un problema técnico es porque se ha facilitado toda la información relevante para hallarla. Por desgracia, no suele ser lo más habitual.. pero el objetivo es ayudarnos los unos a los otros.

    En todo caso, ten en cuenta que la responsabilidad de buscar y aplicar soluciones en tu infraestructura técnica es tuya, no nuestra. De ahí que cualquier respuesta que se te hubiera facilitado hubiera sido "solo" de soporte; al fin y al cabo, yo no tengo acceso en tu infraestructura para revisar otras opciones que tambien tenía en mente, compañero..

    Ejem! Tambien pudiera haber sido que mis conocimientos no fueran tan amplios para con esta consulta..


    Desiderio Ondo || Engineer

    martes, 28 de noviembre de 2017 17:42
  • Je! Ten en cuenta que lo que se facilita aquí es una orientación (lo más exacta possible en función a los conocimiento, experiencias.. etc) para encontrar soluciones, compañero.. no la solución "per se".
    Personalmente, considero que todos aquellos casos en que se facilita LA solución a un problema técnico es porque se ha facilitado toda la información relevante para hallarla. Por desgracia, no suele ser lo más habitual.. pero el objetivo es ayudarnos los unos a los otros.

    En todo caso, ten en cuenta que la responsabilidad de buscar y aplicar soluciones en tu infraestructura técnica es tuya, no nuestra. De ahí que cualquier respuesta que se te hubiera facilitado hubiera sido "solo" de soporte; al fin y al cabo, yo no tengo acceso en tu infraestructura para revisar otras opciones que tambien tenía en mente, compañero..

    Ejem! Tambien pudiera haber sido que mis conocimientos no fueran tan amplios para con esta consulta..


    Desiderio Ondo || Engineer

    Muchas gracias por tu tiempo y por tu respuesta!

    Saludos

    martes, 28 de noviembre de 2017 17:45
  • Disculpen la molestia, creí no conveniente volver a abrir un nuevo tema ya que viene en relacion a lo que veniamos hablando. La solucion al problema es aplicar el comando attrib, pero la causa todavia la desconozco. Me sigue ocurriendo lo mismo constantemente, se ocultan carpetas aleatoriamente. Tienen idea por donde puede venir el problema?

    Muchas gracias

    miércoles, 29 de noviembre de 2017 13:36