none
No puedo montar almacen de carpetas publicas y almacen del buzon RRS feed

  • Pregunta

  • Hola, tengo el siguiente problema, no puedo montar el almacen de capetas publicas y el almacen del buzon. Hay ciertos servicios de Exchange que quiero inciar y no puedo porque no me inicia el servicio de administracion IIS. En el visor de suceso me sale el evento IIS Config 51262. Revisando el historial unos dias antes tenia el suceso IIS Config 4275. Buscando encontre que se podria deber a que el archivo metabase.xml podria estar corrupto y que debo reemplazarlo por una version anterior. Buscando en la carpeta history dentro de inetsrv encontre los archivos metabase.xml pero ninguno era anterior a la fecha del suceso 4275. Dicho esto quisiera saber si tengo alguna alternativa que no sea reinstalar IIS y Exchange
    miércoles, 11 de agosto de 2010 17:45

Todas las respuestas

  • Por lo que comentas en principio suena a que no vas a tener otra opción.

    No tenes ningun backup del equipo?

    Que versión de Exchange es? De Windows?

    Pasanos por favor también la descripción de los eventos 51262 y 4275.

     

    Saludos,


    Dario Woitasen | MCITP: Enterprise Messaging Administrator | MCTS: Microsoft Exchange Server 2010, Configuration
    miércoles, 11 de agosto de 2010 19:15
  • Hola dario, te comento que de IIS no tengo backup.  Te paso los sucesos que me solicitaste:

    Tipo de suceso:    Advertencia
    Origen del suceso:    IIS Config
    Categoría del suceso:    Catálogo
    Id. suceso:    51262
    Fecha:        11/08/2010
    Hora:        04:19:20 p.m.
    Usuario:        No disponible
    Equipo:    SERVIDOR
    Descripción:
    No se puede descifrar la propiedad segura. Se omitirá la propiedad./LM/NNTPSVCAdminACL
    ErrorCode           : 0x80090006

    Para obtener más información, vea el Centro de ayuda y soporte técnico en http://go.microsoft.com/fwlink/events.asp.


    Tipo de suceso:    Error
    Origen del suceso:    IIS Config
    Categoría del suceso:    Catálogo
    Id. suceso:    4275
    Fecha:        11/08/2010
    Hora:        12:32:20 p.m.
    Usuario:        No disponible
    Equipo:    SERVIDOR
    Descripción:
    Error al analizar el archivo XML. Motivo: Falta el signo igual entre el atributo y su valor.
     XML incorrecto: <IIsConfigObject    Location ?"/LM/SMTPSVC/1/EventManager/EventTypes/{F6628C8E-0D5E-11d2-AA68-00C04FA35B82}/Bindings/{3DBCF4C5-B781-469E-9A37-FA322C150394}/SourceProperties"
    ErrorCode           : 0xC00CE501
    Interceptor         : 14
    OperationType       : Populate
    Table               : MBProperty
    ConfigurationSource : file:///C:/WINDOWS/system32/inetsrv/MetaBase.xml
    Row                 : 4440
    Column              : 27

    Para obtener más información, vea el Centro de ayuda y soporte técnico en http://go.microsoft.com/fwlink/events.asp.

    La version de Exchange es 6.5.7638.1. Esta corriendo sobre un Windows Server 2003 Enterprise Edition SP2. En este servidor tengo corriendo Active Directory.

    miércoles, 11 de agosto de 2010 19:27
  • Me surge una duda, en caso de tener que reinstalar IIS y Exchange en ese servidor que ademas tiene Active Directory yo pensaba seguir la siguiente guia:

    http://support.microsoft.com/kb/320202/es

    Una vez que realices esos pasos, los permisos de las carpetas compartidas, recursos, etc, se mantienen? No tengo bien en claro esta parte

    miércoles, 11 de agosto de 2010 21:36
  • En caso de tener que reinstalar el IIS ese es el artículo indicado, te recomiendo que lo leas en inglés. Los permisos de las carpetas compartidas y recursos se deberian mantener sin problemas, ya que solo vas a estar afectando las carpetas, archivos y servicios relacionados a IIS y Exchange.

    Antes de reinstalar proba abriendo el archivo C:/WINDOWS/system32/inetsrv/MetaBase.xml con notepad y anda a la fila 4440 columna 27 y fijate si identificas un atributo y su valor y en el medio que falta el igual. Agregalo ya que perdido por perdido...

    Luego probas iniciar los servicios de IIS y si no funciona tendrias que ir por la reinstalación a mi parecer...

     

    Saludos,


    Dario Woitasen | MCITP: Enterprise Messaging Administrator | MCTS: Microsoft Exchange Server 2010, Configuration
    jueves, 12 de agosto de 2010 1:58
  • Dario, te cuento que tuve que reinstalar IIS y Exchange. Lo hice siguiendo el enlace que te comente. El problema que tengo ahora es que no puedo montar los buzones. Me sale los siguientes eventos

    Tipo de suceso:    Error
    Origen del suceso:    MSExchangeIS
    Categoría del suceso:    General
    Id. suceso:    9518
    Fecha:        14/08/2010
    Hora:        08:36:46 p.m.
    Usuario:        No disponible
    Equipo:    SERVIDOR
    Descripción:
    Error 0xfffffae7 al iniciar el grupo de almacenamiento /DC=local/DC=mediplus/CN=Configuration/CN=Services/CN=Microsoft Exchange/CN=Mediplus/CN=Administrative Groups/CN=Primer grupo administrativo/CN=Servers/CN=SERVIDOR/CN=InformationStore/CN=Primer grupo de almacenamiento en el almacén de información de Microsoft Exchange.
    MDB failed to start.

    Para más información, haga clic en http://www.microsoft.com/contentredirect.asp.

     

    Tipo de suceso:    Error
    Origen del suceso:    MSExchangeIS
    Categoría del suceso:    General
    Id. suceso:    9519
    Fecha:        14/08/2010
    Hora:        08:36:46 p.m.
    Usuario:        No disponible
    Equipo:    SERVIDOR
    Descripción:
    Error 0xfffffae7 al iniciar la base de datos "Primer grupo de almacenamiento\Almacén del buzón (SERVIDOR)" en el Almacén de información de Microsoft Exchange.

    Para obtener más información, haga clic en http://www.microsoft.com/contentredirect.asp.
    Datos:
    0000: 46 61 69 6c 65 64 20 74   Failed t
    0008: 6f 20 63 6f 6e 66 69 67   o config
    0010: 75 72 65 20 4d 44 42 00   ure MDB.

    Hasta ahora no he podido encontrar solucion a este problema

    sábado, 14 de agosto de 2010 23:51
  • Este servidor fue restaurado de algún backup??

    Realiza las pruebas de el siguiente post y luego pasanos los resultados:

    http://social.technet.microsoft.com/Forums/es-ES/exchangees/thread/4d6b000e-3219-4cfc-b07f-95a15d9622e1


    Dario Woitasen | MCITP: Enterprise Messaging Administrator | MCTS: Microsoft Exchange Server 2010, Configuration
    martes, 17 de agosto de 2010 15:35
  • Estaba viendo que lo que tenes es un Exchange 2003...

    Seguiste el procedimiento paso por paso como se indica? O sea realizaste un backup de los mailbox store y luego lo volviste a restaurar como se indica?


    Dario Woitasen | MCITP: Enterprise Messaging Administrator | MCTS: Microsoft Exchange Server 2010, Configuration
    martes, 17 de agosto de 2010 15:37
  • Llevo un par de dias con este inconveniente y no he podido hasta ahora solucionar el inconveniente. Reinstale todo siguiendo los instructivos, aplique los parches pero aun asi no puedo montar los buzones. Tengo una copia de seguridad de cada buzon que hice unos dias antes del inconveniente con exmerge. Instalar desde cero Exchage y restaurar los buzones es la unica solucion que tendria? Me gustaria que me orienten al respecto.

     

    Gracias

    martes, 17 de agosto de 2010 15:46
  • Con el procedimiento del artículo para reinstalar IIS deberia funcionar, seguiste los pasos de Exchang 2000/2003 tal cual se indican??
    Dario Woitasen | MCITP: Enterprise Messaging Administrator | MCTS: Microsoft Exchange Server 2010, Configuration
    martes, 17 de agosto de 2010 16:30
  • Dario, te pasolos resultados eseutil /mh y eseutil/ml


    C:\Archivos de programa\Exchsrvr\bin>eseutil /ms "database.edb"

    Microsoft(R) Exchange Server Database Utilities
    Version 6.5
    Copyright (C) Microsoft Corporation. All Rights Reserved.

    Initiating FILE DUMP mode...
             Database: database.edb

    Operation terminated with error -1811 (JET_errFileNotFound, File not found) afte
    r 1.62 seconds.




    C:\Archivos de programa\Exchsrvr\bin>eseutil /mh "C:\Archivos de Programa\exchsr
    vr\mdbdata\pub1.edb"


    Microsoft(R) Exchange Server Database Utilities
    Version 6.5
    Copyright (C) Microsoft Corporation. All Rights Reserved.

    Initiating FILE DUMP mode...
             Database: C:\Archivos de Programa\exchsrvr\mdbdata\pub1.edb

            File Type: Database
       Format ulMagic: 0x89abcdef
       Engine ulMagic: 0x89abcdef
     Format ulVersion: 0x620,11
     Engine ulVersion: 0x620,11
    Created ulVersion: 0x620,9
         DB Signature: Create time:10/26/2005 11:28:05 Rand:11193672 Computer:
             cbDbPage: 4096
               dbtime: 12536931 (0xbf4c63)
                State: Clean Shutdown
         Log Required: 0-0 (0x0-0x0)
       Streaming File: Yes
             Shadowed: Yes
           Last Objid: 27663
         Scrub Dbtime: 0 (0x0)
           Scrub Date: 00/00/1900 00:00:00
         Repair Count: 0
          Repair Date: 00/00/1900 00:00:00
     Old Repair Count: 0
      Last Consistent: (0x183C,23C,E1)  08/17/2010 12:26:54
          Last Attach: (0x183C,23B,99)  08/17/2010 12:26:53
          Last Detach: (0x183C,23C,E1)  08/17/2010 12:26:54
                 Dbid: 1
        Log Signature: Create time:10/26/2005 11:28:02 Rand:11162883 Computer:
           OS Version: (5.2.3790 SP 2)

    Previous Full Backup:
            Log Gen: 5451-5451 (0x154b-0x154b)
               Mark: (0x154B,1A97,1DE)
               Mark: 04/13/2010 18:03:07

    Previous Incremental Backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

    Current Full Backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

    Current Shadow copy backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

         cpgUpgrade55Format: 0
        cpgUpgradeFreePages: 0
    cpgUpgradeSpaceMapPages: 0

           ECC Fix Success Count: found (13)
       Last ECC Fix Success Date: 08/01/2010 02:00:23
       Old ECC Fix Success Count: none
             ECC Fix Error Count: none
         Old ECC Fix Error Count: none
        Bad Checksum Error Count: none
    Old bad Checksum Error Count: none

    Operation completed successfully in 3.0 seconds.



    C:\Archivos de programa\Exchsrvr\bin>eseutil /ml "C:\Archivos de Programa\exchsr
    vr\mdbdata\pub1.edb"


    Microsoft(R) Exchange Server Database Utilities
    Version 6.5
    Copyright (C) Microsoft Corporation. All Rights Reserved.

    Initiating FILE DUMP mode...

          Base name: pub
          Log file: C:\Archivos de Programa\exchsrvr\mdbdata\pub1.edb
                    ERROR: Cannot read log file header. Error -514.

    Operation terminated with error -514 (JET_errBadLogVersion, Version of log file
    is not compatible with Jet version) after 1.31 seconds.



    martes, 17 de agosto de 2010 20:55
  • Dario te copio tambien el resultado de aplicar el comando en los buzones privados:



    C:\Archivos de programa\Exchsrvr\bin>eseutil /mh "C:\Archivos de Programa\Exchsr
    vr\mdbdata\priv1.edb"

    Microsoft(R) Exchange Server Database Utilities
    Version 6.5
    Copyright (C) Microsoft Corporation. All Rights Reserved.

    Initiating FILE DUMP mode...
             Database: C:\Archivos de Programa\Exchsrvr\mdbdata\priv1.edb

            File Type: Database
       Format ulMagic: 0x89abcdef
       Engine ulMagic: 0x89abcdef
     Format ulVersion: 0x620,11
     Engine ulVersion: 0x620,11
    Created ulVersion: 0x620,9
         DB Signature: Create time:10/26/2005 11:28:06 Rand:11181714 Computer:
             cbDbPage: 4096
               dbtime: 82089548 (0x4e4964c)
                State: Clean Shutdown
         Log Required: 0-0 (0x0-0x0)
       Streaming File: Yes
             Shadowed: Yes
           Last Objid: 24281
         Scrub Dbtime: 0 (0x0)
           Scrub Date: 00/00/1900 00:00:00
         Repair Count: 0
          Repair Date: 00/00/1900 00:00:00
     Old Repair Count: 0
      Last Consistent: (0x183C,23E,1D6)  08/17/2010 12:36:13
          Last Attach: (0x183C,23D,18B)  08/17/2010 12:36:12
          Last Detach: (0x183C,23E,1D6)  08/17/2010 12:36:13
                 Dbid: 1
        Log Signature: Create time:10/26/2005 11:28:02 Rand:11162883 Computer:
           OS Version: (5.2.3790 SP 2)

    Previous Full Backup:
            Log Gen: 5451-5451 (0x154b-0x154b)
               Mark: (0x154B,1A97,1DE)
               Mark: 04/13/2010 18:03:07

    Previous Incremental Backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

    Current Full Backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

    Current Shadow copy backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

         cpgUpgrade55Format: 0
        cpgUpgradeFreePages: 0
    cpgUpgradeSpaceMapPages: 0

           ECC Fix Success Count: found (746)
       Last ECC Fix Success Date: 08/04/2010 09:31:34
       Old ECC Fix Success Count: none
             ECC Fix Error Count: none
         Old ECC Fix Error Count: none
        Bad Checksum Error Count: none
    Old bad Checksum Error Count: none

    Operation completed successfully in 3.0 seconds.


    C:\Archivos de programa\Exchsrvr\bin>eseutil /ml "C:\Archivos de Programa\Exchsr
    vr\mdbdata\priv1.edb"

    Microsoft(R) Exchange Server Database Utilities
    Version 6.5
    Copyright (C) Microsoft Corporation. All Rights Reserved.

    Initiating FILE DUMP mode...

          Base name: pri
          Log file: C:\Archivos de Programa\Exchsrvr\mdbdata\priv1.edb
                    ERROR: Cannot read log file header. Error -514.

    Operation terminated with error -514 (JET_errBadLogVersion, Version of log file
    is not compatible with Jet version) after 1.0 seconds.




    C:\Archivos de programa\Exchsrvr\bin>

    martes, 17 de agosto de 2010 21:15
  • Dario, te comento que sobre la base ejecute los comandos eseutil /P y /D y luego hice un isinteg -s servidor -fix -test alltests. Asi y todo sigo sin poder montar los buzones. Te queria consultar si puedo instalar nuevamente exchange y levantar los buzones de los usuarios que los tengo en .pst. Esos backups lo hice con exmerge

     

    miércoles, 18 de agosto de 2010 17:27
  • El comando eseutil /ml esta mal ejecutado, de todas maneras parece que el backup no esta bien realizado. Podrías instalar el Exchange nuevamente y luego levantar los .pst con exmerge, pero no es lo más agradable.

    Si vas a hacer esto instala el servidor con el parametro /disasterrecovery, así podes utilizar el mismo nombre de equipo y te recupera información de Active Directory:

    http://technet.microsoft.com/en-us/library/aa997239(EXCHG.65).aspx

    Después podes levantar las bases vacias (dial tone):

    http://technet.microsoft.com/en-us/library/aa998947(EXCHG.65).aspx

    Y por ultimo con exmerge subis la info de los .pst.


    Dario Woitasen | MCITP: Enterprise Messaging Administrator | MCTS: Microsoft Exchange Server 2010, Configuration
    viernes, 20 de agosto de 2010 12:50