none
Terminal Server pierde conexión con impresoras RRS feed

  • Pregunta

  • Buen día, agradezco su ayuda con el siguiente problema que nos tiene de cabeza. Tenemos un servidor con Terminal Server sobre Windows Server 2008 R2 en un dominio Windows 2003 con un solo DC. Los usuarios de ese servidor obtienen sus impresoras desde otro servidor en red que hace las veces de servidor de impresión y que también está dentro del mismo dominio. El servidor de impresión es un equipo Windows 2003 con SP2. Los drivers de las impresoras de red son los últimos disponibles por el fabricante (usamos Ricoh solamente).

    Hemos notado que cuando el servidor de terminal pierde conexión de red con el controlador de dominio las impresoras desaparecen. Tampoco puedo examinar el servidor de impresión usando \\printserver desde el servidor de terminal pero puedo examinar otros servidores sin problema. Los otros equipos del dominio no tienen esete problema. Nos hemos dado cuenta de esto porque hemos tenido en estos días un par de problemas con el cableado de red.

    Reiniciar el servicio de Cola de Impresión no resuelve el problema. Tenemos otro servidor de Terminal (igual con Windows 2008 R2) con pocos usuarios y que presenta el mismo problema pero si reiniciamos el servicio de workstation (estación de trabajo) se restaura la conectividad. Eso no funciona en el primer servidor (motivo de esta consulta) porque éste tiene una alta carga de usuarios y al tratar de reiniciar el servicio de estación de trabajo nunca termina de detenerse y toca reiniciar el equipo para que se restaure la conectividad.

    Alguna idea de qué es lo que puede estar pasando? Alguna solución para el servidor de alta carga que no implique reiniciar el equipo?

    Xavier Villafuerte

     

     

     

    miércoles, 20 de octubre de 2010 20:01

Respuestas

  • Encontré que existe un servicio que está relacionado con esto aparte del de Cola de impresión. Se llama: "Redirector de puerto en modo usuario de Servicios de Escritorio remoto" En ocaciones lo reinicio y ya se pueden volver a las impresoras, además lo puse en inicio Automático ya que por default está en Manual.

     

     Si tienes un servidor HP Proliant, asegúrate de tener el firmware y drivers actualizados por completo. Esto me solucionó el problema a mí.

     

    Espero les ayude.

    • Editado XL5 miércoles, 23 de noviembre de 2011 0:56 update.
    • Propuesto como respuesta XL5 miércoles, 23 de noviembre de 2011 0:57
    • Marcado como respuesta Uriel AlmendraModerator martes, 2 de abril de 2013 15:59
    jueves, 10 de noviembre de 2011 16:24

Todas las respuestas

  • Usáis Easy Print Driver en el 2008 o usáis el driver de la impresora directamente instalado en el propio server de 2008?. Lo ideal es que los puestos de trabajo cliente tengan mapeada la impresora contra el servidor de imrpesión; y en el 2008R2 se use la EasyPrintDriver directamente; es así?
    -------- Salu2!! Javier Inglés - Microsoft Active Professional 2010
    viernes, 22 de octubre de 2010 6:13
    Moderador
  • En este caso en particular, usamos los drivers directo en el servidor porque son impresoras de red. Lo que hemos notado con el tiempo es que el problema se resuelve reiniciando el servicio de workstation pero cuando tienes una alta cantidad de usuarios en el servidor, el servicio nunca se reinicia y nos toca forzar el reinicio del servidor.
    Xavier Villafuerte - http://preempalverec.blogspot.com
    lunes, 9 de mayo de 2011 23:14
  • Hola Xavier,

    Lo ideal sería encontrar el origen del problema ya que el reinicio del servicio Wokrstation no es una solución efectiva.

    1. ¿El problema siempre te ocurre cuando existe perdida de conectividad entre los servidores?
    2. ¿ Cuantos usuarios soporta concurrentemente tu TS?
    3. ¿Cuantas  impresoras tienes configuradas en dicho servidor de impresion?

    Por otro lado, podrías revisar el Visor de Eventos del TS para concretar que eventID aparecen cuando te desaparecen las impresoras. Así mismo, es posible que alguno de los drivers esté generando algun problema en el servidor. Puede probar la siguiente herramienta para descartar que algun drivers sea el origen del problema.

    StressPrinters 1.3.2 for 32-bit and 64-bit Platforms
    http://support.citrix.com/article/CTX109374

    Esperamos tus comentarios.

     


    Un saludo,

    Tomas Hidalgo

    Colobora con el foro: Si la respuesta es de utilidad para resolver tu duda/problema, usa la opción "Marcar como repuesta". Otros usuarios con dudas similares -en un futuro- lo agradecerán.

    martes, 10 de mayo de 2011 15:16
    Moderador
  • Gracias Tomás. El problema ocurre cuando hay cualquier tipo de pérdida de conexión en el servidor. Nuestro TS está dimensionado para soportar más de 120 usuarios concurrentes y en un día normal tenemos un poco más de 115 sesiones activas al mismo tiempo. Nuestros usuarios obtienen un máximo de 2 impresoras por cada uno puesto que se les asigna a través de un script en base a su localización física; el script detecta si la impresora ya fue instalada y no trata de instalarla de nuevo. Usamos conexiones a las impresoras en base a la dirección UNC del servidor de impresión \\printserver\impresoracompartida por lo que no tenemos puertos LPT o físicos en el servidor de TS con los cuales hacer pruebas para la herramienta que indicas arriba.

    Nuestras impresoras son Ricoh y los drivers de 64 bits son los últimos ofrecidos por ellos para Windows 2008 R2.

    El visor de eventos no reporta nada relevante al problema.

    Lo que es para ripley es que cualquier otra cosa en el servidor funciona perfecto luego de restaurar la conectividad. Solo la conexión al servidor de impresión se pierde. Es importante aclarar que no es que tenemos pérdidas de conexión todos los días. Las que nos han pasado han ocurrido porque han existido fallas eléctricas que duraron demasiado (más de 1 hora) y los UPS de soporte de los equipos de red no soportaron la carga (los UPS de los servidores funcionaron perfecto y no se apagaron). Estamos hablando tal vez de menos de 5 eventos de este tipo en el último año.

     


    Xavier Villafuerte - http://preempalverec.blogspot.com
    martes, 10 de mayo de 2011 22:30
  • Me pasa lo mismo, mis usuarios/clientes dejan de ver las impresoras locales. Seguí las indicaciones de este artículo: http://blogs.msdn.com/b/rds/archive/2009/09/28/using-remote-desktop-easy-print-in-windows-7-and-windows-server-2008-r2.aspx y sin embargo pasa lo mismo. Para solucionarlo, he realizado algunas o todas estas acciones:
    -En el servidor de acceso que se presenta el incidente, ir a la carpeta: C:\Windows\System32\spool\PRINTERS  y verificamos que no hayan trabajos en la cola de impresión. Si son muy viejos (más de 15-30 minutos) he encontrado que lo mejor es eliminarlos.
    -Verificar que el proceso spoolsv.exe está ejecutándose y consumiendo recursos de CPU y memoria.
    -Reiniciar el servicio de cola impresión: Herramientas administrativas -> Servicios -> Cola de impresión. Seleccionarlo, clic derecho, reiniciar.
    Concluyendo que para algunos funciona y para otros no. Si reinician su computadora o cerrando su sesión funciona de nuevo, repito, en ocasiones. Es muy variable y por lo tanto frustrante. 
    ¿Alguien sabe qué debemos hacer?

    XL5
    • Editado XL5 miércoles, 28 de septiembre de 2011 18:23 liga/link
    miércoles, 28 de septiembre de 2011 18:22
  • Encontré que existe un servicio que está relacionado con esto aparte del de Cola de impresión. Se llama: "Redirector de puerto en modo usuario de Servicios de Escritorio remoto" En ocaciones lo reinicio y ya se pueden volver a las impresoras, además lo puse en inicio Automático ya que por default está en Manual.

     

     Si tienes un servidor HP Proliant, asegúrate de tener el firmware y drivers actualizados por completo. Esto me solucionó el problema a mí.

     

    Espero les ayude.

    • Editado XL5 miércoles, 23 de noviembre de 2011 0:56 update.
    • Propuesto como respuesta XL5 miércoles, 23 de noviembre de 2011 0:57
    • Marcado como respuesta Uriel AlmendraModerator martes, 2 de abril de 2013 15:59
    jueves, 10 de noviembre de 2011 16:24
  • Es lo que voy a intentar.....

    miércoles, 24 de julio de 2019 23:24