none
OWA 2007 no carga la pagina de inicio de sesion RRS feed

  • Pregunta

  • Señores tengo la siguiente situacion:

     

    Tengo un Exchange 2007 STD y el OWA no carga la pagina de inicio de sesion, después que le dije que ejecutará los comandos de Power Shell del articulo a continuación, a fin de resolver el mensaje de error de certificado que les aparecía a los usuarios de Outlook 2007.

     

    Warning message when you start Outlook 2007 and then connect to a mailbox that is hosted on an Exchange 2007-based server: "The name of the security certificate is invalid or does not match the name of the site.

    http://support.microsoft.com/kb/940726

     

     

    Lo extraño es que este procedimiento le he realizado en aproximadamente tres servidores de Exchange 2007 mas y no se ha presentado el problema.

     

    Lo que se me ocurre es remover y recrear el OWA con los comandos

     

    Remove-OwaVirtualDirectory "exchange (default web site)"

    Remove-OwaVirtualDirectory "public (default web site)"

    Remove-OwaVirtualDirectory "exchweb (default web site)"

    Remove-OwaVirtualDirectory "owa (default web site)"

     

    New-OwaVirtualDirectory "exchange" -OwaVersion Exchange2003or2000 -

    VirtualDirectoryType Mailboxes -WebSiteName "Default Web Site"

     

    New-OwaVirtualDirectory "public" -OwaVersion Exchange2003or2000 -

    VirtualDirectoryType PublicFolders -WebSiteName "Default Web Site"

     

    New-OwaVirtualDirectory "exchweb" -OwaVersion Exchange2003or2000 -

    VirtualDirectoryType Exchweb -WebSiteName "Default Web Site"

     

    New-OwaVirtualDirectory -name "owa" -OwaVersion Exchange2007 -WebSiteName

    "Default Web Site"

     

     

    SUGERENCIAS POR FAVOR.

     

    Ronald

     

     

     

    domingo, 31 de agosto de 2008 17:49

Todas las respuestas

  • No me queda muy claro cual es tu problema, pero entiendo que el problema es el certificado:

    Lo propio es que uses un certificado correcto, es decir, si tu OWA está en la URL: https://servidor.dominio.com/owa lo propio es que tengas un certificado que identifique servidor.dominio.com, ya que sino los navegadores te darán un error.

    Si por ej. tu servidor se llama exchange.dominio.local y exchange te genera el certificado autofirmado, lo va a hacer para esa máquina por defecto. Si tu quieres que por ej, desde el exterior accedan con otra url como te indicaba arriba te dará un error.

    También es conveniente que los clientes tengan ese certificado agregado como entidades raiz en las que se confía, esto lo puedes poner en todas las máquinas vía AD con una GPO o a mano.

    Revisate esto: http://technet.microsoft.com/en-us/library/bb851554(EXCHG.80).aspx

    Otra solución es tener tu entidad certificadora y solicitar un certificado y asignarlo, o bien solicitarlo a un tercero. Los certificados los puedes generar con múltiples nombres y asignarlos a los servicios que estimes oportunos.
    Te pego una respuesta que hice en este mismo foro por algo similar, relacionado con autodiscover http://forums.microsoft.com/technet-es/ShowPost.aspx?PostID=3675915&SiteID=30:



    Code Snippet
    New-ExchangeCertificate
    -DomainName
    correo.dominio.com,servidor.dominiowin.local,autodiscover.dominio.com,servidor,owa.dominio.com,webmail.dominio.com,webmail.dominio.org,nombresdedominio
    quevayaagestionar -SubjectName "dc=com,dc=dominio,o=Empresa
    S.A,cn=webmail.dominio.com" -PrivateKeyExportable:$True
    -GenerateRequest:$True -Path "C:\CertRequest.req"

     

     

     

    El contenido cd C:\certrequest.req lo pegas en la CA y descargas el certificado.

     

    Importas el certificado:



    Code Snippet
    Import-ExchangeCertificate
    -Path "C:\certificado.cer" -friendlyname "Certificado servicios de
    correo" | enable-exchangecertificate -services "IIS,POP,IMAP" 

     

     

     

    Por lo que el certificado te valdrá para que por DNS accedas a la máquina a través de cualquiera de los nombres:

    autodiscover.dominio.com

    correo.dominio.com

    servidor.dominiowin.local

    servidor

    owa.dominio.com

    ...etc...


    Espero que te sea de ayuda.


    lunes, 1 de septiembre de 2008 23:04
  • Hola.
    Yo tengo el mismo problema. Cada vez que accedo al webmail me dice que el certificado no es válido y desde un equipo normal, pues vale, le doy a continuar y por ahi pasa, pero en los PocketPC no puedo aceptar el certificado si intento sicronizarlas con exchange directamente. Necesito que instalar ese certificado pero no soy capaz.  La duda que tengo es a la hora de importar el contenido del archivo *.req en la CA, que plantilla debo usar? La de administrador o la de servidor Web... o cual? Uso la CA que he instalado en un controlador de mi propio dominio. El servidor de correo es un exchange 2007 en cluster con 2 win 2003 haciendo de transporte.
    Gracias y un saludo.
    miércoles, 29 de octubre de 2008 11:01
  • Debes usar el certificado raiz de la entidad, es el que deberás de importar en las pocket pc.

     

    Por ej: http://www.cacert.org/index.php?id=3

     

    Saludos.

    miércoles, 29 de octubre de 2008 11:12