none
nslookup RRS feed

  • Pregunta

  •  

    Hola a todos,

     

    Tengo un problema que consultarle y saber si alguie me puede ayudar tengo unos servidores y cada uno trabaja como controlador de dominio, el problema es que corro el comando nslookup desde la ventana de dos y me aparece lo siguiente:

     

    Microsoft Windows [Version 5.2.3790]
    (C) Copyright 1985-2003 Microsoft Corp.

    C:\Documents and Settings\Administrator>nslookup www.google.com.mx
    Server:  whs706.costco.com.mx
    Address:  170.167.106.210

    Name:    www.google.com.mx.com.mx
    Address:  66.226.75.118


    en lo que es name me arroja lo siguiente

    Name:    www.google.com.mx.com.mx

     

    lo que se hizo fue agregar una zona inversa reinicio los servicio del DNS y aparentemente corrige el error, ya que corro el comando nslookup y desaparece el error, pero si vuelvo a correr el comando por segunda vez, vuelve a aparecer el error


    C:\Documents and Settings\Administrator>nslookup www.google.com.mx
    Server:  whs706.costco.com.mx
    Address:  170.167.106.210

    DNS request timed out.
        timeout was 2 seconds.
    Non-authoritative answer:
    Name:    www.l.google.com
    Addresses:  74.125.19.99, 74.125.19.147, 74.125.19.103, 74.125.19.104
    Aliases:  www.google.com.mx, www.google.com


    Les agradecere si alguien me puede ayudar en decirme por que sucede esto y como puedo hacer para solucionar el problema. Mil gracias a todos.

    miércoles, 24 de septiembre de 2008 15:09

Respuestas

  • Es un comportamiento "normal" en un W2003; W2008 lo mejoró, y W2012 lo solucionó :-)

    El tema es que en USA, no usan sufijo de dominio de país. O sea ".com" es ".com", y no ".com.algo"

    El problema es que cuando se hace una búsqueda con el nombre no totalmente calificado, por ejemplo pones "server". El sistema trata primero con el sufijo de dominio propio de la máquina, y luego va quitando nombres del lado izquierdo del FQDN, hasta que se queda con dos sufijos, que es cuando se detiene

    Entonces termina buscando el nombre de, por ejemplo, nombreServidor.com.mx, y si realmente no eres el "dueño" de "com.mx" se produce el resultado antes mencionado :-)

    El tema ha sido tratado y solucionado varias veces en todo Internet, pon en un buscador "name devolution"

     


    Guillermo Delprato - Buenos Aires, Argentina
    Visite Windows Server - Todos los Paso a Paso
    MVP [Directory Services] - MCT - MCSE - MCSA
    MAP - MCC - MCSA Windows Server 2012
    MCSA Windows Server 2008 MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory / Network Configuration / Applications Configuration / Server Virtualization / Windows 7 Configuration / Windows 7 & Office 2010 Deployment / Vista Configuration
    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    miércoles, 10 de abril de 2013 11:49
    Moderador

Todas las respuestas

  • Agrega en las propiedades de tu placa de red un sufijo DNS "." Basicamente los dominios terminan en . en algunos casos este no se agrega. Entonces puedes forzarlo para asignarselo.

     

    La politica se encuentra en

    Computer Configuration->Administrative Template->Network->DNS Client->DNS Suffix Search List

     

    Deberias agregar solo el sufijo DNS "." (Solo el Punto sin las comillas)

     

    Puedes modificarla en en tu Default Domain Policy.

     

    Slds
    Sebastian del Rio

    miércoles, 24 de septiembre de 2008 17:10
    Moderador
  • hola, buen dia.

     

    muchas gracias por la ayuda, estoy haciendo pruebas en un servidor y aparentemente ya se soluciono el problema, posteriormente estare aplicando los cambios en mis demas equipos esperando que con esto ya se soluciones el problema, lo que si no entiendo es por que sucede esto si me reportan que anteriormente los servidores no tenian problema con el DNS, solo si me pudiesen explicar por que sucede.

     

    Gracias por la ayuda

    lunes, 29 de septiembre de 2008 13:58
  • saben si este es un comportamiento normal o es un error en mi dns o en mi directorio activo

    Quedo en espera de sus comentarios

    martes, 9 de abril de 2013 22:45
  • Es un comportamiento "normal" en un W2003; W2008 lo mejoró, y W2012 lo solucionó :-)

    El tema es que en USA, no usan sufijo de dominio de país. O sea ".com" es ".com", y no ".com.algo"

    El problema es que cuando se hace una búsqueda con el nombre no totalmente calificado, por ejemplo pones "server". El sistema trata primero con el sufijo de dominio propio de la máquina, y luego va quitando nombres del lado izquierdo del FQDN, hasta que se queda con dos sufijos, que es cuando se detiene

    Entonces termina buscando el nombre de, por ejemplo, nombreServidor.com.mx, y si realmente no eres el "dueño" de "com.mx" se produce el resultado antes mencionado :-)

    El tema ha sido tratado y solucionado varias veces en todo Internet, pon en un buscador "name devolution"

     


    Guillermo Delprato - Buenos Aires, Argentina
    Visite Windows Server - Todos los Paso a Paso
    MVP [Directory Services] - MCT - MCSE - MCSA
    MAP - MCC - MCSA Windows Server 2012
    MCSA Windows Server 2008 MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory / Network Configuration / Applications Configuration / Server Virtualization / Windows 7 Configuration / Windows 7 & Office 2010 Deployment / Vista Configuration
    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    miércoles, 10 de abril de 2013 11:49
    Moderador