none
Problemas tras la migración de Sharepoint Online 2010 a Sharepoint Online 2013 RRS feed

  • Pregunta

  • Hola me encuentro en una situación algo delicada y necesito alternativas sobre como proceder, intetaré explicarlo lo mejor posile:

    • Teniendo aún la versión de sharepoint online 2010 desarrollamos un gestor documental para el cual se definieron una biblioteca de documentos personalizada, unos tipos de contenido (documentos con plantilla y conjuntos documentales) personalizados y una serie de columnas personalizadas para estos contenidos. Tras crear este gestor documental se creó una lista de proyectos y un flujo de trabajo que se lanzaba con la creación de cada nuevo proyecto, el flujo, creaba una serie de conjuntos documentales en el gestor documental en base a ciertos valores de los campos del nuevo proyecto creado.
    • En un momento dado hace aproximadamente un mes y antes de la anunciada migración a sharepoint online 2013, el flujo de trabajo comenzó a completarse en un estado "error" en el cual la instancia del flujo no moría ni terminaba correctamente cargando el motor de flujos de trabajo innecesariamente. No obstante los conjuntos eran creados correctamente y se ejecutaban todos los pasos definidos en el flujo. Detecté que a partir de este suceso algunas características de los conjuntos documentales de sharepoint habían cambiado: la biblioteca les asignaba ahora un Id. de documento (antes no lo hacía) y las vistas definidas ahora los trataba como elementos de la bibliteca y no como carpetas (que era como lo había hecho hasta ese momento).
    • Trás abrir el caso en O365 las pruebas recreando el flujo de trabajo y probando posibles origenes para el error se aproximó la fecha de la migración a 2013 y me recomendaron desde microsoft esperar a la actualización del servicio y verificar si mis problemas se solventaban volviendo a definir el flujo en el nuevo motor de flujos de trabajo de Sharepoint Online 2013. Esperé pues a la actualización.
    • La actualización de la colección de sitios no presenta ningún problema y ya en la versión del 2013 vuelvo a reproducir los pasos del flujo de trabajo. Cuando el flujo se lanza ahora si que finaliza sin errores pero los pasos definidos en él pese a ser los mismos que en su versión 2010 no producen los efectos deseados. En primer lugar no crean los conjuntos documentales del tipo de contenido que se define y estos conjuntos han perdido características tales como las plantillas documentales que tienen disponibles y las vistas que se definen en cada uno de ellos.

    ¿Qué debo hacer? No puedo permitirme volver a definir la biblioteca, los tipos de contenido y las columnas para dichos contenidos ahora en la versión 2013 pues mi organización lleva algunos meses trabajando con el gestor y sería una inversión de tiempo importante y un problema logístico a la hora de pasar los documentos al nuevo gestor. ¿Tengo alternativas? ¿Un nuevo caso de soporte con O365 arrojaría otra solución que no fuese ésta?

    Por favor admito todo tipo de sugerencias y aportes al tema pues me parece algo crítico y extremadamente preocupante que dice mucho del proceso de actualización del paquete de O365 a Sharepoint Online 2013. Gracias por vuestra seguro que útil ayuda.

    viernes, 7 de junio de 2013 12:52

Todas las respuestas

  • Hola David,

    ¿Cómo creaste todos los componentes: mediante la interfaz de usuario? Si es así, y viendo los problemas que tienes, yo abriría el caso de soporte que comentas para que te solucionen el problema al que te han llevado por esperar y no decirte que preparares un plan de contingecia para tu solución...entiendo que estás en este caso, ya que si todos los tipos de contenidos y plantillas las hubieses definido mediante los correspondientes paquetes WSP creados con Visual Studio, recrear la solución no te llevaría mucho tiempo.

    Un saludo


    ------------------------------------------------------------
    Juan Carlos González Martín MVP de SharePoint Server
    Director revista CompartiMOSS: http://www.compartimoss.com
    Blog: http://geeks.ms/blogs/ciin
    Twitter: @jcgm1978
    ------------------------------------------------------------

    viernes, 7 de junio de 2013 16:14
  • Hola Juan Carlos gracias por contestar. Te confirmo que todos los componentes han sido creados mediante la interfaz de usuario de ahí el coste que me supondría volver a generar la solución en la versión 2013. El caso ya está en el soporte de O365, espero que actúen lo antes posible. Actualizaré con más información sobre el caso.

    Saludos.

    lunes, 10 de junio de 2013 7:02