locked
Ip y máquina virtual RRS feed

  • Pregunta

  •  

    Felices fiestas a todos!!!!!

    Aquí volvemos con un tema no resuelto respecto de mis máquinas virtuales con vmWare Workstation 6.5

     

    Cuando conecto un programa P2P desde el host tengo IP alta, desde las virtuales no lo doy conseguido y he probado infinitas posibilidades, a pesar de ello siempre consigo IP baja. Y ya es una cuestión de amor propio.

     

    Mi configuración es la siguiente. Me conecto a traves de un router en el que tengo abiertos los puertos TCP y UDP.

    Mi maquina host tiene una ip fija que yo le he asignado y se conecta con una Conexión de area local  que usa un VIA Rhine II Fast Ethernet Adapter

    Me conecto sin problemas y consigo Ip alta.

     

    En la virtual tengo seleccionado Bridged Connected directly to the physical network

    Abro el Virtual Network Editor y tengo lo siguiente:

    En la primera pestaña Summary:

    Aparecen como Enabled VMNet1(NAT) y VMNet8 (Host-only) la otra  opcion VMNet0(Bridged)  no aparece como Enabled.

    En la pestaña Host Virtual Netwok Mapping tengo seleccionado VIA Rhine II Fast Ethernet Adapter

    En la pestaña Host Virtual Addapters  aparece Conexión de Area local 2 WMNet1 y aparece como ENABLED y Conexión de Area local 3 WMNet8 y ENABLED

     

    En el System Tray del Escritorio de windows al ponerse sobre el icono de conexiones aparecen dos:

    Red Acceso:Local e Internet (red privada) Conexión de area local

    Red no identificada Acceso: Solo local (red publica) Conexión de area local 2

     

    ¿Alguna idea?

     

     

     

     

    martes, 30 de diciembre de 2008 16:31

Respuestas

  •  lucasas Escribió:

    Cuando dices Ponla fija en la virtual ¿a que te refieres (a Propiedades de conexión de area local)? ¿en que lugar(en el icono del system tray)?


    Me refiero a las conexiones de red (Panel de Control). La idea es ponerla fija para que no cambie....

    Y en el router supongo que haces NAT a esa IP... ¿no?...

    Un saludo,
    martes, 30 de diciembre de 2008 18:08
  •  lucasas Escribió:

    Por cierto, ¿la conexión de area local que crea el VMware en el host y que aparece como red no identificada se puede borrar?


    Bueno... vamos a optimizar un poco ese sistema. Solo es válido -por si acaso lo lee alguien mas- para casos como el tuyo: es decir que usas modo bridge (que ademas es el aconsejado).

    EN este caso:

    1) Panel de Control, Herramientas Administrativas, Servicios. Localiza el VMWare DCP Server y VMWare NAT, paralos, y pon el arranque en Manual (está en automatico). Solo estos dos servicios.

    2) Las dos interfaces de red que crea... ponlas en Disabled. (no las borres).

    Un saludo,
    martes, 30 de diciembre de 2008 18:50

Todas las respuestas

  •  lucasas Escribió:
    En la pestaña Host Virtual Netwok Mapping tengo seleccionado VIA Rhine II Fast Ethernet Adapter[/quote]

    ¿en la VMnet0, no?... bien si no es así, ponselo. Luego en la configuracion de la maquina virtual, en la red, ponlo en "Custom" y apunta a esa VMNet0.

    Arrancas la maquina virtual, y miras con IPCONFIG la IP que te ha dado el router (debe dartela, verificalo). Ponla fija en la virtual y luego reconfigura el router para que los puertos de la P2P están apuntando a la IP de la virtual.

    Un saludo,
    martes, 30 de diciembre de 2008 17:51
  • Está en la pestaña Host Virtual Network Mapping y en VMnet0 también apunta ahí, a la tarjeta del anfitrión. En la configuración de la red apunta a Custom VMnet0 también.

    Hago un IPCONFIG y me da:

     

    Configuración IP de Windows


    Adaptador de Ethernet Conexión de área local:

       Sufijo DNS específico para la conexión. . :
       Vínculo: dirección IPv6 local. . . : fe80::a0d3:469f:51e9:9820%10
       Dirección IPv4. . . . . . . . . . . . . . : 192.168.1.35
       Máscara de subred . . . . . . . . . . . . : 255.255.255.0
       Puerta de enlace predeterminada . . . . . : 192.168.1.1

     

     

    Cuando dices Ponla fija en la virtual ¿a que te refieres (a Propiedades de conexión de area local)? ¿en que lugar(en el icono del system tray)?

    martes, 30 de diciembre de 2008 18:05
  •  lucasas Escribió:

    Cuando dices Ponla fija en la virtual ¿a que te refieres (a Propiedades de conexión de area local)? ¿en que lugar(en el icono del system tray)?


    Me refiero a las conexiones de red (Panel de Control). La idea es ponerla fija para que no cambie....

    Y en el router supongo que haces NAT a esa IP... ¿no?...

    Un saludo,
    martes, 30 de diciembre de 2008 18:08
  •  

    Si, ahí están fijos esos datos que arroja el Ipconfig y en el router están abiertos los puertos TCP y UDP para esa dirección 192.168.1.35 (todo esto lo estoy configurando en el OS virtual) Doy por sentado que no es en el anfitrion ¿no?

     

     

    Con hacer NAT a esa Ip en el router ¿a que te refieres?

    Yo lo que hago es entrar en el NAT del router, de ahí en la opción SUA y pongo los puertos y la ip en el Edit SUA/NAT Server Set

     

     

     

    martes, 30 de diciembre de 2008 18:14
  • RESUELTO!!!!

    Todo correcto pero mira que soy burro, al final tenía mal la ip en el router, en lugar de 35 tenía 37. Manda pelotas la de horas que le he dedicado a un número!!!! Al final me servirá para otra vez.

    Por cierto, ¿la conexión de area local que crea el VMware en el host y que aparece como red no identificada se puede borrar?

    martes, 30 de diciembre de 2008 18:39
  •  lucasas Escribió:

    Por cierto, ¿la conexión de area local que crea el VMware en el host y que aparece como red no identificada se puede borrar?


    Bueno... vamos a optimizar un poco ese sistema. Solo es válido -por si acaso lo lee alguien mas- para casos como el tuyo: es decir que usas modo bridge (que ademas es el aconsejado).

    EN este caso:

    1) Panel de Control, Herramientas Administrativas, Servicios. Localiza el VMWare DCP Server y VMWare NAT, paralos, y pon el arranque en Manual (está en automatico). Solo estos dos servicios.

    2) Las dos interfaces de red que crea... ponlas en Disabled. (no las borres).

    Un saludo,
    martes, 30 de diciembre de 2008 18:50
  • A sus órdenes!!!

    Todo listo.

    martes, 30 de diciembre de 2008 19:27