none
Problema con DNS con salida a la pagina Web RRS feed

  • Pregunta

  • Buenas, hemos migrado nuestra pagina web a un hosting externo y cuando colocamos el registro DNS hacia el nuevo servidor este no permite, tendra algo que ver que el dominio de la red sea el mismo de la pagina web, en todo caso como podría solucionarlo.

    Grover Vásquez

    miércoles, 20 de febrero de 2013 17:36

Respuestas

  • Hola grovervas!

    Que bueno que pudiste solucionar inicialmente tu problema! En relación a lo que comentás, a veces esto sucede porque tu dominio interno tiene el mismo nombre que tu dominio externo público, razón por la cual cuando tus clientes internos piden por la web, van a parar a algún lugar que no es el correcto. La solución ante esto es realizar un Split DNS:

    Entiendo que cuando decís "ya colocamos en nuestro dns interno los registros dns y tampoco funciona" lo que hiciste fue ingresar a tu zona interna de Active Directory, poner un registro "www" y apuntarlo a la dirección IP pública de tu sitio (donde está ahora alojado). Si esto no te funciona, te sugiero lo siguiente:

    • Verificá desde un cliente interno con nslookup que te resuelve cuando ingresás tu web (por ejemplo www.misitio.com). Lo esperable es que salga la dirección pública donde ahora tenés la web.
    • Si lo anterior está ok, verificá a través de un tracert el viaje del paquete. Debería llegar a tu servidor web destino.
    • Si esto está ok, vaciá el cache de tu servidor DNS interno de AD. How to clear bad information in Active Directory-integrated DNS: http://support.microsoft.com/kb/305967 

    Ante todo, también, verificá que los clientes internos tengan como DNS a tus servidores controladores de dominio de tu infraestructura.

    Esperamos tu feedback con el resultado.

    Saludos!!


    Pablo Ariel Di Loreto
    IT Consultant

    This posting is provided "AS IS" with no warranties and confers no rights! Always test ANY suggestion in a test environment before implementing!

    • Marcado como respuesta Uriel Almendra jueves, 27 de junio de 2013 16:20
    sábado, 23 de febrero de 2013 21:51

Todas las respuestas

  • Hola grovervas!

    No entiendo que querés decir cuando comentás que "cuando colocamos el registro DNS hacia el nuevo servidor este no permite". Me surgen las siguientes preguntas:

    • ¿Dónde tenés tu zona DNS pública?
    • ¿Qué error aparece?

    Gracias! Esperamos tu feedback!


    Pablo Ariel Di Loreto
    IT Consultant

    This posting is provided "AS IS" with no warranties and confers no rights! Always test ANY suggestion in a test environment before implementing!

    jueves, 21 de febrero de 2013 3:24
  • Te comento nuevamente, tenemos nuestros DNS publicos con nuestro proveedor de servicio, estos apuntaban a nuestro IP publico que tenemos con ellos, pero ahora hemos cambiado por un servicio de hosting, para eso ellos cambiaron nuestro sregistros DNS hacia ese nuevo hosting, todo funciona normal desde internet, pero desde nuestra red LAN no se logra llegar, ya colocamos en nuestro dns interno los registros dns y tampoco funciona, pero al hacer ping se me da respuesta el nuevo ip.

    Grover Vásquez

    viernes, 22 de febrero de 2013 15:21
  • Hola grovervas!

    Que bueno que pudiste solucionar inicialmente tu problema! En relación a lo que comentás, a veces esto sucede porque tu dominio interno tiene el mismo nombre que tu dominio externo público, razón por la cual cuando tus clientes internos piden por la web, van a parar a algún lugar que no es el correcto. La solución ante esto es realizar un Split DNS:

    Entiendo que cuando decís "ya colocamos en nuestro dns interno los registros dns y tampoco funciona" lo que hiciste fue ingresar a tu zona interna de Active Directory, poner un registro "www" y apuntarlo a la dirección IP pública de tu sitio (donde está ahora alojado). Si esto no te funciona, te sugiero lo siguiente:

    • Verificá desde un cliente interno con nslookup que te resuelve cuando ingresás tu web (por ejemplo www.misitio.com). Lo esperable es que salga la dirección pública donde ahora tenés la web.
    • Si lo anterior está ok, verificá a través de un tracert el viaje del paquete. Debería llegar a tu servidor web destino.
    • Si esto está ok, vaciá el cache de tu servidor DNS interno de AD. How to clear bad information in Active Directory-integrated DNS: http://support.microsoft.com/kb/305967 

    Ante todo, también, verificá que los clientes internos tengan como DNS a tus servidores controladores de dominio de tu infraestructura.

    Esperamos tu feedback con el resultado.

    Saludos!!


    Pablo Ariel Di Loreto
    IT Consultant

    This posting is provided "AS IS" with no warranties and confers no rights! Always test ANY suggestion in a test environment before implementing!

    • Marcado como respuesta Uriel Almendra jueves, 27 de junio de 2013 16:20
    sábado, 23 de febrero de 2013 21:51
  • Hola grovervas!

    ¿Te han servidor los datos que te pasamos? ¿Pudiste solucionar tu problema?

    Saludos!


    Pablo Ariel Di Loreto
    IT Consultant

    This posting is provided "AS IS" with no warranties and confers no rights! Always test ANY suggestion in a test environment before implementing!

    martes, 5 de marzo de 2013 4:17