none
Como salir por un gateway concreto al consultar una determinada web (W2003 server) RRS feed

  • Pregunta

  • Hola, tengo W2003 Enterprise server SP 2 y me ocurre algo curioso. Como puerta de enlace en este servidor tengo la de el router de mi isp, y como dns la ip del propio servidor ya que es el controlador del dominio.

    En los clientes tambien tengo como gateway la ip del router de mi isp pero me ocurre algo extraño y es que no puedo acceder a dos webs concretas de diferentes proveedores. Són webs https, con conexión segura. Desde fuera de mi red si puedo acceder correctamente.

    Luego tengo dos routers más de isp's diferentes y, si cambio la puerta de enlace en algún equipo de mi domino por la de uno de estos routers puedo acceder perfectamente.

    Estos routers están dentro de la misma red, así que no acabo de entender que ocurre. He hablado con mi isp y me comenta que no hay ninguna restricción al respecto ni nigún puerto cerrado. Como nadie sabe decirme que ocurreo,  lo que queria saber al menos es como puedo configurar en mi servidor para que, cuando desde alguna máquina del dominio se consulte a una dirección web concreta, salga por un gateway concreto. ¿como puedo hacer esto?.

    Muchas gracias.

    lunes, 7 de mayo de 2012 11:07

Respuestas

  • Hola, hay un dato importante que está faltando :)

    Los clientes con problemas ¿a qué DNS o DNSs están apuntando?

     


    Guillermo Delprato - Buenos Aires, Argentina
    Visite Notas Windows Server
    MVP - MCT - MCSE - MCSA
    MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory/Network Configuration/Applications Configuration/Server Virtualization/Windows 7 Configuration/Windows 7 & Office 2010 Deployment/Vista Configuration
    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    lunes, 7 de mayo de 2012 11:55
    Moderador
  • No puedes rutear a una URL, aunque si puedes rutear por IP si tienes la IP del sitio web puedes crear con el comando route add una ruta para que todo el trafico a la IP que tu quieras salga por la puerta de enlace que tu definas

    Ejemplo de comando, donde 10.0.0.0 deberia ser la IP del webserver mask si es una IP fija puedes poner 255.255.255.255 y luego el gateway

    route add 10.0.0.0 mask 255.0.0.0 192.168.0.1

    Por otro lado estaba pensando a nivel de DNS , pero eso seria solo resolucion y no cambiaria el enlace por el que sales ... creo que la opcion que menciono arriba pareciera ser la mas apropiada para tu escenario


    Sebastian del Rio - MCP - MCSA +S - MCSE +S - MCITP:Enterprise Administrator Buenos Aires - Argentina Este mensaje se proporciona "como está" sin garantías de ninguna clase, y no otorga ningún derecho. Ud. asume los riesgos


    lunes, 7 de mayo de 2012 13:29
    Moderador
  • Hola LeroyBrown,

    Bueno veo que necesitamos mas contexto, tu estas seguro que es un problema de ruteo o es un problema de resolucion ?

    1 . Intenta hacer las siguientes pruebas

    nslookup -q=any dominio
    nslookup -q=any dominio direccionIPDNSdelISP


    En cuanto a configurar desde el servidor no te sera una solucion viable (a menos que estuvieras utilizando RRAS por ejemplo y el servidor estuviera conectado a los tres ISPs ), ten en cuenta que quien inicia la comunicacion y la envia a donde corresponde es el cliente, ahora lo raro es .. el servidor tiene el mismo default gateway que tus clientes y el si sale ? o el default gateway es diferente ?


    Sebastian del Rio - MCP - MCSA +S - MCSE +S - MCITP:Enterprise Administrator Buenos Aires - Argentina Este mensaje se proporciona "como está" sin garantías de ninguna clase, y no otorga ningún derecho. Ud. asume los riesgos


    lunes, 7 de mayo de 2012 14:59
    Moderador
  • OK, entonces puedes configurar la ruta en los clienes con el parametro -p para que quede persistente incluso si reinicias.  Si quieres analizar por que esa pagina no funciona con el gateway actual deberias sacar tracerts a la pagina saliendo por ambos proveedores y verificar si algun router esta frenando el camino hacia la pagina.


    Sebastian del Rio - MCP - MCSA +S - MCSE +S - MCITP:Enterprise Administrator Buenos Aires - Argentina Este mensaje se proporciona "como está" sin garantías de ninguna clase, y no otorga ningún derecho. Ud. asume los riesgos

    lunes, 7 de mayo de 2012 17:52
    Moderador
  • Hola Sebastián, yo creo que sería mejor saber qué es lo que no funciona :)

    Primero ¿NSLOOKUP resuelve a la IP correcta?
    Y segundo ¿qué sucede con un TRACERT?
    Por supuesto siempre con la conexión del ISP original

    Si, ya sé, cambiando la ruta se soluciona, pero creo que sería mejor ver el por qué con un ISP no funciona

     


    Guillermo Delprato - Buenos Aires, Argentina
    Visite Notas Windows Server
    MVP - MCT - MCSE - MCSA
    MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory/Network Configuration/Applications Configuration/Server Virtualization/Windows 7 Configuration/Windows 7 & Office 2010 Deployment/Vista Configuration
    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    lunes, 7 de mayo de 2012 18:16
    Moderador
  • En ese caso necesitamos mas contexto, cual es el error que se da cuado sales por un lado o por el otro ? Resuelve el mismo nombre saliendo por un enlace u el otro ? Hay diferencias en cuanto al ruteo en el tracert ? Cual es la pagina a la que no puedes ingresar  ?  Esa pagina existe en tu red o es una pagina externa  ?

    Quizas tomar una traza de red cuando sales por un proveedor u otro podria darnos alguna pista de lo que esta sucediendo ? Puedes utilizar Network monitor, crea una traza de red en la cual reproduzcas el problema y otra en la cual funciona correctamente mediante el proveedor, puedes analizar las trazas o puedo intentar mirarlas por ti ni bien disponga de tiempo :).


    Sebastian del Rio - MCP - MCSA +S - MCSE +S - MCITP:Enterprise Administrator Buenos Aires - Argentina Este mensaje se proporciona "como está" sin garantías de ninguna clase, y no otorga ningún derecho. Ud. asume los riesgos

    martes, 8 de mayo de 2012 11:41
    Moderador

Todas las respuestas

  • Hola, hay un dato importante que está faltando :)

    Los clientes con problemas ¿a qué DNS o DNSs están apuntando?

     


    Guillermo Delprato - Buenos Aires, Argentina
    Visite Notas Windows Server
    MVP - MCT - MCSE - MCSA
    MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory/Network Configuration/Applications Configuration/Server Virtualization/Windows 7 Configuration/Windows 7 & Office 2010 Deployment/Vista Configuration
    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    lunes, 7 de mayo de 2012 11:55
    Moderador
  • Gracias por responder. Apuntan al servidor de dominio (que tambien es el servidor de dns's) que estoy comentando. Los clientes que no pueden acceder són todos los del dominio, ya que todos apuntan al mismo servidor.

    Un saludo.

    lunes, 7 de mayo de 2012 12:24
  • No puedes rutear a una URL, aunque si puedes rutear por IP si tienes la IP del sitio web puedes crear con el comando route add una ruta para que todo el trafico a la IP que tu quieras salga por la puerta de enlace que tu definas

    Ejemplo de comando, donde 10.0.0.0 deberia ser la IP del webserver mask si es una IP fija puedes poner 255.255.255.255 y luego el gateway

    route add 10.0.0.0 mask 255.0.0.0 192.168.0.1

    Por otro lado estaba pensando a nivel de DNS , pero eso seria solo resolucion y no cambiaria el enlace por el que sales ... creo que la opcion que menciono arriba pareciera ser la mas apropiada para tu escenario


    Sebastian del Rio - MCP - MCSA +S - MCSE +S - MCITP:Enterprise Administrator Buenos Aires - Argentina Este mensaje se proporciona "como está" sin garantías de ninguna clase, y no otorga ningún derecho. Ud. asume los riesgos


    lunes, 7 de mayo de 2012 13:29
    Moderador
  • Muchas gracias, pero eso sería hacerlo por máquina ¿no?; lo he probado sólo en el servidor y desde este sí encuentra la url, pero no desde las máquinas.

    Un saludo.

    lunes, 7 de mayo de 2012 14:12
  • Hola LeroyBrown,

    Bueno veo que necesitamos mas contexto, tu estas seguro que es un problema de ruteo o es un problema de resolucion ?

    1 . Intenta hacer las siguientes pruebas

    nslookup -q=any dominio
    nslookup -q=any dominio direccionIPDNSdelISP


    En cuanto a configurar desde el servidor no te sera una solucion viable (a menos que estuvieras utilizando RRAS por ejemplo y el servidor estuviera conectado a los tres ISPs ), ten en cuenta que quien inicia la comunicacion y la envia a donde corresponde es el cliente, ahora lo raro es .. el servidor tiene el mismo default gateway que tus clientes y el si sale ? o el default gateway es diferente ?


    Sebastian del Rio - MCP - MCSA +S - MCSE +S - MCITP:Enterprise Administrator Buenos Aires - Argentina Este mensaje se proporciona "como está" sin garantías de ninguna clase, y no otorga ningún derecho. Ud. asume los riesgos


    lunes, 7 de mayo de 2012 14:59
    Moderador
  • Gracias por responder. No, el servidor tiene el mismo gateway que los clientes, ahora sale porque he hecho lo del "route".

    Un saludo.

    lunes, 7 de mayo de 2012 16:05
  • OK, entonces puedes configurar la ruta en los clienes con el parametro -p para que quede persistente incluso si reinicias.  Si quieres analizar por que esa pagina no funciona con el gateway actual deberias sacar tracerts a la pagina saliendo por ambos proveedores y verificar si algun router esta frenando el camino hacia la pagina.


    Sebastian del Rio - MCP - MCSA +S - MCSE +S - MCITP:Enterprise Administrator Buenos Aires - Argentina Este mensaje se proporciona "como está" sin garantías de ninguna clase, y no otorga ningún derecho. Ud. asume los riesgos

    lunes, 7 de mayo de 2012 17:52
    Moderador
  • Hola Sebastián, yo creo que sería mejor saber qué es lo que no funciona :)

    Primero ¿NSLOOKUP resuelve a la IP correcta?
    Y segundo ¿qué sucede con un TRACERT?
    Por supuesto siempre con la conexión del ISP original

    Si, ya sé, cambiando la ruta se soluciona, pero creo que sería mejor ver el por qué con un ISP no funciona

     


    Guillermo Delprato - Buenos Aires, Argentina
    Visite Notas Windows Server
    MVP - MCT - MCSE - MCSA
    MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory/Network Configuration/Applications Configuration/Server Virtualization/Windows 7 Configuration/Windows 7 & Office 2010 Deployment/Vista Configuration
    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    lunes, 7 de mayo de 2012 18:16
    Moderador
  • Gracias a los dos. Con un tracert llega perfectamente y con nslookup tambien, incluso la página en cuestion responde con un ping; es al acceder via https.

    Sí que puedo hacer los mismo en todas las máquinas pero no es plan, querria saber que pasa porque no me parece normal.

    Bueno, muchas gracias por la ayuda.

    martes, 8 de mayo de 2012 7:06
  • En ese caso necesitamos mas contexto, cual es el error que se da cuado sales por un lado o por el otro ? Resuelve el mismo nombre saliendo por un enlace u el otro ? Hay diferencias en cuanto al ruteo en el tracert ? Cual es la pagina a la que no puedes ingresar  ?  Esa pagina existe en tu red o es una pagina externa  ?

    Quizas tomar una traza de red cuando sales por un proveedor u otro podria darnos alguna pista de lo que esta sucediendo ? Puedes utilizar Network monitor, crea una traza de red en la cual reproduzcas el problema y otra en la cual funciona correctamente mediante el proveedor, puedes analizar las trazas o puedo intentar mirarlas por ti ni bien disponga de tiempo :).


    Sebastian del Rio - MCP - MCSA +S - MCSE +S - MCITP:Enterprise Administrator Buenos Aires - Argentina Este mensaje se proporciona "como está" sin garantías de ninguna clase, y no otorga ningún derecho. Ud. asume los riesgos

    martes, 8 de mayo de 2012 11:41
    Moderador