none
Reinstalar domain controller 2008R2 RRS feed

  • Pregunta

  • Tengo un controlador de dominio que me gustaria cambiar de maquina conservando nombre e IP ya que hay bastantes servicios exteriores que los utilizan y no me gustaria tener que cambiarlo todo.

    Tenia pensado hacer un dcpromo para degradarlo a maquina dentro del dominio para despues eliminarlo del dominio y hacer una instalacion de cero en la maquina nueva, pero al ejecutar dcpromo me dice: "No se pudo detectar si se instalaron los binarios de los servicios de dominio de Active Directory."

    El AD tiene tres controladores, cada uno en un site diferente. Los tres roles (RID, controlador principal e infraestructura) no los tiene este servidor, pero si tiene catalogo global por ser el unico en este site.

    Es buena idea lo que tenia pensado?

    Como soluciono el problema del dcpromo?

    Gracias. 

    lunes, 24 de enero de 2011 16:29

Respuestas

  • Bueno, pues gracias al soporte de Microsoft lo hemos solucionado.

    Siguendo, mas o menos los pasos de esta pagina: http://blogs.technet.com/b/roplatforms/archive/2010/05/12/how-to-fix-server-manager-errors-after-installing-updates-hresult-0x800f0818-hresult-0x800b0100.aspx

    Solo que despues de dar unas vueltas.

    He seguido al pie de la letra estas indicaciones y no funcionaba.
    Reinicie el servidor y seguia igual.
    En el log habia un fallo y tenia que copiar:
    package_for_kb979687_rtm~31bf3856ad364e35~amd64~~6.1.1.2.cat
    package_for_kb979687_rtm~31bf3856ad364e35~amd64~~6.1.1.2.cat
     
    Pase de nuevo la herramienta y el resultado fue el mismo.
    Repeti el proceso y seguia igual.
    Despues he observado que al descomprimir el Windows6.1-KB979687-x64.cab, que en mi caso era el que daba el error generaba el fichero package_for_kb979687_rtm~31bf3856ad364e35~amd64~~6.1.1.2.cat que era diferente al update.mum que segun el paso 2 hay que cambiar el nombre y copiar. Copie el fichero que se genera con el nombre completo y ha funcionado.
     
    En el administrador del servidor ya veo los roles y al ejecutar el dcpromo ya me aparece el asistente, por lo que he podido despromocionar el equipo como queria.
     
    Muchas gracias por la ayuda.
    • Marcado como respuesta MartinezAlegre martes, 1 de febrero de 2011 18:00
    martes, 1 de febrero de 2011 18:00

Todas las respuestas

  • Hola,

    Lo que quieres hacer no hay problema, tienes que quitarlo como Catalogo Global y sin problema puedes correr el DCPROMO para degradarlo de la plataforma, una ves que el proceso serealizo por completo, puedes reinstalarlo con el mismo nombre y volverlo a promover.

    Tienes que ver tambien si el equipo no es DNS Server, ya que llegado el caso, mantener tambien el mismo servicio configurado en el server que se desinstalara.-

    Salu2


    Leonardo Ponti MCSA - MCSE - MVA - MAP
    lunes, 24 de enero de 2011 17:48
    Moderador
  • Gracias por tu respuesta Leo.

    He quitado el catalogo global de este servidor, pero al ejecutar DCPROMO obtengo el mismo error.

    martes, 25 de enero de 2011 9:51
  • Hola,

    Si vas a Server Manager, tienes el rol instalado?, ese Controlador de Dominio, lo promovieron instalando antes los binarios o corrieron directamente el DCPROMO? (corriendo la segunda opcion directamente, tambien te tendria que instalar antes los binarios, pero quiero ver que pasos hicieron para descartar algun error en esos pasos...)

    Salu2


    Leonardo Ponti MCSA - MCSE - MVA - MAP
    martes, 25 de enero de 2011 15:58
    Moderador
  • En server manager no veo los roles que tiene instalados, simplemente cuando arranco el server manager me aparece recopilando datos y un momento despues Error. Los enlaces de Agregar roles y quitar roles estan , pero no son "pinchables"

    El orden de instalacion supongo que seria desde el server manager instale el rol y despues el dcpromo, es como lo he hecho siempre.

    Saludos.

    martes, 25 de enero de 2011 16:13
  • Hola

    Que error te aparece al refresh de roles y si aparece algo en el log de eventos, por favor comentanos.-

    Salu2


    Leonardo Ponti MCSA - MCSE - MVA - MAP
    martes, 25 de enero de 2011 17:11
    Moderador
  • Simplemente aparece Error. Puedes verlo en http://extranet.diariodeleon.es/microsoft/Error-roles.png

    El mensaje superpuesto es lo que aparece en el enlace inferior "Detalles del error".

    En el visor de eventos veo dos errores y una advertencia, lo acabo de reiniciar y entro de nuevo en el administrador del servidor.

    La unica advertencia que me aparece es la de la mejora de seguridad si rechazo los enalces LDAP de tipo SASL (ID de evento 2886), el visor de eventos/Roles/Servicios de dominio

    Aparecen dos errorres: http://extranet.diariodeleon.es/microsoft/Evento1.png y http://extranet.diariodeleon.es/microsoft/Evento2.png

    Saludos.

     

    martes, 25 de enero de 2011 17:57
  • Hola,

    Como instalas los fixes en el servidor?, directamente desde Windows Update o tienes por ejemplo WSUS?

    Por el error, me suena algun fix que fue instalado en el server y esta generando el error que comentas, podrias desinstalar los fixes instalados de no ser muchos?

    Salu2


    Leonardo Ponti MCSA - MCSE - MVA - MAP
    martes, 25 de enero de 2011 19:23
    Moderador
  • Los instalo a traves de WSUS.

    Desinstalo todas? Hay 95 y debo desinstalarlas una a una, supongo que con algun reinicio que otro ¿no?

     

    miércoles, 26 de enero de 2011 10:57
  • Hola,

    Recuerdas si con anterioridad veias bien los roles desde el Manager?, tal vez no tengas que desinstalar todos, sino hacer la prueba de quitar tandas de 10, reiniciar el server y ver que resultados tienes, hasta encontrar el fix que te presento el problema, seguramente quitando habilitacion de filtros que se usan..., eso no quita que luego no lo puedas volver a instalar, el tema es al encontrar cual es el fix que trae el inconveniente, es quitarlo, reiniciar el server y volverlo a instalar.-

    Salu2


    Leonardo Ponti MCSA - MCSE - MVA - MAP
    miércoles, 26 de enero de 2011 13:47
    Moderador
  • He abierto caso con Microsoft, por el momento estan evaluando logs, en cuanto haya novedades las pongo por aqui.

    Saludos.

    jueves, 27 de enero de 2011 9:40
  • Hola,

    Si persiste el problema y para evitar hacer el trabajo con los fixes sobre un equipo que hasta sera reinstalado, otra opcion es eliminar el Controlador de dominio de tu infraestructura de AD en forma manual y no mediante GUI de DCPROMO (cuyo proceso no te esta funcionando).

    Salu2


    Leonardo Ponti MCSA - MCSE - MVA - MAP
    jueves, 27 de enero de 2011 12:22
    Moderador
  • Te refieres a apagar el equipo y eliminar todas las referencias en el AD?

    Lo habia pensado, pero creo que es como rendirse antes de empezar a pelear, si consigo hacerlo de forma ordenada lo prefiero.

    Gracias.

    jueves, 27 de enero de 2011 12:33
  • Hola,

    Claro, esto lo comento sin saber con que tiempo cuentas para hacer la reinstalacion, osea no veo motivo para perder mucho tiempo en un equipo que sera reinstalado, ahora si cuentas con tiempo y tomando el desafio, por supuesto se pueden hacer mas intentos (ejemplo, con ayuda de PowerShell, forzar la despromocion con linea de comando en el equipo en cuestion).

    Salu2


    Leonardo Ponti MCSA - MCSE - MVA - MAP
    jueves, 27 de enero de 2011 14:21
    Moderador
  • Hola MartinesAlegre

    Hay algún avance en la solución de este problema?

    Saludo

    Ismael Borche - LATAM Forum Support Engineer
    Microsoft Corporation
    martes, 1 de febrero de 2011 17:34
  • Bueno, pues gracias al soporte de Microsoft lo hemos solucionado.

    Siguendo, mas o menos los pasos de esta pagina: http://blogs.technet.com/b/roplatforms/archive/2010/05/12/how-to-fix-server-manager-errors-after-installing-updates-hresult-0x800f0818-hresult-0x800b0100.aspx

    Solo que despues de dar unas vueltas.

    He seguido al pie de la letra estas indicaciones y no funcionaba.
    Reinicie el servidor y seguia igual.
    En el log habia un fallo y tenia que copiar:
    package_for_kb979687_rtm~31bf3856ad364e35~amd64~~6.1.1.2.cat
    package_for_kb979687_rtm~31bf3856ad364e35~amd64~~6.1.1.2.cat
     
    Pase de nuevo la herramienta y el resultado fue el mismo.
    Repeti el proceso y seguia igual.
    Despues he observado que al descomprimir el Windows6.1-KB979687-x64.cab, que en mi caso era el que daba el error generaba el fichero package_for_kb979687_rtm~31bf3856ad364e35~amd64~~6.1.1.2.cat que era diferente al update.mum que segun el paso 2 hay que cambiar el nombre y copiar. Copie el fichero que se genera con el nombre completo y ha funcionado.
     
    En el administrador del servidor ya veo los roles y al ejecutar el dcpromo ya me aparece el asistente, por lo que he podido despromocionar el equipo como queria.
     
    Muchas gracias por la ayuda.
    • Marcado como respuesta MartinezAlegre martes, 1 de febrero de 2011 18:00
    martes, 1 de febrero de 2011 18:00