none
SYSVOL y NETLOGON sin share ni contenido RRS feed

  • Pregunta

  • Tengo dos servidores Windows 2003 R2 SP2, SERVER01 y SERVER02 en ambos corre Active Directory el primero deberia ser el primario o PDC y el segundo el secundario o BDC. El tema es que en el primero se perdio el share de la carpeta sysvol y la carpeta netlogon directamente no existe. En el segundo tengo la carpeta sysvol con su share y tambien netlogon. Por otro lado el contenido de la carpeta sysvol en server01 es diferente de la que hay en server02
    en server01 dentro de c:\windows\sysvol tengo:
    domain (sin contenido)
    staging dentro: domain (sin contenido)
    staging areas dentro: ssplan.asv.com.ar (sin contenido)
    sysvol dentro: ssplan.gcba.gov.ar (sin contenido)

    en server02 dentro de c:\windows\sysvol tengo:
    domain tengo:
    Policies (adentro hay 5 carpetas con nombre entre llaves y un codigo)
    scripts (dentro hay archivo bat creado por mi con varios net use para mapear unidades)
    staging dentro: domain (sin contenido)
    staging areas dentro: ssplan.asv.com.ar (sin contenido)
    sysvol dentro: ssplan.gcba.gov.ar dentro tengo Policies y scripts con el mismo contenido que en la carpeta domain descripta arriba
    En ambos ejecuto servidor de dns.
    En SERVER01 ejecuto servidor DHCP
    En "sitios y servicios de active directory" tengo los dos servidores y estan configuradas para ambos servidores conexiones NTDS que tienen en la columna "desde servidor" el servidor inverso es decir el server01 tiene server02 y el otro lo contrario. La conexion del server01 tiene tildado "catalogo global"
    Me interesa poder lograr que el SERVER01 tenga todo ok ya que en este momento no se cual de los dos es que maneja la seguridad y cual no
    Recuerdo que hace un tiempo se retiro el sevidor y no creo que se haya despromocionado y vuelto a promocionar puede ser que sea desde ese momento.

    Si conocen algun otro foro donde publicar, realmente estoy desesperado tratando de arreglar esto

    ya probe modificando el registro BurstFlags en D2 y D4 para intentar reconstruir las carpetas pero no funciono
    Aclaro que la validacion de seguridad funciona OK

    Gracias

    jueves, 30 de octubre de 2008 12:34

Respuestas

  • Pude solucionar el problema.
    El tema es que tienes que tener 2 servidores ejecutando AD, seguramente uno es GC que viene a ser el maestro de todos los AD que tengas en tu infraestructura, seguramente ese es el que te esta fallando.
    En mi caso el GC tambien era DNS y DHCP ademas de ser AD.
    1o. debes configurar tu dns para que se integre al AD esto si es que ya no lo es.
    2o. debes configurar tu DHCP para que apunte al nuevo servidor de dns, puedes ponerlo en el servidor que si tiene las carpetas sysvol y netshare, esto es lo mejor porque al final este quedara como GC
    3o. Transfiere los los FSMO (http://support.microsoft.com/kb/324801), (En caso que no puedas pasar alguno, sigue el sgte doc para crearlo nuevamente http://support.microsoft.com/kb/255504)
    5o. Pon el server02 como GC (http://support.microsoft.com/kb/313994)

    PROBAR apagando el servidor que funciona mal, prueba si los usuarios se pueden loguear y ademas crea algun logon script para estar totalemte seguro que estan tomando las carpetas sysvol y netshare del servidor que declarastes como GC

    6o. Despromueve el que funciona mal(http://support.microsoft.com/kb/332199)
    Luego de esto el servidor quedara fuera del dominio y deberas ingresarlo como equipo para que tome los permisos del AD, si es que tiene carpetas compartidas
    Luego debes limpiar el AD y el DNS de todas las entradas que queden al equipo que despromovistes como servidor
    Luego si te interesa puedes volver a hacerlo DC

    A mi me funciono, el tema mas importante es el dns

    Emilio
    lunes, 16 de febrero de 2009 21:54

Todas las respuestas

  • Lo primero que verificaria es si ambos equipos se pueden ver en la red, ver si toda la configuracion de red de ambos equipos es correcta, una vez verificado eso iremos por parte para corregir las fallas.

    Te diria que verifiques en los event log de ambos DC por errores en los mismos, de seguro tiene que haber errores que te guiaran mejor para ver la causa de la falla.

    Por otro lado, tienes algun backup reciente del AD? En caso que sea asi puede hacer un autoritative restore en el DC1 y luego hacer el troubleshooting para que repliquen correctamente. (http://support.microsoft.com/kb/290762)

    Tambien corre el dcdiag en ambos DC para ver que te indica y poder corregir dichas fallas

    Los sgtes links puden ayudarte

    http://technet.microsoft.com/en-us/library/cc757048.aspx (aqui tienes detallado paso a paso como reconstruir dichas carpetas)
    http://support.microsoft.com/kb/257338
    http://support.microsoft.com/kb/315457

    sábado, 1 de noviembre de 2008 16:20
  • Respecto de la configuracion de red: ambos equipos ven y se ven entre ellos, de hecho si, por ejemplo, defino un usuario nuevo en el SERVER01 se replica en el SERVER02 y vice versa.

    En SERVER02 no tengo errores en el event log, solo tengo en el SERVER01 y es un problema de replicacion por la falta de la ruta SYSVOL y NETLOGON

    Backups estoy haciendo desde el viernes pasado, tanto del SERVER01 como del SERVER02.-

     

    hice el dcdiag en SERVER01, lamentablemente no lo tengo aqui, mañana te lo envio.

     

    Desde ya mil gracias por tu ayuda

     

    Emilio

    domingo, 2 de noviembre de 2008 12:38
  • Dado que entre ambos de alguna manera estan replicando, lo que puedes tambien probar es, pasar todos los roles al server 02 y verificar que queden funcionando en el mismo (proba todo con el server 01 apagado), luego de que este todo probado y confirmado que funciona, despromoves el 01 y lo pasas a member server y luego lo vuelves a promover.

    Tambien si tienes backup de antes de que falle, puedes restorear el mismo (si hay cambios que NO puedes perder, no lo hagas autoritativo) y luego deja que replique entre dichos servers.


    domingo, 2 de noviembre de 2008 14:38
  • Estoy casi seguro que va por el lado de promocion/despromocion ya que recuerdo que hace ya un tiempo el servidor fue retirado de su lugar, por lo que se desconecto de la red por lo menos durante dias y no creo que se haya despromocionado.

    No se como puedo comprobar esto, la idea de apagarlo es buena salvo que el servidor ademas de ser AD, DNS, etc es DHCP y File Server, si lo apago pierdo el DHCP y lo peor el File Server.

    Si la cuestion es si hay validacion de usuarios con SERVER01 apagado, la respuesta es SI, tuve un problema electrico hace una semana y aun con SERVER01 fuera de linea pudieron hacer logon sin problemas.

    Como se hace para despromocionar o Promocionar el SERVER01 y otra pregunta como se si esta promocionado o no

     

    Gracias

     

    domingo, 2 de noviembre de 2008 15:29
  • Si es un domain controller es que ya esta promovido como tal.

    Sigue estos pasos

    1. Antes que nada ten un backup por si es necesario volver atras. Siempre se debe tener en cuenta la estrategia de hacer un rollback en caso que el troubleshooting que vayamos a hacer falle.
      Luego:
    2. Configura las zonas DNS como AD integrated
    3. Configura el DHCP para que usen como Primary DNS server al server02
    4. Transfiere los los FSMO (http://support.microsoft.com/kb/324801), (En caso que no puedas pasar alguno, sigue el sgte doc para crearlo nuevamente http://support.microsoft.com/kb/255504)
    5. Pon el server02 como GC (http://support.microsoft.com/kb/313994)
    6. Instala el DHCP server en el server02 (en el doc http://support.microsoft.com/kb/325473, tambien explica como)
    7. Mueve la base del dhcp (http://support.microsoft.com/kb/325473)
    8. Autoriza el dhcp del server02, verifica que funciona correctamente.
    9. Desinstala el servicio dhcp del server01
    10. Despromueve el server01(http://support.microsoft.com/kb/332199)
    Luego de eso el server01 quedara como member server, seguira funckionando como file server, pero solo contaras con un DC, luego puedes volver a promoverlo como DC (dcpromo)

    Espero que te ayude.

    domingo, 2 de noviembre de 2008 19:54
  • Hoy descubri que tengo un problema.

    No tengo GPOs en ninguno de los 2 servidores

     

    Siguiendo los pasos anteriores deberia dejar al SERVER01 como servidor de archivos solamente.

    Mi necesidad es poder solucionar el problema sin perder los perfiles de los usuarios debido a que los mismo guardan cantidad de informacion en sus carpetas mis documentos, escritorio, etc. y de perder los perfiles deberia recuperar los datos usuario por usuario y seria un gran problema.

    La configuracion de DNS y DHCP la puedo replicar a mano sin ningun problema.

    El trabajo se hara en horarios en donde las estaciones de trabajo estaran apagadas por lo que puedo dejar el dhcp vacio y que se genere automaticamente.

    Pero necesito saber como safo con el tema de los usuarios, si me decis que con los pasos anteriores desactivo el server01 como AD, DNS, DHCP y solo quedara como File Server y seguira funcionando asi eso me tranquiliza porque no me puedo dar el lujo de bajarlo.

    luego vere la necesidad de promoverlo o no

    Por el tema de la GPO creo que puedo armar una plantilla base para comenzar desde cero con las configuraciones de politicas restrictivas, etc. esto lo haria en el server02 una vez desactivado el server01

    Otra pregunta, si quito las replicaciones, especialmente la que replica del server01 al server02 y armo una GPO desde cero eso me va a permitir que tomen esa GPO.

     

    Gracias

     

    viernes, 7 de noviembre de 2008 0:13
  • Con los pasos solo dejas el server como file server, si quieres antes de despromoverlo para estar seguro, apagalo e intenta crear una gpo y ver que se aplique, crear una maquina nueva en el dominio, crear un user nuevo en el dominio y ver que todo funcione bien.
    viernes, 7 de noviembre de 2008 1:40
  • Hice casi todo:

    Transferi los FSMO

    Despromovi el DC

    deje andando el DNS (debo quitarlo) y el DHCP

    Quisiera saber si hay alguna herramienta o producto o instructivo que me sirva para limpiar todo lo que quedo del viejo DC para que luego lo vuelva a promover

    la carpeta sysvol sigue ahi

     

    Emilio

    Gracias

    lunes, 10 de noviembre de 2008 13:57
  • Estos docs te explican

    http://technet.microsoft.com/en-us/library/cc736378.aspx
    http://support.microsoft.com/kb/216498
    http://support.microsoft.com/kb/555846
    http://support.microsoft.com/default.aspx?kbid=332199


    lunes, 10 de noviembre de 2008 14:54
  • Mil Gracias

    Te voy a molestar otra vez.

    Supongamos que tengo un servidor que es AD y DC

    Como puedo hacer para que si se rompiera el disco rigido donde esta instalado pueda recuperar el servidor sin perder los perfiles de los usuarios.

    Como se hace un backup de Actve Directory y como se recupera desde una instalacion nueva de Windows 2003 R2 SP2

     

    Gracias

    lunes, 10 de noviembre de 2008 15:16
  • Hola,

     

    Para hacer backup de los usuarios/grupos/gpo/etc, es decir toda la estructura AD, puedes hacer backup del System State desde la herramienta de backup de tu Windows Server. Con eso estas cubierto ante cualquier desastre para volver al punto en que generaste el backup.

     

    En el caso de falla, si tienes otro DC puedes instalar luego de cambiar el disco (en el supuesto de que falle) y promover el equipo.

     

    Recuerda validar que maquinas tienen los FSMO de tu Active Directory para armar un buen plan.

     

    Saludos

     

    lunes, 10 de noviembre de 2008 18:55
  • http://technet.microsoft.com/en-us/library/cc779518.aspx
    lunes, 10 de noviembre de 2008 19:57
  • Conseguiste al final tener compartidas las carpetas SYSVOL y NETLOGON.
    Te lo pregunto porque yo tengo ahora un caso similar y quería saber como solucionarlo.
    El caso es que tengo una red con un server 2003 y he introducido otro server nuevo con 2003 R2, quería hacer toda la migración del viejo al nuevo y quitar luego el viejo. todo funciona, pero si desconecto el server antiguo, los usuarios se loguean pero no pueden acceder a su carpeta privada (ZSmile, y es porque no existen la SYSVOL ni NETLOGON y además no están compartidas lógicamente

    Si lo conseguiste dime como para ver si me funciona a mi también.
    Gracais
    lunes, 29 de diciembre de 2008 10:04
  • Pude solucionar el problema.
    El tema es que tienes que tener 2 servidores ejecutando AD, seguramente uno es GC que viene a ser el maestro de todos los AD que tengas en tu infraestructura, seguramente ese es el que te esta fallando.
    En mi caso el GC tambien era DNS y DHCP ademas de ser AD.
    1o. debes configurar tu dns para que se integre al AD esto si es que ya no lo es.
    2o. debes configurar tu DHCP para que apunte al nuevo servidor de dns, puedes ponerlo en el servidor que si tiene las carpetas sysvol y netshare, esto es lo mejor porque al final este quedara como GC
    3o. Transfiere los los FSMO (http://support.microsoft.com/kb/324801), (En caso que no puedas pasar alguno, sigue el sgte doc para crearlo nuevamente http://support.microsoft.com/kb/255504)
    5o. Pon el server02 como GC (http://support.microsoft.com/kb/313994)

    PROBAR apagando el servidor que funciona mal, prueba si los usuarios se pueden loguear y ademas crea algun logon script para estar totalemte seguro que estan tomando las carpetas sysvol y netshare del servidor que declarastes como GC

    6o. Despromueve el que funciona mal(http://support.microsoft.com/kb/332199)
    Luego de esto el servidor quedara fuera del dominio y deberas ingresarlo como equipo para que tome los permisos del AD, si es que tiene carpetas compartidas
    Luego debes limpiar el AD y el DNS de todas las entradas que queden al equipo que despromovistes como servidor
    Luego si te interesa puedes volver a hacerlo DC

    A mi me funciono, el tema mas importante es el dns

    Emilio
    lunes, 16 de febrero de 2009 21:54
  • Hola a todos, tengo un problema similar, se ha perdido la carpeta NETLOGON y el SYSVOL esta vacio, solamente hay carpetas vacias.

    El tema es que este servidor trabaja solo, no hay replicas del directorio activo.

    Que me sujieren hacer?

    Gracias de antemano

    Saludos
    jueves, 21 de enero de 2010 7:10