none
VPN clientes no resuleven nombres RRS feed

  • Pregunta

  • Muy Buenas...

    He venido experimentando problemas con el acceso al VPN el problema que se me presenta es que cuando un cliente se conecta a mi red a travez de la VPN pasa los siguiente:

    1. Al cliente se le asigna el siguiente direccionamiento:

    IP: 192.168.1.100
    Mask: 255.255.225.225
    Gateway: 192.168.1.100
    DNS: 192.168.1.100

    2. El cliente no puede resolver nombres.

    En el ISA Server, espeficamente en las Propiedades de VPN la configuracion esta asi:

    1. Asignamiento de Direcciones

    + Esta por DHCP y los datos de DNS, DHCP y WINS los toma del adaptador definido como Internal

    + En la pestaña Avanzados esta configurado para que tome DNS y WINS por DHCP

    2. Acceso a Redes

    + Esta marcada la Red Interna.

    Cabe destacar que mi ISA Server es version 2006 SP1 ademas tiene 3 tarjetas de Red (LAN, WAN y DMZ) estos adaptadores estan configurados de esta forma:

    LAN:

    IP: 192.168.1.8
    Mask: 255.255.255.0
    Gateway: Sin configurar
    DNS1: 192.168.1.1
    DNS2: 192.168.1.6

    WAN:

    IP: 201.201.50.46
    Mask: 255.255.255.252
    Gateway: 201.201.50.40
    DNS1:196.100.0.1
    DNS2:196.100.0.5

    DMZ:

    IP: 172.16.0.1
    Mask: 255.255.255.0
    "Los demas datos estan sin configurar"

    Cualquier dato adicional que consideren importante no duden en solicitarlo... De antemano muchas gracias por sus comentarios...

    Saludos,
    mjk_b25
    miércoles, 13 de enero de 2010 0:17
    Moderador

Respuestas

  • Buenos dias Jim:

     

    En tu caso de la ultima configuración:

    PPP adapter VPN:
       Connection-specific DNS Suffix  . : 
       Description . . . . . . . . . . . : VPN
       Physical Address. . . . . . . . . : 
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv4 Address. . . . . . . . . . . : 192.168.1.138(Preferred) 
       Subnet Mask . . . . . . . . . . . : 255.255.255.255
       Default Gateway . . . . . . . . . : 0.0.0.0
       DNS Servers . . . . . . . . . . . : 192.168.1.1
                                                   192.168.1.6
       NetBIOS over Tcpip. . . . . . . . : Enabled

     

    Ya debería de trabajar, Yo tengo esa configuracion sin GW y me comunica con la red local/wan, lo que te sugiero revises es:

     

    Regla en el ISA para permitir a los VPN-Clientes el acceso a la red local, no es necesario que sean usuario autenticados ya que pasan por la VPN primero. No confundir el acceso "Externo" a "Interno", por que no es lo mismo.

    Entiendo que a nivel de red, sin GW no podrías comunicarte con otros segmentos, sin embargo pensando en la configuración de red en el ISA server, claramente dice que las redes VPN las va a routear, verifica que diga Route.

     

    Prueba a hacer un ping o una terminal remota a la tarjeta LAN del ISA, si en teoría tienes una ip del mismo segmento de DHCP que te dio al conectarte a la VPN, debes de alcanzarlos sin GW.

     

    Saludos.

    • Marcado como respuesta Ismael Borche lunes, 4 de abril de 2011 20:28
    martes, 18 de enero de 2011 19:31

Todas las respuestas

  • Hola Jimcesse,

     En principio por lo que comentas la configuracion es correcta, por lo que quizas el tema es de configuración del DHCP. Indicame la configuración y veremos si sacamos algo en claro.


    Un saludo

    Grego J.
    miércoles, 13 de enero de 2010 12:04
  • Exactamente que configuracion necesitas saber... DHCP (el que me asigna direcciones en la LAN) que por cierto funciona muy bien...

    Gracias por tus comentarios...

    Saludos,
    mjk_b25
    miércoles, 13 de enero de 2010 13:04
    Moderador
  • Muy Buenas...

    He venido experimentando problemas con el acceso al VPN el problema que se me presenta es que cuando un cliente se conecta a mi red a travez de la VPN pasa los siguiente:

    1. Al cliente se le asigna el siguiente direccionamiento:

    IP: 192.168.1.100
    Mask: 255.255.225.225
    Gateway: 192.168.1.100
    DNS: 192.168.1.100

    2. El cliente no puede resolver nombres.

    En el ISA Server, espeficamente en las Propiedades de VPN la configuracion esta asi:

    1. Asignamiento de Direcciones

    + Esta por DHCP y los datos de DNS, DHCP y WINS los toma del adaptador definido como Internal

    + En la pestaña Avanzados esta configurado para que tome DNS y WINS por DHCP

    2. Acceso a Redes

    + Esta marcada la Red Interna.

    Cabe destacar que mi ISA Server es version 2006 SP1 ademas tiene 3 tarjetas de Red (LAN, WAN y DMZ) estos adaptadores estan configurados de esta forma:

    LAN:

    IP: 192.168.1.8
    Mask: 255.255.255.0
    Gateway: Sin configurar
    DNS1: 192.168.1.1
    DNS2: 192.168.1.6

    WAN:

    IP: 201.201.50.46
    Mask: 255.255.255.252
    Gateway: 201.201.50.40
    DNS1:196.100.0.1
    DNS2:196.100.0.5

    DMZ:

    IP: 172.16.0.1
    Mask: 255.255.255.0
    "Los demas datos estan sin configurar"

    Cualquier dato adicional que consideren importante no duden en solicitarlo... De antemano muchas gracias por sus comentarios...

    Saludos,
    Jimcesse
    jueves, 14 de enero de 2010 4:06
    Moderador
  • Cual son los DNS que asigna?

    Un saludo

    Grego J.

    jueves, 14 de enero de 2010 11:54
  • Hola Jimcesse:

    Si la dirección que pusiste del cliente aquí es sacada de un cliente, con esta dirección no podría comunicarse con la red, por un lado el Gateway debe ser 192.168.1.100, el DNS 192.168.1.1 y la máscara de subred no puede ser 255.255.255.255.

    Reconfigura tu servidor de DHCP, para que de las direcciones correctas.

    Suerte y cuéntame si puedes resolver el problema.

    Juan Valenzuela

    MCT, MCSA, MCSE, MCIT

    jueves, 14 de enero de 2010 21:35
  • Juan gracias por comentar...

    Te comento que tengo muy claro lo que me dices... Lo interesante es que mi servicio de DHCP me funciona muy bien a la hora de entregar direcciones en la LAN, el problema lo tengo solo con la VPN!!!

    Como lo vez?

    Saludos,
    Jimcesse
    jueves, 14 de enero de 2010 23:45
    Moderador
  • Desde la LAN asigan:

    IP: 192.168.1.x
    Mask: 255.255.255.0
    GW: 192.168.1.8
    DNS1: 192.168.1.1
    DNS2: 192.168.1.6

    Desde la VPN asigan:

    IP: 192.168.1.100
    Mask: 255.255.225.225
    Gateway: 192.168.1.100
    DNS: 192.168.1.100

    Gracias por comentar...

    Saludos,


    Jimcesse
    jueves, 14 de enero de 2010 23:49
    Moderador
  • Hola Jimcesse:

    Seguramente lo que tengas mal configurado es tu agente de retransmisión de DHCP (Relay Agent), debido a esto es que no entregas direcciones correctas a tus clientes de VPN.

    En el link siguiente viene como configurarlo.

    http://technet.microsoft.com/en-us/library/cc781416(WS.10).aspx

    Si con eso queda resuelto me lo dices, por favor o me mandas el nuevo status.

    Saludos!

    Juan Valenzuela

    MCT, MCSA, MCSE, MCITP

    viernes, 15 de enero de 2010 5:08
  • Juan muchas gracias por tus comentarios...

    Estuve revisando la configuracion del Routing and Remote Access y efectivamente no tengo configurado ningun DHCP Relay, en link que me dejastes veo que hay un paso a paso de como configurarlo...

    Mi pregunta es: Es un requisito indispensable tener dicho Relay configurado para hacer VPN...?

    Te pregunto pq en algun momento mi VPN funcionaba sin problemas y no recuerdo tener configurado dicho Relay... Pero si tu recomendacion es ponerlo a funcionar... Lo pruebo...

    Nuevamente gracias...


    Jimcesse
    viernes, 15 de enero de 2010 15:49
    Moderador
  • Juan agregue el Relay como  me recomendastes... Y efectivamente me reolvio el problema de nombres... Pero aun me sigue entregando el direccionamiento:

    IP: 192.168.1.100
    Mask: 255.255.225.225
    Gateway: 192.168.1.100
    DNS: 192.168.1.1
    DNS: 192.168.1.6

    Aunque en este momento estamos resolviendo bien los nombres...

    Ahora se me ha presentado otra inconveniente... El cliente del ISA server no se esta conectado ya que pone un error que dice: Error en la operacion debido a un error en la red, he revisado si deja algun log pero no encuentro nada... Te comento en el visor de sucesos y en el loggin del ISA no hay nada de este error...

    Alguna idea?

    Jimcesse
    viernes, 15 de enero de 2010 17:30
    Moderador
  • Hola Jimcesse:

    Es normal que el cliente no se pueda conectar, esto es debido a que pertenecen a redes diferentes, y no hay comunicación entre ellos, si te parece bien revisa los scopes (ámbito) del DHCP, si no encuentras nada raro pon la información aquí y la revisamos.

    Saludos,

    Juan Valenzuela

    MCT, MCSA, MCSE, MCITP

    viernes, 15 de enero de 2010 19:37
  • Hola Juan en el ambito no hay ningun dato incorrecto el ambito dice:

    Adress Pool: 192.168.1.100 a 192.168.1.254
    Scope Options:

    003 Router: 192.168.1.8
    006 DNS: 192.168.1.1, 192.168.1.6
    015 DNS Domain Name: midominio.com
    044 Wins/Nbns Server: 192.168.1.1, 192.168.1.6
    046 Wins/Nbns Node Type: 0x8

    No si esa es la info que querias o necesitas algo mas?

    Avisame estoy super pendiente...

    Gracias,
    Jimcesse
    viernes, 15 de enero de 2010 19:58
    Moderador
  • Hola Jimcesse:

    Lo que está entregando mal es la marcara de red, Mask: 255.255.225.225, debe ser 255.255.255.0, esto puede ser debido a que tengas más de un scope configurado. ¿Es esto así?

    Saludos y seguimos en contacto

    Juan Valenzuela

    MCT, MCSE, MCSA, MCITP

     

    martes, 19 de enero de 2010 5:11
  • Interesante tu comentario...

    Te cuento que en la consola de DHCP tengo solo un Scope pero tengo la misma configuracion dos veces... Osea una a nivel de servidor y otra a nivel de scope... :D

    Mira no se si me explico... Pero el asunto esta asi...

    En la consola del DHCP tengo algo asi...

    + Nombre del servidor
        * Scope (miservidor) ----> este es el que se entrega
        * Address pool
        * Address leases
        * Reservations
        * Scope Options
    + Server options

    Los Tabs Scope Options y Server Options tienen la misma configuracion... Sera esto a lo que te refieres???

    Gracias por tus comentarios, estoy super pendiente

    Saludos,
    Jimcesse
    martes, 19 de enero de 2010 5:21
    Moderador
  • Hola Jimcesse:

    En teoría no debería de pasar nada por tenerla misma información en dos sitios diferentes, pero por si acaso ponlo únicamente en scope options y borrala de server options y asegurate que la mascara de subred sea de 24 bits (255.255.255.0)

    Saludos!

    Juan Valenzuela

    MCT, MCSE, MCSA, MCITP

    martes, 19 de enero de 2010 5:32
  • Hola Juan...

    Hice las pruebas q me recomendastes... Pero no di con la solucion... :(

    Te cuento q ademas, note algo que talvez he pasado por alto... Mira hice un IPCONFIG a un TXT para poder analizar el resultado y me he encontrado con lo siguiente:

    PPP adapter VPN:
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : VPN
       Physical Address. . . . . . . . . :
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv4 Address. . . . . . . . . . . : 192.168.1.138(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.255
       Default Gateway . . . . . . . . . : 0.0.0.0
       DNS Servers . . . . . . . . . . . : 192.168.1.1
                                                   192.168.1.6
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Como ves es el resultado del IPCONFIG para el adaptador de VPN me llama mucho la atencion que dice DHCP ENABLE ..... NO adicionalmente revise AD para descartar que estuviera configurado para que me entregara este direccionamiento de una forma fija y no por DHCP... Pero bueno como te imaginaras no estaba la opcion habilitada...

    No veo la luz con este tema... :( :( :(

    Que mas podriamos revisar???

    Juan de antemano, muchas gracias por tus comentarios...

    Un saludos,


    Jimcesse
    martes, 19 de enero de 2010 7:36
    Moderador
  • Hola Jimcesse,

    Qué tal? Espero que todo vaya bien :)

    Fue posible solucionar tu problema?
    Háganos saber si usted tiene la respuesta correcta para tu problema o si necesita de alguna ayuda adicional, ok?

    Un saludo,
    Átilla Arruda - Microsoft Corporation
    lunes, 25 de enero de 2010 13:54
    Moderador
  • Señor Atilla,

    Gracias por sus comentarios... No he podido resolver el problema...

    Cualquier ayuda sera bien recibida...

    Saludos,
    Jimcesse
    lunes, 25 de enero de 2010 14:55
    Moderador
  • Buenas Jimcesse.


    En las maquinas servidor, que supongo tendran una ip fija interna,  ¿tienes metida la ip del servidor wins a mano? ¿O has registrado el servidor en el wins estaticamente?

    Mete la direccion de wins mano en un cliente que se conecte por vpn, para descartar que este fallando el wins.

    Un saludo.

    MCP, MCITP SERVER ADMINISTRATOR 2008
    miércoles, 27 de enero de 2010 21:14
  • Buenos dias Jim:

     

    En tu caso de la ultima configuración:

    PPP adapter VPN:
       Connection-specific DNS Suffix  . : 
       Description . . . . . . . . . . . : VPN
       Physical Address. . . . . . . . . : 
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv4 Address. . . . . . . . . . . : 192.168.1.138(Preferred) 
       Subnet Mask . . . . . . . . . . . : 255.255.255.255
       Default Gateway . . . . . . . . . : 0.0.0.0
       DNS Servers . . . . . . . . . . . : 192.168.1.1
                                                   192.168.1.6
       NetBIOS over Tcpip. . . . . . . . : Enabled

     

    Ya debería de trabajar, Yo tengo esa configuracion sin GW y me comunica con la red local/wan, lo que te sugiero revises es:

     

    Regla en el ISA para permitir a los VPN-Clientes el acceso a la red local, no es necesario que sean usuario autenticados ya que pasan por la VPN primero. No confundir el acceso "Externo" a "Interno", por que no es lo mismo.

    Entiendo que a nivel de red, sin GW no podrías comunicarte con otros segmentos, sin embargo pensando en la configuración de red en el ISA server, claramente dice que las redes VPN las va a routear, verifica que diga Route.

     

    Prueba a hacer un ping o una terminal remota a la tarjeta LAN del ISA, si en teoría tienes una ip del mismo segmento de DHCP que te dio al conectarte a la VPN, debes de alcanzarlos sin GW.

     

    Saludos.

    • Marcado como respuesta Ismael Borche lunes, 4 de abril de 2011 20:28
    martes, 18 de enero de 2011 19:31
  • ALGUIEN PODRÍA AYUDARME???

    tengo un cliente al cual le doy soporte en 2 sedes diferentes, cada una con su adsl movistar, cuya ip esta enestatica y router en monopuerto ya que necesito utilizarlos para un router vpn conectado a centralita, pero el cliente ha puesto un disco duro interno en plan backup y debe usar ip pública, la cual creo que al yo intentar usarla para mi router vpn no puedo conectarlo, si conectas un ordenador al router monopuerto va perfecto pero cuando lo conectas al router vpn no pasa el ADSL. Me comentan que voy a necesitar una segunda ip para conectarlo, ¿Como puedo hacer para sobre el mismo adsl tener otra ip sin coste??

    Gracias.

    Saludos

    • Propuesto como respuesta soyyomisma sábado, 25 de febrero de 2012 17:18
    • Votado como útil soyyomisma sábado, 25 de febrero de 2012 17:18
    sábado, 25 de febrero de 2012 17:17
  • Buenas Jimcesse, tuve el mismo problema y acabo de solucionarlo. En mi caso me conectaba al servidor de VPN que yo mismo había creado en un servidor, y con algunas máquinas me dejaba entrar a las máquinas de la red remota, tanto por ip como por nombre, y conectándome vía VPN desde otras no.

    Encontré la siguiente diferencia entre las máquinas que sí funcionaba todo Ok, y las que no:


    En la conexión VPN que cree en el cliente hice clic derecho y fui a propiedades, luego a funciones de red, y luego a "Protocolo de internet (TCP/IP)", ahí a propiedades, y luego a opciones avanzadas, en la ventana que se abre, pestaña General, debe estar destildada la opción:

    "Usar la puerta de enlace predeterminada en la red remota."

    Con eso a mí me bastó, y tiene coherencia con el problema que estaba teniendo.

    Espero que resulte. Saludos.


    • Editado Juan84z domingo, 5 de agosto de 2012 20:35
    domingo, 5 de agosto de 2012 20:34