locked
compatibilidad con Visual Studio 2003 RRS feed

  • Pregunta

  •  

    Que tal!

     

    Tengo desarrollada una aplicación en VS2003 que ha funcionado muy bien sobre windowsXP, pero ahora que la ejecuté sobre windows vista empezó a fallar, por el momento lo que le he encontrado es que cuando le das un doble click a un combo la aplicación truena y se reinicia el explorer.

     

    Alguien sabe a que se debe eso? hay algún parche o algo que me pueda instalar para que esto no suceda?

     

    Agradezco cualquier comentario

     

    Muchas gracias

     

    Saludos

     

    BalckJack

    martes, 14 de agosto de 2007 16:04

Respuestas

  • El problema no es el framework, tiene que ver con la version del visual studio que estas usando, para poder trabajar con Vista necesitas tener el Visual Studio 2005 el cual incluye el framework .NET 2.0, no estoy seguro si necesitas el Service Pack 1, pero en verdad te recomiendo que instales el Visual Studio 2008 beta 2 (Orcas), es la nueva version de Visual Studio, funciona perfectamente con Windows Vista e incluye el framework .NET 3.5 beta 2.

     

    Puedes descargar la version beta del Visual Studio 2008 desde aqui: http://msdn2.microsoft.com/en-us/vstudio/aa700831.aspx

     

    Saludos.

    --

    Octavio Licea Leon

    Visual Studio North Carolina

    sábado, 6 de octubre de 2007 4:38

Todas las respuestas

  • Que yo sepa no es compatible. Incluso el VS2005 tiene problemas y se deben aplicar los parches en este caso, pero con todo, sigue con malfuncionamientos. Habrá que esperar al proximo VS.

     

    Un saludo,

    martes, 14 de agosto de 2007 18:57
  • Hola

     

    Bueno hay ciertas complicaciones en cuanto las aplicaciones en VS 2003, el problema basicamente esta en el frameword el 2003 trabaja con el 1.1 y en Vista esta con el 3.0, y se debe a problemas de librerias en tu app, ahora bien en VS 2005 esto ya funciona perfectamente ya que debes de tener el vs 2005 SP1 y una actualizacion Especial para Vista y con esto no tendras ningun problema en VS 2005.

     

    Saludos,

    miércoles, 15 de agosto de 2007 21:17
  • Seamos realisatas, Visual 2005 no funcion en Vista ni con el SP1. Cualquier desrrrollador que intente esta combinacion en Vista, mejor que se dedique a otra cosa.

     

    Por el momento, quien quiera desarrollas con VS2005 deberá restringirse a las sistemas para los que fue desarrollado y no se debe usar Vista hasta que salga la siguiente version de VS (que por cierto, la beta, sobre Vista es infinitamente mas estable que VS2005+SP1).

     

    Un saludo,

    jueves, 16 de agosto de 2007 5:03
  •  

    Upps, pues al parecer no hay muchas esperanzas, tendré que migrar a 2005 haber si tengo mas suerte y ahí si funciona bien...

     

    De cualquier forma agradezco cualquier otro comentario o sugerencia.

     

    Saludos y gracias

     

    BlackJack

     

    miércoles, 22 de agosto de 2007 23:27
  • El problema no es el framework, tiene que ver con la version del visual studio que estas usando, para poder trabajar con Vista necesitas tener el Visual Studio 2005 el cual incluye el framework .NET 2.0, no estoy seguro si necesitas el Service Pack 1, pero en verdad te recomiendo que instales el Visual Studio 2008 beta 2 (Orcas), es la nueva version de Visual Studio, funciona perfectamente con Windows Vista e incluye el framework .NET 3.5 beta 2.

     

    Puedes descargar la version beta del Visual Studio 2008 desde aqui: http://msdn2.microsoft.com/en-us/vstudio/aa700831.aspx

     

    Saludos.

    --

    Octavio Licea Leon

    Visual Studio North Carolina

    sábado, 6 de octubre de 2007 4:38
  • Pues el 2005 funciona por decirlo asi a un 80%, los depuradores no funcionan perfectamente pero tambien es cierto que hay cosas que si se pueden desarrollar y depurar perfectamente.. el detalle aqui es que el depurador es importante luego para desarrollar, con el SP1, hay que hacer cambios a WebService, Lineas que cargan configuracion o partes del registro del sistemas. sin embargo hay alternativas.

     

     

     

    lunes, 26 de noviembre de 2007 1:24
  • No es necesario ya opciones: el VS 2008 ya ha salido y es el que debe usarse con Vista.

     

    Un saludo,

     

    lunes, 26 de noviembre de 2007 6:13