locked
programa p2p en una maquina virtual RRS feed

  • Pregunta

  • Hola: siguiendo consejos creo que acertados de seguridad he instalado un programa p2p en una maquina virtual pero consigo solo low-id. Los puerto en el router apuntan a la tarjeta de red de Vista por lo que deberia estar bien.

     

    Besos

    miércoles, 30 de abril de 2008 20:53

Respuestas

  • Siempre que tengamos un programa servidor en una maquina, los puertos en el router deben hacer mapeo a la maquina que actua de servidor. En el caso de una maquina virtual, que tiene dicho programa, se debe apuntar a la IP de la maquina virtual (aunque esta esté montada sobre la tarjeta principal).

    Esto asumiendo que la red está configurada como "bridge" es decir, en la maquina virtual apuntando directamente a la tarjeta de red de la maquina real: en este caso, los puertos del router deben apuntar a la IP de la virtual.

    Un saludo,
    miércoles, 30 de abril de 2008 20:56
  • A ver... lo primero que aconsejo es no usar el NAT sino el bridge. Por tanto ¿xomo sales a internet en la maquina princpila? ¿por router ADSL?... Dime esto y lo configuramos correctamente....

    Y lo de usar un disco real en una maquina virtual no es recomendable...

    Comentame el primer punto y lo configuramos.

    Un saludo,


    domingo, 27 de julio de 2008 21:02
  •  Fenixxx Escribió:
    y del modem pasa a un router que yo coloque y dentro de este configure todo como automatico y configure el usuario y el passware de PPoE...

    Mi equipo real se conecta directamente al router ahh y otro equipo tambien se conecta al router... y no pasan por el switch

    Entonces es facil: recuerda que una maquina virtual es como otra maquina... como si fuese una maquina fisica de tu red que lo que comparte es el cable fisico de red, pero  atodos los efectos es como si fuese una maquina real.

    En este caso, abre el programa "Manage Virtual Networks" de vmware. En la tercera pestaña en VMNet0 ponle que apinte a tu tarjeta de red real. Posteriormente en la maquina virtual (en sus opciones de configuracion de la tarjeta de red) le dices que haga bridge a ese VMNet0 y por ultimo, arrancas el sistema operativo virtual y le dejas la IP y DNS en automatico tal y como supongo que lo tienes en otros equipos de tu red...

    Y a correr.... :-)

    Un saludo,
    lunes, 28 de julio de 2008 12:27
  •  Fenixxx Escribió:
    ... pero nada... no se como colocar imagenes con las capturas de pantalla (son pequeñas 44K) para que pueda verificar que lo hice tal cual...

     

    Tengo un servidor propio de noticias  news://jmtella.com al cual puedes suscribirte pinchandop simplemente el link anterior. Te apareceran varios grupos, suscribete a los que quieras excepto al de "especiales" ya que ese requiere password. En él, existe un grupo de virtualizacion, ponme allí las capturas.

     

     Fenixxx Escribió:

    3 - Mi board tiene (2) t. red y una inalambrica... pero la otra t. de red esta desactivada como tambien la inalambrica... no se, si eso influye

     

    Cuidado.. el "bridge" en la pestaña que te he comentado debe hacerse en la VMNet0 apuntando a la tarjeta FISICA que te da salida a internet... a la que va conectada al router...

     

    Un saludo,

    martes, 29 de julio de 2008 5:59
  •  Javi_TMI Escribió:

    Mi maquina tiene 2 tarjetas de red. Una por la que siempre he salido a internet, y la otra (que ha estado inhabilitada hasta ahora) la he conectado para que la use la maquina virtual. Esta configurado de la siguiente forma. En la maquina servidor, la tarjeta tiene asignada una IP propia, y en las opciones de red de Virtual PC, esta seleccionada dicha tarjeta de red.


    A ver... en esta configuracion está claro que no puedes salir a internet ya que tu maquina virtual está en red con tu PC... pero a traves de la segunda tarjeta de red.

    Para poder salir a internet, se deberia tener un software de router que enrute la conexion tuya a internet a la otra tarjeta de red. Debido a que Vista no trae software de routing te quedan dos alternativas:

    1) Configurar Virtual PC para que use la tarjeta de red que tre da salida a internet. En ese caso poniendole una IP del rango del router ya lo tendrás.

    2) O bien usar la conexion compartida en la maquina host de tal manera que comparta la conexion a internet. Mas complejo pero si quieres lo comentamos...

    Mi consejo es que uses la 1) y en el router entonces "natees" los puertos de ese programa a la IP de la maquina virtual.

    Un saludo,
    viernes, 1 de agosto de 2008 18:39
  •  jmunoz1984 Escribió:

    , puesto qu esi le doy red a la virtual, la maquina real no toma red.


    ¿quien te da red? ¿un router? ¿un modem? ¿cable?... parece que tu ISP solo te asinga una IP. Si esto fuese así, configura en la red de VIrtual PC (en las opciones de red de la maquina virtual) para que en vez de apuntar a tu tarjeta de red, sea median NAT .... abriendo el combo veras esa opcion-)

    Un saludo,
    viernes, 1 de agosto de 2008 20:58
  •  jmunoz1984 Escribió:

    Si la realizo mediante nat, van a tener la maquina y el pc conexion a internet, y se pueden ver ambas??


    Por supuesto  :-)

    Un saludo,
    viernes, 1 de agosto de 2008 21:25
  • Con ese NAT lo que noi podrás es "natear" puertos si tienes herramientas sevidoras... para poderlo hacer, hay que hacer una "trampa! que es instalar un Adaptador de Lazo Invertido (MSLoopback) el cual es un adaptador de red virtual. (se hace en añadir nuevo hardware y localizarlo en redes y Microsoft). Una vez realizado, compartir la conexion con ese adptador y en Virtual PC, usar dicho adaptador...

    Un saludo,
    sábado, 2 de agosto de 2008 7:37
  • ¿cortafuelgos, antivirus, suite de seguridad?... hay que configurarlos...

    Un saludo,
    domingo, 3 de agosto de 2008 7:04
  •  Jose Manuel Tella Llop Escribió:
    ¿cortafuelgos, antivirus, suite de seguridad?... hay que configurarlos...

    Y esto que preguntas:

    >Lo que indias se instala en la virtual o en el real??

    no se lo que quieres decir...

    Un saludo,
    domingo, 3 de agosto de 2008 7:11
  • ok.

    Si sigues teniendo problemas o didas, comentame...

     

    Un saludo,

     

    lunes, 4 de agosto de 2008 4:48

Todas las respuestas

  • Siempre que tengamos un programa servidor en una maquina, los puertos en el router deben hacer mapeo a la maquina que actua de servidor. En el caso de una maquina virtual, que tiene dicho programa, se debe apuntar a la IP de la maquina virtual (aunque esta esté montada sobre la tarjeta principal).

    Esto asumiendo que la red está configurada como "bridge" es decir, en la maquina virtual apuntando directamente a la tarjeta de red de la maquina real: en este caso, los puertos del router deben apuntar a la IP de la virtual.

    Un saludo,
    miércoles, 30 de abril de 2008 20:56
  •  Jose Manuel Tella Llop Escribió:
    Esto asumiendo que la red está configurada como "bridge" es decir, en la maquina virtual apuntando directamente a la tarjeta de red de la maquina real: en este caso, los puertos del router deben apuntar a la IP de la virtual.

     

    Hola...

    Estaba leyendo el tema y me llamo la atencion.. no entiendo mucho los terminos de "redes" y hasta ahorita estoy practicando con maquinas virtuales...

     

    Estoy utilizando VMware Workstation 6 0 4 Build 93057... creo que es la ultima version.. y en el momento de configuracion me dio una opcion en ingles (me atropella el ingles) algo asi como NAT.. y fue la unica forma de hacer navegar mi VM... ya habia leido algo de JMT... donde decia que la LAN debia estar configurada con IPs estaticas y algo asi como DHCP no debia estar automatico.. no se si estoy recordando mal lo que habia leido... el caso es que yo tengo mi LAN con DHCP automatico... y el router asigna las IP automaticamente... nuevamente les recuerdo que NO manejo los terminos de redes muy bien... y no quiero cambiar mi configuracion... y fue la unica manera de hacer navegar mi VM

     

    Ahora estaba pensando usar un programa p2p y por eso me llamo la atencion el tema... se puede colocar a funcionar un disco real en vez de uno virtual en la VM para un programa de estos (p2p)..??? es ó no es recomendable..??

     

     

    Gracias... Saludos

    domingo, 27 de julio de 2008 20:30
  • A ver... lo primero que aconsejo es no usar el NAT sino el bridge. Por tanto ¿xomo sales a internet en la maquina princpila? ¿por router ADSL?... Dime esto y lo configuramos correctamente....

    Y lo de usar un disco real en una maquina virtual no es recomendable...

    Comentame el primer punto y lo configuramos.

    Un saludo,


    domingo, 27 de julio de 2008 21:02
  •  Jose Manuel Tella Llop Escribió:

    A ver... lo primero que aconsejo es no usar el NAT sino el bridge. Por tanto ¿xomo sales a internet en la maquina princpila? ¿por router ADSL?... Dime esto y lo configuramos correctamente....

     
    Ok... vale... gracias
    Mi internet es adsl... llega a un modem adsl... y del modem pasa a un router que yo coloque y dentro de este configure todo como automatico y configure el usuario y el passware de PPoE... despues hay un switch que sale del router al que estan 4 equipos de mi LAN ... no manejo bien los terminos tecnicos de las redes...
     
    Mi equipo real se conecta directamente al router ahh y otro equipo tambien se conecta al router... y no pasan por el switch
     
    En la maquina real tengo Smart security 3 0 667 el cual tiene cortafuegos..
     
    Ahora, JMT, no quiero cambiar la configuracion del router por otra que no sea automatico... si las configuracion que ested me va a hacer el favor de recomendar tienen que ver con el equipo real o la VM tratare de hacerlas... ó si las recomendaciones tienen que ver con el router, pero que no cambien mi configuracion automatica las intentare hacer..
     
    Sobre el disco que alberga los datos del p2p montado en la VM... estaba pensando que fuera un disco real por que me quedaba como dificil pasar todos los datos del real al virtual..
     
    Gracias... un saludo...
    domingo, 27 de julio de 2008 22:07
  •  Fenixxx Escribió:
    y del modem pasa a un router que yo coloque y dentro de este configure todo como automatico y configure el usuario y el passware de PPoE...

    Mi equipo real se conecta directamente al router ahh y otro equipo tambien se conecta al router... y no pasan por el switch

    Entonces es facil: recuerda que una maquina virtual es como otra maquina... como si fuese una maquina fisica de tu red que lo que comparte es el cable fisico de red, pero  atodos los efectos es como si fuese una maquina real.

    En este caso, abre el programa "Manage Virtual Networks" de vmware. En la tercera pestaña en VMNet0 ponle que apinte a tu tarjeta de red real. Posteriormente en la maquina virtual (en sus opciones de configuracion de la tarjeta de red) le dices que haga bridge a ese VMNet0 y por ultimo, arrancas el sistema operativo virtual y le dejas la IP y DNS en automatico tal y como supongo que lo tienes en otros equipos de tu red...

    Y a correr.... :-)

    Un saludo,
    lunes, 28 de julio de 2008 12:27
  •  Jose Manuel Tella Llop Escribió:
    En este caso, abre el programa "Manage Virtual Networks" de vmware. En la tercera pestaña en VMNet0 ponle que apinte a tu tarjeta de red real. Posteriormente en la maquina virtual (en sus opciones de configuracion de la tarjeta de red) le dices que haga bridge a ese VMNet0 y por ultimo, arrancas el sistema operativo virtual y le dejas la IP y DNS en automatico tal y como supongo que lo tienes en otros equipos de tu red...

    Y a correr.... :-)

     

    ... nada que puedo correr... ... hice tal cual me oriento... pero nada... no se como colocar imagenes con las capturas de pantalla (son pequeñas 44K) para que pueda verificar que lo hice tal cual...

     

    Aclaro:

    1 - Que se me olvido decir que la maquina real tiene Win Xp Pro 64 Bit Sp2.... y la virtual tambien...

    2 - Ademas por hacer unas cosita (que luego colocare en otro tema) tengo algunos problemillas con las t. red reales... pero creo que no influye ya que con NAT todo es normal...

    3 - Mi board tiene (2) t. red y una inalambrica... pero la otra t. de red esta desactivada como tambien la inalambrica... no se, si eso influye

     

    Voy a verificar algunas cosas de lo escrito y vuelvo a postear...

     

    Gracias... saludos...

     

    lunes, 28 de julio de 2008 22:34
  •  Fenixxx Escribió:
    ... pero nada... no se como colocar imagenes con las capturas de pantalla (son pequeñas 44K) para que pueda verificar que lo hice tal cual...

     

    Tengo un servidor propio de noticias  news://jmtella.com al cual puedes suscribirte pinchandop simplemente el link anterior. Te apareceran varios grupos, suscribete a los que quieras excepto al de "especiales" ya que ese requiere password. En él, existe un grupo de virtualizacion, ponme allí las capturas.

     

     Fenixxx Escribió:

    3 - Mi board tiene (2) t. red y una inalambrica... pero la otra t. de red esta desactivada como tambien la inalambrica... no se, si eso influye

     

    Cuidado.. el "bridge" en la pestaña que te he comentado debe hacerse en la VMNet0 apuntando a la tarjeta FISICA que te da salida a internet... a la que va conectada al router...

     

    Un saludo,

    martes, 29 de julio de 2008 5:59
  • Buenas tardes

     

    Aprovechando este hilo, expongo aqui un problema parecido, pero que no soy capaz de resolver. Mi caso es el siguiente

     

    Tengo un equipo con Vista Ultimate, en el que he instalado el Virtual PC 2007. He creado una maquina virtual con Windows XP Profesional SP3, en el que, entre otras cosa, he instalado el eMule. El caso es que algo no he configurado bien el la red, ya que obtengo una low ID (aun habiendo abierto el puesrto correspondiente en el router).

     

    Mi maquina tiene 2 tarjetas de red. Una por la que siempre he salido a internet, y la otra (que ha estado inhabilitada hasta ahora) la he conectado para que la use la maquina virtual. Esta configurado de la siguiente forma. En la maquina servidor, la tarjeta tiene asignada una IP propia, y en las opciones de red de Virtual PC, esta seleccionada dicha tarjeta de red.

     

    Dentro de la maquina virtual (en el XP) si selecciono la opcion de obtener direccion automaticamente, me da conectividad limitada o nula, y si le asigno la IP que tiene la tarjeta asignada (que es la IP que tengo en el router para el puerto del eMule), pues evidentemente me sale un error de conflicto de IP's en la red. No he visto ninguna opcion para hacer bridge con la tarjeta de red (supongo que es la opcion que tengo puesta, no se)

     

    Que he pasado por alto, o que estoy haciendo mal?

     

    Muchas gracias, y un saludo

    viernes, 1 de agosto de 2008 18:31
  •  Javi_TMI Escribió:

    Mi maquina tiene 2 tarjetas de red. Una por la que siempre he salido a internet, y la otra (que ha estado inhabilitada hasta ahora) la he conectado para que la use la maquina virtual. Esta configurado de la siguiente forma. En la maquina servidor, la tarjeta tiene asignada una IP propia, y en las opciones de red de Virtual PC, esta seleccionada dicha tarjeta de red.


    A ver... en esta configuracion está claro que no puedes salir a internet ya que tu maquina virtual está en red con tu PC... pero a traves de la segunda tarjeta de red.

    Para poder salir a internet, se deberia tener un software de router que enrute la conexion tuya a internet a la otra tarjeta de red. Debido a que Vista no trae software de routing te quedan dos alternativas:

    1) Configurar Virtual PC para que use la tarjeta de red que tre da salida a internet. En ese caso poniendole una IP del rango del router ya lo tendrás.

    2) O bien usar la conexion compartida en la maquina host de tal manera que comparta la conexion a internet. Mas complejo pero si quieres lo comentamos...

    Mi consejo es que uses la 1) y en el router entonces "natees" los puertos de ese programa a la IP de la maquina virtual.

    Un saludo,
    viernes, 1 de agosto de 2008 18:39
  • Hola a todos.

     

    Yo tambien instale VirtualPC 2007 en mi pc, pero no logro dar red a la maquina virtual, no se en cual de las opciones colocarle, puesto qu esi le doy red a la virtual, la maquina real no toma red. Me puede colaborar con esto, gracias.

    En la virtual tengo instalado Linux Suse 9.2, esto daria problema alguno ??

     

    viernes, 1 de agosto de 2008 20:50
  •  

    casi seguro, yo nisiquiera pude meterle linux(ni ubuntu, ni fedora, ni linux mint etc) a virtual pc....creo q esa maquina virtual, funciona "bien" con windows!

     

    aun asi, espera aver q dice jose manuel q sabe mas q yo!

     

    Saludos!

    viernes, 1 de agosto de 2008 20:57
  •  jmunoz1984 Escribió:

    , puesto qu esi le doy red a la virtual, la maquina real no toma red.


    ¿quien te da red? ¿un router? ¿un modem? ¿cable?... parece que tu ISP solo te asinga una IP. Si esto fuese así, configura en la red de VIrtual PC (en las opciones de red de la maquina virtual) para que en vez de apuntar a tu tarjeta de red, sea median NAT .... abriendo el combo veras esa opcion-)

    Un saludo,
    viernes, 1 de agosto de 2008 20:58
  • La red me la da un modem adsl, el cual esta configurado en modo brige, y la conexion se establece desde el pc.

     

    Si la realizo mediante nat, van a tener la maquina y el pc conexion a internet, y se pueden ver ambas??

     

    viernes, 1 de agosto de 2008 21:03
  •  jmunoz1984 Escribió:

    Si la realizo mediante nat, van a tener la maquina y el pc conexion a internet, y se pueden ver ambas??


    Por supuesto  :-)

    Un saludo,
    viernes, 1 de agosto de 2008 21:25
  • Lo verificare y estrae escribiendo el resultado,

     

    Gracias

     

    viernes, 1 de agosto de 2008 22:13
  • Con ese NAT lo que noi podrás es "natear" puertos si tienes herramientas sevidoras... para poderlo hacer, hay que hacer una "trampa! que es instalar un Adaptador de Lazo Invertido (MSLoopback) el cual es un adaptador de red virtual. (se hace en añadir nuevo hardware y localizarlo en redes y Microsoft). Una vez realizado, compartir la conexion con ese adptador y en Virtual PC, usar dicho adaptador...

    Un saludo,
    sábado, 2 de agosto de 2008 7:37
  • Hola de nuevo.

     

    Ya logra compartir la conexion a internet.

     

    Lo que no logro hacer es que la maquina virtual y el real se vean en la red, no responden los ping ni nada parcido, solo logro compartir la conexion a internet.

     

    Q sugerencias me haces.

     

    Lo que indias se instala en la virtual o en el real??

     

    Gracias por los comentarios

    sábado, 2 de agosto de 2008 22:23
  • ¿cortafuelgos, antivirus, suite de seguridad?... hay que configurarlos...

    Un saludo,
    domingo, 3 de agosto de 2008 7:04
  •  Jose Manuel Tella Llop Escribió:
    ¿cortafuelgos, antivirus, suite de seguridad?... hay que configurarlos...

    Y esto que preguntas:

    >Lo que indias se instala en la virtual o en el real??

    no se lo que quieres decir...

    Un saludo,
    domingo, 3 de agosto de 2008 7:11
  • Gracias de nuevo por las respuesta.

    Con respecto a seguridad ya se ha configurado para permitir la comunicacion.

    Con respecto a lo que me indicas de instalar, lo del artefacto de red, ya lo lei en otro post q puesite, lo voy a hacer.

    Gracias de nuevo por la colaboracion
    lunes, 4 de agosto de 2008 4:28
  • ok.

    Si sigues teniendo problemas o didas, comentame...

     

    Un saludo,

     

    lunes, 4 de agosto de 2008 4:48