none
BD Exchange 2010 sp1 RRS feed

  • Pregunta

  • Hola a todos, tengo la siguiente consulta, existe algun comando que permite verificar el buen estado de la BD del exchange Server 2010.Como puedo verificar si realmente la BD esta en buen estado de salud.

    Es normal que por ejm cuando un nodo se apague y el servidor esta en shutdown demore en reflejar en el exchange, por comandos es rapido pero para poder visualizarlo desde el entorno grafico del exchange demora en refrescar, eso es normal ?

    Cuando apago uno de los nodos, para validar unas pruebas la BD no inicia y muestra un error de Failed , cuando ejecuto el comando Get-MailboxDatabaseCopyStatus BDEX, que podria estar pasando ?

    A la hora de realizar una copia de la BD del exchange mostro el siguiente error , que deberia revisar, indica problemas de replicacion que deberia de revisar

    couldn't communicate with the microsoft exchange replication service on server

    Gracias por la ayuda

     


    • Editado mikent jueves, 12 de enero de 2012 7:06
    jueves, 12 de enero de 2012 7:03

Todas las respuestas

  • Vayamos por puntos.

    1. Para verificar el estado de las DB, desde el SP1 se usa el cmdlet "New-MailboxRepairRequest", http://technet.microsoft.com/en-us/library/ff625226.aspx
    2. Sí, es normal que tarde en refrescar. Además es molesto porque si no lo haces desde un server con el rol de MBX todavía tarda más en refrescar
    3. Con Get-MailboxDatabaseCopyStatus te da fallo porque no se está replicando la DB, normal si el servidor está parado o en error, http://technet.microsoft.com/en-us/library/dd298044.aspx. Para revisar la DB activa mejor usa Get-MailboxDatabase, http://technet.microsoft.com/en-us/library/bb124924.aspx y para la replicación, Test-ReplicationHealth, http://technet.microsoft.com/en-us/library/bb691314.aspx
    4. Te da el error de "couldn't communicate with the microsoft exchange replication service on server" con todo el DAG levantado o con un equiop parado?

    Saludos,

    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator (Windows Server 2008)
    MCITP: Enterprise Messaging Administrator (Microsoft Exchange 2007 & Exchange 2010)
    MCITP: Lync Server Administrator 2010
    MCC: Microsoft Community Contributor 2011
    Citrix CCA
    Visita mi blog en ITPro.es
    MCP Virtual Bussines Card
    viernes, 13 de enero de 2012 9:26
    Moderador
  • Estimado Marc, otra vez gracias por la ayuda, te comento

    1. Te da el error de "couldn't communicate with the microsoft exchange replication service on server" con todo el DAG levantado o con un equiop parado?


    El error solo se presento cuando quise agregar una copia de la BD a unos de los servidores, se llego agregar pero salio en estado reconectando, lo que hice fue seleccionar la copia y le di Update y con eso se refrezco. Es normal que se presenten estas anomalias en las copias ?

    Luego probe el DAG apagando uno de los nodos y al parecer todo funciona bien, pero no se porque me salio el error mencionado

    Gracias por la ayuda

    sábado, 14 de enero de 2012 3:15
  • Pues no sabría qué decirte. Yo me he encontrado con errores de generación de copias de DAG cuando no he dejado que los DCs replicaran información de Exchange.

    De todos modos, no tengo "anotado" que sea un error habitual pero como cada entorno es diferente aunque se monte igual :) y si forzando el update funciona, lo podemos dejar como una anéctota a revisar.


    Saludos,

    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator (Windows Server 2008)
    MCITP: Enterprise Messaging Administrator (Microsoft Exchange 2007 & Exchange 2010)
    MCITP: Lync Server Administrator 2010
    MCC: Microsoft Community Contributor 2011
    Citrix CCA
    Visita mi blog en ITPro.es
    MCP Virtual Bussines Card
    sábado, 14 de enero de 2012 19:44
    Moderador