none
OWA 2010 no funciona con HTTP pero si con HTTPS y tampoco funciona la autenticacion integrada RRS feed

  • Pregunta

  • Hola a todos,

    Estoy en el proceso de migrar un Exchange 2007 a 2010. La instalación del nuevo servidor se llevó a cabo sin ningún tipo de problema. El único problema que tengo es con el OWA.

    En primer lugar no hay forma de que me funcione la autenticación integrada en el servidor Exchange 2010, evidentemente ya agregué el URL en la zona intranet del navegador y tengo activa la autenticación integrada tanto en el IIS como en los subdirectorios de OWA y ECP.

     Y en segundo lugar tampoco hay forma de que me funcione sobre HTTP, sobre HTTPS funciona perfectamente. Cuando accedo por HTTP me muestra el buzón pero en cuanto hago algún clic sobre algún elemento del buzón siempre me sale un mensaje que dice: "Error, No se pudo completar la solicitud. Esto puede haber ocurrido por motivos de seguridad o porque su sesión ha sobrepasado el tiempo de espera." Esto sin embargo por HTTPS no pasa, funciona perfectamente.

    En el visor de eventos no encuentro nada que me de pistas ni que pueda compartir con vosotros para ver que puede estar pasando con estos dos problemas

    Agradezco la ayuda de antemano a todos.


    MCSA, MCSE, MCT, A+, Inet+, Server+, Network+

    martes, 27 de marzo de 2012 15:22

Respuestas

Todas las respuestas

  • Ejecuta un "test-owaconnectivity" y mira qué resultados muestra

    Saludos,

    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator (Windows Server 2008)
    MCITP: Enterprise Messaging Administrator (Microsoft Exchange 2007 & Exchange 2010)
    MCITP: Lync Server Administrator 2010
    MCC: Microsoft Community Contributor
    Citrix CCA
    Visita mi blog en ITPro.es
    MCP Virtual Bussines Card

    jueves, 29 de marzo de 2012 14:08
    Moderador
  • Buen día amigo, tengo el mismo problema el servidor me dice solo esto al ejecutar el comando.

    [PS] C:\Program Files\Microsoft\Exchange Server\V14\Scripts>test-owaconnectivity
    ADVERTENCIA: [13:27:47.968] : El servidor devolvió la página de selección de idioma. Este es el primer inicio de sesión
     del usuario de prueba.

    ClientAccessServer MailboxServer URL                     Scenario Result  Latency Error
                                                                               (ms)
    ------------------ ------------- ---                     -------- ------  ------- -----
    midominio... midominio... https://midominio... Inici... Corr... 1424...


    [PS] C:\Program Files\Microsoft\Exchange Server\V14\Scripts>

    martes, 9 de diciembre de 2014 18:02
  • Hola Derwing,

    Apoyando un poco en este thread, de igual manera valida que no tengas algun tipo de redireccionamiento en IIS (HTTP Redirect) para el default web site y para OWA que te este causando problemas

    Saludos


    Saludos cordiales | Systems Integration Advisor | MCITP-MCSA-MCT-MVP


    martes, 9 de diciembre de 2014 18:21
  • Hola Geovany, no tengo redirecconamiento en ninguno de los dos sitios. Pero notó que en el default website de IIS tengo un signo de interrogación -

    A nivel del visor de eventos veo la siguiente advertencia para el rol de IIS

    Error al detener un canal de escuchas para el protocolo 'http' en el tiempo asignado de un proceso de trabajo '8676' que sirve al grupo de aplicaciones 'MSExchangeSyncAppPool'. El campo de datos contiene el número de error.


    martes, 9 de diciembre de 2014 19:12
  • Hola Derwing,

    Tratemos algo

    1) navega a IIS y expande el directorio virtual de OWA

    2) deshabilita SSL (desmarca la casilla de "require SSL" dentro de SSL settings)

    3) Haz un recycle del AppPool de OWA desde application pools

    4) ejecuta el comando: iisreset /noforce desde cmd

    5) Trata de nuevo

    Saludos


    Saludos cordiales | Systems Integration Advisor | MCITP-MCSA-MCT-MVP


    • Editado Geovany Acevedo martes, 9 de diciembre de 2014 20:06 iisreset corrected
    martes, 9 de diciembre de 2014 19:43
  • El comando es iisreset en lugar de issreset - (lo aclaro solo por si otra persona lee el caso le sirva la ayuda)

    Amigo Geovany al ejecutar el comando luego de los cambios me arroja el siguiente error.

    El servicio no respondió a tiempo a la solicitud de inicio o de control. (214794
    3453, 8007041d)

    De todos modos no estaba requiriendo SSL en la configuración, esto ya se lo había quitado antes (aunque no había ejecutado iisreset)


    Derwing Medina

    martes, 9 de diciembre de 2014 20:01
  • hola Derwing,

    IISRESET error de dedo, podrias compartir una pantallazo al momento que entras a OWA por HTTP?

    Saludos


    Saludos cordiales | Systems Integration Advisor | MCITP-MCSA-MCT-MVP

    martes, 9 de diciembre de 2014 20:03
  • aunque puedo entrar, al intentar casi cualquier cosa dentro de owa http, recibo esta advertencia y no puedo continuar. - Recalco que si lo uso en https todo funciona perfecto.

    Derwing Medina

    martes, 9 de diciembre de 2014 20:14
  • Hola Derwing,

    Desde IIS dale click derecho al VD de OWA y selecciona explorar>abre con notepad el archivo web.config

    Busca las siguientes entradas y eliminalas (OJO, antes de hacer esto, haz un respaldo del archivo)

    1) <httpRedirect childOnly="true" />

    2) <system.webServer>
            <httpRedirect enabled="true" exactDestination="false" />
        </system.webServer>

    Finalmente ejecuta nuevamente un IISRESET

    Saludos, me indicas que paso


    Saludos cordiales | Systems Integration Advisor | MCITP-MCSA-MCT-MVP

    martes, 9 de diciembre de 2014 20:22
  • No me salen esas líneas, intenté pegarte el contenido del archivo aquí, pero es muy grande. 

    Derwing Medina

    martes, 9 de diciembre de 2014 20:33
  • Mmm interesante,

    Podrias darle click derecho a "Default Web Site" y darle lcick en explorar

    Si ves un archivo web.config en este directorio, eliminalo (previo respaldo) y vuelve a hacer un IISreset y un recycle del AppPool de OWA

    Saludos


    Saludos cordiales | Systems Integration Advisor | MCITP-MCSA-MCT-MVP

    martes, 9 de diciembre de 2014 20:39
  • Eso último salió bastante mal: Primero arrojo un error enorme luego de reiniciar el iis, y no abría, tuve que volver al archivo original y de paso se tardo bastante en arrancar el iis luego de restaurar el archivo.

    Por ahora tengo que salir, pero si se te ocurre otra cosa avísame a ver si logro resolver esto cuando vuelva. Saludos y gracias


    Derwing Medina

    martes, 9 de diciembre de 2014 21:12
  • Mmm interesante,

    Podrias darle click derecho a "Default Web Site" y darle lcick en explorar

    Si ves un archivo web.config en este directorio, eliminalo (previo respaldo) y vuelve a hacer un IISreset y un recycle del AppPool de OWA

    Saludos


    Saludos cordiales | Systems Integration Advisor | MCITP-MCSA-MCT-MVP

    Tengo el mismo problema de hace varios meses, hasta el momento no lo puedo solucionar, el exchange 2010 es la version 14.3 (build 123.4) con un update rollup 9 for exchange server 2010 servipack 3 (KB3030085), leyendo por las web me comentan que con rollup se soluciona esto, quisiera saber que version seria.

    gracias

    miércoles, 4 de noviembre de 2015 14:04
  • aunque puedo entrar, al intentar casi cualquier cosa dentro de owa http, recibo esta advertencia y no puedo continuar. - Recalco que si lo uso en https todo funciona perfecto.

    Derwing Medina

    Hola Derwing, que tal, has resuelto el problema, ya que igualmente tengo el mismo problema de hace varios meses, hasta el momento no lo puedo solucionar, el exchange 2010 es la version 14.3 (build 123.4) con un update rollup 9 for exchange server 2010 servipack 3 (KB3030085),  ........... Si sabes como se puede solucionar, me avisas, gracias ...

    lunes, 9 de noviembre de 2015 23:17
  • Otra solucion, cual seria???, ya que hasta el momento tengo el  mismo problema de hace varios meses, hasta el momento no lo puedo solucionar, mi  exchange 2010 es la version 14.3 (build 123.4) con un update rollup 9 for exchange server 2010 servipack 3 (KB3030085),  gracias por la ayuda.
    lunes, 9 de noviembre de 2015 23:18