none
Problema al exportar solucion de una organizacion a otra RRS feed

  • Pregunta

  • Que tal amigos,

    Estoy queriendo exportar las entidades Cuenta y Cliente potencial a otra organizacion y me arroja este error

    Failure: lead-account:

    This attribute map is invalid.

    A valid attribute map must meet these requirements:
-	

    The data type must match.
-	

    The length of the target attribute cannot be shorter than the source attribute.
-	

    The format should match.
-	

    The target attribute must not be used in another mapping.
-	

    The source attribute must be visible on the entity form.
-	

    The target attribute must be a field a user can enter data into.
-	

    Address ID values cannot be mapped.

    Por lo que entiendo es un problema de mapeo. Lo que hice fue primero verificar que todos los campos nvarchar y ntext mapeados entre sí tengan la misma longitud.

    Luego elimine todos los mapeos que no se habian creado y luego dejaron de usarse, para ver si el problema venia por el lado de que un campo que completabas en Lead se mapeaba con un campo inexistente en Account.

    Lamentablemente ninguna de las dos cosas me dio resultado porque sigue arrojando el mismo error.

    A alguien le ha pasado esto y sabe como solucionarlo?

    Saludos!


    viernes, 11 de enero de 2013 16:19

Respuestas

  • Que tal Demian,

    Era CRM 4, el problema después de mucho revisar fue que mapie un campo que era url a uno que era text.... cambiando eso (y otros mapeos que por ejemplo eran de un lado de longitud de 100 y del otro de 150, etc) se solucionó.

    Lo que me parece extraño es que me los haya dejado mapear si después iba a tirar error de importación.

    Tampoco fue para nada cómodo tener que andar chequeando con un editor XML campo por campo.

    En fin, solucionado. 

    Gracias!

    lunes, 14 de enero de 2013 13:07

Todas las respuestas

  • Hola Leandro, es un CRM 4 o 2011?
    Si es un 2011, revisa el Excel que te da para descargar, y muestranos que te dice, ya que eso puede darnos mas informacion.
    Parece ser un problema de mapeos en alguna relacion entre Cuenta y Cliente potencial, por ahi estaría bien que en los dos entornos elimines esos "mappings" tanto en origen como en destino, e intentes volver a importarlo.
    un saludo,

    Demian Adolfo Raschkovan Blog: http://crmtoall.blogspot.com If this post answers your question, please click "Mark As Answer" on the post and "Mark as Helpful"

    viernes, 11 de enero de 2013 22:26
    Moderador
  • Que tal Demian,

    Era CRM 4, el problema después de mucho revisar fue que mapie un campo que era url a uno que era text.... cambiando eso (y otros mapeos que por ejemplo eran de un lado de longitud de 100 y del otro de 150, etc) se solucionó.

    Lo que me parece extraño es que me los haya dejado mapear si después iba a tirar error de importación.

    Tampoco fue para nada cómodo tener que andar chequeando con un editor XML campo por campo.

    En fin, solucionado. 

    Gracias!

    lunes, 14 de enero de 2013 13:07