locked
Archivos en red no se muestran hasta pasado un cierto tiempo RRS feed

  • Pregunta

  • Hola,

    Desde hace un tiempo tengo el siguiente problema con una aplicación cliente-servidor en entorno de ejecución 2008R2 como servidor y Windows 7 como cliente (solo en este caso) y no consigo ver la solución, recurro a vuestros conocimientos.

    El problema es el siguiente: la aplicación crea un fichero en una carpeta compartida del servidor, ese fichero localmente en el servidor aparece como es normal de inmediato en dicha carpeta, pero no aparece inmediatamente en la carpeta vista como recurso compartido en el Windows 7, ni siquiera dando F5 repetidamente. Tienen que pasar varios segundos para que finalmente aparezca el fichero por sí sólo.

    No es problema de permisos ni hay sincronización de carpetas, ni nada raro.

    Es decir, y por si no me he explicado bien, yo en servidor creo el fichero c:\miaplicacion\fichero.txt y lo veo enseguida. Desde el Windows 7, accedo a m:\miaplicacion (la unidad m conectada al recurso del servidor) y NO veo el fichero.txt que YA existe en el servidor. Con F5 repetidamente tampoco, nada, y al cabo de unos segundos (hasta 15), ya se ve, sin hacer nada más.

    Esto causa un problema a la aplicación (que se ejecuta en el Windows 7) porque controla la existencia de ficheros de control creados en el servidor para realizar acciones y claro, deberían estar y no están.

    ¿Os suena algún tipo de parámetro de red que se pueda ajustar?

    Gracias, saludos.

    jueves, 20 de febrero de 2014 9:58

Respuestas

  • ok.

    Revisa este enlace por si te sirve.

    Adicionalmente, en la maquina W7 escribe en una consola elevada y prueba a ver si mejora.

    netsh interface tcp set global rss=disabled
    netsh interface tcp set global autotuninglevel=disabled
    netsh int ip set global taskoffload=disabled

    Saludos,

    • Marcado como respuesta Uriel Almendra viernes, 21 de febrero de 2014 15:33
    jueves, 20 de febrero de 2014 15:50

Todas las respuestas

  • Hola,

    Has comprobado desde otro equipo cliente si ocurre lo mismo?. ¿Tienes instalado algún firewall / antivirus ...?

    Alguna vez he visto algo similar y el culpable ha sido el AV...

    saludos

    jueves, 20 de febrero de 2014 15:21
  • Hola,

    Pues no, no vemos que sea eso, hay casos con antivirus y sin antivirus.

    Por otra parte, como he comentado en el post, sólo observamos ese comportamiento en el binomio W2008R2-W7, no hemos tenido ningún caso ni en W2003 ni en XP. Muy raro.

    Gracias, saludos,

    jueves, 20 de febrero de 2014 15:35
  • ok.

    Revisa este enlace por si te sirve.

    Adicionalmente, en la maquina W7 escribe en una consola elevada y prueba a ver si mejora.

    netsh interface tcp set global rss=disabled
    netsh interface tcp set global autotuninglevel=disabled
    netsh int ip set global taskoffload=disabled

    Saludos,

    • Marcado como respuesta Uriel Almendra viernes, 21 de febrero de 2014 15:33
    jueves, 20 de febrero de 2014 15:50
  • Gracias, probamos a ver.

    Saludos.

    jueves, 20 de febrero de 2014 16:03