none
Buscar un valor de una columna en otra RRS feed

  • Pregunta

  • Hola a todos.

    Tengo dos columnas en office 2007 y quiero que cada valor de la primera columna se busque en todos los valores de la segunda columna y que me muestre las coincidencias encontradas en una tercera columna.

    Pongo un ejemplo por si no me explicado bien:

    C1 C2 C3 
    2   15 54
    32 55 12 
    43 77 78
    55 35
    66 78
    78 12
    54 89
    36 54
    12 0

    La columna resultante C3 solo contendria esos dos valores porque son los unicos repetidos en las dos columnas.


    Gracias de antemano


    Un saludo.
    viernes, 2 de mayo de 2014 6:32

Respuestas

  • Hola Rafael_1978, he de suponer que los errores en tu escrito son eso, errores:

    - Muestras 3 valores como resultado, dices que son 2 y en realidad son 4... (?)

    Tus datos en el rango A1:B9 (los habrás de adaptar a la realidad), en C1 pones la fórmula:

    =SI(ESNUMERO(COINCIDIR(A1;$B$1:$B$9;0));A1;"")  y copias hacia abajo hasta la celda C9.

    En las celdas te aparecerá o blanco o el valor que se encuentra en las dos listas.

    Yo utilizo el ";" como separador de fórmulas si no es el tuyo lo habrás de cambiar.

    Problema: ¿qué ocurre si hay repetidos en la columna A? Pués que dará repetido...

    Saludos,

    Xavier

    • Marcado como respuesta Rafael_1978 lunes, 5 de mayo de 2014 10:07
    viernes, 2 de mayo de 2014 15:14

Todas las respuestas

  • Hola Rafael_1978, he de suponer que los errores en tu escrito son eso, errores:

    - Muestras 3 valores como resultado, dices que son 2 y en realidad son 4... (?)

    Tus datos en el rango A1:B9 (los habrás de adaptar a la realidad), en C1 pones la fórmula:

    =SI(ESNUMERO(COINCIDIR(A1;$B$1:$B$9;0));A1;"")  y copias hacia abajo hasta la celda C9.

    En las celdas te aparecerá o blanco o el valor que se encuentra en las dos listas.

    Yo utilizo el ";" como separador de fórmulas si no es el tuyo lo habrás de cambiar.

    Problema: ¿qué ocurre si hay repetidos en la columna A? Pués que dará repetido...

    Saludos,

    Xavier

    • Marcado como respuesta Rafael_1978 lunes, 5 de mayo de 2014 10:07
    viernes, 2 de mayo de 2014 15:14
  • Hola.

    Funciona perfecto

    lunes, 5 de mayo de 2014 10:07