none
Problemas al conectar a dominio RRS feed

  • Pregunta

  • Buenos dias.

    Tengo un problema con un dominio. Hubo un cambio de servidor para lo cual segui estos pasos (a grandes razgos).

    Al nuevo server (2003) lo hice Controlador de dominio secundario sin antes hacerlo equipo del dominio. ¿Esto esta bien?

    Cambie los roles del server viejo (2003 tambien) al nuevo con la linea de comando, no mediante la GUI. Usa la interface para darle el catalogo global al nuevo server.

    Copie los datos del server viejo que queria tener en el nuevo.

    Apague el server viejo y levante el nuevo en el lugar del viejo. Despues cree el servicio dns pero no hice ninguna zona nueva para que solo mostrara la del AD.

     

    Ahora, cuando quize agregar otra maquina al ad me da este error.

    """ Nota: esta información está dirigida a un administrador de red. Si usted no lo es, notifique al administrador
    de red que ha recibido esta información que se ha registrado en el archivo C:\WINDOWS\debug\dcdiag.txt.

    Es posible que el nombre de dominio xx.xx.xx sea un nombre de dominio NetBIOS. Si este es el caso, compruebe que el nombre de dominio está registrado correctamente con WINS.

    Si está seguro de que el nombre no es un nombre de dominio NetBIOS, la siguiente información le ayuda a solucionar los problemas con su configuración DNS:

    Se hizo correctamente la consulta al DNS para el registro de recursos de ubicación de servicio (SRV) usado para ubicar un controlador de dominio para el dominio xx.xx.xx:

    La solicitud era para el registro SRV para _ldap._tcp.dc._msdcs.xx.xx.xx

    La solicitud identificó los siguientes controladores de dominio:

    servidor_nuevo.xx.xx.xx

    Las siguientes son causas comunes de este error:

    -Faltan registros de host (A) que asignan el nombre del controlador de dominio a sus direcciones IP o contienen direcciones incorrectas.

    - Los controladores de dominio registrados en DNS no están conectados a la red o no se están ejecutando.

    Para obtener más información sobre cómo corregir este problema, haga clic en Ayuda. """

    Alguien me da una idea????

    Gracias.

     

    P.D: Tuve otros problemas ademas de este pero ya los fui solucionando, como por ejemplo el GPO del dominio como del controlador no existia o estaba corrupto.

    miércoles, 1 de febrero de 2012 17:11

Respuestas

  • Hola JoTaEssEuy

    Por lo que lei no tengo claro algo y quisas aqui este tu ploblema

    1. Al nuevo server (2003) lo hice Controlador de dominio secundario sin antes hacerlo equipo del dominio.

    R. segun esto lo que hiciste fue entrar dcpromo crear un dominio con el mismo nombre como si fuese principal lo recomendable es que agregaras el servidor al dominio exsistente y elevarlo a controlador de dominio secundario.

    2. Copie los datos del server viejo que queria tener en el nuevo.

    R. si te refieres a datos no hay problemas pero si es configuración lo que tenias que hacer es dejar que los servidores replicaran (esto ya despues de agregarlo como DNS secundario)

    3. Apague el server viejo y levante el nuevo en el lugar del viejo. Despues cree el servicio dns pero no hice ninguna zona nueva para que solo mostrara la del AD.

    R. Despues de haber transferido todos los roles, FSMO, etc. de tu servidor viejo al nuevo lo unico que tendrias que hacer es dale de baja al viejito y reiniciar las PC y cuando estas inician se autenticaran con el nuevo servidor

    Espero haberme explicado cualquier consulta a la orden

     

    Saludos,


    Marcial Espitia
    • Propuesto como respuesta Ismael Borche martes, 7 de febrero de 2012 16:30
    • Marcado como respuesta Ismael Borche miércoles, 8 de febrero de 2012 13:47
    viernes, 3 de febrero de 2012 18:32

Todas las respuestas

  • Primero, levanta al controlador de dominio "viejo"

    Segundo apunta al "nuevo" para que use como DNS al "viejo"

    Si en "nuevo" ya está agregado el servicio DNS, no hace falta hacer nada, ni configurar zonas
    Lo que hay que hacer es esperar que repliquen las zonas, si están integradas en AD ¿si?

    Recién luego que replique las zonas, apagas al "viejo", apuntas a los clientes como DNS al "nuevo", y cuando vas a unir una máquina al dominio usa el nombre DNS (dominio.sufijo), y no solamente "dominio"

     


    Guillermo Delprato - Buenos Aires, Argentina
    Visite Notas Windows Server
    MVP-MCT-MCSE-MCSA MCITP: Enterprise/Server Administrator MCTS: Active Directory/Network/Applications Configuration
    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.
    miércoles, 1 de febrero de 2012 17:23
    Moderador
  • Gracias por tu respuesta pero lamento decirte que es parte de lo que hice. Quizas puede haber sido que cuando saque el server viejo y puse el nuevo en su lugar, fisicamente lo movi hasta donde estaba el viejo, al reiniciar le puse la IP del viejo. No se, ya me tiene paranoico esto porque segui todos los pasos al pie de la letra se podria decir y me esta dando problemas muy extraños como al usar rdp no me puedo loguear como ningun usuario porque dice ".. el dominio no esta disponible" cuando ME ESTOY LOGUEANDO AL SERVER CON EL DOMINIO!!! y lo raro es que logueandome en el server mismo, fisicamente en frente a la maquina, y haciendo un refresh en la consola de usuarios y equipos de active directory alcanza para que luego pueda acceder via rdp, hasta que pasan unas horas cuando vuelve a dar el mismo error y vuelta a refrescar la consola y asi estoy con la cabeza dando vueltas como loco.

    Lo otro semi-extraño, porque ya me ha pasado en otros servers, es el tiempo prolongado que lleva levantar el server despues de un reiniciio sobre todo en la parte de "preparando conecciones de red". La remata al terminar de levantar y loguearme porque recien despues de los avisos del antivirus y otros softs que se ejecutan al inicio salta el cartel de "Ahora esta conectado a la red" o algo asi como si recien hubiese encontrado la tarjeta de red, que por cierto es on-board y de chip atheros, algo no muy bueno para tener en un server pero el cliente queria "ahorrar" y no comprar un server como la gente.

    Ya hice todo tipo de pruebas al server, a las terminales y al oto server que tengo con otro dominio porque tambien lo uso de servidor DNS pero sin privilegios de la zona, solo como secundario.

    Otros datos que no dije que pueden ser relevantes:

    Server viejo:

    server 2003 actualizado en español de 32 bits. Es un IBM viejo que no recuerdo el modelo ahora. Actuaba como AD, DNS y File Server.

    Server nievo:

    server 2003 actualizado en ingles de 64 bits. Es un pc con un i5 y 6 giga de RAM. Tendria que actuar con los mismos servicios que el viejo pero me trae loco.

    viernes, 3 de febrero de 2012 5:40
  • Al nuevo server (2003) lo hice Controlador de dominio secundario sin antes hacerlo equipo del dominio. ¿Esto esta bien?

    Perdón? Si el equipo no está en dominio, no puedes promocionarlo a DC secundario.
    Saludos,

    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator (Windows Server 2008)
    MCITP: Enterprise Messaging Administrator (Microsoft Exchange 2007 & Exchange 2010)
    MCITP: Lync Server Administrator 2010
    MCC: Microsoft Community Contributor 2011
    Citrix CCA
    Visita mi blog en ITPro.es
    MCP Virtual Bussines Card
    viernes, 3 de febrero de 2012 10:31
    Moderador
  • [Guillermo] Respondo entre líneas

    Gracias por tu respuesta pero lamento decirte que es parte de lo que hice. Quizas puede haber sido que cuando saque el server viejo y puse el nuevo en su lugar, fisicamente lo movi hasta donde estaba el viejo, al reiniciar le puse la IP del viejo.

    [Guillermo] Eso de cambiar la IP por la del viejo no se debe hacer, tanto porque los clientes tienen "cacheada" esa dirección, como que no te permite poner en línea nuevamente al "viejo"

     

    No se, ya me tiene paranoico esto porque segui todos los pasos al pie de la letra

    [Guillermo] Es evidente que no :)

     

     se podria decir y me esta dando problemas muy extraños como al usar rdp no me puedo loguear como ningun usuario porque dice ".. el dominio no esta disponible" cuando ME ESTOY LOGUEANDO AL SERVER CON EL DOMINIO!!!

    [Guillermo] No es nada extraño. Una cosa es en el propio servidor, y otra que tenga que resolver un nombre desde otro equipo

     y lo raro es que logueandome en el server mismo, fisicamente en frente a la maquina, y haciendo un refresh en la consola de usuarios y equipos de active directory alcanza para que luego pueda acceder via rdp, hasta que pasan unas horas cuando vuelve a dar el mismo error y vuelta a refrescar la consola y asi estoy con la cabeza dando vueltas como loco.

    Lo otro semi-extraño, porque ya me ha pasado en otros servers, es el tiempo prolongado que lleva levantar el server despues de un reiniciio sobre todo en la parte de "preparando conecciones de red".

    [Guillermo] Este es un síntoma típico que está mal la configuración de DNS, que es lo que supongo que está mal y por eso te puse la solución en el post anterior

     La remata al terminar de levantar y loguearme porque recien despues de los avisos del antivirus y otros softs que se ejecutan al inicio salta el cartel de "Ahora esta conectado a la red" o algo asi como si recien hubiese encontrado la tarjeta de red, que por cierto es on-board y de chip atheros, algo no muy bueno para tener en un server pero el cliente queria "ahorrar" y no comprar un server como la gente.

    [Guillermo] Cuidado con los antivirus en un DC, muchos de ellos asumen funciones de cortuegos que *no* puedes tener en un DC.
    Y menos tener dos cortafuegos simultáneamente, como el incluido y otro

     

    Ya hice todo tipo de pruebas al server, a las terminales y al oto server que tengo con otro dominio porque tambien lo uso de servidor DNS pero sin privilegios de la zona, solo como secundario.

    [Guillermo] Si como te preguntaba antes y que no me respondes, la zona está integrada en AD, no hay DNSs secundarios. No hay que crear la zona a mano, sino esperar que replique
    Y cada DNS debe tener configurado para usar como DNS a sí mismo y al otro. Igual para los clientes

     

    Otros datos que no dije que pueden ser relevantes:

    Server viejo:

    server 2003 actualizado en español de 32 bits. Es un IBM viejo que no recuerdo el modelo ahora. Actuaba como AD, DNS y File Server.

    Server nievo:

    server 2003 actualizado en ingles de 64 bits. Es un pc con un i5 y 6 giga de RAM. Tendria que actuar con los mismos servicios que el viejo pero me trae loco.

     

    AGREGO:

    Y relacionando lo que comentas, con la pregunta de Marc

    ¿Cómo haz promocionado al "nuevo"?

    ¿Agregándolo como Controlador de Dominio adicional al Dominio existente?

    ¿O creando un nuevo DC con el mismo nombre de servidor y dominio?

     

     


    Guillermo Delprato - Buenos Aires, Argentina
    Visite Notas Windows Server
    MVP-MCT-MCSE-MCSA MCITP: Enterprise/Server Administrator MCTS: Active Directory/Network/Applications Configuration
    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.
    viernes, 3 de febrero de 2012 10:51
    Moderador
  • Hola JoTaEssEuy

    Por lo que lei no tengo claro algo y quisas aqui este tu ploblema

    1. Al nuevo server (2003) lo hice Controlador de dominio secundario sin antes hacerlo equipo del dominio.

    R. segun esto lo que hiciste fue entrar dcpromo crear un dominio con el mismo nombre como si fuese principal lo recomendable es que agregaras el servidor al dominio exsistente y elevarlo a controlador de dominio secundario.

    2. Copie los datos del server viejo que queria tener en el nuevo.

    R. si te refieres a datos no hay problemas pero si es configuración lo que tenias que hacer es dejar que los servidores replicaran (esto ya despues de agregarlo como DNS secundario)

    3. Apague el server viejo y levante el nuevo en el lugar del viejo. Despues cree el servicio dns pero no hice ninguna zona nueva para que solo mostrara la del AD.

    R. Despues de haber transferido todos los roles, FSMO, etc. de tu servidor viejo al nuevo lo unico que tendrias que hacer es dale de baja al viejito y reiniciar las PC y cuando estas inician se autenticaran con el nuevo servidor

    Espero haberme explicado cualquier consulta a la orden

     

    Saludos,


    Marcial Espitia
    • Propuesto como respuesta Ismael Borche martes, 7 de febrero de 2012 16:30
    • Marcado como respuesta Ismael Borche miércoles, 8 de febrero de 2012 13:47
    viernes, 3 de febrero de 2012 18:32