none
Error al abrir una cuenta RRS feed

  • Pregunta

  • Hola a todos tengo un problema, ya que dese que hize la migración de datos de cuentas y contactos ahora al abrir una cuenta no me la muestra, me marca un error pero si estan todas mi lista de cientas migradas,   y con los contactos no tengi ningun problema. Alguien podría explicrame como resolverlo? Gracias
    • Cambiado Atilla Arruda miércoles, 17 de marzo de 2010 1:51 (De:Entrenamiento y Certificación (Latinoamérica))
    martes, 16 de marzo de 2010 21:23

Respuestas

  • Hola Yenni,
    me da la sensacion de que es algun problema con las personalizaciones.
    Prueba en primer lugar prueba habilitando la descripcion de los errores "DevErrors" del Web.Config (mira este articulo: http://support.microsoft.com/kb/857192). Es posible que te aparezce entonces un error que te diga algo mas acerca del mismo.
    Sino intenta ir quitando todos los atributos del formulario hasta detectar cual es el que está mal, creo que podria ser algun atributo que no esté correctamente (podría ser por ejemplo un lookup, o algún otro atributo).

    un saludo
    Demian Adolfo Raschkovan Blog: http://crmtoall.blogspot.com
    • Marcado como respuesta Yenni_libni jueves, 18 de marzo de 2010 3:38
    miércoles, 17 de marzo de 2010 8:34
    Moderador

Todas las respuestas

  • Yenni,

    Qué tipo de cuentas usted estas hablando? Qué tipo de servicio estas usando?

    Gracias por la aclaración..

    Saludos!


    Átilla Arruda - Microsoft Corporation
    martes, 16 de marzo de 2010 21:32
  • Estoy hablando de la entidad cuenta en Microsoft Dynamics crm.
    ni siquiera me deja crear una cuenta nueva, me aparece una venta que dice error intente esta acción de nuevo si el problema persiste consulte a Microsoft Dynamics crm para obtener soluciones o pongase en contacto con el administrador de Microsoft Dynamics CRM

    martes, 16 de marzo de 2010 23:55
  • Te voy a agradecer mucho si me puedes ayudar.

    martes, 16 de marzo de 2010 23:56
  • Hola Yenni,
    me da la sensacion de que es algun problema con las personalizaciones.
    Prueba en primer lugar prueba habilitando la descripcion de los errores "DevErrors" del Web.Config (mira este articulo: http://support.microsoft.com/kb/857192). Es posible que te aparezce entonces un error que te diga algo mas acerca del mismo.
    Sino intenta ir quitando todos los atributos del formulario hasta detectar cual es el que está mal, creo que podria ser algun atributo que no esté correctamente (podría ser por ejemplo un lookup, o algún otro atributo).

    un saludo
    Demian Adolfo Raschkovan Blog: http://crmtoall.blogspot.com
    • Marcado como respuesta Yenni_libni jueves, 18 de marzo de 2010 3:38
    miércoles, 17 de marzo de 2010 8:34
    Moderador
  • hola Demian, gracias por la información y ya active los mensajes de error pero ahora, y estos son las detalles del error, honestamente no entiendo nada, me puedes ayudar a decifrar de que se trata. Gracias

    detalles de error:


    Microsoft CRM Error Report:
    Error Description:
    Método no encontrado: 'System.String Microsoft.Crm.Formatting.CrmFormatter.GetCurrencySymbolForAttribute(Microsoft.Crm.Metadata.MoneyAttributeMetadata, System.Guid, Microsoft.Crm.IOrganizationContext)'.

    Error Details:
    Se produjo una excepción de tipo 'System.Web.HttpUnhandledException'.

    Full Stack:
    [MissingMethodException: Método no encontrado: 'System.String Microsoft.Crm.Formatting.CrmFormatter.GetCurrencySymbolForAttribute(Microsoft.Crm.Metadata.MoneyAttributeMetadata, System.Guid, Microsoft.Crm.IOrganizationContext)'.]
       en Microsoft.Crm.Application.Components.Sdk.FormControls.Web.MoneyControl.set_Metadata(AttributeMetadata value)
       en Microsoft.Crm.Application.ControlActivator.CreateControl(ControlDescriptor controlDescriptor, String clientId)
       en Microsoft.Crm.Application.Forms.CrudForm.BuildFormModel(FormDescriptor formDescriptor)
       en Microsoft.Crm.Application.Forms.CustomizableForm.Execute(Entity entity, String formType)
       en Microsoft.Crm.Application.Forms.CustomizableForm.Execute(Entity entity)
       en Microsoft.Crm.Web.SFA.AccountDetailPage.ConfigureForm()
       en Microsoft.Crm.Application.Controls.AppUIPage.OnPreRender(EventArgs e)
       en System.Web.UI.Control.PreRenderRecursiveInternal()
       en System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
    
    [HttpUnhandledException: Se produjo una excepción de tipo 'System.Web.HttpUnhandledException'.]
       en System.Web.UI.Page.HandleError(Exception e)
       en System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
       en System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
       en System.Web.UI.Page.ProcessRequest()
       en System.Web.UI.Page.ProcessRequestWithNoAssert(HttpContext context)
       en System.Web.UI.Page.ProcessRequest(HttpContext context)
       en ASP.automatizacionesindustrialesyd_sfa_accts_edit_aspx.ProcessRequest(HttpContext context)
       en System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
       en System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
    
    

    Other Message:
    Error Number:
    Source File:
    Not available

    Line Number:
    Not available


     
    Date: 03-17-2010

    Time: 11:18:15

    Server: 192.168....
    Request URL:
    miércoles, 17 de marzo de 2010 17:17
  • Buenas Yenny,

    Mmmm el problema en general se puede deber a muchos motivos, uno de ellos es el que comento Demian,
    yo me inclinaría mas a pensar de que esta relacionado con algún script que estas manejando dentro de esta entidad.

    Por favor pueba lo siguiente, entre a personalizar la entidad cuentas y en el Formulario dale click a propiedades y revisa si no hay un evento script en el onload o en el onsave.

    Del mismo modo si has actualiazado, a una nueva versión es aconsejable q borres las cookies de la maquina cliente, Internet Explorer , Options , Delete cookies.


    Comentanos como te fue.


    Jimmy Larrauri http://jimmylarrauri.blogspot.com
    miércoles, 17 de marzo de 2010 23:30
  • Gracias, después de analizar cuidadosamente, resulto ser que era debisdo a campos en el formulario se los quite y ya puedo abrir una cuenta y crear una nueva. Gracias por la ayuda
    jueves, 18 de marzo de 2010 3:42




  • Hola Demian, gracias por tu ayuda, resulto ser un campo.
    Muchas muchas gracias :)

    jueves, 18 de marzo de 2010 3:57