none
carpeta Redirected folders RRS feed

  • Pregunta

  •      Hola a todos,

         En una instalación con SBS2008 tengo a los usuarios con el perfil de usuario móvil configurado. Esto es una gran ventaja puesto que cuando alguna máquina cae, el usuario puede iniciar sesión en otra máquina y trabajar con todos sus documentos, etc. Bien, esto se debe a que todas las carpetas personales del usuario (escritorio, documentos, favoritos, ...) se almacenan en el servidor en la carpeta "C:\Users\FolderRedirections\NombreInicioSesión".

         Bueno, pues el caso es que tengo configurada la copia de seguridad de TODO el servidor utilizando el sistema de copias de Win2008 y para mi sorpresa, los contenidos de estas carpetas no se copian.   :-!

         ¿Alguien se ha encontrado con esta problemática y me sabría aconsejar alguna solución o alternativa?

         Gracias anticipadas.


    Un saludo.
    domingo, 14 de noviembre de 2010 10:38

Respuestas

  • Bueno pues parece que he dado con una solución. Hay que quitar la herencia de los permisos que trae por defecto la carpeta y dejar sólo, en cada carpeta, acceso total a la cuenta de SYSTEM, del Usuario y/o de administradores del dominio. Con esto ya puedo ver los contenidos desde una sesión de administrador y además el backup accede a las carpetas y las copia.   :-)

    El único derecho heredado que no copio es el de "Usuarios" (leer, mostrar contenido).

    No acabo de entenderlo porque si el backup es un servicio que se ejecuta como SYSTEM, para esa cuenta nada cambia. Lo único que para cambiar los permisos reasigno como propietario de las carpetas a 'Administradores del dominio'.    X-)


    Un saludo.
    domingo, 28 de noviembre de 2010 21:16

Todas las respuestas

  • El backup da algún error? Has probado la restauración de TODO el servidor para ver si efectivamente no está?
    -------- Salu2!! Javier Inglés - Microsoft Active Professional 2010
    domingo, 14 de noviembre de 2010 12:42
  •      Hola Javier,

         Ante todo gracias por responder. Lo que digo lo he detectado al intentar restaurar un archivo del escritorio (móvil), de un usuario. He ido al asistente de copias, restauración, archvos o carpetas, he buceado por el árbol de carpetas de la copia de seguridad y, aunque las carpetas están, no tienen archivos.

         También he notado que no puedo acceder con el explorador a estas carpetas con normalidad, aun siendo usuario del grupo de administradores, cuando intento examinar una carpeta de este tipo, al intentar abrir una carpeta de usuario, aparece la ventana de que 'debe confirmar esta operación...', acepto y tras una pausa aparece el contenido de la carpeta con normalidad. Esto pensaba que era normal, ya que son carpetas creadas por el sistema y a las que los administradores no tenemos acceso por defecto, sólo el usuario que aloja en ellas su perfil, y me imagino que la cuenta de system... y supongo que el backup se realiza con alguna credencial válida para extraer el contenido, pero parece que no es así.

         No sé, quizás me equivoque pero me da que no se copia.


    Un saludo.
    domingo, 14 de noviembre de 2010 15:50
  • El que te pida autorización de acceso a las carpeas es normal al hacer uso de la UAC; aunque tú seas adminsitrador, por seguridad el explorer que abres requiere de privilegios para acceder al contenido, de ahí que te pida antes la elevación de permisos para ese proceso y poder acceder a ello por seguridad.

    Si haces el backup entero, prueba a restaurar la carpeta para ver si efectivamente está vacía o no


    -------- Salu2!! Javier Inglés - Microsoft Active Professional 2010
    lunes, 15 de noviembre de 2010 7:16
  •      Si, si... lo entiendo. :-)

         Probaré lo que me dices aunque no creo en 'archivos fantasmas'   :-)

         También lo he comprobado en otra instalación con SBS2008 Std y pasa exactamente lo mismo. Yo diría que el usuario que usa el nuevo sistema de backup en 2008, no tiene privilegios para leer el contenido de estas carpetas y por eso las copia vacías.


    Un saludo.

         Hola de nuevo. Lo acabo de probar y no, no hay nada. Selecciono una de las carpetas con el nombre del usuario, le doy a recuperar en otra ubicación, y cuando termina me dice que todo bien, ha recuperado 0Kb.   :-(   Si voy a la ubicación de la carpeta restaurada veo que se ha creado la estructura de la carpeta hasta el nivel del nombre del usuario, nada más, ni si quiera se crean las de Desktop, Favoritos, etc. Casualmente las que no puedo ver su contenido sin la elevación de privilegios con el explorer (UAC).

         Que mal!   :-/

     

    lunes, 15 de noviembre de 2010 18:52
  • El usuario con el que se ejecuta el backup es administrado? Si es así, prueba a ponerlo si no l oestá ren el grupo de Operadores de copia también; y prueba además a ejecutar el backup celevando los permisos de administrador
    -------- Salu2!! Javier Inglés - Microsoft Active Professional 2010
    martes, 16 de noviembre de 2010 7:44
  • La verdad es que no me he preocupado de esto, el tema del backup con 2008 se realiza a través de un asistente, el cual te va guiando y por defecto ya te propone hacer backup de TODO el sistema. Me imagino que actua como servicio, ¿sabes el nombre? antes era NTbackup, si no, lo busco y miro a ver con qué cuenta se ejecuta el backup.. pero me imagino que con la cuenta de system.
    Un saludo.
    jueves, 18 de noviembre de 2010 17:12
  • No recuerdo si era Backup Service (WBENGINE.EXE)


    -------- Salu2!! Javier Inglés - Microsoft Active Professional 2010
    jueves, 18 de noviembre de 2010 17:15
  • Buena memoria   ;-)

    Pues se ejecuta como cuenta del sistema local... lo he cambiado como la cuenta de administrador del dominio, a ver qué pasa. Lo reviso estos días y comento los resultados.


    Un saludo.
    jueves, 18 de noviembre de 2010 19:56
  • Hola de nuevo...  :-(  Nada, ni cuenta de admin. del dominio, ni cuenta de servicio de red, ninguna de estas cuentas es capaz de levantar el servicio, así que la dejo como estaba, cuenta del sistema local. Con lo que vuelvo al punto de partida.

    ¿Alguna otra idea?

    Gracias :-)


    Un saludo.
    sábado, 20 de noviembre de 2010 13:35
  • Por si acaso, prueba a poner el fgrupo de administradores de dominio en el de backup operators; si programas la tarea por si acaso con el task Scheduler que ejecute la línea de comandos de backup y ver si así resulta?
    -------- Salu2!! Javier Inglés - Microsoft Active Professional 2010
    • Propuesto como respuesta Ismael Borche viernes, 26 de noviembre de 2010 12:32
    • Votado como útil Guillermo Piquer viernes, 26 de noviembre de 2010 18:54
    domingo, 21 de noviembre de 2010 11:16
  • Hola Guillermo Piquer

    Hay algún avance en la solución de este problema?

    Saludo

    Ismael Borche
    miércoles, 24 de noviembre de 2010 18:23
  • Hola,

    No, el tema sigue no resuelto. La última idea de Javier no la he probado aún. No sé dónde buscar de nuevo una solución, ¿quizás me puedas sugerir otro foro más apropiado?


    Un saludo.
    viernes, 26 de noviembre de 2010 15:08
  • Javier, creo que hay un problema de permisos en la configuración que establece el sistema por defecto y de ahí que la aplicación de backup no pueda acceder a estas carpetas. Te explico un poco lo que veo:

    La carpeta \\redirectedfolders se encuentra en C:\Users\FolderRedirections  y tiene permisos establecidos de SYSTEM y ADMINISTRADORES (control total), también aparece USUARIOS_DEL_DOMINIO pero no tienen ningún permiso concedido ni denegado.

    De esta carpeta cuelga una más por cada nombre de usuario del dominio. Para acceder con el explorador a cualquiera de estas carpetas, aún haciéndolo con el usuario administrador, te sale el UAC, aceptas y accedes al primer nivel donde realmente no hay ningún archivo aún, eso sí, de ahí nacen ya las carpetas susceptibles de copiarse (desktop, my documents, etc...).

    Pues bien, a esas carpetas no hay manera de acceder ya que después hacer doble click, de pasar el mensaje del UAC como en el anterior caso, te dice que imposible acceder. Si vas a la ficha de seguridad de las carpetas te dice que como no puede mostrar cuál es el propietario actual, o lo cambias tú por otro o no puedes ver nada, ni los permisos que tiene ni nada. Y claro, no voy a cambiar los propietarios de momento.

    Imagino que por este mismo motivo la cuenta de SYSTEM no puede acceder a hacer el backup. ¿No parece un pequeño bug del W2008?

     


    Un saludo.
    viernes, 26 de noviembre de 2010 19:03
  • Bueno pues parece que he dado con una solución. Hay que quitar la herencia de los permisos que trae por defecto la carpeta y dejar sólo, en cada carpeta, acceso total a la cuenta de SYSTEM, del Usuario y/o de administradores del dominio. Con esto ya puedo ver los contenidos desde una sesión de administrador y además el backup accede a las carpetas y las copia.   :-)

    El único derecho heredado que no copio es el de "Usuarios" (leer, mostrar contenido).

    No acabo de entenderlo porque si el backup es un servicio que se ejecuta como SYSTEM, para esa cuenta nada cambia. Lo único que para cambiar los permisos reasigno como propietario de las carpetas a 'Administradores del dominio'.    X-)


    Un saludo.
    domingo, 28 de noviembre de 2010 21:16