none
Problemas con el NAP y libreria en Windows 2008 Enterprise RRS feed

  • Pregunta

  • Hola todos,

    De vez en cuando el servicio IAS da el siguiente mensaje:

    "Faulting application svchost.exe_IAS, version 6.0.6001.18000, time stamp 0x47918b89, faulting module msvcrt.dll, version 7.0.6002.18005, time stamp 0x49e0379e, exception code 0xc0000005, fault offset 0x0000a1c3, process id 0x414, application start time 0x01c9e9d991aa7614."

    Y todo el sistema se va de paseo, no puedo reiniciar la máquina, tengo que presionarl el boton de reset etc.....

    Sucede en las 2 máquinas Windows 2008 Enterprise 32 bits con los últimos parches instalados... (sucedía también antes de la actualización del pasado martes...), aunque la que peor lo lleva es una que tiene adiconalmente el "Certificatation Authority Service" instalado 

    Esto no sucede en la máquina con Windows 2008 Enterprise de 64 bits.

    Alguna idea???

    viernes, 12 de junio de 2009 15:45

Respuestas

  • Hola,

    Para los interesados en intentar resolver este problema:

    En el foro en ingles está abierto en el siguiente LINK

    http://social.technet.microsoft.com/Forums/en-US/winserverNAP/thread/a9698005-aac3-42e6-9b5c-c00e9604b045/

    COmo se darán cuenta, es un tema abierto a la espera de respuesta por soporte (y fallo reconocido por soporte), y no es un problema de seguir unas guias de escenarios propuestos (que pueden ser útiles a la hora de implantar una red de autenticación, pero no soluciona este problema en particular).

    Se supone, por uno de los comentarios en el foro en ingles, que la posible solución la liberarán en el set de parches de diciembre, pero no está confirmado.

    Como la guia que propone Diego Muñoz y confirma Ailla Arruda no es la solución al problema, las he desmarcado como respuestas.


    Un saludo

    Ing. HMolina Ph.D.

    viernes, 16 de octubre de 2009 15:11

Todas las respuestas

  • Hmolina,

    Tu puedes documentar el Error con la siguiente informacion.

    - Event ID y Source.
    - Cuales servicios tienes instalado en los servidores?

    Espero su respuesta.
    Ing. Diego Fernando Muñoz L. MCT - MCSA - MCSE - CCAI - CCNA.
    lunes, 15 de junio de 2009 20:34
  • Hola,

    El EventID es 1000 y el source es "Application Error".

    Servicios: tengo 3 servidores con el mismo problema todos:

    1 Servidor con el Print Service, NAP (Network Policy y Remote Manager connection), Active Directory (Global Catalog), DNS y Terminal Server. Arquitectura 32 bits.
    1 Servidor con el Print Service, NAP (Network Policy y Remote Manager connection), Active Directory (Global Catalog), DNS, Certificate Service, IIS. Arquitectura 32 bits.
    1 Servidor con el Print Service, NAP (Routing and Remote Access, Network Policy y Remote Manager connection), Active Directory (RID Master, PDC, Schema Master, Infrastructure Master) y
     DNS. Esto es de lo más curioso, es de 64 bits.

    Aplicaciones instaladas en los 3 casos: Firefox, WireShark, Snort y WinPCAP. Aunque las he desinstalado y sigue el mismo error.

    He logrado replicar el problema:

    Si un usuario desde un equipo Mac (Probado desde un MacBook, MacBook Pro, iMac con Leopard 10.5.6 y 10.5.7 y un iPhone) se conecta usando el protocolo PEAP e introduce el password equivocado,  se genera el evento de error y el servicio de IAS deja de funcionar.... y al momento el sistema se desestabiliza y toca reiniciarlo físicamente (boton reset).

    Probamos desde un equipo con Windows 7, con protocolo PEAP y password equivocado. No genera el mensaje de error.

    Si no se comete el error del password, el servicio IAS autentica correctamente al usuario y lo deja acceder.

    En algunos casos es posible, desde otro servidor de dominio, ejecutar el comando shutdown sobre el servidor inestable, inicia el proceso de apagado, pero despues, al reinicar el sistema, aparece registrado que el equipo se apagó inesperada e indebidamente.

    El servicio funcionaba sin problemas con Windows 2003. :-s

    Gracias por la ayuda.

    H.
    lunes, 15 de junio de 2009 21:01
  • Estimado Diego,

    Paralela a esta línea de discusión, yo abri otra en los foros en ingles:

    http://social.technet.microsoft.com/Forums/en-US/winserverNAP/thread/a9698005-aac3-42e6-9b5c-c00e9604b045/

    donde han solicitado información de depuración, ya que parece ser una inconsistencia del servicio. Creo conveniente centrarnos en esa línea, y no realizar el doble de trabajo.

    Gracias en todo caso por su colaboración.

    Un cordial saludo

    H.
    miércoles, 17 de junio de 2009 9:38
  • Hmolina.

    Con su respuesta quiero saber el escenario de tener tres NAP. 

    Cuantos usuarios trabajan?
    Cual es el requerimiento para NAP?

    Espero su respuesta.

    Ing. Diego Fernando Muñoz L. MCT - MCSA - MCSE - CCAI - CCNA.
    miércoles, 17 de junio de 2009 13:30
  • Hola,

    Tenemos 3 NAP por redundancia.

    Servicios que usan este servicio:

    VPN de Windows, a través del servicio de Routing and Access service de NAP, atacando el servicio de autenticación local.

    Red Wireless con WPA2 Enterprise, 2 servidores radius por redundancia en cada AP, se rotan los 3 servidores entre los distintos A.P. para evitar que el servicio wireless se quede sin autenticación en todos los puntos. 10 puntos de acceso. Solapamiento de areas de cobertura para evitar caidas del servicio, con la consiguiente gestión de espectro radioeléctrico y potencia.

    Usuarios, más bien pocos: 200 usuarios, unos 60 con acceso a la wireless.

    Porcentaje de usuarios wireless Mac 50%
    Porcentaje de usuarios wireless Windows 50%

    Ninguno de los usuarios linux usa la infrastructura wireless, que hayamos detectado.

    Y la redundancia no nos sirve de nada, ya que en el momento que el servidor radius primario deja de responder por la caida del sistema, el cliente con la contraseña mala pasa al siguiente, el cual tambien deja de funcionar, se conecta al siguiente AP, y elimina al tercero.

    Un cordial saludo

    H.






    miércoles, 17 de junio de 2009 14:14
  • Hmolina,

    Adjunto link de informacion con Guias para implementacion de NAP.

    http://technet.microsoft.com/es-es/library/cc730902(WS.10).aspx

    Verifica los escenarios y asi puedes acomodar tu escenario a las mejores practicas.

    Espero que esta informacion ayude a solucionar tu inconveniente.


    Ing. Diego Fernando Muñoz L. MCT - MCSA - MCSE - CCAI - CCNA.
    • Propuesto como respuesta Diego Fernando Muñoz L miércoles, 17 de junio de 2009 17:53
    • Marcado como respuesta Atilla ArrudaModerator miércoles, 7 de octubre de 2009 18:44
    • Desmarcado como respuesta hmolina viernes, 16 de octubre de 2009 15:07
    • Votado como útil hmolina viernes, 16 de octubre de 2009 15:12
    miércoles, 17 de junio de 2009 17:53
  • Estimado Diego,

    Gracias por la respuesta.

    El problema no es el escenario de implantación, el problema es interno, debido a un "bug" al invocar la librería msvcrt.dll por parte del proceso de IAS, tal como se ha establecido en el hilo similar que abrí en el foro de ingles. Como te darás cuenta en ese caso, el problema es replicable (ya lo describi como replicarlo en un mensaje anterior en este mismo hilo), y a través de las herramientas de depuración se ha logrado adquirir la información necesaria para analizar esta situación. Según me indican, lo están analizando alli.

    En todo caso, gracias por la guia, le echaré un vistazo para verificar como mejorar el despliegue, de ser necesario.

    Un cordial saludo

    Harold Molina-Bulla Ph.D.
    miércoles, 17 de junio de 2009 19:56
  • Hola,

    Para los interesados en intentar resolver este problema:

    En el foro en ingles está abierto en el siguiente LINK

    http://social.technet.microsoft.com/Forums/en-US/winserverNAP/thread/a9698005-aac3-42e6-9b5c-c00e9604b045/

    COmo se darán cuenta, es un tema abierto a la espera de respuesta por soporte (y fallo reconocido por soporte), y no es un problema de seguir unas guias de escenarios propuestos (que pueden ser útiles a la hora de implantar una red de autenticación, pero no soluciona este problema en particular).

    Se supone, por uno de los comentarios en el foro en ingles, que la posible solución la liberarán en el set de parches de diciembre, pero no está confirmado.

    Como la guia que propone Diego Muñoz y confirma Ailla Arruda no es la solución al problema, las he desmarcado como respuestas.


    Un saludo

    Ing. HMolina Ph.D.

    viernes, 16 de octubre de 2009 15:11