none
Problemas con DNS RRS feed

  • Pregunta

  • Hola buenos días, estoy teniendo comportamientos extraños en mi DNS, uno de mis servidores que tiene IP fija (asignada en el mismo servidor no en el DHCP) pierde su IP y el DNS lo registra con otra IP. Esto es solo en el DNS por que el servidor sigue siendo accesado con la IP. Alguien sabe por que se da este comportamiento? Esto pasa todos los días a las 12 am. Cada cuando tendría que "renovar" su asociación de IPs el DNS?
    jueves, 25 de abril de 2013 14:44

Respuestas

  • Por lo que dices yo investigaría por varios lugares

    Primero en el Router, si puedes ver la tabla de MACs porque el DHCP identifica a los clientes por su MAC

    Y segundo, quizás el tema está relacionado justamente con los cambios de interfaz ya que cada una tiene su propia MAC (para el Router son diferentes máquinas), pero sin embargo en el Registro de Windows está la dirección IP solicitada de preferencia

    Y si como comentas más arriba, el problema ya no se produce, no me preocuparía demasiada ahora

     


    Guillermo Delprato - Buenos Aires, Argentina
    Visite Windows Server - Todos los Paso a Paso
    MVP [Directory Services] - MCT - MCSE - MCSA
    MAP - MCC - MCSA Windows Server 2012
    MCSA Windows Server 2008 MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory / Network Configuration / Applications Configuration / Server Virtualization / Windows 7 Configuration / Windows 7 & Office 2010 Deployment / Vista Configuration
    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    • Marcado como respuesta Matt Malpica jueves, 9 de mayo de 2013 16:03
    martes, 30 de abril de 2013 11:32
    Moderador

Todas las respuestas

  • Matt Malpica, algunas preguntas para tener datos y poder ayudarte

    - ¿Dominio Active Directory?

    - ¿Es en el DNS que está en el controlador de dominio?

    - ¿La zona está integrada en AD?

    - ¿Qué tipo de actualizaciones dinámicas están permitidas (si lo están)?

     


    Guillermo Delprato - Buenos Aires, Argentina
    Visite Windows Server - Todos los Paso a Paso
    MVP [Directory Services] - MCT - MCSE - MCSA
    MAP - MCC - MCSA Windows Server 2012
    MCSA Windows Server 2008 MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory / Network Configuration / Applications Configuration / Server Virtualization / Windows 7 Configuration / Windows 7 & Office 2010 Deployment / Vista Configuration
    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    jueves, 25 de abril de 2013 15:03
    Moderador
  • Claro!

    Solo tengo un dominio

    Un controlador de dominio (AD y DNS)

    La zona esta integrada al AD

    Estan permitidas: Secure Only

    Lo mas extraño de todo es que solo pasa con este servidor y tengo varios...

    jueves, 25 de abril de 2013 15:13
  • Muy muy raro eso :-)

    Te comento lo que haría, por las dudas y para estar seguro que la seguridad del registro esté bien:
    - Eliminaría el registro A del servidor con problemas
    - Luego, en el servidor, desde un CMD ejecutado como "Ejecutar como administrador" haría IPCONFIG /REGISTERDNS

    De esa forma se eliminaría el registro que aparentemente tiene problemas en su seguridad, y luego la nueva registración quedaría con los valores por omisión

    Ya después habría que hacer trabajo de "detective" ¿hay otro administrador? ¿quién tiene acceso al servidor que tiene problemas? ¿es una IP del tipo 169.254.y.z?

     


    Guillermo Delprato - Buenos Aires, Argentina
    Visite Windows Server - Todos los Paso a Paso
    MVP [Directory Services] - MCT - MCSE - MCSA
    MAP - MCC - MCSA Windows Server 2012
    MCSA Windows Server 2008 MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory / Network Configuration / Applications Configuration / Server Virtualization / Windows 7 Configuration / Windows 7 & Office 2010 Deployment / Vista Configuration
    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    jueves, 25 de abril de 2013 15:44
    Moderador
  • SI de hecho eso es lo que hago cada qeu el problema ocurre... Ahora ese problema se fue y me quedo con el problema de Host not found. This message indicates that the key (name, address, and so on) was not found. Socket Error # 11001 Host not found. (socket error # 11001).

    Alguna idea?

    domingo, 28 de abril de 2013 16:50
  • ¿Qué rango de dirección asume el servidor con problemas? ¿169.254.0.0?

    Respecto del error que nombras ahora, debes describir, cuándo, dónde, en qué momento, etc. De acá no vemos tu pantalla :-)

    Y si ya está solucionado el problema original, deberías comenzar con una nueva pregunta, así mantenemos el foro ordenado

     


    Guillermo Delprato - Buenos Aires, Argentina
    Visite Windows Server - Todos los Paso a Paso
    MVP [Directory Services] - MCT - MCSE - MCSA
    MAP - MCC - MCSA Windows Server 2012
    MCSA Windows Server 2008 MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory / Network Configuration / Applications Configuration / Server Virtualization / Windows 7 Configuration / Windows 7 & Office 2010 Deployment / Vista Configuration
    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    lunes, 29 de abril de 2013 11:44
    Moderador
  • Tiene un rango de IP 172.16.X.X... Antes de cerrar este thread solo quisiera confirmar, es normal que las entradas sean renovadas todos los dias (si no fue configurado asi desde el principio)? Que puede causar este comportamiento?
    lunes, 29 de abril de 2013 14:10
  • Pero ¿es en el mismo rango?

    ¿No habrá otro DHCP funcionando? quizás algún Router

    ¿Tiene más de una interfaz de red? ¿o una interfaz con más de una dirección IP? (Avanzadas de TCP/IP)

    En el enlace que pongo más abajo informa cómo configurar cada cuanto registra en DNS, que por omisión es 24 horas

    http://support.microsoft.com/kb/816592

     


    Guillermo Delprato - Buenos Aires, Argentina
    Visite Windows Server - Todos los Paso a Paso
    MVP [Directory Services] - MCT - MCSE - MCSA
    MAP - MCC - MCSA Windows Server 2012
    MCSA Windows Server 2008 MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory / Network Configuration / Applications Configuration / Server Virtualization / Windows 7 Configuration / Windows 7 & Office 2010 Deployment / Vista Configuration
    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    lunes, 29 de abril de 2013 16:45
    Moderador
  • Si todos los servidores estan en el mismo rango. Y de hecho el DHCP que esta funcionando es un router no el de Microsoft, si tenia mas de una interfaz pero ya fueron deshabilitadas.
    lunes, 29 de abril de 2013 19:22
  • Por lo que dices yo investigaría por varios lugares

    Primero en el Router, si puedes ver la tabla de MACs porque el DHCP identifica a los clientes por su MAC

    Y segundo, quizás el tema está relacionado justamente con los cambios de interfaz ya que cada una tiene su propia MAC (para el Router son diferentes máquinas), pero sin embargo en el Registro de Windows está la dirección IP solicitada de preferencia

    Y si como comentas más arriba, el problema ya no se produce, no me preocuparía demasiada ahora

     


    Guillermo Delprato - Buenos Aires, Argentina
    Visite Windows Server - Todos los Paso a Paso
    MVP [Directory Services] - MCT - MCSE - MCSA
    MAP - MCC - MCSA Windows Server 2012
    MCSA Windows Server 2008 MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory / Network Configuration / Applications Configuration / Server Virtualization / Windows 7 Configuration / Windows 7 & Office 2010 Deployment / Vista Configuration
    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    • Marcado como respuesta Matt Malpica jueves, 9 de mayo de 2013 16:03
    martes, 30 de abril de 2013 11:32
    Moderador
  • Hice varias cosas que ya no supe cual fue la solución, deshabilite otras interfaces, revise el router etc... Y el problema desaparecio, gracias por la ayuda.
    jueves, 9 de mayo de 2013 16:04