none
wpad vía dns RRS feed

  • Pregunta

  • hola

    tengo un wpad funcionando vía dhcp y va muy bien, pero si les asigno ip fija a los equipos no funciona la detección automática del isa server en el explorer o el client firewall. He intentado instalar poniendo en el servidor DNS que el alias wpad es servidor.midominio.dom, pero no funciona (a pesar de haber puesto autodetección en el puerto 80 y que el ISA atienda peticiones en este puerto y no en el 8080). ¿Alguien tiene el WPAD operativo funcionando vía DNS con éxito? Gracias

    lunes, 9 de octubre de 2006 8:33

Respuestas

  • DNS Issues

    This section describes issues you might encounter when configuring WPAD in DNS.

    DNS Auto Detection Is Not Working as Expected

    Problem:

    Clients cannot retrieve automatic detection information from DNS.

    Cause:

    ISA Server may not be listening for automatic discovery requests on the correct port. When using DNS, ISA Server must listen for WPAD requests on port 80.

    Solution:

    To use DNS WPAD entries, check that automatic discovery is enabled for port 80 on the ISA Server computer. To verify this, in ISA Server Management, click the Networks node. Right-click the network on which you want to enable automatic discovery, and then click Properties. On the Auto Discovery tab, verify that Publish automatic discovery information is selected, and that port 80 is specified in Use this port for automatic discovery requests. Note that you cannot configure ISA Server to listen for Web proxy requests and automatic discovery requests on the same port.

    Configure Automatic Discovery to Check DNS Only

    Problem:

    By default, the automatic discovery mechanism checks for a WPAD entry in DHCP, and then DNS. How can it be configured to check only DNS?

    Cause:

    There may be some circumstances in which you want to skip the DHCP check, for example, to increase response times.

    Solution:

    You can configure Internet Explorer to use only DNS for automatic discovery. To do this, navigate to the following registry location:

    HKEY_Current_User\Software\Microsoft\Windows\CurrentVersion\Internet Settings

    Then add the following value:

    DWORD: AutoProxyDetectType. Set the value to 2 to force DNS only.

     

    Un saludo.

    Buenas practicas para el uso de los foros
    Si la respuesta te es de utilidad marca la pregunta como respondida, ayudaras a mantener el foro util para todos y asi agradeces las respuestas.
    No pongas las preguntas en mas de un foro.

    Daniel Matey.
    MCSE, MCSA, MCSD, MCDBA.
    Blog: http://dmatey.spaces.live.com

    • Marcado como respuesta Ismael Borche martes, 5 de abril de 2011 16:08
    lunes, 9 de octubre de 2006 11:34

Todas las respuestas

  • DNS Issues

    This section describes issues you might encounter when configuring WPAD in DNS.

    DNS Auto Detection Is Not Working as Expected

    Problem:

    Clients cannot retrieve automatic detection information from DNS.

    Cause:

    ISA Server may not be listening for automatic discovery requests on the correct port. When using DNS, ISA Server must listen for WPAD requests on port 80.

    Solution:

    To use DNS WPAD entries, check that automatic discovery is enabled for port 80 on the ISA Server computer. To verify this, in ISA Server Management, click the Networks node. Right-click the network on which you want to enable automatic discovery, and then click Properties. On the Auto Discovery tab, verify that Publish automatic discovery information is selected, and that port 80 is specified in Use this port for automatic discovery requests. Note that you cannot configure ISA Server to listen for Web proxy requests and automatic discovery requests on the same port.

    Configure Automatic Discovery to Check DNS Only

    Problem:

    By default, the automatic discovery mechanism checks for a WPAD entry in DHCP, and then DNS. How can it be configured to check only DNS?

    Cause:

    There may be some circumstances in which you want to skip the DHCP check, for example, to increase response times.

    Solution:

    You can configure Internet Explorer to use only DNS for automatic discovery. To do this, navigate to the following registry location:

    HKEY_Current_User\Software\Microsoft\Windows\CurrentVersion\Internet Settings

    Then add the following value:

    DWORD: AutoProxyDetectType. Set the value to 2 to force DNS only.

     

    Un saludo.

    Buenas practicas para el uso de los foros
    Si la respuesta te es de utilidad marca la pregunta como respondida, ayudaras a mantener el foro util para todos y asi agradeces las respuestas.
    No pongas las preguntas en mas de un foro.

    Daniel Matey.
    MCSE, MCSA, MCSD, MCDBA.
    Blog: http://dmatey.spaces.live.com

    • Marcado como respuesta Ismael Borche martes, 5 de abril de 2011 16:08
    lunes, 9 de octubre de 2006 11:34
  • Hola Daniel, gracias:

    By default, the automatic discovery mechanism checks for a WPAD entry in DHCP, and then DNS. How can it be configured to check only DNS?

    El punto 1 ya estaba hecho (autodetección en el puerto 80), y el 2 entiendo que no es obligatorio, es decir, incluso por el texto que cito se supone que el Explorer va a intentar detectar la configuración vía DHCP, pero si tiene IP fija no lo usará y por lo tanto debería recurrir a la resolución vía DNS... que es lo que no va. Incluso el client firewall no se entera de quién es el servidor ISA. No entiendo qué puede pasar...

    lunes, 9 de octubre de 2006 11:53
  • Hola de nuevo

    Este tema sigue sin ir. He seguido los pasos de http://www.microsoft.com/technet/prodtechnol/isa/2004/help/SRSP1_H_WPADentry.mspx y con el IE va perfecto, pero si quiero que un cliente sin IE (ni client firewall) autodetecte el proxy como por ejemplo el Firefox o el Opera no van. ¿Alguien lo ha conseguido? Es decir, que un ordenador sin client firewall y con las casillas de autoedetcción del proxy en el firefox, opera e IE consiga que los 3 vayan... Gracias!!!

    jueves, 16 de noviembre de 2006 13:12
  • Hola

    Creo que el tema puede ser que como está activado el proxyweb y el autodescubrimiento en el puerto 80 no vaya bien. Caso de cambiar el proxy al 8080, ¿habría que cambiar también la entrada wpad del dhcp a servidor:8080 o dejar servidor:80? Gracias...

    martes, 21 de noviembre de 2006 12:18