none
Windows 2012 FailoverCluster y MTU RRS feed

  • Pregunta

  • Hola a todos.

    Tengo configurado un Cluster  en Windows 2012 Datacenter, el cual integran 3 nodos. Hace un par de días recibimos un Storage Dell PS6500, y conectamos al server a través de iSCSI. Hasta ahí todo perfecto.

    Leyendo en la web, encontré que recomendaban, si las placas de red lo soportaban, habilitar el paquete gigante (MTU 9000) para obtener mejor rendimiento. Lo hicimos y desde ese momento comenzamos a tener algunos problemas, como por ejemplo tratar de mover en vivo máquinas virtuales y que se interrumpan la transferencia, mover el almacenamiento y que se corte o tarde más del doble de lo que venía tardando, no poder ingresar al Administrador del Cluster desde el equipo que tiene el control en ese momento, etc.

    Deshabilité el MTU, lo deje como estaba (creo que por defecto está en 1518 bytes) y todos los inconvenientes desaparecieron.

    Hay algo que se pueda hacer para habilitar el MTU a 9000? Es necesario habilitarlo para tener un buen rendimiento (almacenamiento SAN)?

    Muchas Gracias.

    Germán.


    Lic. German Weber

    martes, 15 de abril de 2014 14:13

Respuestas

  • Hola Germán

    Para poder habilitar los Jumbo Frames (MTU 9000) no sólo deben soportarlo los adaptadores de red, sino también toda la electrónica de red intermedia, por lo que deberías comprobar también los switches intermedios. Por otro lado, el problema también podría tener que ver con los drivers de los adaptadores de red, así que no estaría de más que los actualizases a versiones más modernas, si es posible.


    Saludos
    José Antonio Quílez
    Mi Blog

    • Propuesto como respuesta Nicolás E. Granata martes, 15 de abril de 2014 18:30
    • Marcado como respuesta gerweb martes, 15 de abril de 2014 18:41
    martes, 15 de abril de 2014 17:18
    Moderador

Todas las respuestas

  • Hola Germán

    Para poder habilitar los Jumbo Frames (MTU 9000) no sólo deben soportarlo los adaptadores de red, sino también toda la electrónica de red intermedia, por lo que deberías comprobar también los switches intermedios. Por otro lado, el problema también podría tener que ver con los drivers de los adaptadores de red, así que no estaría de más que los actualizases a versiones más modernas, si es posible.


    Saludos
    José Antonio Quílez
    Mi Blog

    • Propuesto como respuesta Nicolás E. Granata martes, 15 de abril de 2014 18:30
    • Marcado como respuesta gerweb martes, 15 de abril de 2014 18:41
    martes, 15 de abril de 2014 17:18
    Moderador
  • Efectivamente José,  la electrónica que conecta los servidores no permitía paquetes mayores a 1516 bytes. Tenemos dos Switch Dell PowerConnect 6248 y no estaba habilitado el Jumbo Frame. Ahora configuraré los switch y luego posteo el resultado de la prueba.

    Desde ya muchas gracias.

    Saludos.


    Lic. German Weber

    martes, 15 de abril de 2014 18:41