none
Resultados no deseados en condicion al restar números con decimales en Excel. RRS feed

  • Pregunta

  • Buenas.

      Tengo un comportamiento extraño al calcular unas restas de los valores de varias celdas. Por ejemplo teniendo cuatro celdas con valores con decimales:

    A1 con valor 1,20

    A2 con valor 0,80

    A3 con valor 0,40

    A4 con valor 0,00

    Calculo la resta de las celdas:

    A6 es "=+A1-A2-A3-A4"

    A7 es "=+A1-A2-A3"

    Compruebo si el resultado es cero:

    B6 es "=SI(A6=0;"Es cero";"No es cero")

    B7 es "=SI(A7=0;"Es cero";"No es cero")

    Como resultado obtengo en B6 "No es cero" y en B7 "Es cero".

    ¿Alguien me puede ayudar a comprender la diferencia?

    Tras realizar la misma operativa en LibreOffice el resultado es el esperado, en los dos casos la respuesta es "Es cero".

    Parece ser un error de redondeo o de ajuste.

    Gracias.

    jueves, 4 de julio de 2019 14:23

Respuestas

  • Hola,

    Lo que indicas es correcto, acabo de hacer la prueba y el resultado es diferente al restar otra vez 0.00 y si das formato a la celda para visualizar más decimales verás que no es 0.0 sino -0.00000000000000011102230246

    Por este motivo la función condicional no funciona correctamente.

    He probado otra forma de escribir la formula y soluciona tu problema:

    En lugar de colocar A1-A2-A3-A4 coloca A1-(A2+A3+A4)

    Aparentemente el signo menos es el que hace la diferencia.


    Saludos. Francisco Diez.

    jueves, 4 de julio de 2019 21:31

Todas las respuestas

  • Hola,

    Lo que indicas es correcto, acabo de hacer la prueba y el resultado es diferente al restar otra vez 0.00 y si das formato a la celda para visualizar más decimales verás que no es 0.0 sino -0.00000000000000011102230246

    Por este motivo la función condicional no funciona correctamente.

    He probado otra forma de escribir la formula y soluciona tu problema:

    En lugar de colocar A1-A2-A3-A4 coloca A1-(A2+A3+A4)

    Aparentemente el signo menos es el que hace la diferencia.


    Saludos. Francisco Diez.

    jueves, 4 de julio de 2019 21:31
  • Muchas gracias.
    viernes, 5 de julio de 2019 11:41