Windows XP SP3 installation hangs


  • unlike every other post iv read, i have not even gotten SP3 installed on my computer yet. whenever i try to install windows xp sp3 it gets to the point where it creates a restore point and hangs. i have tried it under a normal login, a safemode as admin login and a safemode as me login and every time it hangs at the same spot and every time. i have had to restart the computer via the reset button every time. and a few times on reboot my computer cant find my harddrive. is the hang a natural occurence  or is there actually a problem? also where do i find the install logs?
    lunes, 12 de mayo de 2008 15:09

Todas las respuestas

  • Man I have the exact same problem!!! Even worse though cause at the beginning I had the "svchost 100% cpu use" problem everytime I tried to install sp3 ...fortubately solved it and now the system freezes at the point of creation of restore point. I think I ll try to disable system restore and see what happens Wink

    Hope somenone has a solution for our problem though! I just thought to write so you dont feel alone out there Smile

    jueves, 15 de mayo de 2008 19:00
  • its good to know someone cares.

    i have recieved some info from a friend of my dad's who works for Windows that SP3 has issues with AMD processors. my computer has an AMD processor. so i guess i'm screwed. either that or microsoft will notice and fix the problem, if that is really the problem. if anyone has an amd processor and has gotten the update to work please post. even if you havent gotten it to work post as well. that way we actually know it's not just an isolated incident.

    and disabling system restore didnt work, fyi. plus i think that would be dangerous even if it did, cuz if you encountered problems after updating you wouldnt be able to undo it.
    sábado, 17 de mayo de 2008 21:11
  • For problems with SP3 and AMD processors, read this thread:

    XP SP3 and continuos reboots on AMD based systems
    domingo, 18 de mayo de 2008 1:24
  • Hi,

    First run secedit if XP pro or media center.


    Run subinacl if XP Home.

    After running secedit or subinacl try installing service pack 3.

    Deepak S.
    domingo, 18 de mayo de 2008 5:28
  • I'm running an Intel pent d. Install hangs creating driver list. Needs manual reset. Any help Would be nice.

    domingo, 18 de mayo de 2008 10:32
  • you are doing a new installation of SP3 or updating from SP2 ?

    lunes, 19 de mayo de 2008 5:02
  • The thread you suggest is for problems AFTER installinf sp3. DrJaul's problem and mine also is that we cant even install sp3. The installation freezes at the moment of creation a restore point. And of course disabling system restore doesnt solve the problem as DrJaul mentioned above. Searching around in other forums I also discovered that this problem is encountered by pple with AMD and Asus A8N mobos...some say is incobatibility issues with ACPI others that the BIOS needs updating... I am so confused and frustrated though that I think I will skip the installation of sp3 ...After all it doesnt offer anything that worths all this trouble and time I ve spend on the issue... I think MS should send me a check for debugging the faulty they wrote ...LOL!!!

    sábado, 24 de mayo de 2008 8:36
  • You have a combination of AMD+ ASUS A8N ?

    If yes; plese wait till the storm settles for the problems sorrounding them.

    or be brave and help people in finding out differtent issues related to this; might not be a smooth drive though


    Please run the below from a command prompt and do a reboot


    verifier /flags 0x3B /all


    Restart the system & sart the installation.

    If you really have any issue; the system hopefully will bugcheck (you get a BSOD).

    let's know the error code details

    If it doesn't bugcheck then copy paste the last few entries from eventviewer, after your installation freezes and you complete the reboot. Also share the setupapi.log from system32 folder.


    For eventviewer

    Start->Run->type "eventvwr.msc"-> Ok ->Click system


    to get the machine into its original state run the below from command prompt and reboot

    verifier /reset


    Though nothing wil happen to your sytem data; I take no responsibilty of your data,back up on your own

    domingo, 25 de mayo de 2008 4:46
  • Well unfortunately I do have the AMD + ASUS A8N combo....LOL!!!

    Anyway I decided to be brave and follow your instructions but it seems my pc has other issues too Sad

    After activating the verifier /flags 0x3B /all command and reboot I get a BSOD before even starting the installation of sp3, with the following error:

    IO system verification error in NDIS.SYS (WDM DRIVER ERROR 226)

    [NDIS.SYS + 7010 at BA4E3010]


    I googled it and found a guy reporting solving this error by replacing the ndis.sys file from another pc. I did it but to no avail. I get the same error in the verifying mode, but other than that windows run normally.

    I guess I have to wait for the storm to settle ...LOL...

    unless you have smth else to advise.



    domingo, 25 de mayo de 2008 7:55

    Evening Eraklis

      Prior to installing Sp3

    Which video card are you using?

     Nvidia has the 175.16 WHQL signed and avail. The lowest number I think for problems is 80 something. (which ever ones came with my 6600gt, dont remind me) at least with out throwing error with Windows.


     Ati has the catalyst 8.5 drivers available  Lowest number sp3 sort of comptible is 8.3 or 8.4

      8.5 is much more stable then recent drivers.


    Are you using any sort of Sata? Latest chipset or .inf may help you out here.



      This basically states if you attached some additional protocal that the driver verify may fail.


    I would search your hard disk and see if there is another copy in the c:\windows\system32\dllcache

    Boot to your cd(m,ay need to enable in bios settings), recovery console and copy the file from the dllcache to the system32 folder.


    Reboot. And check the verify now.

    While here you have removed all traces of NIS or Norton antivirus correct? I knew you have, since norton has a problem with the Sp3 it leaves behind many currupt registry entrys. This applys to  Trend microsecurity also. Using ccleaner Windows Live care will clear out the bad entrys


    Also to prevent other problems please clear out the bit download folder.This has an extra step but is use full


    net stop wuauserv

    regsvr32 wups2.dll

    rmdir c:\windows\softwaredistribution /s

    net start wuauserv


      If you are having driver problems I would also download and re-install the windows installer. then reboot


    Thjere is a reason for this two. If there still is a problem with MU th second command will fix a portion of this problem. Then once Sp3 is installed it will see other jobs in the que and try to download them. Both of these preventproblems with MU and slow downs.

    Once you have the ndis.sys restored. I would attempt an Update from the "adminstrator" log in instead of computer adminstrator/user account.


      Unless you are willing to download and install subinacl.exe and the reset command as mentioned in access denied in these forums. Be beware this makes your computer adminstrator account with special permissions and results in being  more volunerable to mal ware.


    Here is

    domingo, 25 de mayo de 2008 10:41
  • IO system verification error in NDIS.SYS (WDM DRIVER ERROR 226)


    Please open device manager for network adapters

    Start -> Run -> devmgmt.msc -> Network Adapters


    and send us the details of the available entries.

    In the mean time let me find out what the error in NDIS.sys means here.

    domingo, 25 de mayo de 2008 17:34
  • Hi 1st knight and thnx for your suggestions.

    I am not willing to follow them though (lol) cause it's a matter of principal: I will not adapt to Microsoft's bidings...they should adapt to me. To reply to your answer though I am not using Norton or NIS and my video card is an Albatron 7900gt with the forceware 169.21 I dont know if its WHQL certified and I dont care. It is unbelievable to think that MS is trying to control the software we use by enforcing this certification.

    To Saroj:

    Thank you to Saroj for helping me. I am not using network cause it's my home pc but it has the onboard network card enabled along with the firewire port and a usb dsl modem that I use to connect to internet.

    lunes, 26 de mayo de 2008 7:03
  • In that case lets keep apart the error of NDIS.


    You can start the installation.


    But some points regarding your opinions about WHQL.


    I dont know if its WHQL certified and I dont care.

    Actually MS does this so that someone creating drivers for MS - Windows is following the specs created by MS.

    Here is why its needed :  Let's say you have an current setup. Windows + software(including drivers not signed by WHQL). This means its complete responsibility of your driver provider to let you know what will happen if you want to upgrade\update the OS. In your case you have SP2+ some working but non WHQL driver. When you update to SP3 it'll replace some of the existing MS drivers with its newer version which will have some bugs(security, functionalty) fixed. Now unless the drivers on your system are WHQL signed Microsoft doesn't take the responsibilty of breaking the functinality of your existing system. Now when you move to SP3 some internal functionalty might have changed which will prevent your existing non-WHQL drivers to run. And you run into trouble. So the point is you can run non WHQL drivers; but then no-one takes the responsibilty for smooth update from one version of OS to the other.


    lunes, 26 de mayo de 2008 12:37
  • I have AMD and AN8SLI Deluxe and I'm not laughing either.  I just did a system restore, but now I can't even get my windows xp media center boot disk to boot up in addition to the regular boot failing.  This is maddening.

    jueves, 28 de agosto de 2008 19:19
  • Working solution : While SP3 still hanging

                                         1- Start TaskManager

                                         2- Select Process

                                         3- Select Regsvr32.exe

                                         4- End Process

                                         5- Close TaskManager

    You should notice an extensive hard disk activity.let it go until the end of installation and restart.

    Good luck !

    • Propuesto como respuesta firststknight martes, 01 de marzo de 2011 0:27
    jueves, 18 de septiembre de 2008 12:26
  • wow thank you buddy, my wouldnt instal, till i read ur fix an used the comand promp, it worked but my computer was lagging like crazy for 3 days, i went back, finished reading ur post, an found out i had to  "verifier /reset". it's in turbo mode right now =)  " i got the "amd+asus a8n deluxe combo too"
    lunes, 28 de febrero de 2011 23:37