locked
Win Vista no me reconoce T. video Como deberia..!!! RRS feed

  • Pregunta

  • Hola, el caso es que instale win vista varias versiones 32 y 64 bits, ultimate, home, home premiun, bussines y al terminar la instalacion queria revisar como detectaba con sus controladores mis dispositivos... y note que la tarjeta de video una nvidia GeForce 7300 GS 256 MB PCI express la toma como una 6500... entonces me dije ahorita voy a nvidia descargo la ultima, ultimisima version de los drivers y listo el "pizco"... pero resulta que no... hasta con lo ultimas versiones... y aun ahorita sigo descargando las ultimas versiones y nada de nada... entonces pense donde la compre me estafaron... pero al arrancar el equipo y lo primero que muestra es el mensaje de la "BIOS" de la tarjeta de video antes que los mensajes de la BIOS de la placa y me confirman que es una 7300 GS de 256 MB... entonces por "manitas creativas" quite la T. de video y le quite el disipador que tiene y verifique visualmente que lo escrito en el chip es una 7300 GS... entonces estoy mas perdido, desubicado, todo eso le gana a mi ignorancia atrevida y mis pocos conocimientos....

     

    Gracias... alguien tiene alguna opinion al respecto...???

    lunes, 3 de diciembre de 2007 4:18

Respuestas

  • Explicado mejor de otra manera: cualquier dispositivo hardware se identifica con un string que debe ser unico, por ejemplo: VEN_8086&DEV_24CB en donde en VEN_ corresponde a un "vendor" (fabricante) y DEV_ a un dispositivo dentro de ese fabricante. Todos los fabricantes tienen un numero unico, por ejemplo VEN_8086 corresponde a Intel. Este numero lo piden a una sociedad que los identifica y a partir de ese momento ellos lo graban en el firmware de su hardware. Igualmente cada fabricante va numerando sus dispositivos. (DEVICES), de esta forma, el string anterior corresponde al DEV_24CB de Intel.

     

    Este string identificativo, junto con las necesidades del dispositivo (IRQ's, direcciones de memoria, puertos de entrada salida, DMA, etc) son con las que el dispositivo se identifica a la Bios del equipo (al objeto de pedirle recursos que necesite) e igualmente con lo que se identifica a los sistemas operativos.

     

    En Windows Vista puede verse este string que envia el dispositvo hardware en el Administrador de Dispositivos, en propiedades del dispositivo, ultima pestaña y seleccionando en el combo que aparece "Hardware ID".

     

    Los instaladores de drivers (sean de windows, o sean instaladores propios del fabricante) lo que hacen es comparar ese string con los string's que existen dentro de los .INF. Si son identicos, es cuando se monta el driver. En otro caso dirá que el driver falta.

     

    Por tanto, el .INF de nVidia no coincide con el que se identifica el hardware. Esto es impensable que suceda a no se que el montador de la tarjeta haya cometido un error.

     

    Un saludo,

    lunes, 3 de diciembre de 2007 8:43

Todas las respuestas

  • Realmente es una estafa, pero la estafa no te la hace el que te la ha vendido, sino el que ha "montado" (OEM) esa tarjeta. Recuerda que nVidia no fabrica tarjetas, sino chips y los montadores dbene realizar el ensamblaje y montarles una bios propia.

     

    Parece ser que tiene el chip que comentas y asi es el mensaje de la Bios de la tarjeta. Pero el string identificativo con el cual se muestra a la Bios de la placa madre y que es el que posteriormente esta Bios muestra al sistema operativo, coincide con otro modelo de nVudua y no con el vendido.

     

    Si analzias un .INF cualquiera de una instalacion de un driver, veras que hay una seccion en donde viene un identificativo de PC, VEN (vendor), modelo etc -puede verse tambien en el Administrador de Dispositivos, en las propiedades de cualquiera de ellos, ultima pestaña y seleccionando Hardware ID.

     

    Este identificativo es el que usa el instalador del driver para buscarlo en los .INF de instalacion.

     

    Un saludo,

    lunes, 3 de diciembre de 2007 6:37
  • Explicado mejor de otra manera: cualquier dispositivo hardware se identifica con un string que debe ser unico, por ejemplo: VEN_8086&DEV_24CB en donde en VEN_ corresponde a un "vendor" (fabricante) y DEV_ a un dispositivo dentro de ese fabricante. Todos los fabricantes tienen un numero unico, por ejemplo VEN_8086 corresponde a Intel. Este numero lo piden a una sociedad que los identifica y a partir de ese momento ellos lo graban en el firmware de su hardware. Igualmente cada fabricante va numerando sus dispositivos. (DEVICES), de esta forma, el string anterior corresponde al DEV_24CB de Intel.

     

    Este string identificativo, junto con las necesidades del dispositivo (IRQ's, direcciones de memoria, puertos de entrada salida, DMA, etc) son con las que el dispositivo se identifica a la Bios del equipo (al objeto de pedirle recursos que necesite) e igualmente con lo que se identifica a los sistemas operativos.

     

    En Windows Vista puede verse este string que envia el dispositvo hardware en el Administrador de Dispositivos, en propiedades del dispositivo, ultima pestaña y seleccionando en el combo que aparece "Hardware ID".

     

    Los instaladores de drivers (sean de windows, o sean instaladores propios del fabricante) lo que hacen es comparar ese string con los string's que existen dentro de los .INF. Si son identicos, es cuando se monta el driver. En otro caso dirá que el driver falta.

     

    Por tanto, el .INF de nVidia no coincide con el que se identifica el hardware. Esto es impensable que suceda a no se que el montador de la tarjeta haya cometido un error.

     

    Un saludo,

    lunes, 3 de diciembre de 2007 8:43
  • Ok, JMT, muchas gracias... a este tipo de informacion era al que me referia en otros post sobre todo el que ya le habia comentado que coloque en el foro de win xp... informacion la cual ire buscando por internet mientras mas tardecito entro a su servidor de noticias.... la verdad deseo profundizar en ese tipo de informacion para no tener que estar preguntando cada ratico sobre las mismas cosas pero que difieren solo en detalles.. mas tardecito estare en su web...

     

    Gracias... de nuevo....

    lunes, 3 de diciembre de 2007 17:55
  • Se me olvidaba, hubiera deseado antes de haber colocado el tema, haber hecho pruebas con win xp para ver si detectaba la tarjeta de video igual que lo hace win vista pero xp no me reconoce bien la placa y se queda pegado si no estoy mal en el segundo reinicio... por eso mi necesidad de obtener informacion de esta indole para asi solucionar mis problemas... aunque por lo que mas o menos entendi el problema se hubiera presentado tambien con win xp...

     

    Un saludo.

    lunes, 3 de diciembre de 2007 18:08
  • Insisto... no es XP o VIsta. Si la reconoce diferente... el problema es del dirver (me parece raro pero es posible que tenga mal los .INF), si lo reconoce igual... problema de la tarjeta (de su montador).

     

    Un saludo,

    lunes, 3 de diciembre de 2007 18:49