none
Agente RRS feed

  • Pregunta

  • Hola a todos, tengo la sigueinte, consulta

    Tengo instalado el scom 2007 R2 y deseo monitorear servidores con Windows 2008,2008r2 y 2003 R2 pero cuando voy a  Monitoring > Windows Computers y en la ventana central se puede visualizar el estado de la monitorización  “Not monitored”. Quisiera saber porque muestra este estado, con que cuenta necesito instalar el agente con SDK o MSA (en mni caso lo instale con la cuenta del dominio).

    Luego en Monitoring >Active Alerts me muestra todo en rojo y mostrando el siguiente mensaje Failed agent push/repair-colud no connect.   A que se podria deber este error o los agentes estan mal instalado.

    Alguna recomendacion

     

    Gracias por la ayuda

     

    domingo, 9 de octubre de 2011 0:48

Todas las respuestas

  • que columna de monitoreo te aparece como "not monitored"? de manera predeterminada,
    esto puede estar pasandote si no esta instalado el management pack de windows
     
     
    Saludos,
    Jose
     
     
    martes, 11 de octubre de 2011 21:01
    Moderador
  • Si tengo instalado el pack management, es necesario agregar la cuenta MSA en el grupo de administradores local del servidor destino Gracias por la ayuda
    martes, 11 de octubre de 2011 21:20
  •  
    no haria falta agregar ninguna cuenta. Hay eventos de error que notes en
    los agentes?
     
     
    martes, 11 de octubre de 2011 21:22
    Moderador
  • Jose,

    Yo he iniciado sesion con una cuenta que he creado llamada MSA , con esa cuenta me he autenticado, pero cuando despliquego el agente instala pero luego aparece en estado fallido y no esta monitoreando, mi consulta es con que cuenta debo desplegar el scom con SDK o con la cuenta de dominio ?

     

    Gracias por la ayuda

    martes, 11 de octubre de 2011 21:34
  • entonces el problema parece de instalacion del agente...
     
    como se instalo el agente? manual, o a traves de la consola? si fue por la
    consola es mas facil, si fue manual, no es dificil pero require un poco mas
    de detalle.
     
    avisa como se instalo el agente. la cuenta que usaste (si es la management
    server action account) y es administradora local en el agente, deberia de
    funcionar bien.
     
    Jose
     
     
    martes, 11 de octubre de 2011 21:36
    Moderador
  • El agente lo desplegue desde la consola , pero estoy auntenticado con una cuenta MSA, pero cuando lo quise instalar me decia que no tenia permisos, fue por eso que instale la cuenta del dominio para instalar los agentes, donde puedes asignarles los permisos a la cuenta MSA para que pueda instalar los agentes en los servidores

     

    Gracias por la ayuda

    martes, 11 de octubre de 2011 21:58
  • cuando decis que esta autenticando con cuenta MSA que estas queriendo decir?
    que el servicio de healthservice corre con esa cuenta?
     
    los permisos que tenes que dejar son localsystem. no esta soportado usar
    alguna otra cuenta para corer el servicio.
     
    podes enviar screenshots? subilos a alguna ubicacion (x ej skydrive) y pasa
    el link.
     
    Jose
     
     
    martes, 11 de octubre de 2011 23:13
    Moderador
  • Me refiero a que estoy logueado con una cuenta MSA que fue creada en el Controlador de dominio, mi consulta si con dicha cuenta puedo desplegar los agentes?

     

     

    Gracias por la ayuda

    martes, 11 de octubre de 2011 23:20
  • no se entiende a que te referis cuando decis cuenta MSA. Si te referis a
    la management server action account (la cuenta que corre el health service
    en el rms) entonces si.
     
    los errores de consola que podes llegar a encontrarte estan documentados
     Jose
     
     
    miércoles, 12 de octubre de 2011 12:18
    Moderador
  • Estimado Jose,

    en cuanto a la cuenta MSA, yo he creado una cuenta en el active directory llamada MSA, luego inicie sesion en el servidor con la cuenta MSA, con dicha cuenta he instalado el SQL y el scom, por eso mi pregunta era si con esa cuenta puedo desplegar los agentes ya que isntalan pero luego dice error

     

     

    Gracias por la ayuda

    miércoles, 12 de octubre de 2011 15:56
  • cual es la descripcion exacta del error? por lo que decis la cuenta deberia
    estar bien.
     
    Jose.
     
     
    miércoles, 12 de octubre de 2011 17:41
    Moderador
  • Estimado Jose, tuvieras un correo para poder enviarte los pantallazos y asi explicarte a detalle

     

    Gracias por la ayuda


    • Editado mikent miércoles, 12 de octubre de 2011 18:27
    miércoles, 12 de octubre de 2011 18:25
  • ya con copiar/pegar en el thread los mensajes ya seria suficiente.
     
    Jose.
     
     
    miércoles, 12 de octubre de 2011 20:06
    Moderador
  • Estimado Jose, al intentar desplegar el agente me sale los siguientes errores en

    Abrir la consola scom 2007 r2 /Monitoring /Active Alerts,   los errores son los siguientes

    - Health Service Unloaded System Rule

    - RunAs Authorization Check Failed scom

    Estoy intentando desplegar el agente a un controlador de dominio en Windows Server 2008 r2, ahora cuando  estoy en el asistente para desplegar el agente me pide 2 cuentas , la 1era para descubrir los equipos en el dominio (ahi puse la cuenta administrator del dominio) y la 2da cuenta  que es para instalar el agente (aca lo dejo por defecto local System)

    cuando le doy en iniciar , el agente me sale como satifastorio, pero luego me muestra los errores mencionados arriba

    Mi consulta son :

    - La cuenta con la que he iniciado sesion (scomMSA) es valido desplegar el agente ?

    - La cuenta scomMSA tiene que pertenecer al grupo administradores del dominio ?

    - Actualmente la cuenta scomMSA pertenece al grupo de adminitradores del servidor local, eso esta bien ?

    - La cuenta ScomMSA tiene que pertencer al grupo de administradores del servidor local , en el  servidor Destino ?

     

    Gracias por la ayuda

     

     

    jueves, 20 de octubre de 2011 21:01
  •  
    Mi consulta son :
     
    - La cuenta con la que he iniciado sesion (scomMSA) es valido desplegar el
    agente ?
     
    si.
     
    - La cuenta scomMSA tiene que pertenecer al grupo administradores del dominio
    ?
     
    no hace falta
     - Actualmente la cuenta scomMSA pertenece al grupo de adminitradores del
    servidor local, eso esta bien ?
    - La cuenta ScomMSA tiene que pertencer al grupo de administradores del servidor
    local , en el  servidor Destino ?
     
    la cuenta de MSA tiene que ser administradora del equipo y se usa solamente
    para la instalacion del agente. Despues el agente corre con localsystem.
     
    el error que mencionas puede estar pasando porque la cuenta definida para
    correr el servicio no es localsystem. Si cambiaste la cuenta para correr
    como un usuario "X", volve atras el cambio y deja localsystem. Sino, reinstala
    el agente usando las opciones predeterminadas.
     
    Jose
     
     
    viernes, 21 de octubre de 2011 1:40
    Moderador
  • Estimado Jose, he aqui mi duda, por aqui anda el problema

    - La cuenta scomMSA tiene que pertenecer al grupo administradores del dominio
    ?
     
    no hace falta
     - Actualmente la cuenta scomMSA pertenece al grupo de adminitradores del
    servidor local, eso esta bien ?
     
    - La cuenta ScomMSA tiene que pertencer al grupo de administradores del servidor
    local , en el  servidor Destino ?
     
    la cuenta de MSA tiene que ser administradora del equipo y se usa solamente
    para la instalacion del agente. Despues el agente corre con localsystem.
     
    -  Jose pero si es un controlador de dominio no tengo la opcion para que la cuenta scomMSA pertenezca al grupo  de administradores en este caso mi servidor es un active Directory como podria hacer en este caso
    -  Ahora tu mencionas que en el agente utilice la cuenta local system tanto en la 1era(descubrir equipos del dominio) y 2da (instalacion de agente) opcion como te mencione en la parte de arriba, entonces no es necesario instalar los agentes con un cuenta administrator de dominio.
    En conclusion deberia de hacer lo siguiente:
    1. Iniciar sesion en el servidor de SCOM con la cuenta scomMSA,
    2. Desplegar el agente con la cuenta scomMSA y seleccionar localsystem
        Tengo entendido que hay que esperar unos minutos para que los cambios refresquen, te comento que ya instale el pak management de AD , pero no me aparece como monitoreado, puede deberse a que primero debo solucionar lo que te comente
    Podrias ayudarme en la consulta que esta en negrita
    Gracias por la ayuda
    viernes, 21 de octubre de 2011 3:34
  • en mi caso, la cuenta que use para instalar el agente en un dc ya es administrador
    de dominio.
     
    probaste hacer eso? tene en cuenta que la cuenta solo es necesaria para instalar
    el agente..despues solo usas localsystem (correr workflows, etc..)
     
     
    sábado, 22 de octubre de 2011 4:49
    Moderador
  • Jose, eso solo aplicaria para los DC (domain controller), otra consulta he instalado el pack management para monitorear mis AD en 2008 r2, pero revisando he visto que dice no Monitoreado, a que se puede deber o que tendria que revisar ?

     

     

    Gracias por la ayuda

    sábado, 22 de octubre de 2011 16:58
  • MikeNT,
     
    podrias por favor abrir un thread Nuevo para la otra consulta? para darle
    un sentido de continuidad no tengo problema en ayudar..sin embargo tener
    varias consultas en el mismo thread no ayuda a dar una idea si alguien lee
    todo este thread.
     
    Gracias
    Jose.
     
     
    domingo, 23 de octubre de 2011 22:32
    Moderador
  • Jose es necesario abrir puertos en el firewall, se requiere levantar algun servicio en el servidor destino donde se instalo el agente ? , en mi caso he deshabilitado el firewall de mi controlador de dominio, de la misma manera en el servidor scom, tambien menciona que hay que poner la cuenta en el grupo administradores del equipo local , en mi caso puse la cuenta scomMSA en el grupo de administradores del dominio, pero ni asi, me salen estos errores en monitorin/active alert
    OleDB: Result Error
    Health Service Unloaded system
    ad domain availability health degraded
    ad domain performance health degraded

    adjunto el link de los puertos

     http://srvcore.wordpress.com/2010/01/04/scom-agent-firewall-ports-and-requirements/

    La imagen adjuntada es del servicio de AD,pero en la pestaña logon no tien una cuenta, eso normal o necesariamente hay q poner la cuenta y contraseña de scomMSA ?

    Que podria estar fallando, gracias por la ayuda



    • Editado mikent jueves, 27 de octubre de 2011 8:15
    jueves, 27 de octubre de 2011 6:49