none
Problema con AD y clientes (windows server 2012 R2) RRS feed

  • Pregunta

  • Buenos días,

    Me encuentro configurando un nuevo servidor con Windows Server 2012 R2. He creado un Dominio con el propio asistente y he empezado a unir clientes al dominio. La mayoría aún son Windows XP (aún que no estarán por mucho tiempo) y tengo un cliente con Windows 7. Con un cualquiera de las máquinas ya unidas a domino, cuando inicio sesión y intento entrar en un directorio compartido por nombre me aparece el siguiente error:

    - No tiene acceso a \\nombre-servidor\carpeta-compartida.  Puede que no tenga permiso para utilizar este recurso de red. Póngase en contacto con el administrador de este servidor para comprobar si tiene permisos de acceso. 
       La información de configuración no se puede leer del controlador de dominio, porque la máquina no está disponible o porque se ha denegado el acceso.

    Este error aparece si intento entrar mediante \\nombre-servidor\carpeta-compartida.

    En cambio, si entro via ip del servidor \\xxx.xxx.xxx.xxx\carpeta-compartida puedo acceder sin problemas, respetando siempre los permisos definidos en los directorios.

    Que puede estar fallando? He probado desactivando firewalls, repasando DNS... etc.

    Aprecio vuestra ayuda.

    Saludos!

    miércoles, 24 de agosto de 2016 9:57

Respuestas

  • Hola Noubit, el síntoma que nombras, poder entrar por IP, pero no por nombre, indica que el problema es la autenticación Kerberos que se utiliza en Dominios

    Revisa lo siguiente:

    - Que el nombre del Dominio tenga la forma "dominio.sufijo" (que contenga por lo menos un ".")
    - Que esté instalado el servicio DNS, y que estén los registros correspondientes
    - Que todas las máquinas, incluyendo al Controlador de Dominio tengan configurado para usar como DNS únicamente al Controlador de Dominio

    Desde una de las máquinas puedes verificar si la resolución de nombres es correcta con NSLOOKUP. Por ejemplo, desde un CMD ejecuta NSLOOKUP <NombreDC.dominio.sufijo>

     


    Guillermo Delprato
    Buenos Aires, Argentina
    El Blog de los paso a paso

    MVP - MCSE - MCSA2012
    MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory/Network Configuration/Applications Configuration/Server Virtualization/Windows 7 Configuration/Windows 7 & Office 2010 Deployment/Vista Configuration

    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    • Marcado como respuesta Noubit miércoles, 24 de agosto de 2016 10:35
    miércoles, 24 de agosto de 2016 10:04
    Moderador

Todas las respuestas

  • Hola Noubit, el síntoma que nombras, poder entrar por IP, pero no por nombre, indica que el problema es la autenticación Kerberos que se utiliza en Dominios

    Revisa lo siguiente:

    - Que el nombre del Dominio tenga la forma "dominio.sufijo" (que contenga por lo menos un ".")
    - Que esté instalado el servicio DNS, y que estén los registros correspondientes
    - Que todas las máquinas, incluyendo al Controlador de Dominio tengan configurado para usar como DNS únicamente al Controlador de Dominio

    Desde una de las máquinas puedes verificar si la resolución de nombres es correcta con NSLOOKUP. Por ejemplo, desde un CMD ejecuta NSLOOKUP <NombreDC.dominio.sufijo>

     


    Guillermo Delprato
    Buenos Aires, Argentina
    El Blog de los paso a paso

    MVP - MCSE - MCSA2012
    MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory/Network Configuration/Applications Configuration/Server Virtualization/Windows 7 Configuration/Windows 7 & Office 2010 Deployment/Vista Configuration

    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    • Marcado como respuesta Noubit miércoles, 24 de agosto de 2016 10:35
    miércoles, 24 de agosto de 2016 10:04
    Moderador
  • Buenos días,

    Por el momento parece que he podido acceder.

    - El dominio tiene sufijo.

    - El DNS está instalado, y teóricamente tiene los registros correspondientes. De hecho tiene los que ha creado automáticamente Windows Server mediante el asistente, + un puntero para el mismo servidor y una zona de búsqueda inversa también para el servidor (raramente, no aparecian). Esto parece ser lo que ha resuelto el problema.

    - Los DNS del cliente y servidor tienen como primario el propio del PDC, y de secundario el de Google. Eso seria correcto?

    Por lo demás, muchas gracias por tu rápida respuesta! Me ha ayudado mucho, casi al momento!

    Saludos

    miércoles, 24 de agosto de 2016 10:35
  • Primero quitémos los méritos :) la rapidez ha sido sólo casualidad, entro 2 o 3 veces al día y justo casi coincidimos en horario

    La zona de búsqueda inversa, no es requerida por Dominios; se crea a mano solamente porque a veces ayuda en la resolución de problemas

    Lo que sí debes corregir es la configuración de DNS. Todas (todas, todas) deben tener configurado para usar como DNS únicamente a el o los Controladores de Dominio con DNS. Nunca uno externo ni el Router

    Para que se resuelvan los nombres de Internet, en la consola DNS, Propiedades, Reenviadores, debes configurar para que se usen los de Google. el ISP, o los que quieras

     


    Guillermo Delprato
    Buenos Aires, Argentina
    El Blog de los paso a paso

    MVP - MCSE - MCSA2012
    MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory/Network Configuration/Applications Configuration/Server Virtualization/Windows 7 Configuration/Windows 7 & Office 2010 Deployment/Vista Configuration

    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    • Propuesto como respuesta Moderador M miércoles, 24 de agosto de 2016 14:33
    miércoles, 24 de agosto de 2016 11:27
    Moderador