none
Error al desinstalar Exchange 2007 sobre windows server 2008 R2 RRS feed

  • Pregunta

  • Al tratar de instalar Exchange 2007 sobre windows server 2008 R2 me marca el siguiente error

    El programa de instalación generó antes un error al realizar la accion "Uninstall". No puede reanudar la instalación si ejecuta la acción "Install"

    Antecedentes:

    efectué una instalación de exchange 2007 y efectué algunas pruebas pero me marcaba error en los usuarios al inicar el buzon.

    Se me hizo facil y decidí desinstalar el exchange 2007 para volver a empezar, pero al desinstalar exchange por medio del panel de contro, la funcion de buzón me marco error.

    Ahora nome deja ni instalar ni desinstalar, me marca el error que indiqué arriba.

    Tengo toda la semana atorado y no he encontrado nada al respecto de este error en internet, agradeceré mucho cualquier ayuda

     

    viernes, 14 de mayo de 2010 16:38

Todas las respuestas

  • Puedes poner el código de error?
    Saludos,

    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator
    MCITP: Enterprise Messaging Administrator
    viernes, 14 de mayo de 2010 19:25
    Moderador
  • - En el programa de instalacion me aparece el siguiente mensaje

    El programa de instalación generó antes un error al realizar la accion "Uninstall". No se puede reanudar la instalación si ejecuta la accion "Install"

    - Y en el log de eventos se registra lo siguiente

    1.- Se inicio el programa de instalacion de exchange (compilación 8.1.436.0:función de Buzón)

    2.- Error en el componente de Función de Buzón de Exchange Server

    Error:Error:

    No se encontró el servidor de Exchange "serverarrgon.arrgon.local". Asegurese que lo escribió correctamente

    - Otra cosa, en la consola de administración del exchange, en Configuracion de Servidores, Buzon me marca:

    La organización de Exchange no tiene servidors con la función de servidor de Buzón instalada

    Gracias de antemano por su ayuda

     

    viernes, 14 de mayo de 2010 22:44
  • Al revisar el log de eventos del setup de exchange, el problema que tengo es que no se encuentra el servidor de Exchange, pero si lo trato de desinstalar me marca que no encuentra el servidor de exchange y si trato de instalarlo tambien me marca que no se encuentra el servidor de exchange.

     

    domingo, 16 de mayo de 2010 2:22
  • Has probado con un setup /recoverserver para recuperar el servidor y luego desinstalarlo? si te dice que no está instalado evidentemente es que está 100% desinstalado del AD aunque pudiera haber quedado algún resto en la máquina.
    domingo, 16 de mayo de 2010 20:08
  • Hola,

    Este error puede generarse por varias razones

    • Eliminaste el directorio SETUP LOGS en C:\
    • El servidor de Exchange no tiene conectividad con AD
    • Exhange Server fue removido

    Te recomiendo validar en la particion de configuracion dentro de la organizacion de Exchange si el servidor EXISTE, si es asi , puedes hacer un proceso para recuperar este servidor

    Gracias

    Andrés Lozada

    lunes, 17 de mayo de 2010 2:49
  • Hola, primero que nada gracias por su tiempo, los actualizo de mis intentos, hasta ahora infructuosos de reinstalar este exchange 2007

    - Cuando ejecuto  setup /mode:RecoverServer el resultado es:

    Se recuperaran las siguientes funciones de servidor

       Herramientas de Administracion

     El servidor no se encuentra en Active Directory. El servidor debe estar presente en el Active Directory para recuperar

    - Cuando trato de instalar la funcion de buzon con el comando setup /mode:Install /role:MailBox el resultado es:

    Se instalarán las siguientes funciones de servidor

       Funcion de Buzon

    El programa de instalación generó antes un error al realizar la accion "Uninstall". No puede reanudar la instalación si ejecuta la accion "Install"

    La instalación de exchange Server ha detectado un error

    - Al tratar de desinstalar el exhange con la instrucción setup /mode:Uninstall el resultado es:

    Se quitaran las siguientes funciones de servidor

       Funcion de Buzon

       Herramientas de Administracion

    Realizando las comprobacion es previas ..... FINALIZADA

    Configurando Microsoft Exchange Server

    Funcion de Servidor de Buzones ... Error

    No se encuntro el servidor de exhange "serverarrgon.arrgon.local".  Asegurese de que lo escribió correctamente

    --- Y hasta aquí he llegado, no importa en que orden trate de instalar o desinstalar o si lo ejecuto en modo comando o por medio del disco de instalación, obtengo siempre los mismos resultados

    Quedo a sus ordenes agradeciendo de antemano su apoyo

    Miguel Varela

     

    martes, 18 de mayo de 2010 22:52
  • otra cosa mas, cuando ejecuto Setup /PrepareAD  el resultado es:

    Se ha producido un error en la instalación al instalar la funcion Mailbox. Ejecute de nuevo la instalación para esta función en concreto, o quite la función mendiante el Panel de Control

    - Al tratar de desinstalar por el panel de control, recibo el mismo error: No se encontro el servido de exhange "serverarrgon.arrgon.local". Asegurese de que lo escribió correctamente

    Miguel Varela

    martes, 18 de mayo de 2010 23:01
  • Siguiendo con mis pesquisas, al revisar los objetos de Active Directory utilizando el editor ADSI me encontré con que no tengo ningun objeto de Exchange en el servidor con problemas, según investigué con Setup /PreparaAD debería generarlos, pero me marca el error que estoy indicando arriba

    Miguel Varela

     

    miércoles, 19 de mayo de 2010 2:12