none
Lentitud de acceso a disco

    Pregunta

  • Hola a todos.

    Tengo un servidor con un Xeon silver 4108 a 1.8GHz, 48 GB de RAM y 4 discos sata 7200 en RAID 5. Windows server 2019 con el ROL de HyperV.

    2 maquinas virtuales. 1 es DC y tiene documentos compartidos, la 2 con sql express, pero una aplicación muy pequeña. Teoricamente debería ir bastante sobrado de recursos. En la red hay media docena de usuarios y todos se quejan de que cambiar de pagina en un PDF les tarda 5 segundos. O la aplicación de SQL tiene continuos mensajes de no responde.

    El problema es que el rendimiento de disco duro baja terriblemente cuando las maquinas estan encendidas. Aunque no esten haciendo nada. 

    Ahora mismo no hay usuarios. El disco duro del host trabaja apenas a 100-200 Kb por segundo.

    Pero si me pongo a copiar (para hacer una prueba) un fichero de gran tamaño en el host, no sube de 9 MB por segundo. Las pruebas de acceso me dan una latencia de 20 ms. Si apago las máquinas virtuales, la misma copia alcanza los 90 MB por segundo.

    Entiendo que hyperv le de prioridad a las maquinas y realmente no uso el host para nada más. Pero es que el rendimiento de las MV es patético.

    Como con las MV apagadas el acceso a disco es correcto, no creo que sea problema del RAID sino de configuración. 

    ¿Algún consejo? muchas gracias.

    miércoles, 24 de abril de 2019 23:22

Respuestas

  • Hola CTeruel

     

    Gracias por levantar tu consulta en los foros de TechNet. Con respecto a la misma, te recomiendo ingresar al siguiente enlace donde puedes encontrar una posible solución para tu problema.

     

    https://docs.microsoft.com/es-es/system-center/vmm/vm-optimization?view=sc-vmm-2019

    Gracias por usar los foros de TechNet.

     

    Pablo Rubio

     ____

     

    Por favor recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema, es una forma común de reconocer a aquellos que han ayudado, y hace que sea más fácil para los otros visitantes encontrar la solución más tarde.

     

    Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de conocimientos relacionados con los productos y tecnologías de Microsoft. 

     

    Este contenido es proporcionado "tal cual" y no implica ninguna responsabilidad de parte de Microsoft.

    • Propuesto como respuesta eRiver1 lunes, 6 de mayo de 2019 22:11
    • Marcado como respuesta Pablo RubioModerator jueves, 9 de mayo de 2019 15:17
    jueves, 25 de abril de 2019 15:35
    Moderador
  • Hola CTeruel, te paso información adicional para que puedas investigar un poco más. Es muy difícil que consigas la solución desde acá porque hay que mirar varios factores

    Primero, desde un CMD "ejecutado como administrador" usa DISKPERF para ver si los contadores de disco están habilitados o no, y en caso contrario habilítalos

    Luego mira en el "Task Manager", sobre todo en la ficha "Details" y si no aparecen agrega las columnas relativas al uso de disco

    Y todavía más, si con lo anterior aún no está claro, con el "Performance Monitor" puedes ver muchos datos (demasiados a veces) pero revisa los contadores referentes a los discos, especialmente lo que indican "Queue lenght"

    Estos últimos son importantes porque indican la cantidad de procesos "encolados" esperando acceder a disco. En uso normal no deberían en promedio ser superiores a dos

    No creo que con esto encuentres muy fácil el problema, pero por lo menos te da más elementos para evaluar

     


    Guillermo Delprato
    Buenos Aires, Argentina
    El Blog de los paso a paso

    MCSE - MCSA2012
    MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory/Network Configuration/Applications Configuration/Server Virtualization/Windows 7 Configuration/Windows 7 & Office 2010 Deployment/Vista Configuration

    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    • Propuesto como respuesta eRiver1 martes, 7 de mayo de 2019 16:58
    • Marcado como respuesta Pablo RubioModerator jueves, 9 de mayo de 2019 15:17
    martes, 7 de mayo de 2019 15:48
    Moderador
  • Hola, Pablo y gracias por contestar.

    Pero creo que el enlace no me sirve. Es una instalacion muy sencilla. Un servidor HP con el ROL de hyperV en el mismo RAID donde estan las maquinas. No hay clusters ni tiene que haber problemas de carga de ningun tipo. El servidor deberia ir sobrado de recursos.

    Creo que es algun tipo de incompatibilidad. En HP han hecho pruebas y me confirman que el servidor no tienen problemas y el caso está muy claro. En cuanto enciendo una de las 2 maquinas virtuales el rendimiento de lectura y escritura de disco baja a un 10%

    Las pruebas de velocidad son muy claras. Con 1 maquina virtual encendida pero sin uso, escribe a 9MB/s (tanto en el host como en la propia MV) Es simplemente un copia pega de un fichero de gran tamaño.

    El mismo proceso con la MV apagada sube a 90 MB/s

    Un saludo

    Carlos 

    lunes, 6 de mayo de 2019 15:50
  • Hola CTeruel,

    ¿Se resolvió tu asunto?

    Debido a que no hemos recibido alguna notificación que aún se esté presentando el problema que enuncias en tu consulta  y que la respuesta provista provee un amplio panorama y campo de acción sobre tu duda; vamos a considerar tu duda como resuelta debido a la respuesta apropiada proporcionada  y así proceder a calificar las misma como respuesta.

    No dudes en ampliar más sobre este tema si es que aún lo requirieras o de abrir una nueva consulta en caso de tener alguna situación o necesitarla con algún otro de los productos de Microsoft.

     

    Adicional le invito a consultar los siguientes recursos:

    Guía para formular preguntas en el foro

    Channel 9 - donde puedes encontrar una sección de: hyper-V

     

    Gracias por usar los foros de TechNet.

    Erick Rivera

     ____

     

    Por favor recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema, es una forma común de reconocer a aquellos que han ayudado, y hace que sea más fácil para los otros visitantes encontrar la solución más tarde.  

    Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de    conocimientos relacionados con los productos y tecnologías de Microsoft.   

    Este contenido es proporcionado "tal cual" y no implica ninguna responsabilidad de parte de Microsoft.

    lunes, 6 de mayo de 2019 22:12

Todas las respuestas

  • Hola CTeruel

     

    Gracias por levantar tu consulta en los foros de TechNet. Con respecto a la misma, te recomiendo ingresar al siguiente enlace donde puedes encontrar una posible solución para tu problema.

     

    https://docs.microsoft.com/es-es/system-center/vmm/vm-optimization?view=sc-vmm-2019

    Gracias por usar los foros de TechNet.

     

    Pablo Rubio

     ____

     

    Por favor recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema, es una forma común de reconocer a aquellos que han ayudado, y hace que sea más fácil para los otros visitantes encontrar la solución más tarde.

     

    Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de conocimientos relacionados con los productos y tecnologías de Microsoft. 

     

    Este contenido es proporcionado "tal cual" y no implica ninguna responsabilidad de parte de Microsoft.

    • Propuesto como respuesta eRiver1 lunes, 6 de mayo de 2019 22:11
    • Marcado como respuesta Pablo RubioModerator jueves, 9 de mayo de 2019 15:17
    jueves, 25 de abril de 2019 15:35
    Moderador
  • Hola, Pablo y gracias por contestar.

    Pero creo que el enlace no me sirve. Es una instalacion muy sencilla. Un servidor HP con el ROL de hyperV en el mismo RAID donde estan las maquinas. No hay clusters ni tiene que haber problemas de carga de ningun tipo. El servidor deberia ir sobrado de recursos.

    Creo que es algun tipo de incompatibilidad. En HP han hecho pruebas y me confirman que el servidor no tienen problemas y el caso está muy claro. En cuanto enciendo una de las 2 maquinas virtuales el rendimiento de lectura y escritura de disco baja a un 10%

    Las pruebas de velocidad son muy claras. Con 1 maquina virtual encendida pero sin uso, escribe a 9MB/s (tanto en el host como en la propia MV) Es simplemente un copia pega de un fichero de gran tamaño.

    El mismo proceso con la MV apagada sube a 90 MB/s

    Un saludo

    Carlos 

    lunes, 6 de mayo de 2019 15:50
  • Hola CTeruel

    Por lo que entiendo solo presentas problemas en el performance de escritura cuando tienes las VMs encendidas, ¿Los VHD/VHDX que les asignaste a tus VM's son Dynamically expanding? de ser así eso podría estar ocasionando el problema, es muy raro que suceda pero podría ser un factor.

    Tu servidor cuenta con todo los firmware/controladores actualizados compatibles con  Windows Server 2019, te pregunto ya que con servidores DELL e tenido problemas de funcionalidad por no tener los firmwares/controladores mas actuales para la versión de Windows Server que utilizo.


    lunes, 6 de mayo de 2019 16:44
  • Hola CTeruel,

    ¿Se resolvió tu asunto?

    Debido a que no hemos recibido alguna notificación que aún se esté presentando el problema que enuncias en tu consulta  y que la respuesta provista provee un amplio panorama y campo de acción sobre tu duda; vamos a considerar tu duda como resuelta debido a la respuesta apropiada proporcionada  y así proceder a calificar las misma como respuesta.

    No dudes en ampliar más sobre este tema si es que aún lo requirieras o de abrir una nueva consulta en caso de tener alguna situación o necesitarla con algún otro de los productos de Microsoft.

     

    Adicional le invito a consultar los siguientes recursos:

    Guía para formular preguntas en el foro

    Channel 9 - donde puedes encontrar una sección de: hyper-V

     

    Gracias por usar los foros de TechNet.

    Erick Rivera

     ____

     

    Por favor recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema, es una forma común de reconocer a aquellos que han ayudado, y hace que sea más fácil para los otros visitantes encontrar la solución más tarde.  

    Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de    conocimientos relacionados con los productos y tecnologías de Microsoft.   

    Este contenido es proporcionado "tal cual" y no implica ninguna responsabilidad de parte de Microsoft.

    lunes, 6 de mayo de 2019 22:12
  • Hola CTeruel,

    ¿Se resolvió tu asunto?

    Debido a que no hemos recibido alguna notificación que aún se esté presentando el problema que enuncias en tu consulta  y que la respuesta provista provee un amplio panorama y campo de acción sobre tu duda; vamos a considerar tu duda como resuelta debido a la respuesta apropiada proporcionada  y así proceder a calificar las misma como respuesta.

    No dudes en ampliar más sobre este tema si es que aún lo requirieras o de abrir una nueva consulta en caso de tener alguna situación o necesitarla con algún otro de los productos de Microsoft.

     

    Adicional le invito a consultar los siguientes recursos:

    Guía para formular preguntas en el foro

    Channel 9 - donde puedes encontrar una sección de: hyper-V

     

    Gracias por usar los foros de TechNet.

    Erick Rivera

     ____

     

    Por favor recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema, es una forma común de reconocer a aquellos que han ayudado, y hace que sea más fácil para los otros visitantes encontrar la solución más tarde.  

    Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de    conocimientos relacionados con los productos y tecnologías de Microsoft.   

    Este contenido es proporcionado "tal cual" y no implica ninguna responsabilidad de parte de Microsoft.

    Sí que he contestado a la respuesta que habéis marcado como válida y no lo es. Voy a probar lo que comenta salvador, aunque la lentitud se produce solo con tener la maquina encendida, aunque no esté haciendo absolutamente nada. Si miro en el monitor de recursos, no hay apenas actividad de disco excepto el copia pega. 

    Carlos

    martes, 7 de mayo de 2019 7:39
  • Hola CTeruel, te paso información adicional para que puedas investigar un poco más. Es muy difícil que consigas la solución desde acá porque hay que mirar varios factores

    Primero, desde un CMD "ejecutado como administrador" usa DISKPERF para ver si los contadores de disco están habilitados o no, y en caso contrario habilítalos

    Luego mira en el "Task Manager", sobre todo en la ficha "Details" y si no aparecen agrega las columnas relativas al uso de disco

    Y todavía más, si con lo anterior aún no está claro, con el "Performance Monitor" puedes ver muchos datos (demasiados a veces) pero revisa los contadores referentes a los discos, especialmente lo que indican "Queue lenght"

    Estos últimos son importantes porque indican la cantidad de procesos "encolados" esperando acceder a disco. En uso normal no deberían en promedio ser superiores a dos

    No creo que con esto encuentres muy fácil el problema, pero por lo menos te da más elementos para evaluar

     


    Guillermo Delprato
    Buenos Aires, Argentina
    El Blog de los paso a paso

    MCSE - MCSA2012
    MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory/Network Configuration/Applications Configuration/Server Virtualization/Windows 7 Configuration/Windows 7 & Office 2010 Deployment/Vista Configuration

    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    • Propuesto como respuesta eRiver1 martes, 7 de mayo de 2019 16:58
    • Marcado como respuesta Pablo RubioModerator jueves, 9 de mayo de 2019 15:17
    martes, 7 de mayo de 2019 15:48
    Moderador
  • Hola.

    Sigpo con ello. Solo puedo hacer pruebas porque son maquinas en produccion y cualquier trabajo afecta. No puedo convertir los discos en tamaño fijo así que los copiaré (uno de 250 GB estaba tardando la copia mas de 10 horas esta noche, así que he tenido que pararlo y lo haré el fin de semana.

    Gracias por la ayuda.

    Carlos


    Carlos

    viernes, 10 de mayo de 2019 6:23
  • Hola Carlos, con los comandos que puse antes no afectas mayormente el rendimiento del sistema. Lo único es el habilitar los contadores de disco para poder medir, pero así como los habilitas luego se pueden deshabilitar sin ninguna consecuencia

     


    Guillermo Delprato
    Buenos Aires, Argentina
    El Blog de los paso a paso

    MCSE - MCSA2012
    MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory/Network Configuration/Applications Configuration/Server Virtualization/Windows 7 Configuration/Windows 7 & Office 2010 Deployment/Vista Configuration

    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    viernes, 10 de mayo de 2019 11:05
    Moderador
  • Hola de nuevo.

    Estas ultimas noches he podido reconvertir las maquinas a discos de tamaño fijo, he monitorizado y también vi que HP acaba de publicar un nuevo Support pack con drivers y firmwares con la descripcion "compatible con windows 2019" 

    No ha servido de nada. Bueno, algo sí, para saber que NO influyen las maquinas virtuales en el rendimiento. Lo que dije al principio de que con las maquinas paradas iba bien no es cierto. Me engañaba el hecho de que al tener mucha mas memoria libre para usar de cache tardaba más en bajar el rendimiento. 

    Siento la confusión.

    Quitamos una posible causa de error, pero el problema persiste. Tengo velocidades de lectura secuencial por encima de 200 MB/s pero la velocidad de escritura REAL no pasa de 10 MB/S con colas de 4 y supongo cuellos de botella que producen cuelgues de varios segundos.

    El hilo puede cerrarse porque ya no pertenece a hilos sobre HYPERV y abriré otro específico donde corresponda.

    Gracias a todos por los consejos.

    :(

    Carlos 



    Carlos

    viernes, 17 de mayo de 2019 7:58