locked
Imposible instalar el Service Pack 2 en el Windows Vista 64 bits RRS feed

  • Pregunta

  • Buenas. He probado varias veces instalar el Service Pack 2 en el Windows Vista, porque Windows Update me la da como nueva actualizacion, pero no hay manera. Se descarga, se pone a instalarse, y cuando esta va por el paso 3 a 3 en un 100%, me dice "el service pack no fue instalado, revertiendo los cambios".

    Fijandome en este mensaje, he hecho lo que en el se decia:
    http://social.technet.microsoft.com/Forums/es-ES/wcvistaes/thread/1215d998-3679-4ac1-a6a2-f5a6275ebeac
    He borrado los archivos temporales de las 2 formas, desde el mismo Windows Vista, y manualmente, los de las carpetas temp y los del perfil de usuario. Pero no hay manera.

    Tambien me he bajado la actualizacion y la he intentado instalar manualmente, pero tampoco hay manera.
    http://windows-vista-service-pack-2-x64.softonic.com/

    La verdad que ya no se que hacer, porque lo he probado 3 veces, una de update, otra descargandome la actualizacion y otra cuando borre los archivos temporales. Llevo desde ayer con el tema este.

    A ver si alguien me puede decir a que se debe el que no pueda instalar esta actualizacion, y como puedo hacer.

    Por otra parte si no es importante tener instalado el Service Pack 2, me voy olvidando del tema.
    sábado, 17 de octubre de 2009 13:35

Respuestas

  • Asegúrate de que hayas seguido las pautas generales de este documento de la KB de Microsoft:

    Cómo solucionar problemas de instalación de un Service Pack en Windows Vista y Windows Server 2008
    http://support.microsoft.com/kb/947366/es

    Entre ellas se te indica (como te comentó molpii) que desinstales temporalmente el antivirus. Los antivirus pueden impedir que el programa de instalación del Service Pack actualice ciertos componentes del sistema.
    Microsoft MVP Windows Desktop Experience
    lunes, 19 de octubre de 2009 10:00

Todas las respuestas

  • Antivirus o alguna suite de seguridad de terceros activa?? podrias probar desactivandolas e intentar instalar, ademas probar un arranque en limpio e instalarlo manualmente, pero no bajandote la actualizacion desde softonic, sino desde aqui http://www.microsoft.com/DOWNLOADS/details.aspx?FamilyID=656c9d4a-55ec-4972-a0d7-b1a6fedf51a7&displaylang=es 

    Saludos!
    sábado, 17 de octubre de 2009 20:38
  • Antivirus o alguna suite de seguridad de terceros activa?? podrias probar desactivandolas e intentar instalar, ademas probar un arranque en limpio e instalarlo manualmente, pero no bajandote la actualizacion desde softonic, sino desde aqui http://www.microsoft.com/DOWNLOADS/details.aspx?FamilyID=656c9d4a-55ec-4972-a0d7-b1a6fedf51a7&displaylang=es  

    Saludos!
    De antivirus tengo el Eset Nod 32.
    Y desde ahi, donde me das la pagina, me baje la actualizacion. Lo que al escribir el mensaje no encontraba esa pagina y me fui al primer lugar donde se encontraba tambien para descargar la actualizacion. ¿Igualmente hay alguna diferencia entre una y otra actualizacion?. Tienen el mismo nombre, ocupan lo mismo...


    Por otra parte, una duda que tengo, es que he visto esta misma actualizacion pero en todos los idiomas, no solamente con los 5 idiomas principales. Al mirar los idiomas de mi S.O, he visto que trae mas de 5 idiomas, puede ser que esto este produciendo alguna incompatibilidad.

    Esta es la actualizacion que te digo:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=891ab806-2431-4d00-afa3-99ff6f22448d&DisplayLang=es

    Bueno, de momento que me recomiendas que haga. ¿Que deshabilite el antivirus?

    Cuando dices que intente un arranque en limpio a que te refieres, perdona.

    Por cierto, yo no se si ha sido por el fallido intento de instalacion de este service pack 2, o por el tema de la eliminacion de archivos temporales. Pero un monton de programas me han estado dando errores, y he tenido que volver a instalarlos.

    La verdad que me tiene este tema un poco quemado.

    Un saludo.


    domingo, 18 de octubre de 2009 10:04
  • hola, a mi tambien me ocurria lo mismo que a ti, lo que hice fue deshabilitar el control de cuentas de usuario, y se instalo sin problemas

    domingo, 18 de octubre de 2009 11:00
  • hola, a mi tambien me ocurria lo mismo que a ti, lo que hice fue deshabilitar el control de cuentas de usuario, y se instalo sin problemas

    Gracias por responder compañero.
    Lo he probado, y tampoco ha funcionado.

    Si nadie me da otra opcion para poder instalar este Service Pack, creo que desistire, y se quedara esta actualizacion sin instalar. Mas de lo que lo he intentado ya.

    El problema es del Window Vista, no mio.


    lunes, 19 de octubre de 2009 9:39
  • Asegúrate de que hayas seguido las pautas generales de este documento de la KB de Microsoft:

    Cómo solucionar problemas de instalación de un Service Pack en Windows Vista y Windows Server 2008
    http://support.microsoft.com/kb/947366/es

    Entre ellas se te indica (como te comentó molpii) que desinstales temporalmente el antivirus. Los antivirus pueden impedir que el programa de instalación del Service Pack actualice ciertos componentes del sistema.
    Microsoft MVP Windows Desktop Experience
    lunes, 19 de octubre de 2009 10:00
  • Bueno, lo he probado 2 veces mas y me ha sido imposible.
    He deshabilitado lo de cuentas de usuario, el firewall, he desinstalado el antivirus. Y no hay manera.
    El error que me tira es este Error: E_FAIL (0X80004005).

    Viendo que no hay ninguna solucion a esto, lo que voy a hacer con las actualizaciones es elegir poder bajarlas e instalarlas manualmente, porque ahora me sale cada 2 por 3 un aviso para instalar el service pack 2, cuando es imposible.
    jueves, 22 de octubre de 2009 20:30