locked
Particion oculta de Windows borrada, no puedo volver a instalarlo RRS feed

  • Pregunta

  • Hola gente.
    Me la mandé y necesito de su ayuda!

    Antes de empezar, mi maquina es una Acer Aspire 7741G.
    El problema empezó cuando quise crear una nueva partición y no podía hacerlo. No entendía por que, hasta que me di cuenta que ya había alcanzado el limite de 4 particiones primarias.
    Entonces, desde Ubuntu con el gparted, elimine una partición de 104 mb, que había leído que era de Windows 7 y se podía borrar.

    Desde ese momento no pude entrar mas a Windows, formatie la partición donde estaba Windows 7 para reinstalarlo, pero no me encuentra ninguna partición donde instalarlo. Dice que no encuentra lo controladores necesarios, los cuales supongo que estaban en la partición de 104 mb que eliminé.
    Estuve tocando las particiones, para llegar a tener todas las que quería antes de empezar con todo esto, y dejé libre una partición de 110 mb, ya que lei que el instalador de Windows 7 la usa si es que existe. Ubuntu lo pude instalar sin problemas, ahora estoy escribiendo desde ahi.

    Volví a intentar instalar Windows 7 pero lo mismo, no encuentra particiones y le falta algunos controladores, no me dice cuales.
    Justo tenia conectado un rígido externo por USB, y ese si me lo reconoció el instalador de Windows.. no entiendo como reconoce el USB y no reconoce el disco rígido..

    Asi quedaron las particiones:

    • sda1 Primaria: 1mb, boot.. supongo que aquí se instala el grub, no?
    • sda2 Primaria: 15gb, windows recovery o algo así
    • sda3 Primaria: 104mb, la volvi a crear con la esperanza de que si Windows la utilice.
    • sda4 Extendida: Aca puse 4, ext4 y swap para Ubuntu, una ntfs grande para musica y demás, y otra ntfs de 50gb que es donde quiero instalar Windows 7.

    Alguna idea de como arreglar esto? Tengo entendido que el XP no usa esta partición, así que calculo que instalaría bien, pero yo quiero meter el 7.

    Gracias!!!
    martes, 12 de junio de 2012 14:34

Respuestas

  • Hola gente.
    Me la mandé y necesito de su ayuda!

    Antes de empezar, mi maquina es una Acer Aspire 7741G.
    El problema empezó cuando quise crear una nueva partición y no podía hacerlo. No entendía por que, hasta que me di cuenta que ya había alcanzado el limite de 4 particiones primarias.
    Entonces, desde Ubuntu con el gparted, elimine una partición de 104 mb, que había leído que era de Windows 7 y se podía borrar.

    Desde ese momento no pude entrar mas a Windows, formatie la partición donde estaba Windows 7 para reinstalarlo, pero no me encuentra ninguna partición donde instalarlo. Dice que no encuentra lo controladores necesarios, los cuales supongo que estaban en la partición de 104 mb que eliminé.
    Estuve tocando las particiones, para llegar a tener todas las que quería antes de empezar con todo esto, y dejé libre una partición de 110 mb, ya que lei que el instalador de Windows 7 la usa si es que existe. Ubuntu lo pude instalar sin problemas, ahora estoy escribiendo desde ahi.

    Volví a intentar instalar Windows 7 pero lo mismo, no encuentra particiones y le falta algunos controladores, no me dice cuales.
    Justo tenia conectado un rígido externo por USB, y ese si me lo reconoció el instalador de Windows.. no entiendo como reconoce el USB y no reconoce el disco rígido..

    Asi quedaron las particiones:

    • sda1 Primaria: 1mb, boot.. supongo que aquí se instala el grub, no?
    • sda2 Primaria: 15gb, windows recovery o algo así
    • sda3 Primaria: 104mb, la volvi a crear con la esperanza de que si Windows la utilice.
    • sda4 Extendida: Aca puse 4, ext4 y swap para Ubuntu, una ntfs grande para musica y demás, y otra ntfs de 50gb que es donde quiero instalar Windows 7.

    Alguna idea de como arreglar esto? Tengo entendido que el XP no usa esta partición, así que calculo que instalaría bien, pero yo quiero meter el 7.

    Gracias!!!

    Elimina todas las particiones e instala windows desde cero.

    Y Linux, si lo quieres en la misma maquina, usalo solo y olvidate de windows... o bien, usalo en virtual.


    Jose Manuel Tella Llop news://jmtella.com

    martes, 12 de junio de 2012 15:10
  • Hola Jose Manuel 

    Dijistes en tu primera intervención ésto:

    Elimina todas las particiones e instala windows desde cero.

    Y Linux, si lo quieres en la misma maquina, usalo solo y olvidate de windows... o bien, usalo en virtual.

    Y te dí las gracias, porque es una valiosa información, no por mi, pues yo solo tengo instalado Windows 7 solamente, pero muchisima gente tiene instalado Windows y Linux (no virtual)

    ¿Pero porque no pueden estar instalados los 2 sistemas operativos, excepto si virtualmente Linux?

    Es una curiosidad, además, ya sabes que yo intento ayudar, pero tengo que argumentar el porque no son compatibles Windows y Linux en una misma maquina.

    Saludos.


    Para un tecnico de sistema no tendria ningun problema en tener ambos en la misma maquina conociendo sobre todo como actua el boot de windows. Pero es dificil de mantener esto a usuarios finales... Y además hay que tener mucho cuidado con las particiones que se accede desde uno a otro sistema. Por ejemplo, si Linux monta una de las particiones de windows, windows se dará cuenta cuando arranque y eliminarña todos los puntos de restauración.

    Además, si instalado dos sistemas, o tengo uno o tengo otro. La ventaja de tener uno de ellos en virtual, (el que menos use), es que puedo tener ambos a la vez... y los problemas que someramente te he descrito, no los tendrás de esta forma.

    Un saludo,


    Jose Manuel Tella Llop news://jmtella.com

    jueves, 14 de junio de 2012 11:25

Todas las respuestas

  • Hola gente.
    Me la mandé y necesito de su ayuda!

    Antes de empezar, mi maquina es una Acer Aspire 7741G.
    El problema empezó cuando quise crear una nueva partición y no podía hacerlo. No entendía por que, hasta que me di cuenta que ya había alcanzado el limite de 4 particiones primarias.
    Entonces, desde Ubuntu con el gparted, elimine una partición de 104 mb, que había leído que era de Windows 7 y se podía borrar.

    Desde ese momento no pude entrar mas a Windows, formatie la partición donde estaba Windows 7 para reinstalarlo, pero no me encuentra ninguna partición donde instalarlo. Dice que no encuentra lo controladores necesarios, los cuales supongo que estaban en la partición de 104 mb que eliminé.
    Estuve tocando las particiones, para llegar a tener todas las que quería antes de empezar con todo esto, y dejé libre una partición de 110 mb, ya que lei que el instalador de Windows 7 la usa si es que existe. Ubuntu lo pude instalar sin problemas, ahora estoy escribiendo desde ahi.

    Volví a intentar instalar Windows 7 pero lo mismo, no encuentra particiones y le falta algunos controladores, no me dice cuales.
    Justo tenia conectado un rígido externo por USB, y ese si me lo reconoció el instalador de Windows.. no entiendo como reconoce el USB y no reconoce el disco rígido..

    Asi quedaron las particiones:

    • sda1 Primaria: 1mb, boot.. supongo que aquí se instala el grub, no?
    • sda2 Primaria: 15gb, windows recovery o algo así
    • sda3 Primaria: 104mb, la volvi a crear con la esperanza de que si Windows la utilice.
    • sda4 Extendida: Aca puse 4, ext4 y swap para Ubuntu, una ntfs grande para musica y demás, y otra ntfs de 50gb que es donde quiero instalar Windows 7.

    Alguna idea de como arreglar esto? Tengo entendido que el XP no usa esta partición, así que calculo que instalaría bien, pero yo quiero meter el 7.

    Gracias!!!

    Elimina todas las particiones e instala windows desde cero.

    Y Linux, si lo quieres en la misma maquina, usalo solo y olvidate de windows... o bien, usalo en virtual.


    Jose Manuel Tella Llop news://jmtella.com

    martes, 12 de junio de 2012 15:10
  • Hola Jose Manuel Tella Llop gracias por la información tan precisa, ¡eres genial!

    Saludos.

    martes, 12 de junio de 2012 17:51
  • Eliminar todas? Incluso la 1 y la 2 de windows recovery?

    Crees que de esa forma me va a encontrar los controladores que faltan?

    Probé bajando los drivers SATA desde la pagina de Acer, para cargarlos en ese momento en que el instalador me dice que faltan controladores, lo encuentra y supuestamente instala pero despues siguen sin aparecerme las particiones de mi disco (el disco externo lo sigue encontrando..)

    Puede ser que no encuentre porque las ntfs que tengo estan dentro de la extendida y ninguna de ellas es primaria?

    Gracias!

    martes, 12 de junio de 2012 18:19
  • Eliminar todas? Incluso la 1 y la 2 de windows recovery?

    Crees que de esa forma me va a encontrar los controladores que faltan?

    Probé bajando los drivers SATA desde la pagina de Acer, para cargarlos en ese momento en que el instalador me dice que faltan controladores, lo encuentra y supuestamente instala pero despues siguen sin aparecerme las particiones de mi disco (el disco externo lo sigue encontrando..)

    Puede ser que no encuentre porque las ntfs que tengo estan dentro de la extendida y ninguna de ellas es primaria?

    Gracias!

    Es queesas de WIndows Recovery... ¿son del OEM?... es decir, ¿desde donde instalas?.. ¿desde DVD de instalacion?. En ese caso elimina todas.

    Si fuese desde las particiones ocultas de instalacion que dejan los OEM's... mal asunto porque puede que el gparted las haya dañado...

    Un saludo,


    Jose Manuel Tella Llop news://jmtella.com

    martes, 12 de junio de 2012 18:48
  • Esa de 15gb de recovery y la de 104mb que elimine, vinieron de fabrica con la notebook, pero el windows 7 ahora lo estoy tratando de instalar desde un dvd..

    Es mas, si quiero usar el recovery me dice 'bad partition type', o algo asi.. calculo que es porque no encuentra la de 104mb..

    Voy a probar de poner una de las particiones ntfs que tengo en la extendida, directamente como primaria a ver si el instalador me la reconoce.. sino no se que mas hacer..

    martes, 12 de junio de 2012 19:09
  • Esa de 15gb de recovery y la de 104mb que elimine, vinieron de fabrica con la notebook, pero el windows 7 ahora lo estoy tratando de instalar desde un dvd..

    Es mas, si quiero usar el recovery me dice 'bad partition type', o algo asi.. calculo que es porque no encuentra la de 104mb..

    Voy a probar de poner una de las particiones ntfs que tengo en la extendida, directamente como primaria a ver si el instalador me la reconoce.. sino no se que mas hacer..

    La de 104 no tiene nada que ver... es el bootloader de WIndows 7.

    Las de recovery (de los OEM) siempre tienen un tipo de particion raro... que pueden confgndir a muchos gestores de particiones y que no deben tocarse.

    Ahora bien, si tienes DVD, vas a instalar desde él, y lo del recovery no lo usas y no vas a usarlo, elimina todo e instala desde DVD...

    Un saludo,


    Jose Manuel Tella Llop news://jmtella.com

    martes, 12 de junio de 2012 20:23
  • Barbaro, intento eso entonces

    la sda1 Primaria, de 1mb, tipo boot.. tambien la borro?

    martes, 12 de junio de 2012 20:44
  • Barbaro, intento eso entonces

    la sda1 Primaria, de 1mb, tipo boot.. tambien la borro?

    todo...

    lo puedes hacer al instalar: cuando Windows 7 te muestre el disco, en la parte de avanzado, le eliminas las particiones: no crear ninguna y seleccionar el disco simplemente para instalar. Hará dos particiones, una de 100 MB para el boot y otra con windows. 

    Esta ultima, despues de instalar, si te interesa, desde el admin de discos puedes reducirla para dejar espacio a otras posibles particiones.

    Un saludo,


    Jose Manuel Tella Llop news://jmtella.com

    miércoles, 13 de junio de 2012 11:22
  • Hola Jose Manuel 

    Dijistes en tu primera intervención ésto:

    Elimina todas las particiones e instala windows desde cero.

    Y Linux, si lo quieres en la misma maquina, usalo solo y olvidate de windows... o bien, usalo en virtual.

    Y te dí las gracias, porque es una valiosa información, no por mi, pues yo solo tengo instalado Windows 7 solamente, pero muchisima gente tiene instalado Windows y Linux (no virtual)

    ¿Pero porque no pueden estar instalados los 2 sistemas operativos, excepto si virtualmente Linux?

    Es una curiosidad, además, ya sabes que yo intento ayudar, pero tengo que argumentar el porque no son compatibles Windows y Linux en una misma maquina.

    Saludos.


    jueves, 14 de junio de 2012 6:45
  • Hola Jose Manuel 

    Dijistes en tu primera intervención ésto:

    Elimina todas las particiones e instala windows desde cero.

    Y Linux, si lo quieres en la misma maquina, usalo solo y olvidate de windows... o bien, usalo en virtual.

    Y te dí las gracias, porque es una valiosa información, no por mi, pues yo solo tengo instalado Windows 7 solamente, pero muchisima gente tiene instalado Windows y Linux (no virtual)

    ¿Pero porque no pueden estar instalados los 2 sistemas operativos, excepto si virtualmente Linux?

    Es una curiosidad, además, ya sabes que yo intento ayudar, pero tengo que argumentar el porque no son compatibles Windows y Linux en una misma maquina.

    Saludos.


    Para un tecnico de sistema no tendria ningun problema en tener ambos en la misma maquina conociendo sobre todo como actua el boot de windows. Pero es dificil de mantener esto a usuarios finales... Y además hay que tener mucho cuidado con las particiones que se accede desde uno a otro sistema. Por ejemplo, si Linux monta una de las particiones de windows, windows se dará cuenta cuando arranque y eliminarña todos los puntos de restauración.

    Además, si instalado dos sistemas, o tengo uno o tengo otro. La ventaja de tener uno de ellos en virtual, (el que menos use), es que puedo tener ambos a la vez... y los problemas que someramente te he descrito, no los tendrás de esta forma.

    Un saludo,


    Jose Manuel Tella Llop news://jmtella.com

    jueves, 14 de junio de 2012 11:25
  • Ya pude solucionarlo.

    Como me dijiste, borre todas las particiones que tenia, incluida la de 1mb y la de recovery.

    Asi el instalador me reconocio el disco y pude instalar Windows, me creo la particion de 100mb tambien ademas de la ntfs primaria donde se instalo Win.

    La 3er primaria la hice para datos, otra ntfs

    Y la 4ta, una extendida con swap y ext4 donde meti Ubuntu.

    Supongo que algo en las particiones de recovery o en la de 1mb estaba confundiendo al instalador de win..

    Gracias por la ayuda!

    jueves, 14 de junio de 2012 15:21
  • Hola Jose Manuel   muchas gracias por aclararmelo.

    Saludos.

    viernes, 15 de junio de 2012 8:31