locked
Error instalación SP1exchange 2010. RRS feed

  • Pregunta

  • Hola,

    estoy intentando instalar el SP1 de Exchange 2010 (para posteriormente instalar el SP2) pero obtengo este error:

    Función de transporte de concentradores
    Error: Se ha generado el siguiente error cuando se ejecutó "$error.Clear(); $vdirName = "PowerShell (Default Web Site)"; $InternalPowerShellUrl="http://" + $RoleFqdnOrName + "/powershell"; $vdir = get-PowerShellVirtualDirectory -server $RoleFqdnOrName -DomainController $RoleDomainController | where { $_.Name -eq $vdirName }; if ($vdir -eq $null) { $vdirName = "PowerShell"; new-PowerShellVirtualDirectory $vdirName -InternalUrl $InternalPowerShellUrl -DomainController $RoleDomainController -BasicAuthentication:$false -WindowsAuthentication:$false -RequireSSL:$false; } else { update-PowerShellVirtualDirectoryVersion -DomainController $RoleDomainController; Set-PowerShellVirtualDirectory $vdirName -InternalUrl $InternalPowerShellUrl -DomainController $RoleDomainController -WindowsAuthentication:$false -RequireSSL:$false; } ": "El directorio virtual "PowerShell" ya existe en "server.dominio.local/Sitio web Predeterminado". Nombre del parámetro: VirtualDirectoryName". El directorio virtual "PowerShell" ya existe en "server.dominio.local/Sitio web Predeterminado". Nombre del parámetro: VirtualDirectoryName 

    He estado buscando soluciones encontrando esto:

    http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/0eb81c20-9868-4157-94b0-74aee0cbdabd/ donde se detalla la solución:

    ere is the resoltuion for the Power Shell Virtual Directory Issue:

    1. Open ADSIEDIT.msc and navigate to SERVER - PROTOCOLS – HTTP, then delete PowerShell VD.

    2. Log onto the server , launch IIS Manger and remove the PowerShell VD.

    3.Run this command from the Elevated cmd prompt -> cscript.exe Adsutil.vbs delete w3svc/1/root/PowerShell

    4. Restart Server

    After Following these steps Installation should move forward.

    La pregunta es si es seguro hacer esto, veo que a personas les funciona a otras no... Los requisitos previos a la instalación del SP1 son correctos. El Exchange Server lleva instalado y funcionando una temporada sin problemas.

    Muchas gracias.

    jueves, 14 de febrero de 2013 6:50

Todas las respuestas

  • Hola,

    No es necesario instalar el SP1 para instalar el SP2. Puedes instalar éste último directamente, previa ampliación del Schema del dominio.


    Saludos,

    Marc
    Microsoft MVP - Directory Services
    MCSA/MCSE 2003
    MCSA: Windows Server 2008/2012
    MCITP: Enterprise Administrator, Enterprise Messaging Administrator, Lync Server Administrator 2010
    MCTS: SCOM 2007, Configuring; SCCM 2007, Configuring; Windows 7 and Office 2010, Deploying; Windows Server 2008 R2, Server Virtualization; Administering and Deploying System Center 2012 Configuration Manager
    MCC: Microsoft Community Contributor
    Citrix CCA
    Visita mi blog en ITPro.es
    MCP Virtual Bussines Card

    jueves, 14 de febrero de 2013 8:14
  • Perfecto, probaré con la instalación directamente del SP2.  Respecto a la ampliación del Schema del dominio, te refieres que en nivel funcional del domino y del bosque sean Windows 2003 como mínimo?.

    Gracias por tu ayuda.

    jueves, 14 de febrero de 2013 9:10
  • Hola,

    Me refiero a que para instalar el SP2 (y el reciente SP3 de Exchange 2010) has de ejecutar un setup.com /prepareAD antes de poder instalar el producto.


    Saludos,

    Marc
    Microsoft MVP - Directory Services
    MCSA/MCSE 2003
    MCSA: Windows Server 2008/2012
    MCITP: Enterprise Administrator, Enterprise Messaging Administrator, Lync Server Administrator 2010
    MCTS: SCOM 2007, Configuring; SCCM 2007, Configuring; Windows 7 and Office 2010, Deploying; Windows Server 2008 R2, Server Virtualization; Administering and Deploying System Center 2012 Configuration Manager
    MCC: Microsoft Community Contributor
    Citrix CCA
    Visita mi blog en ITPro.es
    MCP Virtual Bussines Card

    jueves, 14 de febrero de 2013 9:40
  • Gracias por tu respuesta. Sabes dónde conseguir esa información?. Es decir, los requisitos para la instalación de SP2 o SP3 dado que en http://technet.microsoft.com/en-us/library/bb629560(v=exchg.141).aspx no encuentro por ninguna parte que hubiera que ejecutar ese comando. En cambio, si lo hice cuando instale por primera vez Exchange 2010.

    Reitero mi agradecimiento.

    jueves, 14 de febrero de 2013 10:15
  • Hola,

    Lo puedes encontrar en http://technet.microsoft.com/en-us/library/hh529928(v=exchg.141).aspx, en el apartado "Installing Exchange 2010 SP2", concretamente en "Exchange 2010 SP2 makes updates to the Active Directory schema"


    Saludos,

    Marc
    Microsoft MVP - Directory Services
    MCSA/MCSE 2003
    MCSA: Windows Server 2008/2012
    MCITP: Enterprise Administrator, Enterprise Messaging Administrator, Lync Server Administrator 2010
    MCTS: SCOM 2007, Configuring; SCCM 2007, Configuring; Windows 7 and Office 2010, Deploying; Windows Server 2008 R2, Server Virtualization; Administering and Deploying System Center 2012 Configuration Manager
    MCC: Microsoft Community Contributor
    Citrix CCA
    Visita mi blog en ITPro.es
    MCP Virtual Bussines Card

    jueves, 14 de febrero de 2013 10:31