locked
Driver iPhone RRS feed

  • Pregunta

  • Hola: tengo acceso a 5 PC con Windows 7 y en todos menos uno, precisamente el de mi casa, cuando conecto mi iPhone 3GS en todos me sale la ventanita para bajar las fotos; en el de casa, aparece en el administrador de dispositivos en dispositivos portátiles algo como "dispositivo MTP USB" y además en amarillo. Lo he actualzado el driver varias veces y ni flores. Si sincroniza con iTunes pero no va el tema de las fotos. Todas las máquinas son diferentes y en todas funciona menos en una. ¿Qué puede ser?

    Gracias  y un saludo
    martes, 19 de enero de 2010 0:09

Respuestas

  • Bueno, mi hija ha dado con la solución, y es una tontería típica de Apple.

    Cuando tenía los drivers de Apple iPhone me conectaba como cámara, y cuando tenía los del Apple Mobile USB conectaba con el iTunes, pero nunca las dos cosas al tiempo; conectó su iPhone a mi PC y lo mismo y el mío a su Mac... y se encendió la luz!!! Resulta que como había reseteado mi iPhone, NO TENIA NINGUNA FOTO HECHA..., y eso hacía que no cargara el driver de la cámara!!!; en cuanto hice una foto...apareció en el administrador de dispositivos los dos (iPhone y USB driver)

    Joer, y digo yo, ¿ porqué aparecía el driver de la cámara aún sin ninguna foto hecha cuando hacía la farragosa operación comentada antes? estos de Apple...dos días trasteando para semejante jilipollez!!

    Gracias por todo!!!
    sábado, 23 de enero de 2010 19:27
  • Bueno, mi hija ha dado con la solución, y es una tontería típica de Apple.

    Cuando tenía los drivers de Apple iPhone me conectaba como cámara, y cuando tenía los del Apple Mobile USB conectaba con el iTunes, pero nunca las dos cosas al tiempo; conectó su iPhone a mi PC y lo mismo y el mío a su Mac... y se encendió la luz!!! Resulta que como había reseteado mi iPhone, NO TENIA NINGUNA FOTO HECHA..., y eso hacía que no cargara el driver de la cámara!!!; en cuanto hice una foto...apareció en el administrador de dispositivos los dos (iPhone y USB driver)

    Joer, y digo yo, ¿ porqué aparecía el driver de la cámara aún sin ninguna foto hecha cuando hacía la farragosa operación comentada antes? estos de Apple...dos días trasteando para semejante jilipollez!!

    Gracias por todo!!!
    iTunes es muy peligroso... no solo por las tonterias que hace sino por lo que puede dañar. Ha habido versiones que cuando lo instalabas, debido a sus drivers de USB, hacian que en esa maquina a partir de ese momento no pudiesen verse por USB los pen y los discos duros externos... errores en cuanto se intenaba usar uno (no podia instalar los drivers del propio windows).

    NOTA: siempre aconsejo montar iTunes en Virtual... y usarlo desde allí...

     


    Jose Manuel Tella Llop news://jmtella.com

    sábado, 23 de enero de 2010 19:41

Todas las respuestas

  • Hola,

    Le instalaste controladores directos para Windows 7 o sistema inferior? Dale en inicio, Drivers e impresoras, ahí se te visualiza tu dispositivo?
    Normalmente es por no tener instalados los controladores más actuales o del sistema operativo que estás usando realmente.

    Ten en cuenta también tener Windows Update activado.

    Saludos
    Sergio Calderón | Microsoft Student Partner
    martes, 19 de enero de 2010 3:06
  • Hola: tengo acceso a 5 PC con Windows 7 y en todos menos uno, precisamente el de mi casa, cuando conecto mi iPhone 3GS en todos me sale la ventanita para bajar las fotos; en el de casa, aparece en el administrador de dispositivos en dispositivos portátiles algo como "dispositivo MTP USB" y además en amarillo. Lo he actualzado el driver varias veces y ni flores. Si sincroniza con iTunes pero no va el tema de las fotos. Todas las máquinas son diferentes y en todas funciona menos en una. ¿Qué puede ser?

    Gracias  y un saludo

    Necesitaremos saber el tipo de instalacion que hiciste de windows 7 en esa maquina, así como drivers y software instalado previamente.

    Jose Manuel Tella Llop news://jmtella.com

    martes, 19 de enero de 2010 5:26
  • Ahora el dispositivo arranca, pero "Apple iPhone" se pone en amarillo a los pocos segundos; en propiedades en el administrador de dispositivos aparece "este dispositivo no puede iniciar (Código 10)"
    martes, 19 de enero de 2010 7:40
  • Como continuación de lo anterior, cuando le das a resolver problemas con el botón dcho. vuelve a instalar los controladores y funciona...hasta que lo desenchufas , enchufas y vuelta a empezar. Tienes que esperar hasta que el iPhone se pone amarillo y vuelta a resolver problemas, a instalar drivers...etc
    martes, 19 de enero de 2010 10:02
  • Como continuación de lo anterior, cuando le das a resolver problemas con el botón dcho. vuelve a instalar los controladores y funciona...hasta que lo desenchufas , enchufas y vuelta a empezar. Tienes que esperar hasta que el iPhone se pone amarillo y vuelta a resolver problemas, a instalar drivers...etc

    ¿hay diferencia entre ses windows en que te falla y los otros?... por ejemplo 32 y 64 bits, o bien que ese windows provenga de una actualizacion, o bien que sea un OEM cuyo fabricante haya incorporado cosas al sistema... etc...

    Es decir, nos debes dar este tipo de informacion tal y como te habia solicitado... No el problema, que está claro, sino ese windows como está, que diferencias tiene, que software tiene instalado desde su inicio, etc...


    Jose Manuel Tella Llop news://jmtella.com

    martes, 19 de enero de 2010 10:22
  • No es el mismo Windows. Es el Ultimate de 32 bits del cual tenemos en mi empresa licencias corporativas. Todos instalados en limpio sobre las máquinas formateadas. Los drivers son los mismos y no se  dejan copiar de una que funcione ni a prueba de fallos. Las máquinas son diferentes (dos HP. dos APD y un Toshiba portege; no funciona en el Toshiba y en un HP; tienen instalado prácticamente lo mismo
    martes, 19 de enero de 2010 10:36
  • .... Los drivers son los mismos y no se  dejan copiar de una que funcione ni a prueba de fallos. ....
    ¿como intentas la copia de los drivers?... los drivers deben copiarse del .cab que se genera en \windows\system32\DriverStore\FileRepository

    En cualquier caso si el instalador es el mismo deberia instalar lo mismo. Si dichos drviers no son explicitamente para windows 7, hay que instalarlos con boton derecho e instalar en modo compatibilidad (para Vista o XP, depende)... ¿lo hace así?

    NOTA: cuando dices que no es el mismo windows ¿a que te refieres? ¿a que uno es Home y otro Ultimate?... en cualquier caso, son ambos de 32 o ambos de 64, ¿o bien donde falla es un windows de bits diferentes al otro en que funciona?

    Jose Manuel Tella Llop news://jmtella.com

    martes, 19 de enero de 2010 11:01
  • Vamos a ver: yo no le he metido ningún driver nuevo. Son los del windows 7 y más concretamente:

    Windows\system32\drivers\UMDF\WpdMtpDr.dll
    Windows \system32\Drivers\winusb.sys
    Windows\system32\drivers\WUDFRd.sys
    windows\system32\WpdMtp.dll
    windows\system32\WpdMtpUS.dll

    Estos son los que extraidos de una máquina que funciona los intento pegar a las mismas ubicaciones y no se deja (carezco de permisos aunque soy administrador); ni a prueba de fallos.

    Lo que pasa es que en dispositivos e impresoras, en el icono de Apple iPhone, botón dcho sale el triangulito amarillo delante de solucionar problemas. Cuando hago esto, pone buscando el controlador que falta (??) y vuelve a cargar los mismos controladores y luego pone "Apple iPhone tiene un problema con el controlador" :  corregido. y ya ve el teléfono; yo no he metido ningun controlador nuevo, son los que hay en la máquina que por lo que sea hay que instalarlos cada vez que se enchufa el iPhone
    martes, 19 de enero de 2010 11:26
  • Vamos a ver: yo no le he metido ningún driver nuevo. Son los del windows 7 y más concretamente:

    Windows\system32\drivers\UMDF\WpdMtpDr.dll
    Windows \system32\Drivers\winusb.sys
    Windows\system32\drivers\WUDFRd.sys
    windows\system32\WpdMtp.dll
    windows\system32\WpdMtpUS.dll

    Estos son los que extraidos de una máquina que funciona los intento pegar a las mismas ubicaciones y no se deja (carezco de permisos aunque soy administrador); ni a prueba de fallos.

    Lo que pasa es que en dispositivos e impresoras, en el icono de Apple iPhone, botón dcho sale el triangulito amarillo delante de solucionar problemas. Cuando hago esto, pone buscando el controlador que falta (??) y vuelve a cargar los mismos controladores y luego pone "Apple iPhone tiene un problema con el controlador" :  corregido. y ya ve el teléfono; yo no he metido ningun controlador nuevo, son los que hay en la máquina que por lo que sea hay que instalarlos cada vez que se enchufa el iPhone

    Es que eso que estas haciendo no vale nada mas que en XP. En Vista y superiores es necesario obtener el conjunto del .cab que cada vez que se instala un driver el sistema genera en la localizacion que te he comentado:

    \windows\system32\DriverStore\FileRepository

    Tiene que localziar allí cual es... lo cual no es facil ya que tendras que ir entrando en todos hasta que localices uno que tenga alguna de las DLL's anteriores... y ese precisamente es el que hay que usar para instalar en la nueva maquina.

    Jose Manuel Tella Llop news://jmtella.com

    martes, 19 de enero de 2010 11:43
  • Para que pudieras remplazar manualmente, tendrás que tomar posesión de cada archivo dentro de estos directorios, o de la carpeta de System32 pero aveces no funciona también, es por la protección de recursos de Windows y UAC, si lo estás haciendo así, debes ir a las propiedades del archivo, pestaña seguridad, botón avanzado y vas a la pestaña Propietario, allí le das de nuevo avanzado y buscas el tuyo o todos los usuarios.

    Aceptas todo hasta que vuelvas a la pestaña de Seguridad, una vez allí tomado propietario, dale al botón Editar y le das control absoluto, aceptas y vuelves intentar remplazar cada archivo.

    Trata de desinstalar el controlador, y si es posible hacer la instalación manualmente y de una manera limpia otra vez, puedes guiarte dándole clic derecho al ejecutable y que corra los paquetes de compatibilidad, así sea para Windows 7 podría encontrarte problemas que te ayuden a solucionarlo, es para que no sea más por actualización o corrección, en ocasiones el signo indica que no es el más actual (Asegúrate de eso) o problemas con otro que se podrían solucionar reinstalando manualmente.

    Saludos,
    Sergio Calderón | Microsoft Student Partner
    martes, 19 de enero de 2010 11:44
  • Para que pudieras remplazar manualmente, tendrás que tomar posesión de cada archivo dentro de estos directorios, o de la carpeta de System32 pero aveces no funciona también, es por la protección de recursos de Windows y UAC, si lo estás haciendo así, debes ir a las propiedades del archivo, pestaña seguridad, botón avanzado y vas a la pestaña Propietario, allí le das de nuevo avanzado y buscas el tuyo o todos los usuarios.

    Aceptas todo hasta que vuelvas a la pestaña de Seguridad, una vez allí tomado propietario, dale al botón Editar y le das control absoluto, aceptas y vuelves intentar remplazar cada archivo.

    Trata de desinstalar el controlador, y si es posible hacer la instalación manualmente y de una manera limpia otra vez, puedes guiarte dándole clic derecho al ejecutable y que corra los paquetes de compatibilidad, así sea para Windows 7 podría encontrarte problemas que te ayuden a solucionarlo, es para que no sea más por actualización o corrección, en ocasiones el signo indica que no es el más actual (Asegúrate de eso) o problemas con otro que se podrían solucionar reinstalando manualmente.

    Saludos,
    Sergio Calderón | Microsoft Student Partner

    No. No... no tiene que reemplazar nada a mano, sino instalar bien. El problema es que NO tiene los drivers y los está copiando a pelo de otra instalacion... y esto no funciona nunca en Vista y superiores: es una vieja artimaña que funcionaba en XP... porque Dios existe y además es bueno :-P

    Necesita recuperar el .cab que le he dicho y operar con él.

    Jose Manuel Tella Llop news://jmtella.com

    martes, 19 de enero de 2010 12:16
  • Jose Manuel: a ver si he entendido lo que dices; en la carpeta Filerepository hay muchas subcarpetas; parece que dices que hay que buscar en las sospechosas, y si aparece un .dll o un .sys de los drivers, darle con el boton dcho en el fichero .inf e instalar; es así?
    martes, 19 de enero de 2010 12:22
  • Entiendo :-)
    No me ha parecido muy confiable ese tipo de instalación, por eso igual recomendé que instale el controlador bien y en limpio, aunque di la opción para que pudiera remplazar estos archivos entendiendo que no es lo más correcto :-P

    Gracias Jose.

    Saludos,
    Sergio Calderón | Microsoft Student Partner
    martes, 19 de enero de 2010 12:24
  • No tengo los controladores limpios. Apple ni nadie en Google los tiene; tengo que utilizar los que vienen preinstalados en el Windows 7 asi que no puedo desinstalar e instalar limpio con un .exe (setup.exe o lo que sea); en cuanto desinstalo y enchufo, coge los que trae el windows; estos mismos controladores valen en otras máquinas
    martes, 19 de enero de 2010 12:32
  • No tengo los controladores limpios. Apple ni nadie en Google los tiene; tengo que utilizar los que vienen preinstalados en el Windows 7 asi que no puedo desinstalar e instalar limpio con un .exe (setup.exe o lo que sea); en cuanto desinstalo y enchufo, coge los que trae el windows; estos mismos controladores valen en otras máquinas

    Bueno fíjate si en el ejecutable en los dispositivos te habilita la opción de Paquete de compatibilidad, es para que haga un escaneo, si detecta entre lo que está algunos posibles problemas, te dará algunas posibles soluciones, lo importante es que si detecta la corrección del controlador quedará guardada en registro si aceptas, podría no cambiarse y funcionar como cuando haces reinstalación que te funciona por momento.
    Sergio Calderón | Microsoft Student Partner
    martes, 19 de enero de 2010 12:40
  • Jose Manuel: a ver si he entendido lo que dices; en la carpeta Filerepository hay muchas subcarpetas; parece que dices que hay que buscar en las sospechosas, y si aparece un .dll o un .sys de los drivers, darle con el boton dcho en el fichero .inf e instalar; es así?
    Efectivamente, lo que tienes que hacer es localizar el .cab (lo vez como una carpeta... (si lo ordenas por fechas, tendrá la feha de instalacion y tre puede dar una idea).
    Ese mismo .cab lo llevas a tu maquina y lo pones en tu file repository... y le das a que windows instale drivers (windows busca allí).

    Pero... esto deberia haberse hecho sin haber guarreado la maquina... puede que ahora tengas algun problema... Intenalo y comentame.

    Jose Manuel Tella Llop news://jmtella.com

    martes, 19 de enero de 2010 15:29
  • Querido Jose Manuel: ésto ya si que me sobrepasa. Estaba haciendo pruebas en la oficina esta tarde con el portátil Toshiba...y aparece un colega que también tiene un iPhone idéntico al mío..y le dije "déjamelo..." lo conecto al USB...Y A LA PRIMERA!!.
    O sea: ¿ahora resulta que es el iPhone? y ¿ porqué el mío sí funciona en otras máquinas...?...mira os agradezco mucho vuestro interés pero voy a tirar la toalla, cuando las cosas en informática no tienen lógica, como informático profesional que soy lo mejor es olvidarse si no afectan a tu trabajo. Esperaré a la nueva actualización del S.O del iPhone (4.0) que está al caer y a ver si así se arregla.

    Nos vemos por aquí...gracias otra vez
    martes, 19 de enero de 2010 17:43
  • Querido Jose Manuel: ésto ya si que me sobrepasa. Estaba haciendo pruebas en la oficina esta tarde con el portátil Toshiba...y aparece un colega que también tiene un iPhone idéntico al mío..y le dije "déjamelo..." lo conecto al USB...Y A LA PRIMERA!!.
    O sea: ¿ahora resulta que es el iPhone? y ¿ porqué el mío sí funciona en otras máquinas...?...mira os agradezco mucho vuestro interés pero voy a tirar la toalla, cuando las cosas en informática no tienen lógica, como informático profesional que soy lo mejor es olvidarse si no afectan a tu trabajo. Esperaré a la nueva actualización del S.O del iPhone (4.0) que está al caer y a ver si así se arregla.

    Nos vemos por aquí...gracias otra vez
    Pues entonces no es tan identico... es un problema de "ese" iPhone.. ¿firmware?...

    Jose Manuel Tella Llop news://jmtella.com

    martes, 19 de enero de 2010 18:33
  • Pues es posible. Estoy tentado de cargar de nuevo el firmware...pero ya sabes lo puñetero que es el iTunes..puedo perder todos los programas que he comprado y no me fío de la copia de seguridad del iPhone porque me ha dado un error la primera vez.
    martes, 19 de enero de 2010 18:50
  • Bueno...ya dí con el problema. El culpable de todo ésto es el iTunes que parece que mete unos drivers o algo que fastidian a los nativos. Cuando desinstalas el iPhone y lo vuelves a reconocer en el administrador de dispositivos coge los nativos del Windows  y rula bien. Una vez desenchufado y vuelto a enchufar vuelve el iTunes a dar por....aunque no esté cargado. Lo he comprobado en dos PC y es eso. Lo malo es que la desinstalación del iTunes no es limpia, algo deja y si no tienes la precaución antes de instalarlo de crear un punto de restauración, vas dado.

    Gracias de nuevo
    miércoles, 20 de enero de 2010 8:34
  • Bueno...ya dí con el problema. El culpable de todo ésto es el iTunes que parece que mete unos drivers o algo que fastidian a los nativos. Cuando desinstalas el iPhone y lo vuelves a reconocer en el administrador de dispositivos coge los nativos del Windows  y rula bien. Una vez desenchufado y vuelto a enchufar vuelve el iTunes a dar por....aunque no esté cargado. Lo he comprobado en dos PC y es eso. Lo malo es que la desinstalación del iTunes no es limpia, algo deja y si no tienes la precaución antes de instalarlo de crear un punto de restauración, vas dado.

    Gracias de nuevo

    joer.. eso siempre. El iTunes, al menos las versiones viejas, meten filtros en la capa USB para control de sus dispositivos y normalmente j*de todos los de windows...

    NOTA: lo que deja la desistalacion del iTunes es precisamente todos los filtros que mete... pero estos siempre pueden limpiarse "a mano" (o incluso eliminarlos aunque sigas con iTunes: molestan mas que ayudan) ya que los filtros en el USB estan localizados en la variable LowerFilters o bien Upperfilters de la clave:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class.{36FC9E60-C465-11CF-8056-444553540000} 
    y eliminado de ella esos campos (delete a Lower o UpperFilters, o mejor renombrarlo con una z por delante para que no los use y reiniciar) deberia funcionar.

     

    Jose Manuel Tella Llop news://jmtella.com

    miércoles, 20 de enero de 2010 9:44
  • Hola: la clave HKEY_LOCAL...... que me indicas no tiene lo de LoverFilters o UpperFilters sino una serie de subclaves que empiezan en la 0000 y terminan en la 0037. He abierto todas y las que hacen relacion a Apple son cinco, la 0017, 0023, 0024, 0036 y 0037; te pongon lo que dice una de ellas, la 0017

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{36FC9E60-C465-11CF-8056-444553540000}\0017]
    "InfPath"="oem28.inf"
    "InfSection"="USBAAPL.Dev"
    "ProviderName"="Apple, Inc."
    "DriverDateData"=hex:00,c0,ca,07,16,04,ca,01
    "DriverDate"="7-14-2009"
    "DriverVersion"="6.0.9999.45"
    "MatchingDeviceId"="usb\\vid_05ac&pid_1294"
    "DriverDesc"="Apple Mobile Device USB Driver"

    ¿me las cargo todas haciendo un punto de restauración antes por si las flys?

    Gracias

    jueves, 21 de enero de 2010 7:22
  • Hola: la clave HKEY_LOCAL...... que me indicas no tiene lo de LoverFilters o UpperFilters sino una serie de subclaves que empiezan en la 0000 y terminan en la 0037. He abierto todas y las que hacen relacion a Apple son cinco, la 0017, 0023, 0024, 0036 y 0037; te pongon lo que dice una de ellas, la 0017

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{36FC9E60-C465-11CF-8056-444553540000}\0017]
    "InfPath"="oem28.inf"
    "InfSection"="USBAAPL.Dev"
    "ProviderName"="Apple, Inc."
    "DriverDateData"=hex:00,c0,ca,07,16,04,ca,01
    "DriverDate"="7-14-2009"
    "DriverVersion"="6.0.9999.45"
    "MatchingDeviceId"="usb\\vid_05ac&pid_1294"
    "DriverDesc"="Apple Mobile Device USB Driver"

    ¿me las cargo todas haciendo un punto de restauración antes por si las flys?

    Gracias


    No. no vale en ese caso con cargarselas... ya que por desgracia está montando drivers en ese caso... y no lo hace por filtros... Lo siento.

    Un saludo,

    Jose Manuel Tella Llop news://jmtella.com

    jueves, 21 de enero de 2010 12:19
  • Hola: conmo me gustan los retos y aún no he solucionado éste, sigo trasteando.

    Lo primero decir que lo que relato a continuación ocurre exactamente igual con dos PC, ambos con Windows 7 Ultimate 32 y que se parecen como un huevo a una castaña

    -Portátil TOSHIBA PORTEGE R500 con 2 Gb Intel Dual Core
    -HP Pavillon ABE m9554es Intel Core Quad con 4 Gb de RAM

    Ayer cogí el iPhone y lo restauré a la configuración de fábrica sin restaurar lo que tenía en el backup, o sea limpio como el ____ de mi nieta, tal como me lo dieron.

    Desinstalé por completo el iTunes 9.0.02 (el último, incluso borrando lo que deja en usuarios/biblioteca/musica/itunes); luego fuí al registro y borre la clave Apple en software.

    Instalé de nuevo iTunes, que consta de varios módulos entre éllos el Apple Mobile Device Support que es donde creo que está la clave del asunto.

    Empieza el experimento: cuando conecto el iPhone al USB por primera vez, aparece en dispositivos bajo el epígrafe Controladores de bus de serie universal uno que se llama Apple Mobile Device Driver cuyos drivers son :
    -C:\windows\system32\drivers\usbaapl.sys
    -C:\Windows\system\usbaaplrc.dll

    Con esta configuración conecta con iTunes (puedo sincronizar programas, bibliotecas etc...) pero no sincroniza la reproducción automática (no reconoce el dispositivo como una cámara); situación en la que estaba.

    Me voy al dispositivo Apple Mobile Device Driver , lo desinstalo, enchufo el iPhone y le doy a reconocer nuevo hardware y pasa lo siguiente:

    Me reconoce OTRO DISPOSITIVO bajo el epígrafe Dispositivos Portátiles como Apple iPhone cuyos driver son :
    Windows\system32\drivers\UMDF\WpdMtpDr.dll
    Windows \system32\Drivers\winusb.sys
    Windows\system32\drivers\WUDFRd.sys
    windows\system32\WpdMtp.dll
    windows\system32\WpdMtpUS.dll

    y me quita el Apple Mobile Device USB driver del epígrafe Controladores de Bus serie universal, con lo cual ya veo la cámara pero ya NO SINCRONIZO CON ITUNES; cuando enchufo el teléfono en iTunes no aparece y así se queda por mucho que desinstale y reconozca

    ¿Que tengo que hacer si quiero sincronizar con iTunes? un pequeño coñazo:

    Hay que desinstalar en el panel de control "desinstalar o cambiar un programa" el programa o módulo Apple Mobile Device Support.

    Volver a instalar el AppleMobileDeviceSupport.msi que he desmpaquetado del paquete original iTunesSetup.exe con el winrar.

    Hecho ésto ya vuelve a aparecer esta ____ como Controlador de bus de serie universal y puedo conectar a iTunes, pero sin fotos de mi nieta.

    Parece como que el dispositivo no puede estar a la vez como Controlador de bus y como dispositivo portátil con sus juegos de drivers.

    Hoy va a venir mi hija a casa que tiene un Mac portátil a ver si hace más o menos lo mismo.

    ¿se te ocurre algo?

    GRACIAS POR AGUANTAR EL ROLLO.

    sábado, 23 de enero de 2010 9:48
  • Hola: conmo me gustan los retos y aún no he solucionado éste, sigo trasteando.

    Lo primero decir que lo que relato a continuación ocurre exactamente igual con dos PC, ambos con Windows 7 Ultimate 32 y que se parecen como un huevo a una castaña

    -Portátil TOSHIBA PORTEGE R500 con 2 Gb Intel Dual Core
    -HP Pavillon ABE m9554es Intel Core Quad con 4 Gb de RAM

    Ayer cogí el iPhone y lo restauré a la configuración de fábrica sin restaurar lo que tenía en el backup, o sea limpio como el ____ de mi nieta, tal como me lo dieron.

    Desinstalé por completo el iTunes 9.0.02 (el último, incluso borrando lo que deja en usuarios/biblioteca/musica/itunes); luego fuí al registro y borre la clave Apple en software.

    Instalé de nuevo iTunes, que consta de varios módulos entre éllos el Apple Mobile Device Support que es donde creo que está la clave del asunto.

    Empieza el experimento: cuando conecto el iPhone al USB por primera vez, aparece en dispositivos bajo el epígrafe Controladores de bus de serie universal uno que se llama Apple Mobile Device Driver cuyos drivers son :
    -C:\windows\system32\drivers\usbaapl.sys
    -C:\Windows\system\usbaaplrc.dll

    Con esta configuración conecta con iTunes (puedo sincronizar programas, bibliotecas etc...) pero no sincroniza la reproducción automática (no reconoce el dispositivo como una cámara); situación en la que estaba.

    Me voy al dispositivo Apple Mobile Device Driver , lo desinstalo, enchufo el iPhone y le doy a reconocer nuevo hardware y pasa lo siguiente:

    Me reconoce OTRO DISPOSITIVO bajo el epígrafe Dispositivos Portátiles como Apple iPhone cuyos driver son :
    Windows\system32\drivers\UMDF\WpdMtpDr.dll
    Windows \system32\Drivers\winusb.sys
    Windows\system32\drivers\WUDFRd.sys
    windows\system32\WpdMtp.dll
    windows\system32\WpdMtpUS.dll

    y me quita el Apple Mobile Device USB driver del epígrafe Controladores de Bus serie universal, con lo cual ya veo la cámara pero ya NO SINCRONIZO CON ITUNES; cuando enchufo el teléfono en iTunes no aparece y así se queda por mucho que desinstale y reconozca

    ¿Que tengo que hacer si quiero sincronizar con iTunes? un pequeño coñazo:

    Hay que desinstalar en el panel de control "desinstalar o cambiar un programa" el programa o módulo Apple Mobile Device Support.

    Volver a instalar el AppleMobileDeviceSupport.msi que he desmpaquetado del paquete original iTunesSetup.exe con el winrar.

    Hecho ésto ya vuelve a aparecer esta ____ como Controlador de bus de serie universal y puedo conectar a iTunes, pero sin fotos de mi nieta.

    Parece como que el dispositivo no puede estar a la vez como Controlador de bus y como dispositivo portátil con sus juegos de drivers.

    Hoy va a venir mi hija a casa que tiene un Mac portátil a ver si hace más o menos lo mismo.

    ¿se te ocurre algo?

    GRACIAS POR AGUANTAR EL ROLLO.

    ¿y que tal si abres la consulta en algun foro de Apple?... el problema es el iTunes (siempre ha dado problemas... no solo en esta ocasion con iPhome sino cada que que sale un dispositivo tardan dos años en normalizar el que todo funcione...

    Un saludo,

    Jose Manuel Tella Llop news://jmtella.com

    sábado, 23 de enero de 2010 18:20
  • Bueno, mi hija ha dado con la solución, y es una tontería típica de Apple.

    Cuando tenía los drivers de Apple iPhone me conectaba como cámara, y cuando tenía los del Apple Mobile USB conectaba con el iTunes, pero nunca las dos cosas al tiempo; conectó su iPhone a mi PC y lo mismo y el mío a su Mac... y se encendió la luz!!! Resulta que como había reseteado mi iPhone, NO TENIA NINGUNA FOTO HECHA..., y eso hacía que no cargara el driver de la cámara!!!; en cuanto hice una foto...apareció en el administrador de dispositivos los dos (iPhone y USB driver)

    Joer, y digo yo, ¿ porqué aparecía el driver de la cámara aún sin ninguna foto hecha cuando hacía la farragosa operación comentada antes? estos de Apple...dos días trasteando para semejante jilipollez!!

    Gracias por todo!!!
    sábado, 23 de enero de 2010 19:27
  • Bueno, mi hija ha dado con la solución, y es una tontería típica de Apple.

    Cuando tenía los drivers de Apple iPhone me conectaba como cámara, y cuando tenía los del Apple Mobile USB conectaba con el iTunes, pero nunca las dos cosas al tiempo; conectó su iPhone a mi PC y lo mismo y el mío a su Mac... y se encendió la luz!!! Resulta que como había reseteado mi iPhone, NO TENIA NINGUNA FOTO HECHA..., y eso hacía que no cargara el driver de la cámara!!!; en cuanto hice una foto...apareció en el administrador de dispositivos los dos (iPhone y USB driver)

    Joer, y digo yo, ¿ porqué aparecía el driver de la cámara aún sin ninguna foto hecha cuando hacía la farragosa operación comentada antes? estos de Apple...dos días trasteando para semejante jilipollez!!

    Gracias por todo!!!
    iTunes es muy peligroso... no solo por las tonterias que hace sino por lo que puede dañar. Ha habido versiones que cuando lo instalabas, debido a sus drivers de USB, hacian que en esa maquina a partir de ese momento no pudiesen verse por USB los pen y los discos duros externos... errores en cuanto se intenaba usar uno (no podia instalar los drivers del propio windows).

    NOTA: siempre aconsejo montar iTunes en Virtual... y usarlo desde allí...

     


    Jose Manuel Tella Llop news://jmtella.com

    sábado, 23 de enero de 2010 19:41
  • Pues como se nota que no han usado ni explotado el SO de Apple... eso es un sistema operativo como sus programas y aplicaciones... el problema que tienen no es por culpa de Apple! es culpa de la porqueria que es el Sistema Operativo de Windows y todas sus estupideces de drivers!!!

    Cuando en Mac conectas algo te funciona!

    Cuando en Mac instalas algo solo lo haces arrastrando un acceso a las aplicaciones y listo! En windows te llenas de mierdas, virus y mas!

    sábado, 4 de junio de 2011 0:00