none
Retraso en la recepción de las alertas enviadas a través de SharePoint 2010 RRS feed

  • Pregunta

  • Buenas,

    Expongo mi caso:

    Tengo varías listas en un sitio de mi intranet (SharePoint 2010), he creado "alertas de lista" y las he configurado de forma "<label for="ctl00_PlaceHolderMain_ctl07_ctl01_RadioBtnAlertFreq_0">Enviar notificación inmediatamente", para que cada vez que añadan/modifiquen un elemento en la lista, se genere la alerta y la envien por correo, pues bien, al crear esta alerta, me llega en pocos segundos un correo avisandome  de que se ha creado la alerta correctamente, pero aqui viene el problema, cuando creo/modifico un elemento de la lista la alerta no llega inmediatamente sino que tarda entre 3-5minutos, cuando debería de llegar a los pocos segundos.</label>¿A qué puede deberse?¿Existe algún parametro de configuración para este tipo de alertas?

    Gracias por vuestra colaboración.

    jueves, 19 de diciembre de 2013 12:05

Respuestas

  • Hola,

    Pues si eso lo tienes claro, ya te adelanto que no hay nada a nivel de configuración que pueda estar causando el retardo en el envio salvo que en la lista misma puedas tener desplegado algún elemento como un manejador de eventos o un flujo de trabajo que pueda estar ralentizando las operaciones CRUD en la lista...el comportamiento de las alertas es común a toda lista/biblioteca de SharePoint y son enviadas gracias a Timer Jobs que como bien has comprado se ejecutan cada 0-1 minuto.

    Un saludo


    ------------------------------------------------------------<br/> Juan Carlos González Martín MVP de SharePoint Server<br/> Director revista CompartiMOSS: http://www.compartimoss.com <br/> Blog: http://geeks.ms/blogs/jcgonzalez<br/> Twitter: @jcgm1978<br/> ------------------------------------------------------------

    • Propuesto como respuesta Uriel Almendra viernes, 20 de diciembre de 2013 19:01
    • Marcado como respuesta Uriel Almendra viernes, 3 de enero de 2014 21:36
    jueves, 19 de diciembre de 2013 21:35

Todas las respuestas

  • Hola,

    Se puede deber a que tengas el sistema cargado o bien a que tu servidor de correo no está sacando bien los correos. Las alertas de todas formas no se envía de forma inmediata, sino que un timer job que se ejecuta cada minuto es el responsable de su envio.

    Un saludo


    ------------------------------------------------------------<br/> Juan Carlos González Martín MVP de SharePoint Server<br/> Director revista CompartiMOSS: http://www.compartimoss.com <br/> Blog: http://geeks.ms/blogs/jcgonzalez<br/> Twitter: @jcgm1978<br/> ------------------------------------------------------------

    jueves, 19 de diciembre de 2013 12:30
  • Buenas,

    En principio descarto que "el sistema este cargado" ya que las alertas de otras listas las envia entre 0-1min.

    Creo que tampoco se puede deber al "contenido" de la lista porque he probado a crear alertas de listas con 1 solo campo y ocurre lo mismo (tarda entre 3-5min).

    jueves, 19 de diciembre de 2013 16:46
  • Hola,

    Pues si eso lo tienes claro, ya te adelanto que no hay nada a nivel de configuración que pueda estar causando el retardo en el envio salvo que en la lista misma puedas tener desplegado algún elemento como un manejador de eventos o un flujo de trabajo que pueda estar ralentizando las operaciones CRUD en la lista...el comportamiento de las alertas es común a toda lista/biblioteca de SharePoint y son enviadas gracias a Timer Jobs que como bien has comprado se ejecutan cada 0-1 minuto.

    Un saludo


    ------------------------------------------------------------<br/> Juan Carlos González Martín MVP de SharePoint Server<br/> Director revista CompartiMOSS: http://www.compartimoss.com <br/> Blog: http://geeks.ms/blogs/jcgonzalez<br/> Twitter: @jcgm1978<br/> ------------------------------------------------------------

    • Propuesto como respuesta Uriel Almendra viernes, 20 de diciembre de 2013 19:01
    • Marcado como respuesta Uriel Almendra viernes, 3 de enero de 2014 21:36
    jueves, 19 de diciembre de 2013 21:35