none
No puedo acceder a un sitio con SharePoint Designer 2013 RRS feed

  • Pregunta

  • Saludos, el problema se presenta de esta forma: Cuando intento abrir un sitio del tipo https://ejemplo.sharepoint.com en el programa SharePoint Designer 2013 me aparecen las siguientes ventanas:

    sharepoint designer 2013 forbidden

    El administrador del sitio ha comprobado que los permisos para acceder son correctos y además, en su ordenador, el sí puede acceder al sitio con SharePoint Designer 2013 sin ningún problema.

    Investigando en internet encontré que la causa puede ser que en el Administrador de IIS el sitio SharePoint Web Services no tenga asignada la propiedad Anonymous Authentication (http://www.c-sharpcorner.com/UploadFile/anavijai/error-the-server-could-not-complete-your-request-when-tryi/), sin embargo, cuando accedo al administrador de IIS de mi ordenador no puedo encontrar por ningún lado el sitio SharePoint Web Services.

    En otros sitios de internet (http://blogs.technet.com/b/vinitt/archive/2011/05/14/how-to-get-back-the-sharepoint-webservices-applicaion-in-iis-if-deleted-sharepoint-2010.aspx) encontré una forma para poner de nuevo los sitios de sharepoint del IIS introduciendo este código en el Powershell: 

    $webservice = [System.Type]::GetType("Microsoft.SharePoint.Administration.SPIisWebServiceSettings, Microsoft.SharePoint, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c")
    
    $Instance = $webservice::Default
    
    $Method = $webservice.GetMethod("ProvisionLocal", "Instance, NonPublic", $null, @(), $null)
    
    $Method.Invoke($Instance, $null)
    
    $Method = $webservice.GetMethod("Provision", "Instance, Public", $null, @(), $null)
    
    $Method.Invoke($Instance, $null)
    
    
    Get-SPServiceApplication | ForEach-Object {$_.Provision()}

    Pero cuando lo pongo en mi powershell me da estos errores:

    En otro sitio web (http://blogs.msmvps.com/haarongonzalez/how-to-restore-the-sharepoint-web-services-iis-web-site-if-accidently-deleted/) indican que se debe copiar un folder llamado Root (que no tengo) de otro servidor y ponerlo en esta ruta C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\WebServices\ (que tampoco tengo en mi ordenador).

    ¿Qué podría hacer para solucionar este problema? ¿y por qué los sitios de sharepoint no están en mi IIS? ¿no se deberían haber creado automáticamente al instalar el Sharepoint Designer 2013? (he probado volver a instalarlo junto con el IIS, el WAS y el Office365 pero todo sigue igual)

    Gracias de antemano por su ayuda.

    viernes, 29 de mayo de 2015 15:25

Respuestas

  • Hola, has las siguiente pruebas:

    • Agregarte como site collection administrator, y probar el acceso
    • Revisa con que cuenta te estás logueando (Sharepoint Designer 2013 -> Account -> Switch Account)

    Si ninguno de los dos te sirve, deberías reinstalar el Designer.

    Saludos.

    • Propuesto como respuesta Moderador M martes, 2 de junio de 2015 17:14
    • Marcado como respuesta Moderador M lunes, 8 de junio de 2015 20:35
    sábado, 30 de mayo de 2015 0:30