none
Exchange 2007 MapiExceptionNetworkError RRS feed

  • Pregunta

  • Hola

    ¿que tal?

    Tengo dos servidores Exchange 2007, EX1 y EX2, 

    EX1 anteriormente servia un Exchange 2003.

    EX2 Es una instalación completamente nueva y actualizada de Exchange 2007.

    Cuando intento mover un buzón de EX2 a EX1 no es posible, muestra el siguiente error:

    MapiExceptionNetworkError: Unable to make admin interface connection to server. (hr=0x80040115, ec=-2147221227)

    En cambio cuando la operación la realizo del EX1 al EX2 funciona correctamente.

    He comprobado la configuración de red de los servidores, al igual que los DNS, resuelven correctamente los nombres de los dos servidores.

    Ejecutando el comando test-MapiConnectivity en el servidor EX2 me muestra que es correcta, aunque no muestra nada sobre el servidor EX1.

    Por lo que he leido sobre este problema, estoy prácticamente segura de que el problema esta causado por permisos.

    He editado los permisos en el ADSI y sigue sin funcionar.

    ¿Que permisos debería tener configurados?

    ¿Cual puede ser el problema?

    El visor de eventos me muestra un error indicando que no puede sincronizar las carpetas públicas.

    Nuestra idea es realizar una migración completa de todos los buzones de EX1 a EX2 y eliminar EX1.

    Pero para ello desearía que la connectividad entre los dos fuera la correcta.

    He realizado pruebas de envío de correo entre buzones alojados en los servidores, los resultados son los siguientes.

    buzón en: EX1 hacia buzón en EX2: Entrega correcta

    buzón en: EX2 hacia buzón en EX1: Entrega INCORRECTA (no se reciben los correos)

    buzón en: EX2 hacia buzón externo : Entrega correcta

    Muchas gracias por la ayuda!

    Un saludo

    miércoles, 28 de marzo de 2012 10:36

Todas las respuestas

  • Cuántas NICs tienes activas en el servidor EX1?

    Saludos,

    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator (Windows Server 2008)
    MCITP: Enterprise Messaging Administrator (Microsoft Exchange 2007 & Exchange 2010)
    MCITP: Lync Server Administrator 2010
    MCC: Microsoft Community Contributor
    Citrix CCA
    Visita mi blog en ITPro.es
    MCP Virtual Bussines Card

    jueves, 29 de marzo de 2012 14:05
    Moderador
  • Los servidores están alojados en una plataforma de virtualización ESX, disponen de una nic virtual cada uno
    jueves, 29 de marzo de 2012 14:49
  • Has tocado algo del IPv6 en el servidor que falla?

    Saludos,

    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator (Windows Server 2008)
    MCITP: Enterprise Messaging Administrator (Microsoft Exchange 2007 & Exchange 2010)
    MCITP: Lync Server Administrator 2010
    MCC: Microsoft Community Contributor
    Citrix CCA
    Visita mi blog en ITPro.es
    MCP Virtual Bussines Card

    viernes, 30 de marzo de 2012 12:49
    Moderador
  • Hola,

    Muchas gracias por la respuesta

    no he tocado nada de ipv6 en ninguno de los servidores, es mas, el modulo ipv6 está desinstalado en los dos.

    Un saludo

    lunes, 2 de abril de 2012 8:08
  • Pues.... necesitas el IPv6.... aunque no esté configurado.

    Saludos,

    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator (Windows Server 2008)
    MCITP: Enterprise Messaging Administrator (Microsoft Exchange 2007 & Exchange 2010)
    MCITP: Lync Server Administrator 2010
    MCC: Microsoft Community Contributor
    Citrix CCA
    Visita mi blog en ITPro.es
    MCP Virtual Bussines Card

    lunes, 2 de abril de 2012 8:50
    Moderador
  • Gracias por tu rápida respuesta.

    ¿Cual es la razón por la que necesito ipv6?

    ¿lo debo instalar en los dos servidores?

    lunes, 2 de abril de 2012 8:56
  • Es un requisito de Exchange el tener IPv6 (no es necesario que esté configurado, sólo instalado)

    Saludos,

    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator (Windows Server 2008)
    MCITP: Enterprise Messaging Administrator (Microsoft Exchange 2007 & Exchange 2010)
    MCITP: Lync Server Administrator 2010
    MCC: Microsoft Community Contributor
    Citrix CCA
    Visita mi blog en ITPro.es
    MCP Virtual Bussines Card

    lunes, 2 de abril de 2012 10:32
    Moderador
  • He instalado ipv6 en los dos servidores y el problema persiste.

    El visor de eventos en el apartado aplicación muestra el siguiente error.

    Aunque es referente a las carpetas públicas.

    - System
    - Provider
    [ Name] MSExchange Store Driver
    - EventID 1020
    [ Qualifiers] 49156
    Level 2
    Task 1
    Keywords 0x80000000000000
    - TimeCreated
    [ SystemTime] 2012-04-04T13:49:11.000000000Z
    EventRecordID 261195
    Channel Application
    Computer ex2.dominio.com
    Security
    - EventData
    "Backfill Request (PublicFolderDatabase_2.edb@cesicat.cat)"
    MapiExceptionNoAccess: Unable to make connection to the server. (hr=0x80070005, ec=-2147024891) Diagnostic context: ...... Lid: 12952 dwParam: 0x5 Msg: EEInfo: prm[0]: Long val: 5 Lid: 23065 EcDoConnectEx called [length=191] Lid: 28153 EcDoConnectEx exception [rpc_status=0x5 ][latency=0] Lid: 16280 dwParam: 0x5 Msg: EEInfo: ComputerName: n/a Lid: 8600 dwParam: 0x5 Msg: EEInfo: ProcessID: 2840 Lid: 12696 dwParam: 0x5 Msg: EEInfo: Generation Time: 2012-04-04 13:49:11:678 Lid: 10648 dwParam: 0x5 Msg: EEInfo: Generating component: 2 Lid: 14744 dwParam: 0x5 Msg: EEInfo: Status: 5 Lid: 9624 dwParam: 0x5 Msg: EEInfo: Detection location: 1750 Lid: 13720 dwParam: 0x5 Msg: EEInfo: Flags: 0 Lid: 11672 dwParam: 0x5 Msg: EEInfo: NumberOfParameters: 1 Lid: 12952 dwParam: 0x5 Msg: EEInfo: prm[0]: Long val: 5 Lid: 19778 Lid: 27970 StoreEc: 0x80070005 Lid: 17730 Lid: 25922 StoreEc: 0x80070005


    miércoles, 4 de abril de 2012 13:58