locked
Sincronizacion de dispositivos moviles con exchange 2003. RRS feed

  • Pregunta

  • Tengo un exchange 2003 configurado para poder acceder por owa (con certificado) y con outlook (rpc over https). Todo esto funciona bien pero no consigo poder conectar dispositivos moviles tipo telefonos con android, iphones, ipads, etc.

    Quiero configurar los agentes de exchange que vienen por defecto en estos dispositivos para que sincronicen desde internet pero no hay forma.

    ¿Podeis indicarme los componentes que debo configurar en el servidor para este tipo de sincronización?

    Muchas gracias.

    miércoles, 26 de octubre de 2011 11:09

Respuestas

  • finalmente encontré la solución en esta kb 
    http://support.microsoft.com/kb/817379 
    method 2 para resolverlo. 
    prestar especial atención a: 
    Disable the forms-based authentication for the Exchange virtual directory 
    antes de crear la copia del site. 
    y sobretodo al crear la clave de registro 
    ExchangeVDir 
    yo finalmente puse dos claves, la que indica la kb y otra llamada VDirExchange con el mismo valor. 
    esta es la clave que ya viene creada en SBS2003. 
    funciona perfecto. 
    suerte. 
    • Marcado como respuesta Marc Salvador miércoles, 28 de diciembre de 2011 13:53
    miércoles, 28 de diciembre de 2011 8:25
  • No tiene porqué. Si te funciona OWA y Outlook Anywhere, ActiveSync debería funcionar dado que "usa" OWA, con el formato https://direcciónServidor/Active-Sync/

    Sobre el error 500, mira http://support.microsoft.com/kb/817379


    Saludos,

    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator (Windows Server 2008)
    MCITP: Enterprise Messaging Administrator (Microsoft Exchange 2007 & Exchange 2010)
    MCC: Microsoft Community Contributor 2011
    Citrix CCA
    Visita mi blog
    • Marcado como respuesta Marc Salvador miércoles, 28 de diciembre de 2011 13:53
    miércoles, 26 de octubre de 2011 14:24
  • Muchas gracias,

    Resolví el problema, un resumen de lo realizado:

    Mi ambiente es exchange en un SBS 2003 e ISA 2006 en dos servers distintos

    Básicamente lo que hice fue:

    1. Serve ISA: crear una regla de publicación de Active Sync utilizando la misma escucha del OWA (que siempre ha funcionado OK y tiene el  certificado correspondiente).

    2. Validar los directorios virtuales, sugerido en : http://alanhardisty.wordpress.com/2010/02/28/exchange-2003-and-activesync-configuration-and-troubleshooting/  en mi caso desde :: "Exchange 2003 (Part of Small Business Server)

    3. Listo !! mis Samsumg Galaxy y Tablets se conectan con Active Sync.

    NOTA: Me sirvió mucho el test de exchange: https://www.testexchangeconnectivity.com, donde finalmente aparecío la anciada flecha verde, prueba de conectividad correcta

     



    • Marcado como respuesta Marc Salvador jueves, 29 de diciembre de 2011 22:16
    jueves, 29 de diciembre de 2011 16:54

Todas las respuestas

  • Tienes activado y configurado ActiveSync?

    Exchange 2003 and Activesync Configuration and Troubleshooting

    http://alanhardisty.wordpress.com/2010/02/28/exchange-2003-and-activesync-configuration-and-troubleshooting/


    Saludos,

    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator (Windows Server 2008)
    MCITP: Enterprise Messaging Administrator (Microsoft Exchange 2007 & Exchange 2010)
    MCC: Microsoft Community Contributor 2011
    Citrix CCA
    Visita mi blog

    miércoles, 26 de octubre de 2011 13:18
  • He revisado la configuracion y todo parece estar bien. He pasado la utilidad que aparece en el documento para testear el server https://testexchangeconnectivity.com  y se atasca en el siguiente paso:

     

    Attempting the FolderSync command on the Exchange ActiveSync session.
      The test of the FolderSync command failed.
       <label for="testSelectWizard_ctl12_ctl06_ctl05_ctl01_tmmArrow">Tell me more about this issue and how to resolve it</label>
     
    Additional Details
      Exchange ActiveSync returned an HTTP 500 response.

     

    La solucion parece pasar por crear un nuevo site para exchange que no requiera SSL. ¿¿??

    Gracias por la rápida respuesta.


    miércoles, 26 de octubre de 2011 14:22
  • No tiene porqué. Si te funciona OWA y Outlook Anywhere, ActiveSync debería funcionar dado que "usa" OWA, con el formato https://direcciónServidor/Active-Sync/

    Sobre el error 500, mira http://support.microsoft.com/kb/817379


    Saludos,

    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator (Windows Server 2008)
    MCITP: Enterprise Messaging Administrator (Microsoft Exchange 2007 & Exchange 2010)
    MCC: Microsoft Community Contributor 2011
    Citrix CCA
    Visita mi blog
    • Marcado como respuesta Marc Salvador miércoles, 28 de diciembre de 2011 13:53
    miércoles, 26 de octubre de 2011 14:24
  • Es el mismo KB que me dice que debo crear un nuevo site que no requiera SSL. La otra opcion que dice es configurar el servidor de exchange como un front-end. Desconozco las implicaciones que tiene esto. La estructura actual es de un servidor unico para todas las funciones.

     

    miércoles, 26 de octubre de 2011 14:34
  • Ok, en tu caso quizás montar otro site sin SSL es lo suyo dado que para un servidor Front-End de Exchange 2003, necesitas otro equipo.
    Saludos,

    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator (Windows Server 2008)
    MCITP: Enterprise Messaging Administrator (Microsoft Exchange 2007 & Exchange 2010)
    MCC: Microsoft Community Contributor 2011
    Citrix CCA
    Visita mi blog
    miércoles, 26 de octubre de 2011 14:58
  • ¿Y se puede configurar este site para que solo afecte a las comunicaciones de activesync?

     

    miércoles, 26 de octubre de 2011 15:52
  • Amigo, quizá encontraste la solución ?? tengo el mismo problema, llevo varios días investigando y no encuentro la solución.

    Gracias si publicas algo que me oriente.Gracias

    martes, 27 de diciembre de 2011 21:47
  • Podrías probar de quitar el requerir SSL sólo para la parte de ActiveSync pero me da que es enmascarar el problema.

    Mira este link http://alanhardisty.wordpress.com/2010/02/28/exchange-2003-and-activesync-configuration-and-troubleshooting/ y revisa que los permisos de cada carpera sean los correctos.

    Lo de crear otro Site, sólo es seguir el Método 2 del KB que te pasé.


    Saludos,

    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator (Windows Server 2008)
    MCITP: Enterprise Messaging Administrator (Microsoft Exchange 2007 & Exchange 2010)
    MCITP: Lync Server Administrator 2010
    MCC: Microsoft Community Contributor 2011
    Citrix CCA
    Visita mi blog en ITPro.es
    MCP Virtual Bussines Card
    martes, 27 de diciembre de 2011 21:56
  • finalmente encontré la solución en esta kb 
    http://support.microsoft.com/kb/817379 
    method 2 para resolverlo. 
    prestar especial atención a: 
    Disable the forms-based authentication for the Exchange virtual directory 
    antes de crear la copia del site. 
    y sobretodo al crear la clave de registro 
    ExchangeVDir 
    yo finalmente puse dos claves, la que indica la kb y otra llamada VDirExchange con el mismo valor. 
    esta es la clave que ya viene creada en SBS2003. 
    funciona perfecto. 
    suerte. 
    • Marcado como respuesta Marc Salvador miércoles, 28 de diciembre de 2011 13:53
    miércoles, 28 de diciembre de 2011 8:25
  • Gracias Marc y Acegon por las respuestas, intentaré este fin de semana y les cuento.
    miércoles, 28 de diciembre de 2011 17:20
  • Muchas gracias,

    Resolví el problema, un resumen de lo realizado:

    Mi ambiente es exchange en un SBS 2003 e ISA 2006 en dos servers distintos

    Básicamente lo que hice fue:

    1. Serve ISA: crear una regla de publicación de Active Sync utilizando la misma escucha del OWA (que siempre ha funcionado OK y tiene el  certificado correspondiente).

    2. Validar los directorios virtuales, sugerido en : http://alanhardisty.wordpress.com/2010/02/28/exchange-2003-and-activesync-configuration-and-troubleshooting/  en mi caso desde :: "Exchange 2003 (Part of Small Business Server)

    3. Listo !! mis Samsumg Galaxy y Tablets se conectan con Active Sync.

    NOTA: Me sirvió mucho el test de exchange: https://www.testexchangeconnectivity.com, donde finalmente aparecío la anciada flecha verde, prueba de conectividad correcta

     



    • Marcado como respuesta Marc Salvador jueves, 29 de diciembre de 2011 22:16
    jueves, 29 de diciembre de 2011 16:54