none
Publicar Servidor Web RRS feed

  • Pregunta

  • Buenos días

    Ante todo gracias a todos. No estoy seguro si este es el sitio donde hacer mi pregunta. Si no lo es agradecería me lo dijera.

    Soy desarrollador y estoy empezando a valorar la idea de tener un servidor propio en casa. La mayor parte de mi vida he desarrollado para escritorio de ahí mi ignorancia en estos temas.

    Tengo un equipo con W.Vista, donde instalé el IIS, en el directorio c:\inetpub\wwwroot, he creado una carpeta llamada prueba, donde he puesto un fichero llamado default.htm, y por el momento mi intención es únicamente poder ver este fichero desde internet. Si accedo desde mi red privada a localhost(o servidor, o ip privada)/prueba, lo veo sin problema alguno.

    El equipo lo tengo conectado a un router de un proveedor local (ono en este caso), que actualmente me da una ip dinámica. Se que debería tener una estática para cosas más serias, pero de momento sólo trasteo, y no me importa mirar la ip cada vez que conecto.

    El problema es que si desde otro puesto con otra conexión a internet accedo a:   (ip wan del router)xx.xx.xx.xx/prueba, no puedo acceder me da el mensaje de que no existe la página.

    No se si tengo que habilitar algún servicio en el equipo que hace de servidor web, o dar permisos a alguna carpeta, o hacer algo en el router, o qué me puede faltar por instalar o hacer. El router tiene activado DHCP, pero puedo reservar IP estática para el equipo que hace de servidor web si es necesario.

    Como ven sólo quiero un punto de partida para lanzarme a este increible mundo.

    Muchas gracias a todos.

     

    Un Saludo

    Diego

     

    viernes, 17 de junio de 2011 8:56

Respuestas

Todas las respuestas

  • Tienes que publkicar el servidor en el router. generalmente será en la opción NAP o NAPT, depende de marca y modelo, pero el concepto es que pones que cuando la IP WAN reciba una petición entrante por el puerto 80 ésta sea reenviada al puerto 80 de la IP con el servidor Web.
    Un saludo

    Fernando Reyes [MS MVP]
    MCSA 2000/2003
    MCSE 2000/2003
    MCITP EnterpriseAdministrator
    Web: http://freyes.svetlian.com
    Blog: http://urpiano.wordpress.com
    RSS: http://urpiano.wordpress.com/feed/
    freyes.champú@champú.mvps.org
    (Aclárate la cabeza si quieres escribirme)
    • Propuesto como respuesta Ismael Borche lunes, 20 de junio de 2011 18:13
    • Marcado como respuesta Ismael Borche viernes, 24 de junio de 2011 20:24
    viernes, 17 de junio de 2011 10:50
    Moderador
  • Muchas gracias Fernando Reyes, lo probaré.

     

    Por otra parte si tengo la IP WAN, puedo acceder al router desde otro punto de internet o tengo que dar algún tipo de autorización.

     

    Gracias de nuevo

    viernes, 17 de junio de 2011 11:12
  • Generalmente el acceso al propio router desde Internet está desactivado por defecto en la configuración del mismo, teniendo una opción para habilitar la administración remota del router desde internet, aunque esto no es aconsejable por tu propia seguridad. Siempre podrás administrarlo desde la red interna.

    Esto no tiene nada que ver con que, como te ha comentado Fernando, una vez establecida la redirección de puertos en el router, éste reenvíe las peticiones que le lleguen a su dirección ip de internet y puerto 80 en el ejemplo, a la dirección y puerto de la red interna que hayas especificado.


    Saludos
    José Antonio Quílez
    Mi Blog
    viernes, 17 de junio de 2011 16:03
    Moderador
  • Tienes que publkicar el servidor en el router. generalmente será en la opción NAP o NAPT, depende de marca y modelo, pero el concepto es que pones que cuando la IP WAN reciba una petición entrante por el puerto 80 ésta sea reenviada al puerto 80 de la IP con el servidor Web.
    Un saludo

    Fernando Reyes [MS MVP]
    MCSA 2000/2003
    MCSE 2000/2003
    MCITP EnterpriseAdministrator
    Web: http://freyes.svetlian.com
    Blog: http://urpiano.wordpress.com
    RSS: http://urpiano.wordpress.com/feed/
    freyes.champú@champú.mvps.org
    (Aclárate la cabeza si quieres escribirme)


    Buenos días.

    Perdon por haber tardado en responder pero no he podido probar lo que me comentaste. Lo cierto es que sigo sin poder tener acceso a mi servidor web, y no se si debería hacer algo más.

    mi router tiene la ip privada 192.168.1.1 y mi servidor web la 192.168.1.28, en el router he redirigido el serivcio http udp/tcp a la ip 192.168.1.28, pero sigo sin poder acceder a mi página de prueba, tengo que hacer algo más?

     

     

    sábado, 25 de junio de 2011 6:52
  • Comprueba en el propio servidor web que en la configuración del cortafuegos tienes habilitada la regla correspondiente a la publicación web. En caso contrario no se puede ver la web desde fuera del propio equipo.
    Saludos
    José Antonio Quílez
    Mi Blog
    domingo, 26 de junio de 2011 20:55
    Moderador
  • Comprueba en el propio servidor web que en la configuración del cortafuegos tienes habilitada la regla correspondiente a la publicación web. En caso contrario no se puede ver la web desde fuera del propio equipo.
    Saludos
    José Antonio Quílez
    Mi Blog

    Hola

    Entiendo que si desde otro punto de mi red privada, y llamando a 192.168.1.28/prueba (win7 con iis), funciona, esta parte que mencionas  estaría correcta. Es así?

    Gracias

     

    lunes, 27 de junio de 2011 11:28
  • ¿Cuando intentas acceder desde fuera, qué IP pones en el navegador?

    Un saludo

    Fernando Reyes [MS MVP]
    MCSA 2000/2003
    MCSE 2000/2003
    MCITP EnterpriseAdministrator
    Web: http://freyes.svetlian.com
    Blog: http://urpiano.wordpress.com
    RSS: http://urpiano.wordpress.com/feed/
    freyes.champú@champú.mvps.org
    (Aclárate la cabeza si quieres escribirme)
    lunes, 27 de junio de 2011 11:37
    Moderador
  • Hola Diego:

    Una vez tuve un caso similar al tuyo, y el problema estaba en el firewall del router. En mi caso se trataba de un roter de Telefónica, y a pesar de mapear los puertos en él con el NAT seguía sin funcionar. Más tarde descubrí que existían dos filtros predeterminados que bloqueaban el puerto TCP 80.

    Revisa tu router y comprueba que no exista filtro alguno que bloquee dicho puerto.

    Por otro lado, supongo que las pruebas de acceso externo las estás haciendo desde fuera de tu red, no?

    Saludos


    Agustín Morales H. / Blog Agustín Morales H. Formación
    MCT Microsoft Certified Trainer
    MCITP Enterprise Administrator Windows Server 2008
    MCITP Server Administrator Windows Server 2008
    MCSE Windows Server 2003 / 2000 / NT 4.0
    MCSA Windows Server 2003 / 2000

    lunes, 27 de junio de 2011 11:40
  • Hola a todos

    perdonar que haya duplicado el hilo. Si os parece lo traslado todo al otro hilo sin respuesta que existe con el mismo título y que es más reciente. No sabía muy bien si al estar marcado como respondido, seguiría activo. Lo siento de verás y he respondido ya en el otro tema

    Muchas gracias

    lunes, 27 de junio de 2011 12:21