locked
Windows 7 falla en la conexion de dos redes locales simultaneas RRS feed

  • Pregunta

  • Saludos: Les expongo mi problema por si alguien conoce una solucion.
    Tengo en casa 3 pc dos de ellos con Windows 7 ultimatey el otro con windows xp sp2, cada uno con dos tarjetas de red,y conectados a dos redes; una con ip tipo 192.168.... que se conecta a un router que da acceso a internet , y la otra con ip del tipo 10.0.0.... que se usa de red local con un switch gigabit , en la red local ( 10.0.0.. ) tengo un disco duro de red que tiene un servidor de dhcp aparte de los 3 ordenadores.
     el problema es el siguiente: Si pongo una ip fija en la red local, me identifica la red como "RED NO IDENTIFICADA" y se coloca el tipo de red como publica, sin poder compartir nada(cambiando y forzando la comparticion comparto carpetas , pero a veces la comparticion se detiene sin previo aviso ) ahora bien, si activo el DHCP del disco duro de red y le pongo a los pcs en la lan ip automática, la red se identifica , pero  se pierde la conexion a internet... el adaptador (el de 192.168..) indica direccion correcta puerta de enlace , en teoria todo bien pero windows indica que no hay conexion a internet, (y de hecho no la hay ) , y simplemente con colocar una ip estatica en el adaptador de la red local (la de 10.0.0...) vuelve internet pero la red vuelve a RED NO IDENTICADA. si alguien sabe de mi caso y me puede ayudar , le estare infinitamente agradecido .

    Muchas gracias de antemano
    lunes, 1 de marzo de 2010 2:35

Respuestas

  • Hola de nuevo Jose Manuel :

    He probado lo que me dijiste de dar de baja la interface y se coloca como red que elegimos durante un par de segundo luego inmediatamente dice Identificando.... y se vuleve a colocar como RED NO IDENTIFICADA, por otra parte acabo de probar y si estando la IP fija le colo como puerta de enlace la ip del disco de red inmediatamente se identifica la red, pero por supuesto pierdo internet , ahora mismo he probado la solucion poco elegante y funciona bastante bien pero es un incordio y hay que hacerla en los dos ordenadores con windows 7, porque aunque en uno se identifique la red en el otro sigue la red sin identificar , por supuesto despues de hacer tambien lo de desctivar el interface.

    Muchas Gracias de nuevo por tu interes que me es de gran ayuda.

    Jose Alonso
    Bien, pues la cuarta posibilidad (y funciona uqe acabo de probarlo). Cambiar las policitas. Para ello tecleas en Inicio, Buscar: gpedit.msc. Cuando aparezca, boton derecho y "Ekecutar como Administrador".

    Entras en (lo siento lo tengo en ingles):

    Local Computer Policy
       Computer Configuration
           Windows Settings
               Security Settings
                   Network List Manager Policies

    A la derecha verás una llamada: Unidenfied Netowrks. La pinchas y en la zona superior le marcas "Private" y en la inferior "User can change location".

    Ahora, si reinicias lo toma, y sin reiniciar, si en una consola de comandos ejecutas:

    gpupdate /force

     tambien lo toma...

    Un saludo,

    Jose Manuel Tella Llop news://jmtella.com

    • Marcado como respuesta JAC9001 lunes, 1 de marzo de 2010 18:55
    lunes, 1 de marzo de 2010 16:45

Todas las respuestas

  • Saludos: Les expongo mi problema por si alguien conoce una solucion.
    Tengo en casa 3 pc dos de ellos con Windows 7 ultimatey el otro con windows xp sp2, cada uno con dos tarjetas de red,y conectados a dos redes; una con ip tipo 192.168.... que se conecta a un router que da acceso a internet , y la otra con ip del tipo 10.0.0.... que se usa de red local con un switch gigabit , en la red local ( 10.0.0.. ) tengo un disco duro de red que tiene un servidor de dhcp aparte de los 3 ordenadores.
     el problema es el siguiente: Si pongo una ip fija en la red local, me identifica la red como "RED NO IDENTIFICADA" y se coloca el tipo de red como publica, sin poder compartir nada(cambiando y forzando la comparticion comparto carpetas , pero a veces la comparticion se detiene sin previo aviso ) ahora bien, si activo el DHCP del disco duro de red y le pongo a los pcs en la lan ip automática, la red se identifica , pero  se pierde la conexion a internet... el adaptador (el de 192.168..) indica direccion correcta puerta de enlace , en teoria todo bien pero windows indica que no hay conexion a internet, (y de hecho no la hay ) , y simplemente con colocar una ip estatica en el adaptador de la red local (la de 10.0.0...) vuelve internet pero la red vuelve a RED NO IDENTICADA. si alguien sabe de mi caso y me puede ayudar , le estare infinitamente agradecido .

    Muchas gracias de antemano

    Hay varias soluciones ya que el problema de no tener internet es que al poner el DHCP te da puerta de enlace y no se pueden tener dos puertas de enlace en la misma maquina. (RFC's sobre el funcionamientos del tpc/ip)...

    Una de las soluciones es simplemente reconfigurar el firewall. La unica diferencia entre red publica, privada, trabajo, etc... es la configuracion del firewall por defecto. Ninguna mas. Por tanto, simplemente no le pongas con DHCP y reconfigura el firewall para permitir compartir en las redes publicas.

    NOTA: otra solución, pero no me gusta, cuando existen dos puertas de enlace, es suprimir una y dejar solo como puerta de enlace aquella para la cual queremos que salgan los paquetes que no pertenen a nuestras subredes. Para ello, con conocimientos basicos de tcp/ip sabemos que es solo modificar la tabala de rutas. Para ver la tabla de rutas que tenemos en un momento determinado, podemos dar el comando (en una consola de comandos, arrancada en modo elevado):

    route print

    Esto nos lo muestra. Si nos fijamos en la ruta 0.0.0.0 indicará la puerta de enlace y en tu caso verias que hay dos entradas y cada una apuntando a la puerta de enlace correspondiente que ha dado el DHCP. Ese es el problema y que tamopo se solucionaróa cambiando la metrica ya que segun las RFC, la metrica es dicnamica y si una puerta de enlace salta por timeout, y solo por timeout, automaticamente se switchea a la otra y esto en tu caso causaría malfuncionamientos esporadicos aunque funcionase con el cambio de metrica. Por tanto la alternativa es:

    route delete 0.0.0.0
    route add 0.0.0.0 mask 0.0.0.0 x.y.z.t


    dejando en x.y.z.t la puerta de enlace que te interese. Pero estos dos comandos habria que darlos al comienzo de cada sesion o bien en un .bat con privlegios ejecutarlos en el grupo de inicio.

    Insisto en que esta solucion no me gusta...

    Un saludo,

    Jose Manuel Tella Llop news://jmtella.com

    lunes, 1 de marzo de 2010 5:07
  • Saludos: Jose Manuel .

                  Gracias por tu respuesta, era como muy bien dices las puertas de enlace , ya hago lo que me dices que es lo de activar la comparticion a traves del firewall de las redes publicas, lo que me molesta es que el sistema ponga como red no identificada una red local con ips fijas, con lo que no puedo hacer un grupo en el hogar , cosa que no hago en la red que si se identifica (la que conecta a internet) porque en esa red tengo deshabilitada la comparticion de archivos, ya que estos se comparten por la red gigabit ;
    y de esa manera tengo las dos redes separadas , una para internet y la otra para compartir archivos .

    Lo que me gustaria saber es si se puede tener una red local sin DHCP y que no sea identificada como RED NO IDENTIFICADA, o lo que es lo mismo identificar la red manualmente.

    Muchas gracias
     

    Un Saludo de  Jose Alonso
    lunes, 1 de marzo de 2010 11:32

  • Lo que me gustaria saber es si se puede tener una red local sin DHCP y que no sea identificada como RED NO IDENTIFICADA, o lo que es lo mismo identificar la red manualmente.


    Si no hay trafico de red es posible que lo identifique así. Depende del tipo de trafico. ¿tienes ese disco de red encendido? ¿tiene el mismo grupo de trabajo que el Windows 7?... es decir, si windows puede "identificar" el tipo pondrá correcta la red... además lo normal es que la primera vez que establece la red te pregunte y en ese caso se debe seleccionar "trabajo" (WORK). Prueba, con el disco quitado a dar de baja la tarjeta de red en el Administrador de dispositivos, y sin salirte, con boton derecho en cualquier dispositivo dale a buscar nuevo hardware. Esto debería crearte de nuevo uan conexion y preguntarte...

    Un saludo,

    Jose Manuel Tella Llop news://jmtella.com

    lunes, 1 de marzo de 2010 11:43
  • Hola de Nuevo Jose Manuel:


    Tenemos estos tres estados :
    Estando el disco de red desconectado , y solamente los tres ordenadores conectados al switch RED NO IDENTIFICADA

    Estando el disco de red conectado y el DHCP activado e IP automatica red identificada (pero como vemos sin internet por lo de las dos puertas de enlace)

    Estando el disco de red conectado y el DHCP activado e IP fija RED No IDENTIFICADA.
    He probado lo que me comentas pero sin resultado, Tambien he probado do a cambiar el switch y la situacion es la misma, lo mismo pasa en ambos ordenadores con windows7.
    El disco de red tiene el mismo grupo de trabajo que el windows 7

    Probare a desconectar fisicamente el ordenador con windows Xp pro por si tuviese algo que ver .

    Muchas Gracias por tu interes.

    Jose Alonso
    • Editado JAC9001 lunes, 1 de marzo de 2010 15:54
    lunes, 1 de marzo de 2010 15:41
  • Hola de Nuevo Jose Manuel:


    Tenemos estos tres estados :
    Estando el disco de red desconectado , y solamente los tres ordenadores conectados al switch RED NO IDENTIFICADA

    Estando el disco de red conectado y el DHCP activado e IP automatica red identificada (pero como vemos sin internet por lo de las dos puertas de enlace)

    Estando el disco de red conectado y el DHCP activado e IP fija RED No IDENTIFICADA.
    He probado lo que me comentas pero sin resultado, Tambien he probado do a cambiar el switch y la situacion es la misma, lo mismo pasa en ambos ordenadores con windows7.
    El disco de red tiene el mismo grupo de trabajo que el windows 7

    Probare a desconectar fisicamente el ordenador con windows Xp pro por si tuviese algo que ver

    Muchas Gracias por tu interes.

    Jose Alonso
    No. El ordenador con XP no tiene que ver. ¿has probado l oque te he dicho a dar de baja la interface y que lo reconozca?. En cualquier caso hay dos soluciones: la elegante, reconfogurar el cortafuegos, la practica, dejar el DHCP y mediante los comandos route que te he dejado en el primer mensaje reconfigurar la tabla de rutas.

    Y una tercera. que tu seas el server DHCP compartiendo la conexion (y al resto de maquinas les dejas en el rango 192.168.137.x que es el que usa W7 al compartir una conexion)
     


    Jose Manuel Tella Llop news://jmtella.com

    lunes, 1 de marzo de 2010 15:51
  • Hola de nuevo Jose Manuel :

    He probado lo que me dijiste de dar de baja la interface y se coloca como red que elegimos durante un par de segundo luego inmediatamente dice Identificando.... y se vuleve a colocar como RED NO IDENTIFICADA, por otra parte acabo de probar y si estando la IP fija le colo como puerta de enlace la ip del disco de red inmediatamente se identifica la red, pero por supuesto pierdo internet , ahora mismo he probado la solucion poco elegante y funciona bastante bien pero es un incordio y hay que hacerla en los dos ordenadores con windows 7, porque aunque en uno se identifique la red en el otro sigue la red sin identificar , por supuesto despues de hacer tambien lo de desctivar el interface.

    Muchas Gracias de nuevo por tu interes que me es de gran ayuda.

    Jose Alonso
    lunes, 1 de marzo de 2010 16:02
  • Hola de nuevo Jose Manuel :

    He probado lo que me dijiste de dar de baja la interface y se coloca como red que elegimos durante un par de segundo luego inmediatamente dice Identificando.... y se vuleve a colocar como RED NO IDENTIFICADA, por otra parte acabo de probar y si estando la IP fija le colo como puerta de enlace la ip del disco de red inmediatamente se identifica la red, pero por supuesto pierdo internet , ahora mismo he probado la solucion poco elegante y funciona bastante bien pero es un incordio y hay que hacerla en los dos ordenadores con windows 7, porque aunque en uno se identifique la red en el otro sigue la red sin identificar , por supuesto despues de hacer tambien lo de desctivar el interface.

    Muchas Gracias de nuevo por tu interes que me es de gran ayuda.

    Jose Alonso
    Bien, pues la cuarta posibilidad (y funciona uqe acabo de probarlo). Cambiar las policitas. Para ello tecleas en Inicio, Buscar: gpedit.msc. Cuando aparezca, boton derecho y "Ekecutar como Administrador".

    Entras en (lo siento lo tengo en ingles):

    Local Computer Policy
       Computer Configuration
           Windows Settings
               Security Settings
                   Network List Manager Policies

    A la derecha verás una llamada: Unidenfied Netowrks. La pinchas y en la zona superior le marcas "Private" y en la inferior "User can change location".

    Ahora, si reinicias lo toma, y sin reiniciar, si en una consola de comandos ejecutas:

    gpupdate /force

     tambien lo toma...

    Un saludo,

    Jose Manuel Tella Llop news://jmtella.com

    • Marcado como respuesta JAC9001 lunes, 1 de marzo de 2010 18:55
    lunes, 1 de marzo de 2010 16:45
  • Hola de Nuevo :

    Esta es la solucion: Muchas Gracias:
    Solo comentar una cosa... aplico la directiva yla red coge un icono del sistema (el de red) y se pone en red de trabajo por defecto , pero a diferencia de lo que dice la directiva , no me deja cambiar de icono , y usando la tercera directiva ...la que dice todas las redes.. le pongo en todas El usuario puede cambiar... para cambiar icono, nombre y ubicacion, pero en esta se resiste ...

    De todas formas esta es la solucion ya que pone la red como red de trabajo y la comparticion parece que fluye mejor ....

    Muchas Gracias por todo ..

    Jose Alonso
    lunes, 1 de marzo de 2010 18:55
  • Hola de Nuevo :

    Esta es la solucion: Muchas Gracias:
    Solo comentar una cosa... aplico la directiva yla red coge un icono del sistema (el de red) y se pone en red de trabajo por defecto , pero a diferencia de lo que dice la directiva , no me deja cambiar de icono , y usando la tercera directiva ...la que dice todas las redes.. le pongo en todas El usuario puede cambiar... para cambiar icono, nombre y ubicacion, pero en esta se resiste ...

    De todas formas esta es la solucion ya que pone la red como red de trabajo y la comparticion parece que fluye mejor ....

    Muchas Gracias por todo ..

    Jose Alonso
    Si. Las directivas no las toma todas, pero al menos permite el cambiar a red de trabajo.  :-)

    Un saludo,

    Jose Manuel Tella Llop news://jmtella.com

    lunes, 1 de marzo de 2010 18:58
  • hola, gracias tengo el mismo problema(tenia), un pc con windows 7 x86 con conexion compartida a internet  para otro con windows 7 x64, se cambio a red de trabajo y todo funciona normal, sigue mostrando que un equipo de la red no esta identificado y que no tiene acceso a internet aunque tenga conexion y se puedan compartir archivos. Gracias por la solucion.
    lunes, 19 de abril de 2010 21:09