none
Alertas fantasma RRS feed

  • Pregunta

  • Hola a todos/as, tengo un problema con las alertas en SharePoint. La situación es la siguiente:

    Tengo creado un sitio con la plantilla "Portal de colaboración". Este portal tiene varias áreas de trabajo (Llamadas áreas), estas áreas de trabajo tienen otras subáreas (Líneas) y las líneas tienen otras (Proyectos de línea). Estas áreas se crearon con la plantilla "Sitio de grupo".

    He modificado el tipo de contenido "Tarea" para que el campo "Asigned to" sea múltiple. Y he deshabilitado el envío de Notificaciones en la lista de tareas.

    El problema viene cuando me suscribo para que me alerte de los cambios en determinada tarea ("Alert me" sobre un elemento "Tarea"). La alerta se crea correctamente y me envía la notificación de ello. Cuando realizo un cambio en el elemento me llega el correspondiente correo con la alerta. Lo malo es que además de los cambios que se hicieron en la tarea, en el campo "Asigned to" aprecen unos cinco nombres de usuario tachados. Estos usuarios nunca fueron asignados a esta tarea o a la alerta. Por supuesto les ha llegado un mensaje con la alerta a esos usuarios aunque estubieran tachados. Es por eso por lo que escribo "Alertas fantasma" en el título. No quiero que se envíen esos mensajes de alerta a gente que no lo solicitó ni fueron suscritas por otros usuarios. En el siguiente texto está el mensaje de alerta con los usuarios fantasma (aunque no se vea, aparecen tachados):

     

    Tarea de prueba se ha cambiado

     

                 

     

    Título:

    Tarea de prueba Tarea de prueba [Modificada]

    Tiempo de edición

    Prioridad:

    (2) Normal

     

    Estado:

    En curso

     

    Assigned to:

    tachado(Carlos; Roberto; Maria; Pierre; Axel) Carlos

    Tiempo de edición

    Descripción:

    Esto es sólo una prueba. Si recibio alguna alerta relacionada con este elemento ignórela. Modificación.

     

    Fecha de inicio:

    25/03/2010

     

     

    Mis preguntas son las siguientes:

    ¿Este fallo puede ser debido a que cambié el campo "Asigned to" para que fuera múltiple?

    ¿Puede ser un bug de SharePoint?

    ¿Hay algo que pueda hacer para solucionarlo?

     

    Información del sistema:

    Windows Server 2003 (x64)

    SharePoint Server 2007 (x64)

    SQL Server 2008

     

    Gracias de antemano y un saludo

     


     

    • Editado carlosNTC jueves, 25 de marzo de 2010 13:15 Añadir el mensaje de alerta
    jueves, 25 de marzo de 2010 13:08

Todas las respuestas

  • Hola Carlos

    Es posible que este comportamiento extrano sea realacion,ado con el cambio que hiciste, una pregunta las personas que estan tachadas son las mismas que agrgaste al camibio asignado a cuando lo modifiscaste?

    Lo mejor seria que utilizaras las alertas de la manera como estan implementadas,la idea de la alerta es que cada quien se alerte de los cambios que quiere seguir si aun asi necesitas tener multiples destinatarios puedes intentar con algunas herramientas de www.codeplex.com

    Saludos Cordiales

     


    Ricardo Munoz SharePoint MVP blog: http://www.mundomoss.blogspot.com
    miércoles, 21 de abril de 2010 15:35