none
Problema al inicializar el servicio Almacén de informacion de Microsoft exchange RRS feed

  • Pregunta

  •  

     

    Hola a todos,

     

    Ayer tuve un problema con Exchange pero parace ser que fue una falta alarma. No estoy seguro de ello, a ver si alguien puede echarme una mano y confirmarme una cosa u otra.

     

    Tengo un servidor con windows 2003 R2 SP2 y Exchange 2003. Este mismo servidor es controlador primario del dominio.

     

    Ayer tras distribuir el agente antivirus de panda me pidio reiniciar el servidor. Al arrancar de nuevo me aparecía un mensaje diciendo que uno o mas servicios no habias podido iniciarse, que consultara el visor de sucesos.

     

    Comprobé que no tenia acceso al almacen de información de exchange.

     

    En el visor de sucesos (aplicacion) tenía la siguiente información:

    Code Snippet

     

    Error. Orígen: MSExchangeFBPublish. Id Suceso 8197. "Error al inicializar la sesion para la maquina virtual SERV. El numero de error es 0x8004011d. Asegurese de que el almacen de Microsoft Exchange está en ejecución.

     

    Error. Orígen: MSExchangeMTA. Id Suceso: 125. "Error fatal al leer un valor del directorio. No se encontró ningun nombre de MTA. Póngase en contacto con el Soporte Técnico de Microsoft [MTA MAIN BASE 1 12](16)

     

    Advertencia: Origen: MSExchangeMTA. Id Suceso: 9406. No hay suficiente memoria para que el monitor de rendimiento pueda mostrar la información de conexiones MTA. Detenga los monitores de rendimiento adjuntos y reinicie el MTA. [BASE MAIN BASE 1](14)

     

    Error. Origen: MSExchangeIS. Id Suceso: 1121. Error 0x80004005 al conectarse a Microsoft Active Directory.

     

    Error. Origen: MSExchangeIS. Id Suceso: 5000. No se puede inicializar el servicio almacén de información de Microsoft Exchange. : Error 0x80004005

     

    Error. Origen: MSExchangeAL. Id Suceso: 8231. El proveedor de grupos de directivas informo de un error permanente para "CN=System Policies,CN=DOMINIO,CN=Microsoft Exchange, CN=Services,CN=Configuration,DC=dominio,DC=local":"MAD.EXE",error=80040103. Se cerrará la conexión con el proveedor.

     

    Error. Origen: MSExchangeDSAccess. Id Suceso: 2103. Proceso MAD.EXE (PID=2132). No responde ninguno de los servidores Catálogo global en uso:

    serv.dominio.local

     

     

     

    Bien, lo que hice fue reiniciar y comprobar los sevicios de exchange que estaban corriendo.

     

    A pesar de estar en automatico no se habian inicializado: Microsoft Exchange-Almacen de Informacion, Microsoft Exchange-Operador de sistema, Microsoft Exchange-Pila MTA, Microsoft Exchange-Motor de enrutamiento.

     

    Los inicie y en el visor de logs me aparecio la siguiente informacion:

     

    Code Snippet

    Id 9096. Se inicio el subproceso de supervision de MAD

    Id 3. Se inicio el servicio de administracion de Microsoft Exchange.

    Id 100. OleDB de Microsoft Exchange se inicio correctamente.

    Id. 8195. El Agente de calendario se inicializo correctamente.

     

    Advertencia. Origen: MSExchangeIS. Id Suceso: 9665. La configuracion de memoria de este servidor no es optima para Exchange.

     

    Id 100. Information Store (2752). El motor de base de datos 6.05.7638.0008 se ha iniciado.

    Id 302. Information Store (2752). Primer grupo de almacenamiento: El motor de base de datos completo correctamente el procedimiento de recuperacion.

    Id. 9523. Se inicio la base de datos de Microsoft Exchange "Primer grupo de almacenamiento\Almacen de carpetas publicas (SERV)".

    Id. 9523. Se inicio la base de datos de Microsoft Exchange "Primer grupo de almacenamiento\Almacen del buzon (SERV)

    Id 1001. Se inicio el servicio Almacen de información de Microsoft Exchange. Inicio de servicio completo, version 6.5 (compilacion 7642.24).

    Id. 2207. Se completo la recuperacion de la base de datos del MTA. Los detalles de la recuperacion estan en el archivo: C:\Archivos de programa\Exchsrv\mtdata\MTACHECK.OUT\MTACHECK. [DB Server MAIN BASE 1 67](14)

     

    -- En el archivo correspondiente dice que database clean, no errors found.

     

    Id, 9298. Se completo el inicio del servicio MTA de Microsoft Exchange Server, version 6.5 (compilacion 7638.1) [BASE IL MAIN BASE 22 490]()

     

     

     

    Desde que arranque manualmente los servicios ayer no ha aparecido ningun mensaje mas de error en el visor de sucesos y los usuarios trabajan con normalidad con el correo.

     

    ¿Debo preocuparme o ha sido algo puntual debido a alguna incompatibilidad con panda?.

     

    Muchas gracias desde ya por vuestra atencion y vuestro tiempo.

     

    Un saludo,

    David.

     

     

     

     

     

     

     

    miércoles, 5 de noviembre de 2008 8:16

Respuestas

  • Hola,

     

    No, no debes preocuparte. El arranque es correcto y los eventos tambien. Los que te muestra durante el reinicio, seguramente es debido a que reiniciastes el servidor sin parar antes los servicios de Exchange. Cuando haces un shutdown de un servidor Windows, lo primero que hace el sistema es cerrar las conexiones de red. Debido a esto Exchange no puede cerrar sus conexiones del directorio activo. De ahi el evento DSAccess (Directory Service access) son los servicios de acceso al directorio (directorio activo). Y posteriormente arranca mal los servicios.

    Si quieres evitarte esto (y tambien que el servidor reinicie mas rapido) puedes hacerte unos scripts que paren los servicios de forma automatica.

     

     

    net stop REsvc

    net stop MSExchangeMTA

    net stop MSExchangeES

    net stop MSExchangeIS

    .

    .

    .

    .

    y asi con todos. Luego lo metes en un bat y listo.

     

    Un saludo,

    • Marcado como respuesta David GCC miércoles, 4 de noviembre de 2009 19:24
    lunes, 10 de noviembre de 2008 12:24

Todas las respuestas

  • Hola,

     

    No, no debes preocuparte. El arranque es correcto y los eventos tambien. Los que te muestra durante el reinicio, seguramente es debido a que reiniciastes el servidor sin parar antes los servicios de Exchange. Cuando haces un shutdown de un servidor Windows, lo primero que hace el sistema es cerrar las conexiones de red. Debido a esto Exchange no puede cerrar sus conexiones del directorio activo. De ahi el evento DSAccess (Directory Service access) son los servicios de acceso al directorio (directorio activo). Y posteriormente arranca mal los servicios.

    Si quieres evitarte esto (y tambien que el servidor reinicie mas rapido) puedes hacerte unos scripts que paren los servicios de forma automatica.

     

     

    net stop REsvc

    net stop MSExchangeMTA

    net stop MSExchangeES

    net stop MSExchangeIS

    .

    .

    .

    .

    y asi con todos. Luego lo metes en un bat y listo.

     

    Un saludo,

    • Marcado como respuesta David GCC miércoles, 4 de noviembre de 2009 19:24
    lunes, 10 de noviembre de 2008 12:24
  • Muchas gracias por la respuesta y por el consejo.

     

    Un saludo!!

     

    lunes, 17 de noviembre de 2008 12:12
  • hola Guillermo, tengo un problema con mi servidor exchange, resulta que no tengo correo externo y los servicios del exchange estan inicializados, no se ke es lo ke esta pasando, espero me ayudes (soy novato en esto) aki te dejo mi correo para ke te puedas comunicar conmigo y ayudarme, muchas gracias y exitos antonio_2078@hotmail.com

     

    miércoles, 7 de enero de 2009 22:39
  • Hola, a mi me pasa algo parecido, cuando arranco el sistema, lme avisa que hay servicios que no han iniciado correctamente, si me voy al visor de sucesos, veo lo siguiente:

    No se puede inicializar el servicio Almacén de información de Microsoft Exchange.  : Error 0x80004005. Suceso 5000


    Error 0x80004005 al conectarse a Microsoft Active Directory. Suceso 1121

    Tengo como servicio el Fetchmail, pero no me deja ejecutar el servicio, esta en automatico y cada vez que le doy a iniciar, me dice que los procesos que no hacen nada se detienen y se para, no hay forma de iniciarlo, alguien me puede decir que es lo que puede pasar y el porque? ,muchas gracias!
    mi mail es f.nerin@esofitec.com

    Un saludo

    miércoles, 19 de agosto de 2009 9:35