locked
Problema con Robocopy (Error 5 Explorando directorio de origen) RRS feed

  • Pregunta

  • Buenas, espero ser lo mas claro posible...

    Estoy ocupando el comando ROBOCOPY de la POWERSHELL de Microsoft, bueno lo que estoy haciendo es un respaldo en red, tengo un cliente en windows y el servidor es un linux, compartí una carpeta por samba, sin usuario ni contraseña osea publico, de manera que no me pida ni usuario ni contraseña cuando envió la información.

    TODO BIEN HAY, copio todo etc..

    EL PROBLEMA es que cuando ejecuto el siguiente comando en el CMD:

    Code:
    ROBOCOPY C:\Users\marco\Documents \\192.168.1.105\JRomero /E
    la opcion /E es para copiar subdirectorios VACIOS me los copia todo ok pero al final me tira el siguiente error 

    ERROR 5 EXPLORANDO DIRECTORIO DE ORIGEN C:\Users\marco\Documents\Mi música\
    Acceso denegado.

    OJO que lo que quiero es respaldar la carpeta mis documentos remotamente, pero intente local ( en el mismo S.O )y me tira el mismo error.

    creo que al parecer cuando uno no tiene permisos de escritura NTFS sale este tipo de error, busque y me sale que con la opción /COPY:DT se soluciona, y en en realidad si pero cuando, no lo puedo combinar con la opcion /E, por que me copias las carpetas pero el error me lo tira igual...

    espero que me puedan ayudar.
    sábado, 22 de junio de 2013 19:22

Respuestas

  • Buenas, espero ser lo mas claro posible...

    Estoy ocupando el comando ROBOCOPY de la POWERSHELL de Microsoft, bueno lo que estoy haciendo es un respaldo en red, tengo un cliente en windows y el servidor es un linux, compartí una carpeta por samba, sin usuario ni contraseña osea publico, de manera que no me pida ni usuario ni contraseña cuando envió la información.

    TODO BIEN HAY, copio todo etc..

    EL PROBLEMA es que cuando ejecuto el siguiente comando en el CMD:

    Code:
    ROBOCOPY C:\Users\marco\Documents \\192.168.1.105\JRomero /E
    la opcion /E es para copiar subdirectorios VACIOS me los copia todo ok pero al final me tira el siguiente error 

    ERROR 5 EXPLORANDO DIRECTORIO DE ORIGEN C:\Users\marco\Documents\Mi música\
    Acceso denegado.

    OJO que lo que quiero es respaldar la carpeta mis documentos remotamente, pero intente local ( en el mismo S.O )y me tira el mismo error.

    creo que al parecer cuando uno no tiene permisos de escritura NTFS sale este tipo de error, busque y me sale que con la opción /COPY:DT se soluciona, y en en realidad si pero cuando, no lo puedo combinar con la opcion /E, por que me copias las carpetas pero el error me lo tira igual...

    espero que me puedan ayudar.

    Ponle ademas como parametro un /R:0 para que no falle (el error lo dará pero pasará de él. Hay ciertas carpetas que son enlaces simbolicos (o bien están protegidas) y no puede a traves de ellos...


    Jose Manuel Tella Llop news://jmtella.com

    • Marcado como respuesta Uriel Almendra viernes, 12 de julio de 2013 21:15
    sábado, 22 de junio de 2013 19:41

Todas las respuestas

  • Buenas, espero ser lo mas claro posible...

    Estoy ocupando el comando ROBOCOPY de la POWERSHELL de Microsoft, bueno lo que estoy haciendo es un respaldo en red, tengo un cliente en windows y el servidor es un linux, compartí una carpeta por samba, sin usuario ni contraseña osea publico, de manera que no me pida ni usuario ni contraseña cuando envió la información.

    TODO BIEN HAY, copio todo etc..

    EL PROBLEMA es que cuando ejecuto el siguiente comando en el CMD:

    Code:
    ROBOCOPY C:\Users\marco\Documents \\192.168.1.105\JRomero /E
    la opcion /E es para copiar subdirectorios VACIOS me los copia todo ok pero al final me tira el siguiente error 

    ERROR 5 EXPLORANDO DIRECTORIO DE ORIGEN C:\Users\marco\Documents\Mi música\
    Acceso denegado.

    OJO que lo que quiero es respaldar la carpeta mis documentos remotamente, pero intente local ( en el mismo S.O )y me tira el mismo error.

    creo que al parecer cuando uno no tiene permisos de escritura NTFS sale este tipo de error, busque y me sale que con la opción /COPY:DT se soluciona, y en en realidad si pero cuando, no lo puedo combinar con la opcion /E, por que me copias las carpetas pero el error me lo tira igual...

    espero que me puedan ayudar.

    Ponle ademas como parametro un /R:0 para que no falle (el error lo dará pero pasará de él. Hay ciertas carpetas que son enlaces simbolicos (o bien están protegidas) y no puede a traves de ellos...


    Jose Manuel Tella Llop news://jmtella.com

    • Marcado como respuesta Uriel Almendra viernes, 12 de julio de 2013 21:15
    sábado, 22 de junio de 2013 19:41
  • Ok, me funciono, es solo para ahorrarme ese error devido a que es molestoso, como tengo que hacer una copia diaria, pense que podria tener problemas, te pasaste gracias totales.
    sábado, 22 de junio de 2013 20:07