none
Fallo al listar el directorio en un servidor ftp RRS feed

  • Pregunta

  • Hola, cuento con WServer2008 x64 iis7, ftp iis6
    Genero subdominios de mi dominio principal, para sitios web personales de x personas, y que lo puedan estar editando.
    Puerto 21. Sin anonimos. mmm, no se que mas pueda servir.
    Tengo un usuario para cada sitio web personal, al loggear cada usuario en el ftp me dirije al sitio correspondiente, pero el problema viene porque no me lista los archivos y carpetas. Puedo escribir, agregar carpetas y demás, pero no me lista el directorio. Y cuando lo dejo default, para que me envie al sitio default al ftproot, es la misma situacion. Y lo curioso es que, al realizar pruebas desde él mismo, no hay problemas.
    Lo e intentado con:
    Internet Explorer 8
    Firefox 3.0.14
    Windows Explorer
    Filezilla 3.2.7.1
    todo desde Windows 7 y Windows XP

    No encuentro la falla.
    domingo, 27 de septiembre de 2009 0:59

Respuestas

  • FTP es con steve schofield :

    I'd check to make sure the Authentication (basic) and Authorization sections are properly configured.   

    Here is how I use FTP user isolation and it works great.

    1) Create a dummy FTPRoot folder

    2) Create a Master FTP site. (just an FTP site) No http.

    3) Create a vdir called 'LocalUser'. map the 'localuser' virtual directory to your dummy folder (grant authenticated users 'list' only permissions)

    4) Under the LocalUser vdir, create your specific user accounts mapped to the appropriate location (these should be vdirs)

    5) Under the User isolation, select the first option (disable global directories)

    6) Under the Authentication section, enable basic authentication if you are using windows accounts.

    7) Under the authorization, grant the user permissions.

    8) Grant appropriate folder security for your test user. 

    9) Test it out.

    See if you get logged in.


    Colabora con el foro: Si el mensaje te es de utilidad márcalo como respuesta.

    David Nudelman
    MCP, MCSA, MCSE
    MCTS: Vista, Exchange 2007
    MCITP: Windows Server 2008
    Web: http://geeks.ms/blogs/dnudelman

    sábado, 10 de octubre de 2009 7:05
    Moderador